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In this section: 

Typographical Conventions ............................................................................... 6 
Feedback .......................................................................................................... 7 
 
 

Typographical Conventions 

Before you start using this guide, it is important to understand the documentation 
conventions used in it.  

The following kinds of formatting in the text identify special information. 

Formatting convention Type of Information Example 

Special Bold Items you must select, 
such as menu options, 
command buttons, or 
items in a list. 

Go to the System tab. 

 Titles of chapters, 
sections, and subsections. 

Read the Basic Administration 
chapter. 

Italics Used to emphasize the 
importance of a point, to 
introduce a term or to 
designate a command line 
placeholder, which is to be 
replaced with a real name 
or value. 

The system supports the so 
called wildcard character search. 

Monospace The names of commands, 
files, and directories. 

The license file is located in the 
http://docs/common/licen

ses directory. 

Preface 
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Formatting convention Type of Information Example 

Preformatted On-screen computer 
output in your command-
line sessions; source code 
in XML, C++, or other 
programming languages. 

# ls –al /files 

total 14470 

Preformatted Bold What you type, contrasted 
with on-screen computer 
output. 

# cd /root/rpms/php 

CAPITALS Names of keys on the 
keyboard. 

SHIFT, CTRL, ALT 

KEY+KEY Key combinations for 
which the user must press 
and hold down one key 
and then press another. 

CTRL+P, ALT+F4 

 
 

Feedback 

If you have found an error in this guide, or if you have suggestions or ideas on how to 
improve this guide, please send your feedback using the online form at 
http://www.parallels.com/en/support/usersdoc/. Please include in your report the guide's title, 
chapter and section titles, and the fragment of text in which you have found an error. 

 

http://www.parallels.com/en/support/usersdoc/


 

  
 

Parallels Plesk Panel offers an easy and convenient graphical user interface that 
enables you to start your hosting business quickly and maintain it effortlessly. With 
Panel, you set up your hosting offers, manage customer accounts, and do other tasks 
to run and grow your business. Your customers benefit from using Panel too since it 
gives them a complete set of tools for creating and editing their websites. For serving 
both resellers and customers, the Panel GUI is divided into two parts:  

 Server Administration Panel.  
In this panel, you set up and maintain your business. Here you create hosting plans 
and customer accounts, manage subscriptions, and so on. For a comprehensive 
overview of operations available to you in the Server Administration Panel, see the 
section Acquainting with the Panel Interface (on page 10). 

 Control Panel.  

When someone subscribes to one of your hosting plans, Panel sets up an account 
for the subscriber. Under this account, the customer can add domain names and 
mailboxes, edit website content, and carry out other hosting management routines. 
Customers perform these operations in a separate panel called the Control Panel. 
To learn more about operating in the Control Panel, refer to the section Managing 
Web Hosting (on page 189). 

So, after logging in to Panel, customers see the Control Panel while resellers see the 
Server Administration Panel. This is for convenience, to separate the administration of 
customer accounts from administration of websites and hosting services. 

However, you will need to go to the Control Panel in the following cases: 

 To assist customers with performing their tasks. In this case, you log in to the 
Control Panel on a customer's behalf. 

 To create and manage your own websites. In this case, you create your own 
subscription and log in to the Control Panel using your account. 

The links that let you log in to the Control Panel using your own and your customers' 
accounts are located in the list of subscriptions (Server Administration Panel > Hosting 
Services group of the navigation pane > Subscriptions.) 

Your Panel Account and Subscriptions 

When you subscribe to a reseller plan, you get a reseller account in Panel. This 
account stores your profile information and is linked to your subscription - the package 
of hosting resources that you lease for reselling and use for your own needs. 

Your account has a unique username and a password that you use to log in to Panel. 
You can change these at any time. The section Managing Your Profile (on page 15) 
explains how to do it. 

C H A P T E R  1  
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To allow you to easily monitor the current state of your resources and services (for 
example, disk space currently consumed by your account and your customers), Panel 
automatically calculates the resource usage and displays it to you on the appropriate 
pages. To learn how to track the usage of your hosting resources and services, refer to 
the section Viewing Your Subscription Properties (on page 16). 

Parallels Customer and Business Manager 

In a hosting business, you have to deal with two money flows: payments to your 
hosting provider for resources that you lease, and payments from your customers. 
These flows are difficult to handle if you have a lot of customers who use different 
payment methods and adhere to different tax codes and regulations. To automate the 
financial aspect, Parallels offers a turnkey solution – Parallels Customer and Business 
Manager. This component comes in a bundle with the Parallels Plesk Panel package 
and provides tools for carrying out the following operations: 

 Periodical issuing of invoices for your customers. 

 Selling hosting-related resources such as domain names and SSL certificates. 

 Calculating and applying appropriate taxes. 

 Updating and storing accounting information. 

 Other business operations. 

If your service provider uses Business Manager, then additional tools are available in 
your Server Administration Panel. Learn more about Business Manager tools and the 
workflow used in Business Manager in the Becoming Familiar with Business Manager (on 
page 12) section. 

If your service provider uses alternative billing solutions, refer to the documentation for 
the respective software. 

If you do not have integrated tools for managing the financial aspects of your business, 
consult the section Starting Business Without Business Manager (on page 120) to learn how to 
manually perform hosting operations that billing systems normally perform in Panel. 

In this chapter: 

Acquainting Yourself with the Panel Interface .................................................... 10 
Becoming Familiar with Business Manager ....................................................... 12 
Managing Your Profile ....................................................................................... 15 
Viewing Your Subscription Properties................................................................ 16 
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Acquainting Yourself with the Panel Interface 

When you log in to Parallels Plesk Panel, you see the Home page with a summary on 
allocated and used resources. 

The top banner area provides the following links: 

 A link with your name. Click this if you need to update your contact information. Find out 
more about updating contact information in the section Managing Your Profile (on page 15). 

 Log out. This is where you close your session when you have finished working with the 
Panel. 

 Help. This provides context-sensitive help with a search function. 

The navigation pane on the left provides access to the following sets of functions: 

 Home. This is where you start working with the Panel. On this page, you can see the 
following elements.  

 Overview. This widget contains information about your hosting package and provides 
links to the detailed information about available hosting resources and your 
permissions. The section Viewing Your Subscription Properties (on page 16) provides 
information that helps you understand the Panel resources and learn how to view the 
set of resources that you can use or sell. 

 My Subscriptions. This is where you see a list of your own websites hosted on the 
Panel server.  

 Customers. This is where you perform operations on customer accounts. Particularly, you 
can accomplish the following tasks from this page: 

 Create, modify, suspend, unsuspend, and remove user accounts. 

 View traffic usage reports. 

 Domains. This is where you view information about hosted websites and their domain 
names, and go to the Control Panel for managing them. 

 Subscriptions. This is where you manage customer subscriptions to your services. 
Subscription is a way a customer obtains services and resources provided by a service 
plan. 

 Service Plans. This is where you manage your service plans. Service plan is a set of 
resources and services provided to hosting service customers by means of subscriptions. 
There are also service plan add-ons that extend the amount of resources and services 
provided with a subscription. 

 Tools & Utilities. This is where you configure and manage system services, and view 
resource usage statistics. 

 Profile. This is where you fill in your contact information. Learn more about the contact 
information and other profile settings in the section Managing Your Profile (on page 15). 

 Change Password. This is where you change your password for logging in to the Server 
Administration Panel.  

 Interface Preferences. This is where you set interface language and skin. Learn more about 
changing Panel appearance in the section Changing Interface Settings. 
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If your provider uses Parallels Customer and Business Manager for billing their customers, 
there are more links in the left navigation pane. You can find a list of Business Manager 
functions available from Panel's navigation pane in the section Becoming Familiar with Business 
Manager (on page 12). 

To see information about a tool or an item on the page, place the mouse pointer over an item 
without clicking it, and a small tooltip box appears with supplementary information regarding 
that item. 

The main working area on the right provides access to the tools available for the section 
currently selected in the navigation pane. Additional operations are accessible from the More 
Actions menus. 

To navigate through Parallels Plesk Panel, you can use a path bar: a chain of links that 
appears in the right part of the screen, below the banner area. 

To return to a previous screen, use the shortcuts in the path bar, or the Up Level icon in the 
upper-right corner of the screen. 

To sort a list by a certain parameter in ascending or descending order, click on the 
parameter's title in the column heading. The order of sorting will be indicated by a small 
triangle displayed next to the parameter's title. 
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Becoming Familiar with Business Manager 

Business Manager simplifies the process of signing up, provisioning, and billing new 
customers according to the following scheme: 

1. In Business Manager, you set up service plans and add-ons corresponding to your 
service offerings and create online stores where you sell these plans. 

2. A user visiting your site selects one of your hosting plans and subscribes to the services. 

3. Business Manager processes the order. After the payment is received, it sets up a user 
account and subscription in Parallels Plesk Panel, and notifies the new customer by e-
mail. 

4. The customer logs in to Panel and starts using the web hosting, e-mail, and other 
services provided by subscription. 

5. Several days before the end of the billing period, Business Manager sends an invoice to 
the customer stating the account balance and due payment date. On the due date, 
Business Manager charges the due amount on the customer's card or bank account, or 
uses another payment collection scheme that you select. 

In addition to automated provisioning and billing, Business Manager offers the following 
advantages: 

 Support for integration with payment systems, domain name registrars, and certification 
authorities issuing SSL certificates. 

 Customizable online store. 

 Compliance with requirements for stores operating in the European Union countries. 

To learn what operations are available to you when Business Manager is integrated with your 
Panel, see the table below. 

Business Manager Navigation Pane 

If your Panel is connected to Business Manager, the Panel's navigation pane contains a set 
of links leading to Business Manager pages. Each of these links opens the corresponding 
page of Business Manager in the same window. To switch back to Panel, click the Back to 
Parallels Panel button at the top of Business Manager's navigation pane. 

When you are in Business Manager, you see the navigation pane that contains the same 
links plus the controls for managing you own hosting accounts in the My Account group. Find 
more information about these controls in the section Managing Your Account. 

Name Description Help link 

Business 
Operations menu 

Contains links for managing customer 
accounts and service subscriptions. 

 

Customers Add, suspend, and remove customer 
accounts, change customers' billing 
and contact information. Prepare 
invoices and collect payments. 

Administering Customers 
(on page 135) 
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Subscriptions View and change properties of 
service subscriptions. Move 
subscriptions to other service plans 
by upgrading and downgrading them. 

Managing Subscriptions 
(on page 149) 

Invoices View invoices for customer accounts. Managing Invoices and 
Payments (on page 163) 

To-do Items The purpose of the to-do items is to 
act as an automated reminder tool. 
Each task that you create will be 
listed until the action item is 
completed. For example, a To-Do 
task can be anything from reminding 
yourself to run by the accountant's 
office on Thursday to reminding you 
to create a website on a control panel 
because the control panel you are 
using does not support automation of 
that action. Tasks can be assigned to 
any users in the system. 

 

 

Business 
Monitoring menu  

Contains links for viewing accounting 
reports and working with invoices and 
payments. 

 

Accounting View accounting reports. Generating Accounting 
Reports (on page 176) 

Payments Monitor and complete payment 
operations.  

Viewing Transactions List 
(on page 169) 

Events View and manage system tasks 
scheduled for execution. 

Viewing and Running 
Scheduled Tasks (on page 
175) 

Reports View reports on orders, subscriptions, 
payments, transactions, and invoices. 

 

E-mails View a list of automatically sent e-
mails and resend them if needed. 

Setting Up Automatic E-
mails (on page 89) 

Business Setup 
menu 

Contains links for setting up Business 
Manager for serving your customers. 

 

Plans Set up and manage service plans for 
provisioning services to your 
customers. 

Plans and Add-ons (on 
page 112) 

Online Stores Create and manage online stores 
where customers can subscribe to 
your plans. 

Managing Online Stores 
(on page 71) 

Marketing Tools Set up discounts, coupons and 
affiliate programs to promote your 
plans. 

Promoting Your Plans (on 
page 133) 
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All Settings Set up all aspects of Business 
Manager and prepare it for serving 
customers. 

Starting Business with 
Business Manager (on 
page 51) 
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Managing Your Profile 

Your account in Panel stores your access credentials and contact information such as e-mail, 
address, and phone number. Depending on how you subscribed to a Panel reseller plan, you 
can choose your username and password yourself or receive them from your hosting 
provider. To change your account password, click the Change Password link in the navigation 
pane. Your username can only be changed by your provider. If you forget your password and 
cannot log in to Panel, click the Forgot Your Password? link on the login page. Then enter your 
username and the e-mail specified in your contact information into the corresponding fields. 
When you fill in this information, Panel will send your password to the specified e-mail 
address. 

If the contact details in your profile require updating, or you want to add or remove some of 
them, click the Profile link in the navigation pane or the link with your name at the top of the 
page and Panel will take you to a page where you can manage the details. 

Managing Your Account in Business Manager 

If you use Business Manager, your account contains more details. It includes information 
about invoices issued to you by your provider, billing accounts that you use to pay these 
invoices, and so on. The controls for viewing and managing details of your Business 
Manager account are located in the My Account group of the left navigation pane. The 
elements of this group allow you to do the following: 

 My Subscriptions. View a list of your reseller subscriptions and their properties, and 
request an upgrade or downgrade of a subscription. 

 My Invoices. View a list of invoices issued to you by your provider. 

 My To-do Items. View items that may require your attention. 

 My Billing Accounts. View and manage billing accounts - credit cards, bank accounts, and 
so on - that you use to pay for the hosting resources you purchase from your provider. 

 Go to Store. Open your provider's online store to subscribe to other reseller plans. 
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Viewing Your Subscription Properties 

The number of hosting resources and services available to you for reselling or to use for your 
own needs is defined by your reseller subscription. A subscription can limit the use of a 
resource to a certain value, for example, allow you to consume 75 GB of disk space. 
Alternatively, it can allow a resource to be used without limits. In addition, the subscription 
defines what services you can use and what server management actions you can perform: 
manage DNS zones, access application catalogs, and so on.  

To view the information about your subscription, click the My resources and permissions overview 
link on the Home page. 

The subsections of this section tell you more about reseller subscription properties: 

 Panel resources sold in reseller subscriptions: Section Viewing Resources (on page 17). 

 Permissions and services: Section Viewing Permissions (on page 19). 

 IP Addresses: Section Viewing IP Addresses (on page 20). 

 

In this section: 

Viewing Resources ............................................................................................ 17 
Viewing Permissions ......................................................................................... 19 
Viewing IP Addresses ....................................................................................... 20 
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Viewing Resources 

This section lists Panel resources included in reseller subscriptions. To view the resources 
allotted for your account, go to Home > My resources and permissions overview. 

Overselling policy  

Defines if you can sell more resources than allocated to you with the plan. If overselling is 
allowed, you are governed by actual resource usage instead of initial resource allocation. If 
overselling is prohibited, you can create only the number of service subscriptions limited to 
the total amount of disk space or traffic provided to you with your plan.  

Overselling is a marketing strategy based on the following scheme: a reseller, who was 
allotted, for example, ten gigabytes of disk space, allocates five gigabytes of disk space for 
each of their customers, assuming that none of them will actually use all of their allocated 
disk space.  

Domains 

The total number of subscriptions that you can create for your customers and for your own 
purposes. 

Subdomains 

The total number of subdomains that can be hosted within the subscription. 

Domain aliases 

The total number of additional alternative domain names that can be used for websites within 
the reseller subscription. 

Disk space 

The total amount of disk space that can be used by your own websites and sites of your 
customers. It includes disk space occupied by all files related to your reseller subscription: 
contents of websites, databases, applications, mailboxes, log files and backup files. 

Traffic 

The amount of data that can be transferred from the subscription's websites and FTP/Samba 
shares during a month.  

Additional FTP accounts 

The maximum number of FTP accounts used to access the files and folders hosted with a 
subscription. 

Databases (Unix hosting) 

The total number of databases that can be created on the Panel database servers and used 
by the subscription's websites. 
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MySQL databases and Microsoft SQL Server databases (Windows hosting) 

The maximum number of MySQL and Microsoft SQL Server databases respectively that can 
be created on the database servers registered in the Panel and used by websites hosted 
with the subscription. 

MySQL databases quota and Microsoft SQL databases quota (Windows hosting) 

The maximum total amount of disk space (in megabytes) that the MySQL and Microsoft SQL 
Server databases respectively can occupy. 

Mailboxes 

The total number of mailboxes that can be hosted within the subscription. 

Mailbox size  

The maximum amount of disk space that can be allocated to a mailbox for storing e-mail 
messages and auto-reply attachment files. You will not be able to specify the bigger mailbox 
size in your service plans. 

Mailing lists 

The total number of mailing lists that can be hosted with the subscription. 

Customers 

The maximum number of customer accounts that you can create and serve. 

Web users 

The total number of personal web pages that can be hosted on the websites within 
subscription. This service is mostly used in educational institutions that host non-commercial 
personal pages of their students and staff. These pages usually have addresses like 
http://example.com/~webuser. 

Java applications 

The total number of Java applications or applets that can be hosted on websites within the 
subscription  

Sites published with Web Presence Builder 

The total number of websites that can be created, published, and then edited with Web 
Presence Builder. 

Mobile sites 

The total number of websites that can be hosted with the UNITY Mobile online service, which 
optimizes sites for viewing on mobile devices. 
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FrontPage accounts (Windows hosting) 

The maximum number of Microsoft FrontPage accounts that can be used within the 
subscription. 

Shared SSL links (Windows hosting) 

The total number of shared SSL links that can be used within the subscription. 

IIS application pools (Windows hosting) 

The total number of dedicated IIS application pools that can be allocated for websites 
created within the reseller subscription. 

ODBC connections (Windows hosting)  

The total number of ODBC connections that can be used within the subscription. 

ColdFusion DSN connections (Windows hosting) 

The total number of ColdFusion DSN connections that can be used within the subscription. 

Viewing Permissions 

Your permissions either denote the operations available to you as a reseller in the Panel, or 
define which services and privileges can be enabled in the subscriptions of your customers. 
If a particular permission in your reseller subscription is set to Off, then a service subscription 
will not provide the corresponding service or a privilege. A disabled permission also means 
that you are prohibited to perform the designated action in the Control Panel. For example, if 
your subscription does not provide a privilege to use Scheduler (Scheduler management is Off), 
then none of your subscribers will be able to use it, and neither will you. 

Reseller-specific privileges (the ones that do not affect service subscriptions you create for 
your customers) are as follows: 

 Subscription creation in Server Administration Panel and domain creation in Control Panel. Shows 
whether you can create hosting service subscriptions, add domains, create websites, and 
set up web forwardings. 

 Ability to use API RPC. Shows whether you can remotely manage Web sites through 
custom applications. The remote API is an interface that can be used for developing 
custom applications integrated with Web sites, which could be used, for instance, for 
automating setup of hosting accounts and provisioning of services for customers 
purchasing hosting services from your site. To learn more, refer to the Parallels Plesk Panel 
11.0: API RPC Protocol Reference. 

 Access to the Panel. Shows that you can use the Panel graphical user interface. 

 Customer account creation. Lets you create user accounts and subscriptions for your 
customers in the Panel. 

 Allow overselling. Lets you set up oversell policy, meaning that you yourself can define if 
overselling is allowed to you or not. 
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Overselling allows you to sell more resources than is allocated with a plan. If overselling 
is allowed, a reseller is governed by actual resource usage instead of initial resource 
allocation. Overselling is a marketing strategy based on the following scheme: a reseller, 
who was allotted, for example, ten gigabytes of disk space, allocates five gigabytes of 
disk space for each of their customers, assuming that none of them will actually use all of 
their allocated disk space.  

Meanings of the other permissions are the same as in the service subscriptions (on page 
35).  

To view the full list of your subscription permissions, go to Home > My resources and 
permissions overview > Permissions tab.  

Viewing IP Addresses 

To view the IP addresses included in your hosting package, go to Tools & Utilities > IP 
Addresses. Your IP addresses are listed and the following supplementary information is given: 

 An icon in the S (Status) column shows  if your IP address is properly configured on 
the network interface. If your IP address was removed from the network interface by your 

provider, an icon will show . 

 An icon in the T (Type) column shows  if you were allotted a dedicated IP address, and 

 if the address is shared among other customers of your service provider. A dedicated 
IP address is not used by other users, so you can use it to host either: 

 A single e-commerce website secured with Secure Sockets Layer encryption.  

or 

 A number of websites that do not need Secure Sockets Layer encryption. 

Note: Shared IP addresses should be used for hosting only non e-commerce websites. 

 The Certificate column shows which SSL certificate (for what domain name) is tied to an 
IP address. 

 The FTP over SSL column (on Windows-based servers) shows whether it is possible to use 
secure FTP connection (FTP over SSL) on one of the domains hosted on this IP address. 

 The Hosting column shows a number of websites hosted on an IP address. To view the 
domain names of these websites, click the number in the Hosting column. 

You can perform the following operations on IP addresses: 

 Change IP allocation type. You can mark your IP addresses as shared or dedicated 
before you use them for hosting websites. This allows the Panel to distinguish between 
them and to not let you use a dedicated IP address for several customers at once. A 
dedicated IP address can be used in subscriptions of a single customer, while a shared 
IP address can be shared among different customers' subscriptions. Note that SSL 
protection with authentic digital certificates and Anonymous FTP services are available 
only to a dedicated hosting account on a dedicated IP address. Shared hosting accounts 
can also have SSL protection, but visitors of such protected sites will receive error 
messages in their browsers. 

 Assign an SSL certificate to an IP address. This will assign the selected SSL certificate to 
all websites hosted on that IP address. 



 

 Becoming Familiar with Parallels Panel 21 

 

 Select a default website. Because users can refer to a web resource on your server by 
typing an IP address and there can be several websites hosted on that address, the 
Panel needs to know which of the sites to show in such cases. The Panel automatically 
assigns the first website created on an IP address as the default website; however, you 
can select any other website and make it default. 

 To change an IP address allocation type (shared, dedicated), assign another 
SSL certificate to an IP address, or select the default website: 

1. Go to Tools & Utilities > IP Addresses, and click the IP address you need. 

2. Make the required changes, and click OK. 

 

 



 

  
 

This chapter describes how to select Panel's interface language, rebrand Panel, and 
add links to external sites or web applications. 

Change Interface Language 

In addition to English, Panel can be viewed in the following languages: 

 Chinese (traditional and simplified) 

 Dutch 

 French 

 German 

 Italian 

 Japanese 

 Polish 

 Portuguese 

 Russian 

 Spanish 

If you want to switch Panel to any of these languages, go to My Profile > Interface 
Preferences. 

When you switch to a language different from English, some button captions may 
become too long and corrupt the Panel layout. To prevent this, you can specify a limit 
on button caption length. In this case, the system will automatically shorten button 
captions longer than this limit and end them with an ellipsis (...).To define the caption 
length limit, enter its value in the Button label length field in My Profile > Interface 
Preferences. To disable automatic shortening, clear this field. 

Add Branded Content 

To disguise the fact that you are reselling another company's hosting resources, you 
can add your own branded content to Panel. Specifically, this content may be the 
following: 

 The logo in the top left corner. Upload your own logo and your customers will see this 
instead of the original Panel logo in the Control Panel. Use a GIF, JPEG, or PNG 
file for your logo, preferably not larger than 100 kilobytes to minimize the download 
time. To ensure that your logo will fit into the top area, we recommend that you use 
an image 50 pixels in height. 

 The URL to which the logo points. Make your logo a clickable link that points to your 
company's website to let your customers easily open the website any time they are 
in the Control Panel. 
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 The pages title. Let your customers see your company name or other relevant text in 
their browsers' title bars when they work in the Control Panel. 

To change any of these settings, go to Tools & Utilities > Panel Branding. 

Add Links to Websites and Applications 

If you want to have quick access from Panel to certain websites and applications, or 
wish to provide your customers with such access, create custom buttons. The buttons 
may lead to web resources, such as your corporate site, or to a web application that 
can process online requests and accept additional information about the users clicking 
the buttons. You can place these buttons on your Home page for yourself or in the 
Control Panel for your customers. 

You can place the buttons in the following locations of the Server Administration Panel 
and the Control Panel, and decide who should be able to see them: 

 On the Home page in the Server Administration Panel, visible only to you. This is 
achieved by selecting the Reseller's Home page option in the button properties. 

 On the Home tab in the Control Panel, visible to the hosting service customers and 
their users who are allowed to log in to the Control Panel. This is achieved by 
selecting the Customer's Home page option in the button properties. 

 On the Websites & Domains tab in the Control Panel, visible to the hosting service 
customers and their users who are allowed to log in to the Control Panel. This is 
achieved by selecting the Websites & Domains page of Subscription option in the button 
properties. 

 On the Home page in the Server Administration Panel and Control Panel, visible to 
you and your customers. This is achieved by selecting the Common access option in 
the button properties. 

You can specify what information about users should be passed: 

 Subscription ID. 

 Primary domain name associated with a subscription. 

 FTP account username and password. 

 Customer's account ID, name, e-mail, and company name. 

 To add a custom hyperlink button to the Server Administration Panel or 
the Control Panel: 

1. Go to Tools & Utilities > Custom Buttons (in the Panel Management group), and 
click Create Custom Button. 

2. Specify the following properties of the button: 

 Type the text that will show on your button in the Button label box. 

 Choose the location for your button. 

 Specify the priority of the button. Your custom buttons will be arranged in the 
Panel in accordance with the priority you define: the lower the number, the 
higher the priority. Buttons are placed in the left-to-right order. 
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 To use an image for a button background, click Browse to browse for the desired 
file. It is recommended that you use a 16x16 pixel GIF or JPEG image for a 
button to be placed in the navigation pane, and a 32x32 pixels GIF or JPEG 
image for a button placed in the main frame. 

 Type the hyperlink to be attached to the button into the URL box. 

 Using the checkboxes, specify whether you want the customer information and 
other data to be transferred within the URL. These data can be used for 
processing by external web applications. 

 In the Tooltip text input field, type in the help tip that will be displayed when users 
place the mouse pointer over the button. 

 Select the Open URL in Parallels Panel checkbox if you want the destination URL to 
be opened in the main frame of the Panel; otherwise, leave this checkbox 
cleared to open the URL in a separate browser window or tab. 

 If you want to make this button visible only to you, select the Show to me only 
checkbox. 

3. Click Finish to complete creation. 

To remove a custom button from the Panel, go to Tools & Utilities > Custom Buttons (in 
the Panel Management group), select the corresponding checkbox and click Remove. 

 



 

  
 

When you start your hosting reselling business, you should define how you will offer 
your hosting resources and services to customers. Parallels Plesk Panel lets you 
organize your business by means of service plans and subscriptions. 

A service plan is a combination of hosting resources that you sell to your customers. 
For example, a plan can provide customers with the web hosting service, five gigabytes 
of disk space on the server, and ten gigabytes of data transfers each month.  

There are also add-on plans that let you offer additional resources and services to 
subscribers, such as, for example, an additional gigabyte of disk space. 

When customers want to host a website on a Panel-managed server, they subscribe to 
a plan that offers the resources they need. In other words, a subscription is a set of 
resources defined by a plan and available to a certain customer. 

To learn more about service plans and subscriptions in Panel, refer to the section 
Understanding Service Plans and Subscriptions (on page 27). 

Organizing your offerings into service plans is only one of the many steps required to 
get your business ready to run. Before you can start serving customers, you should 
also think about how potential customers will find your offerings, how you will subscribe 
new customers and take payments, and other aspects of your business. To start your 
business more easily, you can use automation solutions that carry out different routines 
for you, for example, issue invoices and take payments from customers. 

The automation tools included in your reseller package by your hosting provider define 
whether you will be able to automate certain business routines. Specifically, you may 
be provided with one of the following options: 

 Parallels Parallels Customer and Business Manager. 

The solution that provides the most complete automation of a hosting business on 
Panel-managed servers is Parallels Customer and Business Manager. Business 
Manager is completely integrated with Panel and automates a number of your 
business routines. For example, a typical workflow with Business Manager looks as 
follows: When a new customer subscribes to a plan in your online store, Business 
Manager creates an invoice. After the customer pays the invoice, Business 
Manager automatically creates a Panel account and subscription for the customer, 
enabling the latter to create a website. 

However, if you run your business with Business Manager, you still have to carry 
out some administrative tasks manually, for example, editing customer accounts or 
changing subscription properties. 

To learn more about how to get Business Manager ready to serve your business 
and how to perform certain tasks in Business Manager manually, refer to the 
section Starting Business with Business Manager (on page 51). 
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 Third-party automation solution. 

Alternatively, your hosting provider can offer you a third-party hosting business 
automation solution. In this case, learn how to automate certain routines in the 
appropriate documentation. 

 No automation solution. 

Your hosting package may include Panel without any automation solution at all. In 
this case, you will not be able to automate tasks that require interaction with Panel, 
for example, creating customer accounts and subscriptions. The section Starting 
Business Without Business Manager (on page 120) tells you how to get ready to start your 
business in Panel without hosting automation solutions.  

In this chapter: 

Understanding Service Plans and Subscriptions ................................................27 
Starting Business with Business Manager .........................................................51 
Starting Business Without Business Manager ....................................................120 
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Understanding Service Plans and 
Subscriptions 

Service plans define what resources you offer to your customers. The properties of a service 
plan in Panel define which server hosting resources are available to plan subscribers. The 
section Properties of Hosting (Add-on) Plans and Subscriptions provides a complete list of Panel 
server resources and services that you can include in your hosting plans. 

Allocation of Resources and Services 

Service plans define potential services; the Panel does not check if a service or a resource 
that a service plan should provide is actually available, whether in the system in general or in 
your reseller subscription. For example, when creating a plan, you can choose to allow 
subscribers to connect to the server shell over SSH even if your subscription does not 
provide the Management of access to the server over SSH privilege. In such a case, the Panel will 
let you do this and will show no error or warning messages. 

Subscriptions provide actual resources and services that are allocated during the creation of 
each subscription. 

Relations Between Subscriptions and Service/Add-on Plans 

Normally, a subscription is associated with a service plan, and this association is reflected in 
a list of subscriptions: each subscription name contains the service plan name in 
parentheses at the end. The amount of resources and services provided with a subscription 
can be extended by associating the subscription with add-on plans. A subscription can be 
associated with several add-ons, but each add-on can be added to the subscription only 
once. 

It is also possible to have subscriptions that are not associated with any service plans or add-
on plans. We call such subscriptions custom subscriptions, and their names are extended 
with "(Custom)" in the list of subscriptions. Having a custom subscription may be useful if you 
want to provide services on specific terms that differ from the usual offerings in your business 
model. 

At any time, you can change the association between a subscription and plans in the 
following ways: 

 Associate the subscription with another service plan. 

 Add and remove add-on plans. 

 Remove the subscription association with the service plan and add-ons. 
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Syncing Service Plans and Subscriptions 

When you change the properties of a service plan, Panel automatically applies the changes 
to all subscriptions to this plan. If you want to prohibit automatic updating of a certain 
subscription, you can lock this subscription. To learn how to configure the synchronizing (or 
syncing) of your plans with subscriptions, see the section Syncing Subscriptions and Plans (on 
page 50). 

In this section: 

Properties of Hosting Plans, Add-ons and Subscriptions ................................... 29 
Syncing Subscriptions and Plans ...................................................................... 50 
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Properties of Hosting Plans, Add-ons and Subscriptions 

Properties of a hosting plan and subscription are grouped as follows: 

 Resources 

Includes validity period, policy on overusing resources, system resources like disk space 
and traffic, and service resources like websites, subdomains, mailboxes, databases and 
so on. 

 Permissions 

Includes provided services and privileges. 

Note: Some permissions prevent settings of the following services from syncing (on page 
50). See the details in the Permissions section (on page 35). 

 Hosting Parameters  

Includes parameters of the provided hosting service.  

 Mail 

Includes parameters of the provided mail service. 

 DNS 

Specifies if the DNS zones of the subscription's domains should be master or slave. 

Note: In case the DNS zone management privilege is provided, this parameter is not synced, 
and subscribers can set up this parameter on a per-domain basis. 

 Performance 

Includes parameters that affect performance of all services provided with the plan. 

 Logs & Statistics 

Includes settings of how statistics and logs of the plan's subscriptions should be stored. 

Note: Hosting, Mail, DNS, Performance, Logs & Statistics parameters are fully visible and editable 
in the Administrative Panel only for service plans. For subscriptions, these parameters are 
available only in the Control Panel. To view or modify the parameters of a particular 
subscription, go to Subscriptions and click Control Panel to the right of the subscription name. 
Also note that the availability of these parameters to a subscriber depends on the 
permissions. 

 Applications 

Lets you select which applications available to you should be provisioned to your 
customers. 
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In this section: 

Visibility of Hosting Features in the Control Panel ............................................. 31 
Resources ......................................................................................................... 31 
Permissions ....................................................................................................... 35 
Hosting Parameters ........................................................................................... 39 
Mail ................................................................................................................... 47 
DNS .................................................................................................................. 48 
Performance ...................................................................................................... 48 
Logs & Statistics ................................................................................................ 49 
Applications ....................................................................................................... 49 
Additional Services ............................................................................................ 49 
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Visibility of Hosting Features in the Control Panel 

Since version 10.4, Panel hides from customers those hosting features that are not provided 
in their subscription. The visibility of GUI elements responsible for a certain feature is 
determined by permissions and resource limits of a subscription. Note that when you (as the 
administrator) log in to the customer's Control Panel, you see GUI elements regardless of 
customer's permissions. The table below explains GUI visibility logic. 

 
Visible to a 
Customer 

Visible to the 
Administrator 

Resource Limit > 0 

Permission = True 

Yes Yes 

Resource Limit > 0 

Permission = False 

No Yes 

Resource Limit = 0 

Permission = True 

No No 

Resource Limit = 0 

Permission = False 

No No 

For example, when the number of Domains in a subscription is 10 and the Domains management 
permission is off, a customer does not see the Add New Domain button in the Control Panel. 
Nevertheless, this button is available to the administrator that logs in to the customer's 
Control Panel. 

Resources Without Numerical Limits 

If the resource type is logical or in other words, it can be just switched on or off (say, a 
scripting language support), its visibility is controlled by a certain permission only. For 
example, if the Hosting settings management permission is granted, a customer is able to toggle 
the support of various scripting languages for their site. If the permission is not granted, the 
customer sees the list of languages that are switched on for their site in the read only mode. 
The disabled languages are not shown in the list. 

Resources 

Resources (located at Service Plans > select a plan > Resources tab) define what system 
resources are provided with the subscription. 
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Overuse policy  

Defines what happens if the subscription's usage of disk space and traffic reaches limit 
values: 

 Overuse is not allowed will suspend the subscription only if you select the checkbox Suspend 
subscription when its disk space or traffic usage goes beyond the limit. If you do not select it, 
websites will not be suspended; only a notice will be sent to the subscribers.  

You can set up sending of notifications as soon as usage of disk space or traffic reaches 
a particular value (the Notify upon reaching options), in order to prevent subscriptions from 
suspension. The notifications will be sent according to the server notifications policy. 

 Overuse is allowed will let the subscription operate properly. 

The option When limit on usage of a resource is reached, send e-mail according to the server 
notification settings triggers sending notifications according to the server notifications 
policy. 

Note: The overuse policy does not apply to the limits set on size of mailboxes. Therefore, 

even if you enable overuse, be sure to allocate enough disk space to mailboxes. 

Disk space 

The total amount of disk space allocated to the subscription. It includes disk space occupied 
by all files related to the subscription: content of websites, databases, applications, 
mailboxes, log files, and backup files. 

Traffic 

The amount of data that can be transferred from the subscription's websites and FTP/Samba 
shares during a month.  

Notify upon reaching 

Available only if overuse is not allowed. This sets the soft quota for disk space or traffic 
usage in order to prevent subscriptions from suspension. When the quota is reached, the 
Panel sends notifications to users' e-mail addresses specified in Settings > Notifications: 
Resource usage limits exceeded by subscription. 

Sites published with Web Presence Builder 

The number of websites that can be published with Web Presence Builder. 

Domains 

The total number of domain names that the subscriber will be able to host within the 
subscription. This includes websites, web forwarding configurations that point to websites 
hosted on other servers, and domain names on which a website or web forwarding is not yet 
set up (domains with no hosting).  

Mobile sites 

The total number of websites that can be hosted with the UNITY Mobile online service, which 
optimizes sites for viewing on mobile devices. UNITY Mobile hosts the optimized site copies 
on their own servers. 
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How it works: 

1. A user creates a website with the domain name example.com and clicks the link Create 

Mobile Site in the Control Panel. 

2. The user is prompted to specify a domain name for access to the mobile site copy. The 

user specifies mobile.example.com. 

3. The Panel connects to the UNITY Mobile hosting servers, sets up an account with UNITY 

Mobile for the domain name mobile.example.com. 

4. The user’s browser opens the UNITY Mobile website, where the user is automatically 
logged in to their account and prompted to import their website from the Panel-managed 
server. 

5. After the site is imported and optimized for mobile viewing, it becomes accessible by the 
address mobile.example.com. The Panel’s DNS server keeps a CNAME record pointing 
to the site on a UNITY Mobile server. 

The user can now perform the following operations on mobile site using links in the 
Control Panel: 

 Open site editor. 

 Change mobile site name. 

 Remove mobile site. 

For more information about UNITY Mobile services, visit their website at 
http://www.unitymobile.com. 

For instructions on managing mobile sites through the Control Panel, refer to the Customer's 
Guide, section Setting Up Mobile Sites. 

Subdomains 

The total number of subdomains that the subscriber will be able to host within the 
subscription. 

Domain aliases 

The total number of additional alternative domain names that the subscriber will be able to 
use for their websites. 

Mailboxes 

The total number of mailboxes that the subscriber can host within the subscription. 

Mailbox size 

The amount of disk space that is allocated to each mailbox in a subscription for storing e-mail 
messages and auto-reply attachment files. 

Total mailboxes quota (available only for Windows hosting) 

The total amount of disk space in megabytes available for all mailboxes within the 
subscription. 

 

http://www.unitymobile.com/
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Mailing lists 

The total number of mailing lists that the subscriber can host within the subscription. 

Additional FTP accounts 

The maximum number of FTP accounts used to access the files and folders created within a 
subscription. This number does not include an account that is always created during the 
subscription creation. 

Databases (Unix hosting) 

The total number of databases that can be created on the Panel database servers and used 
by the subscription's websites. 

MySQL databases and Microsoft SQL Server databases (Windows hosting) 

The maximum number of MySQL and Microsoft SQL Server databases respectively that can 
be created on the Panel database servers and used by the subscription's websites. 

MySQL databases quota and Microsoft SQL databases quota (Windows hosting) 

The maximum amount of disk space (in megabytes) that the subscription's MySQL or 
Microsoft SQL Server databases can occupy respectively. 

Validity period/Expiration Date 

The term for a subscription.  

In service plan properties, it is Validity period: it is used only when a subscription is created: 
the Panel derives the subscription expiration date from it.  

In subscription properties, it is Expiration date: At this date, the subscription will be suspended, 
meaning that all sites within the subscription will be suspended, their Web, FTP and mail 
services will no longer be accessible to the Internet users, and the subscriber and their users 
will not be able to log in to the Control Panel.  

Subscriptions are not renewed automatically, so to bring a subscription's services back to 
operation, you will need to manually activate the subscription (on page 158). 

Java applications 

The total number of Java applications that can be hosted on the subscription's websites. 

Web users 

The total number of personal Web pages that the subscriber can host for other users under 
their websites. This service is mostly used in educational institutions that host non-
commercial personal pages of their students and staff. These pages usually have addresses 
like http://example.com/~webuser. 
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FrontPage accounts (Windows hosting) 

The maximum number of Microsoft FrontPage accounts that the subscriber can create within 
the subscription. 

Shared SSL links (Windows hosting) 

The total number of shared SSL links that the subscriber can use within the subscription. 

ODBC connections (Windows hosting)  

The total number of ODBC connections that the subscriber can use within the subscription. 

ColdFusion DSN connections (Windows hosting) 

The total number of ColdFusion DSN connections that the subscriber can use within the 
subscription. 

Permissions 

Permissions (located at Service Plans > select a plan > Permissions tab) define what privileges 
and services are provided with the subscription.  

DNS zone management 

Allows the subscriber to manage the DNS zones of their domains. 

Note: If this permission is granted, then the DNS service settings are not synced. 

Hosting settings management 

Allows modifying parameters of hosting service provided with the subscription: changing 
hosting account features and switching on or off support for programming and scripting 
languages, custom error documents, SSL support, and (Windows only) Microsoft FrontPage 
support. In addition, it allows you to toggle the following permissions: Hosting performance 
settings management and Common PHP settings management. 

Note: If this permission is granted, then the mentioned hosting parameters are not synced. 

Common PHP settings management 

Allows the subscriber to adjust common PHP settings individually for each website 
(subdomain) in their subscription.  

Note: If this permission is granted, then the common PHP settings are not synced. 

Setup of potentially insecure web scripting options that override provider's policy. Allows the 
subscriber to override the hosting security policy, if it is applied by the provider. 
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Management of access to server over SSH (Linux\Unix hosting)  

Allows the subscriber to access the server shell over SSH under their system user account. 
Also, lets the subscriber set up such hosting parameter as SSH access to server shell under the 
subscription's system user. 

Note: If this permission is granted, then the mentioned hosting parameter is not synced. 

Management of access to server over Remote Desktop (Windows hosting) 

Lets the subscriber access the server via Remote Desktop protocol.  

Anonymous FTP management 

Provides the anonymous FTP service, which lets the subscriber set up a directory shared 
over FTP protocol and available to anonymous users. A subscription should reside on a 
dedicated IP address in order to provide this service. 

Scheduler management 

Allows the subscriber to schedule running of scripts or utilities. 

Spam filter management 

Lets the subscriber customize filtering settings of the SpamAssassin spam filter. 

Antivirus management 

Lets the subscriber change settings of the server-side protection of incoming and outgoing 
mail from viruses. 

Data backup and restoration using the server repository 

Lets the subscriber back up and restore their websites, and use the storage on the server for 
keeping backups. 

Data backup and restoration using a personal FTP repository  

Lets the subscriber back up and restore their websites, and use external FTP servers for 
storing their backups. 

Web statistics management 

Lets the subscriber select which Web statistics engine should be used, and whether reports 
should be accessible via a specific password-protected directory. 

Note: If this permission is granted, then the mentioned hosting parameter is not synced. 
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Log rotation management 

Lets the subscriber adjust the cleanup of processed log files for his or her sites. Also, lets the 
subscriber remove log files. 

Note: If this permission is granted, then the Logs & Statistics parameters (on page 49) are not 
synced. 

Access to Application Catalog 

Provides the subscriber with access to prepackaged applications that can be installed on 
websites. If you select this option, be sure to select the PHP support checkbox on the Hosting 
Parameters tab. 

You can view a list of applications available from your provider by doing the following: 

1. Set up your own website by using a plan or a custom subscription that grants access to 
the Application Catalog. 

2. Go to the Server Administration Panel > Subscriptions, and click the Control Panel link 
corresponding to your domain name. The Control Panel will open in a new browser 
window or tab. 

3. In the Control Panel, go to the Applications tab > All Available Applications. 

There is also a page in the Server Administration Panel, where you can view and update 
installed applications, and purchase license keys for commercial applications at Parallels 
Online Store: Tools & Utilities > Application Vault. 

For instructions on installing applications and license keys, refer to the Customer's Guide, 
section Installing Applications. 

Domains management 

Lets the subscriber add domains, create websites and set up web forwarding. 

Subdomains management 

Lets the subscriber set up additional websites accessible by <subdomain>.<domain> 
addresses. 

Domain aliases management 

Lets the subscriber set up additional alternative domain names for their websites. 

Additional FTP accounts management 

Lets the subscriber manage FTP accounts for accessing the subscription's files and folders. 

Java applications management 

Lets the subscriber install Java applications on their websites. 
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Mailing lists management 

Lets the subscriber use mailing lists provided by the GNU Mailman software. 

Note: If this permission is granted, then the Enable mailing lists parameter (on page 47) is not 
synced. 

Hosting performance settings management 

Allows the subscriber to adjust performance PHP settings individually for each website 
(subdomain) in their subscription. In addition, lets the subscriber set up the limits on 
bandwidth usage and number of connections to their websites. 

Note: If this permission is granted, then the following settings are not synced: PHP 
performance settings, performance settings (on page 48) for bandwidth usage and the number 
of connections. 

IIS application pool management (Windows hosting) 

Provides the subscriber with a dedicated IIS application pool and the means to manage it: 
enable or disable it, and set up the maximum amount of CPU power that the pool may use. 

Note: If this permission is granted, then the Logs & Statistics parameter (on page 49) called 
Use dedicated pool is not synced. 

Additional write/modify permissions management (Windows hosting) 

Lets the subscriber toggle such a hosting parameter as Additional write/modify permissions. 
These permissions are required if a subscriber's web applications use a file-based database 

(like Jet) located in the root of httpdocs folder. Please note that selecting this option might 

seriously compromise the websites' security. 

Note: If this permission is granted, then the mentioned hosting parameter is not synced. 

Shared SSL management (Windows hosting) 

Provides the shared SSL service, and lets the subscriber set up shared SSL links for their 
websites within the subscription.  

Hard disk quota assignment 

Lets the subscriber set up such hosting parameter as Hard disk quota. 

Note: If this permission is granted, then the mentioned hosting parameter is not synced. 

Database server selection 

Lets the subscriber select a database server of each type for creating their databases, as 
opposed to always using the default database server. 

 



 

 Setting Up Your Hosting Offers 39 

 

Access to advanced operations: Website Copying and Website Maintenance Mode 

Specifies whether the website copying and maintenance mode are available to the 
subscriber in the Control Panel > Websites & Domains >  Show Advanced Operations. If denied, the 
Website Copying and Website Maintenance Mode links are not available to the subscriber.  

Password-protected directories management 

Specifies whether the protected directories feature is available to the subscriber in the Control 
Panel > Websites & Domains >  Show Advanced Operations. If denied, the Password-protected 
directories link is not available to the subscriber.  

Ability to manage auxiliary user accounts 

Specifies whether the subscriber can manage auxiliary user accounts on the Control Panel > 
Users tab. If denied, the Users tab is not available to the subscriber.  

Allow activating APS apps using license keys from the Panel license pool 

If granted, users will be able to install certain APS apps without the need to purchase app 
licenses from vendors. In this case, app license keys will be taken from the Panel license 
pool. Note that you cannot limit the number of app installations a user is allowed to perform. 
This permission is relevant only if your Panel license comes in a bundle with APS app 
licenses. Learn more about license bundles. 

Hosting Parameters 

These parameters define the hosting service provided with the plan. The parameters can be 
found in Service Plans > select a plan > Hosting Parameters tab. 

Note: Unless specifically noted, the parameters are not synced if the Hosting management 
permission is selected. 

Enable hosting 

Defines if the hosting service is actually provided with the plan. 

Clear this option to make up a service plan that provides only mail service. Subscribers of 
such a plan will be able to have 'domains without hosting' which will serve mailboxes. 

Hard disk quota 

Hard quota imposed on disk space in addition to the soft quota (set with the option Notify upon 
reaching (on page 31)). Hard disk quota will not allow writing more files to the web space 
when the limit is reached: users will get an "Out of disk space" error at an attempt to write 
files. 

Note: (Linux/Unix hosting) Confirm that your operating system supports hard disk quota 
before you set any value other than Unlimited. In case you define a hard quota when it is not 
supported, you will get a synchronization conflict on all the plan's subscriptions. 
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SSL support 

Allows setting up SSL encryption on websites hosted within the subscription. 

Web statistics 

Selects a statistics engine that will create reports on how the subscription's websites are 
visited: how many people visited a site, and which web pages they viewed. 

The accessible via password protected directory /plesk-stat/webstat option allows a subscriber view 
website statistics at URLs like https://example.com/plesk-stat/webstat using their system 
user account login and password. 

Note: This parameter is not synced if the Web statistics management permission is selected. 

Custom error documents 

Allows subscribers to design and use their own error pages that the web server returns with 
HTTP error codes. 

SSH access to server shell under the subscription's system user (Linux/Unix hosting) 

Allows subscribers to upload securely web content to the server through SSH.  

Note: This parameter is not synced if the Management of access to server over SSH permission is 
selected. 

Scripting 

Support for programming and scripting languages that should be interpreted, executed or 
otherwise processed by a web server: Microsoft ASP.NET framework, PHP hypertext 
preprocessor (PHP), Common Gateway Interface (CGI), Perl, Python, Fast Common 
Gateway Interface (FastCGI), Microsoft or Apache Active Server Pages (ASP), Server Side 
Includes (SSI), ColdFusion, and Miva scripting required for running Miva e-commerce 
solutions. 

To learn more about adjustable PHP settings, see the section PHP Settings. 

Additional write/modify permissions (Windows hosting) 

This option is required if subscriber's web applications use a file-based database (like Jet) 

located in the root of httpdocs folder. Please note that selecting this option might seriously 

compromise the Web site security. 

Allow web users to use scripts  

Allows scripting at web pages available at URLs like 
http://example.com/~<username>/<webpage>, where <username> refers to a web user.  

Web users are individuals who do not need their own domain names. This service is popular 
with educational institutions that host non-commercial personal pages of their students and 
staff. 
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FrontPage support (Windows hosting). The options in the FrontPage support group allow 
subscribers to connect to the server and create websites with Microsoft Frontpage. 

In this section: 

PHP Settings ..................................................................................................... 42 
Customizing PHP Configuration ........................................................................ 44 
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PHP Settings 

Choose one of the following PHP handlers at Hosting Parameters > PHP handler type taking into 
consideration resources consumption and security aspects of each option: 

 
 

Performance 
 

Memory 
Usage 

Security 
 

Apache 
module (Linux 
only) 

High. 

Runs as a part of the 
Apache web server. 

Low This handler (also known as mod_php) is the least secure 
option as all PHP scripts are executed on behalf of the 

apache user. This means that all files created by PHP 

scripts of any plan subscriber have the same owner 

(apache) and the same permission set. Thus, there is a 

theoretical possibility that some users will try to affect files of 
another users or some important system files. 

Note: You can evade some security issues by turning 
the PHP safe_mode option on. It disables a number of 
PHP functions that bring potential security risk. Note 
that this may lead to inoperability of some web apps. 
The safe_mode option is considered to be obsolete 
and is deprecated in PHP 5.3. 

ISAPI 
extension 
(Windows 
only, not 
supported 
since PHP 
5.3) 

High. 

Runs as a part of the 
IIS web server. 

Low The ISAPI extension can provide site isolation in case a 
dedicated IIS application pool is switched on for 
subscriptions. Site isolation means that sites of different 
customers run their scripts independently. Thus, an error in 
one PHP script does not affect the work of other scripts. In 
addition, PHP scripts run on behalf of a system user 
associated with a hosting account. 

Note: The ISAPI extension handler is not supported 
since PHP 5.3. 

CGI 
application 

Low. 
Creates a new 
process for each 
request and closes it 
once the request is 
processed. 

Low The CGI handler provides PHP script execution on behalf of 
a system user associated with a hosting account. On Linux, 
this behavior is possible only when the suEXEC module of 
the Apache web server is on (default option). In other case, 

all PHP scripts are executed on behalf of the apache user. 

We recommend that you use the CGI application handler only 
as a fall-back. 

FastCGI 
application 

High (close to 
Apache module and 
ISAPI extension). 

Keeps the 
processes running to 
handle further 
incoming requests. 

High The FastCGI handler runs PHP scripts on behalf of a system 
user associated with a hosting account.  

Note: Switching PHP from Apache module to FastCGI application may break functionality of 

existing PHP scripts. 
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Additionally, on Windows systems, you are able to specify a certain PHP version for a service 
plan: 

 Version 4.x is outdated, you should use it only if you need to host some old PHP 
application versions. 

 Version 5.x is current and its use is recommended. 

 

Since Panel 10.4, you have the ability to adjust PHP configuration individually for each 
hosting plan or subscription. For this purpose, Panel exposes a number of PHP configuration 
settings on the PHP Settings tab. To learn more about custom per-subscription PHP 
configuration, refer to the section Customize PHP Configuration. 
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Customizing PHP Configuration 

PHP is one of the most popular scripting languages for creating dynamic web pages. The 
majority of today's websites and web applications are based on PHP scripts. Thus, site 
administrators should understand how they can control the execution of PHP scripts. 
Typically, PHP behavior is defined by a number of configuration settings. These settings 
specify various script execution aspects, like performance (for example, the amount of 
memory a script can use), security (for example, access to file system and services), and so 
on. Administrators might want to adjust these settings for a number of reasons: 

 Preventing a memory leak or server hang-up by poorly written scripts. 

 Protecting data from malicious scripts. 

 Meeting the requirements of a certain web app. 

 Testing own scripts and other. 

  

Custom PHP Settings in Panel 

Generally, PHP settings are defined by the server-wide configuration file. For Linux it is, 

typically, /etc/php.ini and for Windows - %WIN%\php.ini. This file is managed by your 

hosting provider and defines PHP configuration for all websites hosted on the server. Since 
Panel 10.4, PHP settings are adjustable through the Control Panel and you can adjust them 
individually for each hosting plan or subscription. Moreover, your customers (if allowed) can 
adjust your PHP settings preset individually for each of their websites and subdomains. See 
the PHP settings hierarchy on the diagram below. 
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You can set the custom PHP configuration in the properties of a certain service plan, add-on 
plan, or subscription (on the PHP Settings tab). PHP settings from a higher level act as a 
preset for a lower level, thus each lower level overrides them. For example, you can 
consciously apply some PHP limitations to a service plan and then offer your customers the 
add-on plan that removes the limitations. PHP settings of the add-on plan will override the 
settings defined in the main service plan. 
If customers have the corresponding permissions, they can specify the PHP configuration 
that is unique for each website (or subdomain) in their subscription. 

  

Groups of PHP Settings 

For convenience, all PHP settings in Panel are divided into two groups: 

 Performance settings.  
These settings define how scripts work with system resources. For example: Use the 

memory_limit parameter to limit the amount of memory for a script and, as a 

consequence, to prevent memory leaks; or prevent scripts from tying up the server by 

limiting the maximum time scripts are allowed to run in max_execution_time. 

 Common settings.  
This group contains other commonly used PHP settings. Generally, these are: Security 
settings (say, the PHP safe mode toggle or the permission to register global variables), 
error reporting settings (say, the directive to log errors), and others. 

Important: If you use Panel for Windows or for Linux, where PHP runs not as an Apache 
module, your customers are able to override some PHP settings regardless of any 

permissions. They can use the ini_set() function in their scripts to change values of the 

following parameters: memory_limit, max_execution_time, and those of your 

additional directives that PHP allows to set anywhere (PHP_INI_ALL directives; learn more 
at http://php.net/manual/en/ini.list.php). 

If you cannot find particular parameters among performance or common settings, contact 
your hosting provider.   

The Default Values of PHP Parameters 

You can set the value of each parameter in PHP Settings either by selecting a value from a 
preset, typing a custom value, or leaving the Default value. In the latter case, Panel takes the 
parameter value from the server-wide PHP configuration. The only exceptions are add-on 
plans: the value set to Default on the add-on's PHP Settings tab will keep the parameter's value 
from the main service plan. 

Allowing Customers to Change PHP Settings 

You can allow your customers to override subscription's PHP settings with their own per-
website and per-subdomain PHP configuration. For this purpose, you should use the 
following permissions on the Permissions tab of a certain service plan or subscription: 

 Hosting performance settings management.  
Along with management of some other settings, this permission grants customers access 
to PHP settings from the performance settings group. 

 Common PHP settings management.  
If granted, allows customers to adjust PHP settings from the common settings group. 

http://php.net/manual/en/ini.list.php
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Note that you can toggle these permissions for a plan (subscription) only if it has the granted 
Hosting settings management permission.  

Even if your customers do not have permissions to adjust PHP settings, you (as the 
administrator) can always perform such per-website (subdomain) PHP configuration. To do 
this, open a certain hosting account from the Server Administration Panel and apply changes 
to the settings of a particular website (subdomain) on the PHP Settings tab. 

Mail 

These parameters (located at Service Plans > select a plan > Mail tab) define the mail service 
provided with the plan. 

Webmail 

Provides the webmail service, which allows users of mailboxes within the subscription to 
work with their mail using a web-based mail application. 

Enable mailing lists 

Turns on the mailing lists service provided by the GNU Mailman software on the 
subscription's websites. 

Note: This parameter is not synced if the permission Mailing lists management is selected. 

Policy on mail for non-existent users 

Defines how mail server should treat e-mail messages sent to e-mail addresses that are 
supposed to be registered under the subscription's domains but actually do not exist. The 
following options are available: 

 Bounce with message returns the mail back to sender with a notice. 

 Forward to address forwards the mail to another e-mail address. 

 Reject silently rejects the mail without accepting it. This setting can decrease mail server 
load caused by a large amount of spam, which is often directed at randomly generated 
user names. However, this might be useful to spammers because scanning your mail 
server for valid e-mail addresses will speed up in such a case. 

 Redirect to external mail server with IP address (on Windows hosting), forwards the mail to the 
specified mail server.  
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DNS 

These parameters (located at Service Plans > select a plan > DNS tab) define how the DNS 
service running on the Panel-managed server will serve DNS zones for websites hosted on 
the plan. 

Master 

A master or primary name server stores locally the zone file it serves, while a secondary 
server only retrieves a copy of this file from the primary. 

Slave 

A slave or secondary server retrieves a copy of the zone file from the primary name server. 

Performance 

These system parameters (located at Service Plans > select a plan > Performance tab) define 
performance of all services provided with the plan. 

Use dedicated IIS application pool (Windows hosting) 

Enables the use of dedicated IIS application pool for web applications within the subscription. 
Using dedicated IIS application pool dramatically improves the stability of web applications 
due to worker process isolation mode. This mode gives each site hosted on the server a 
possibility to allocate a separate process pool for execution of its web applications. This way, 
malfunction in one application will not cause stopping of all the others. This is especially 
useful when you are using shared hosting package. The Maximum CPU use (%) option limits the 
amount of the server CPU that the pool can use. 

Maximum bandwidth usage 

Defines the maximum speed (measured in KB per second) that a domain can share between 
all its connections. 

Connections limited to 

Defines the maximum number of simultaneous connections to web server for all websites 
within the subscription. This setting is intended for preventing the websites from Denial of 
Service (DOS) attacks and excessive usage of bandwidth. 
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Logs & Statistics 

These parameters (located at Service Plans > select a plan > Logs & Statistics tab) define how 
statistics and logs of the subscription should be stored. 

Retain web and traffic statistics 

Sets a period (in months) for which reports on the subscription's web statistics (generated by 
selected web statistics component) and traffic statistics (generated by the Panel) should be 
available.  

Log rotation 

Enables automatic cleanup and recycling of web server log files. You can also switch on 
compression of processed log files and sending them to a specific e-mail address.  
 

Applications 

Depending on your service plan, a number of prepackaged applications may be available to 
you from the Panel. You can install them on your own sites and provision them to your 
customers. 

When setting up a hosting plan, you can select which of the apps should be provisioned to 
the customers: 

 To provide all available applications, on the Permissions tab, select the option Access to 
Application Catalog. 

 To provide only selected applications, on the Permissions tab, select the option Access to 
Application Catalog, and then go to the Applications tab and select the option Provide only 
applications that I select. Use the button >> to add the selected applications to the plan. 

 

Additional Services 

If your provider configured the Panel to provide custom additional services, then the 
Additional Services tab is shown in hosting plan properties. On this tab, you can select the 
services that you want to provide to subscribers. 
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Syncing Subscriptions and Plans 

Subscriptions associated with a particular plan are synchronized, or synced, with it: any 
changes made to the plan are automatically applied to all its subscriptions. This is true for 
both service and add-on plans. 

In case a plan offers a privilege which makes it possible for a subscriber to change a 
particular resource or service, this resource/service allocation is not synced. For example, if 
a subscription provides the privilege of DNS zone management, then the DNS zone settings 
of the associated service plan are ignored during synchronization. 

The Panel allows the following deviations from the default subscription state of being synced 
with its plans: 

 Locked state, which means locked for syncing, indicates that a subscription is excluded 
from syncing with the associated plans. 

A subscription gets locked if you change the parameters of the subscription, without 
changing the associated service plan. Such locking secures your customizations so that 
they are not overwritten the next time you change the plan and all its subscriptions get 
synced. 

 Unsynced state indicates that some services or resources offered with the associated 
plans cannot be actually provided with the subscription.  

 

Unsynced subscriptions 

A subscription is automatically marked as 'Unsynced' if the Panel cannot provision the 
resources or services defined by the plan. This may happen in the following cases:  

 When the subscription is created. 

 When properties of the associated plan are changed. 

 When an add-on plan is added to or removed from the subscription. 

 To know which of the subscription's resources or services are not synced with 
the plan: 

1. Go to Subscriptions, and click the unsynced subscription name. 

2. Click Sync. 

The Panel will retry syncing the subscription with associated plans, and will display the 
conflicting properties if syncing fails. 

Be sure to take note of the conflict report: which properties are affected, and what the 
Plan value and the Available value are. 

Clicking OK at this page will initiate setting the subscription values according to the 
available values, Cancel will leave everything unchanged. 

Once you have identified the problem, you can resolve it. There are two possible ways: 

1. Fine-tune the plan to conform to the system's capabilities. 

2. Fine-tune the system to provide resources and services offered with the plan. 
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 To change the plan properties to conform to the system: 

1. Go to Service plans > <plan name>. 

2. Adjust the required settings so that they correspond to the Available values 
(see above). 

3. Click Update & Sync. 

The subscriptions will be synced automatically. 

 To adjust the system: 

Contact your service provider. 
 

Starting Business with Business Manager 

After you subscribe to a reseller plan and your service provider activates your account, you 
can log in to Business Manager and configure the system to set up and start your business. 
The following sections will familiarize you with all operations you might need to perform. 

Use the Quick Setup widget on the Home page to check the Business Manager configuration 
progress. 

Section Description 

Managing Security Settings Explains how to configure security settings to 
protect sensitive data such as credit card 
numbers. 

Configuring Payment Methods Explains how to set up and configure methods of 
charging your customers. 

Configuring Taxation Contains information about configuring automatic 
taxation of your customers according to applicable 
legal standards. 

Managing Online Stores Provides information about creating and 
configuring online stores - websites where your 
customers can view your offerings and subscribe 
to them. 

Setting Up Invoicing Provides instructions on how to automate issuing 
of invoices to your customers. 

Configuring Schet-Facturas Only for the Russian market. Explains how to set 
up schet-facturas issuing in Business Manager. 

Account Creation and Suspension Policies Explains how to configure the system to 
automatically create accounts for new customers 
and suspend accounts of customers who do not 
pay on time. 

Changing Company Details Instructs you how to change your company 
details. 
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Applying Your Branding Describes ways to include your branded content 
into Business Manager: you domain name, e-mail 
templates, and appearance of online stores. 

Plans & Add-ons Explains how to set up your hosting offerings - 
service plans and add-ons. 

Achieving EU Business Compliance Explains how to configure Business Manager to 
comply with EU laws. 

 

In this section: 

Managing Security Settings ............................................................................... 53 
Configuring Payment Methods .......................................................................... 56 
Configuring Taxation ......................................................................................... 67 
Managing Online Stores .................................................................................... 71 
Setting Up Invoicing .......................................................................................... 74 
Configuring Schet-Facturas ............................................................................... 83 
Account Creation and Suspension Policies ....................................................... 84 
Changing Company Details ............................................................................... 86 
Applying Your Branding ..................................................................................... 87 
Plans and Add-ons ............................................................................................ 112 
Achieving EU Business Compliance .................................................................. 120 
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Managing Security Settings 

To reinforce Parallels Customer and Business Manager security, configure password 
expiration and lockout policy for administrator accounts. To protect data in your database, set 
up encryption of the sensitive data. To track user activity within the system, use the audit log. 
For details on how to perform these tasks, see the corresponding subsections of this section. 

In this section: 

Setting Up Subscription Approval Policy ............................................................ 53 
Setting Up Encryption ........................................................................................ 54 
 
 

Setting Up Subscription Approval Policy 

To prevent fraudulent actions, Business Manager lets new subscribers log in to the system 
only after you approve their orders. You can choose one of the following subscription 
approval policies: 

 Manual approval of all incoming orders. If you choose this policy, you will see notifications 
about new customer accounts on the Home page. You can approve their orders, cancel 
them, or mark as frauds. 

 Automatic approval of all incoming orders. In this case, the system will approve all orders 
from new customers automatically, and they will be able to log in to Business Manager 
immediately after placing the order. This policy does not prevent frauds, therefore, we do 
not recommend using it unless you are sure that the risk is minimal. 

The controls for managing the subscription approval policy are located on the Business Setup 
> All Settings > Fraud Protection Settings page. 
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Setting Up Encryption 

If you process credit card or bank accounts payments directly (through on-site payment 
gateways or bank transfers), customer credit card and bank account numbers are stored in 
Parallels Customer and Business Manager database. To protect customer account data, set 
up encryption. You can use either passphrase or local encryption key (LEK) encryption. If the 
encryption is turned off,  the system neither saves information about new accounts nor stores 
the existing accounts details. 

Use the LEK encryption if you intend to automatically charge customer accounts. However, 
you are required to enter a LEK PIN - a special 4-digit code - to view sensitive information 
like customers' credit card or bank account numbers and to void and refund transactions. 

Use the passphrase encryption if you require confirmation of each transaction. The system 
asks for a passphrase to perform all operations related to customer billing accounts and 
payments. When a customer changes billing account details, you receive a corresponding to-
do item to re-encrypt the new data with your passphrase. The re-encryption of the new data 
is mandatory. For details on how to perform payments with passphrase encryption turned on, 
see Generating and Running Payment Queue (on page 162). 

As the system uses LEK to encrypt and decrypt billing accounts, all operations related to 
payments processing are halted when the key becomes damaged, corrupted, or lost. To 
avoid these situations, back up your LEK in advance and restore it if necessary. 

When you back up an LEK, it is divided between two administrators you assign. You can be 
one of these administrators. These administrators are able to back up their key part or 
restore it. After both administrators restore their key parts, the system restores the LEK and 
displays a notification about it. 

 To configure encryption settings: 

1. Go to the Business Setup > All Settings > Encryption Settings page. 

2. Enter agree in the Encryption Agree field. 

3. Set a secret passphrase or PIN. It may remain empty if you wish 

Note: To change from passphrase to previously specified PIN, leave the PIN fields 

empty. 

4. Click the Submit Changes button. 

Important! To prevent irreversible database corruption during re-encryption by a new 
passphrase, we highly recommend that you back up the Business Manager database 
before submitting changes. You are also required to forbid access to adding and editing 
billing account information during re-encryption process. 
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 To assign a key part owner: 

1. Go to the Business Setup > All Settings > Encryption Settings page. 

It is assumed that LEK encryption is turned on. 

2. Select two administrator accounts. 

3. Click the Submit Changes button. 

 To back up your LEK: 

1. Go to the Business Setup > All Settings > Encryption Settings page. 

It is assumed that LEK encryption is turned on. 

2. Click Backup. 

 To restore your LEK: 

1. Go to the Business Setup > All Settings > Encryption Settings page. 

it is assumed that LEK encryption is turned on. 

2. Fill in the current LEK PIN and specify the backup file. 

3. Click Restore. 

Note: You should turn on LEK encryption. 
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Configuring Payment Methods 

The default Business Manager installation allows you to manually charge your customers via 
checks or bank drafts. To start accepting online payments with credit cards or bank transfers, 
you should configure a payment gateway or a bank transfer plugin.  

When you set up a payment gateway, your customers are able to pay for your services 
online. Depending on your policy, use on-site or off-site gateways for accepting payments. 
The difference between them is the following:  

  If you use on-site gateways, your customers enter their cards information directly in your 
online store and the system saves their secure information to your database. To ensure 
the security of this information, use on-site gateways only if you have configured the 
encryption of customer data as described in the section Setting Up Encryption (on page 54).  

 Off-site gateways connect Business Manager to payment systems that process 
transaction on their own sites, for example, PayPal.  

Bank transfer plugins enable your customers to pay for their subscriptions online by 
transferring money from their bank accounts.  

To add a payment gateway or a bank transfer plugin, go to Business Setup > All Settings > 
Payment Gateways, click Add New Payment Gateway, and choose the module you want to add. 
When you configure a payment gateway or a bank transfer plugin, remember that these 
modules can have limitations or particularities in the configuration. For example, a module 
might support only certain currencies or require you to fill in custom fields, or log in to your 
merchant account and take extra efforts to successfully set up a gateway. To learn these 
module-specific details, refer to the sections Payment Gateways Configuration Details (on page 
57) and Bank Transfer Plugins Configuration Details (on page 61). 

If you want to to change a gateway or a plugin settings, for example, start using it in another 
online store, go to the gateways list Business Setup > All Settings > Payment Gateways, and click 
the gateway name in the list.  

When you decide to stop accepting payments with a certain payment gateway or a bank 
transfer plugin, remove it. To remove a payment gateway or a bank transfer plugin, go to the 
gateways list, select the modules that you do not need anymore, and click Remove. 

Testing gateways and sending transactions manually 

If you want to ensure that that gateway module works properly or manually start a payment 
transaction, use virtual terminal to send transaction data directly to the payment system. 
Learn more about running transactions using virtual terminals in the section Testing Gateways 
Using Virtual Terminals (on page 63). 

Setting up payment queue 

Business Manager creates invoices and runs payment transactions automatically. To initiate 
an invoice payment, the system adds the invoice to the payment queue. To learn how to 
define rules that govern the processing of the invoices in payment queue, refer to the section 
Setting Up Payment Queue (on page 65). 
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In this section: 

Payment Gateways Configuration Details.......................................................... 57 
Bank Transfer Plugins Configuration Details ..................................................... 61 
Testing Gateways Using Virtual Terminals ........................................................ 63 
Managing Gateways and Plugins ...................................................................... 64 
Setting Up Payment Queue ............................................................................... 65 
 
 

Payment Gateways Configuration Details 

Since different payment gateways require different configuration parameters, there is no 
common instruction on configuring the gateway settings. Instead of it, we provide guidelines 
for configuring certain gateways in this section. 

In this section: 

Authorize.net ..................................................................................................... 57 
PayPal ............................................................................................................... 58 
BBVA ................................................................................................................ 58 
Banca Sella ....................................................................................................... 58 
Wirecard ............................................................................................................ 59 
ATOS ................................................................................................................ 60 
LinkPoint ........................................................................................................... 60 
WorldPay........................................................................................................... 60 
WorldPay Direct ................................................................................................ 61 
eWAY ................................................................................................................ 61 
 
 

Authorize.net 

This page provides clarifications on some fields you need to fill in when configuring 
Authorize.net. 

 Authorize.net Login ID. This is the API Login ID that is available from within your 
authorize.net account. 

 Authorize.net Password. This is the API Transaction Key. 

 Gateway URL. This is the URL to which the system will send transaction data. Use Live URL 
when you want to use your Authorize.net module in a production environment. Make sure 
the Gateway Testing checkbox below is unchecked. If you want to test your AuthorizeNet 
module then you should create a test account at the 
http://developer.authorize.net/testaccount/, choose Testing URL and select the Gateway 
Testing checkbox. Use your test account credentials in gateway testing. 

 

http://developer.authorize.net/testaccount/
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PayPal 

This page provides clarifications on some fields you need to fill in when configuring PayPal. 

 ID. yourname@yourdomain.com (Enter your primary PayPal e-mail address). 

 Item Name. Enter a comment or description about the services you offer. This will appear 
on the customer's PayPal receipt. 

 Display Logo. Enter the url to your display logo. This is the logo that will show up on the 
PayPal payment page once they go through the Business Manager shopping cart. This is 
a logo you create. 

 Submit Image. Enter the url to your image. 

 IPN URL. Enter the url to your IPN. PayPal sends IPN messages only to 80 and 443 ports. 
In turn, Business Manager accepts these messages on 8880 and 8443 ports. Learn how 
to configure forwarding of IPN messages to these ports here: 
http://kb.parallels.com/en/112756. 

 Subscription Enable. Do you allow PayPal subscriptions (Recurring payments)? 

 PayPal Accept Addresses. Enter any PayPal addresses at which you would like to receive 
payments, separated either by comma or a new line for each address. Example: 
billing@yourdomain.com, service@yourdomain.com, 

domains@yourdomain.com. 

Note: Any address listed here must be an active PayPal account. 

Note: After you have tested the connection with PayPal, be sure to change Gateway Testing to 

No to accept live payments. 

BBVA 

This module does not have any particularities except for it accepts only EUR. To set up the 
gateway, enter the information you received from your merchant account provider. 

Banca Sella 

The system lets set up Banca Sella as an on-site or off-site payment gateway. The 
configuration steps in these two cases are almost identical. 

To set up the gateway, select it from gateways list in the Add New Payment Gateway wizard, 
specify the initial information about the gateway and proceed to the configuration. Fill in your 
merchant ID, select Basic agreement (only for off-site payment gateways) and click OK to 
save the configuration. 

When ready, go to your merchant account with Banca Sella and authorize Business Manager 
to work with the gateway by following these steps: 

1. Specify the IP address of Business Manager at Configuration > Environment > IP Address. 

2. Provide the e-mail address that will receive notifications about transactions at 
Configuration > Environment > Response. 

http://kb.parallels.com/en/112756
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3. Provide the callback URLs of Business Manager at Configuration > Environment > 
Response. 
The URLs should be the same as the listed below with wildcards substituted to your 
custom values. Namely, substitute <your-host-name> with the actual host name of 
Business Manager, and <gateway-type> with the gateway type. Allowed gateway types 
are: BancaSella (for the on-site payment gateway) and BancaSellaSSL (for the off-site 
payment gateway). 
 
URL for positive response: 

Error! Hyperlink reference not valid. 

URL for negative response: 

Error! Hyperlink reference not valid. 

URL Server to Server: 

Error! Hyperlink reference not valid. 

Example: https://example.com/plesk-billing/lib-
mbapi/include/modules/gateway/return/HSPCCallback.php/plugin_id,OP_B

ancaSellaSSL/action,notify/server_url,ecomm.sella.it 

Banca Sella uses callback URLs to send transaction statuses to Business Manager. 
Unfortunately, the payment processor does not accept port numbers in callback URLs, so 
you should take extra steps to modify the default system configuration to automatically 
receive transaction statuses. Learn more about this problem and recommended solutions at 
http://kb.parallels.com/en/9500. 

Wirecard 

This page provides clarifications on some fields you need to fill in when configuring the 
Wirecard payment gateway. 

 Business Case Signature. A unique number Wirecard assigns to a merchant account. This 
number includes up to 16 hexadecimal digits (0..9,A-F). 

 Name. The username set up for your account. 

 Password. The password set up for your account. 

 Country where the shop is legally registered. The country where your company is legally 
registered and where payment transactions take place. In certain cases, this helps to 
reduce acquirer fees by up to 1% of the transaction volume. Detailed information about 
this functionality can be requested from the Wirecard customer services department. 

 Enable CVV2/CVC2 verification. This item must be selected to make the gateway work. 

 Enable address verification (AVS). This item must not be selected to make the gateway work. 

 Check status period. An interval between attempts to request a transaction status after 
committing the transaction. Default value: 60. 

 Count of transaction checks. The number of attempts to get a transaction status. Default 
value: 10. If exceeded, the error status is assigned to transaction. 

 

http://kb.parallels.com/en/9500
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ATOS 

This module is available only if Business Manager runs on Linux. To set up the gateway, 
enter the information you received from your merchant account provider. 

LinkPoint 

This page provides clarifications on some fields you need to fill in when configuring the 
LinkPoint payment gateway. 

 LinkPoint store name. This is a number that LinkPoint assigns to you when creating your 
account. 

 Key file. Obtain this file from your LinkPoint account and upload the file to the following 
directory on the Business Manager server: 

 On Linux systems: /opt/plesk-billing/config/ 

 On Windows systems: C:\Program 
Files\Parallels\Plesk\billing\config\ 

Ensure that the psaadm user (on Linux systems) or the user that runs the IIS web server 

(on Windows systems) has permissions to read and execute the file. 

WorldPay 

This page describes steps necessary for configuring WorldPay module: 

1. Configure the gateway settings. 

2. Make sure that the Payment Response URL is accessible from the Internet. 

3. Log in to your WorldPay account, go to the Installations > Integration Setup page and 
configure the account settings the following way: 

 Select the Payment Response enabled? checkbox. 

 Enter your Payment Response password and Payment Response URL into the 
corresponding fields. 

 Enter the e-mail address to which the system should send troubleshooting e-mails into 
the Payment Response failure e-mail address field. 

 



 

 Setting Up Your Hosting Offers 61 

 

WorldPay Direct 

Unlike the majority of payment gateways, WorldPay Direct requires a customer to provide 
secret data (for example, CVV or authorization code) on their bank’s website each time they 
perform a payment. This fact implies the following limitations: 

 This gateway does not support automatic payments. If your system is configured so that 
it charges credit cards automatically, it omits the WorldPay Direct payments. 

 Administrators cannot take credit card payments from customers through WorldPay 
Direct using the corresponding button on the invoice details page. 

To configure this module, specify the following parameters: 

 Merchant code that you see in the left navigation pane of the WorldPay merchant interface. 

 XML Password - the password that WorldPay assigns you to securely transfer XML files. 
To see this password, log in to the WorldPay merchant interface and go to the Installations 
page. You will find the XML password in the description of the corresponding installation. 

If you capture funds manually and want to use the WorldPay Direct, you should switch off 
automatic capturing in the WorldPay merchant interface. To do this, log in to your WorldPay 
Direct account, go to Profile > Configuration details and set the Capture Delay value to Off. 

eWAY 

eWAY payment gateway requires a customer to provide their CVV2 code each time they 
perform a credit card payment. Therefore, this gateway does not support automatic 
payments. If your system is configured so that it charges credit cards automatically, it omits 
the eWAY payments. 

Bank Transfer Plugins Configuration Details 

This section explains how to configure certain bank transfer plugins to start accepting 
payments through them.  

In this section: 

Norma19 Plugin................................................................................................. 62 
DTAUS Plugin ................................................................................................... 62 
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Norma19 Plugin 

The Norma19 plugin allows generating batch files of the format widely used in Spain. The 
plug-in is implemented in such a way that an issuer (charging party) and submitter (the party 
delivering a batch into a bank) requisites are always the same in the batch files profile. Thus, 
enter only the issuer requisites into the plug-in configuration form. 

Norma19 Fields 

 Issuer customer code - your bank customer code. 

 Issuer name - your company name (as registered in your bank account). 

 Issuer account information - your bank account requisites, namely: 

 Agency - the bank requisite, 4-digits code identifying the account. 

 Branch - the number identifying the bank branch where your account is registered. 

 CD - control digits, 2-digits code validating the Agency, Branch, and Account Number. 
Control digits ensure that all the requisites are correct. 

 Account - your bank account number. 

You are also able to enter up to 16 positions of additional information (Optional field #1 - #16) 
to be included with batches. When filling the optional fields, use placeholders enlisted below 
the optional fields. The placeholders will be replaced with the actual data fetched from 
information provided by the customer. 

If you want to include a customer's address on a receipt, check the Include customer address 
as optional record box. A customer address will be taken from a customer's account profile. 

DTAUS Plugin 

The DTAUS plug-in allows generating batch files of the format widely used in Germany. 

DTAUS Fields 

 Merchant name - the name you are registered under as a client in your bank. 

 Bank Code- the code of the financial institution (batch file recipient). 

 Account number - your bank account number. 
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Testing Gateways Using Virtual Terminals 

If your gateway account supports it, you can use Business Manager virtual terminal to 
connect directly to your gateway account. This can be useful for two main things: 

1. Testing your connection during the configuration process 

2. Charging a customer's card without having to use the Business Manager payment 
process. 

 To use the virtual terminal: 

1. Go to Business Setup > All Settings > Payment Gateways. 

2. Click  Virtual Terminal in the Available Operations of the gateway you want to test. 
The first page asks two questions: 

 Create Income Accounting Entries. If you would like this transaction to create Income 
Accounting Entries, check the box. Generally, you will want to have this checked. If 
you are testing, however, you may want to uncheck this, as the transactions you are 
putting through the terminal are not for accounting, but to verify connectivity. 

 Currency. Choose the currency which you want to use to test the gateway. 

3. Click Next. 

4. This page acts as the actual terminal. Enter as much information here as you 
have access to. 

 First Name. Enter the first name of the customer to be charged. 

 Last Name. Enter the last name of the customer to be charged. 

 Customer Email. Enter the email address of the customer to be charged. 

 Customer Address. Enter the customer's billing address. 

 Suite. Enter the suite, if applicable. 

 City. Enter the city of the billing address. 

 State. Enter the state of the billing address. 

 Zip. Enter the zip code of the billing address. 

 Customer Country. Enter the country for the billing account. 

 Phone. Enter the customer's phone number. 

 Fax. Enter the customer's fax number, if applicable. 

 Amount Of Payment. Enter the exact amount of the payment to be charged. 

 Payment Comments. Enter any comments you want to accompany the payment. You 
may want to enter your company name here. 

 Payment Type. Enter the payment type here. The virtual terminal will only work with 
payment types that are enabled in your gateway account. 

 Charge Action. Choose to either authorize this transaction only, or to charge the card. 

 Credit Card. Fill in the credit card information: 

 Name on Credit Card. Enter the customer's name as it appears on their credit card. 
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 Credit Card Type. Enter the credit card type. 

 Credit Card Number. Enter the credit card number, with no spaces. 

 Expiration Date. Enter the credit card expiration date. 

 CVV2 Code. Enter the customer's CVV2 code, if this is required by your gateway. 

 Issue Number. If you are using certain debit cards, you must enter this information (if 
you do not know what this is, it's likely you don't need to use this). 

 Start Date. Like the Issue Number, if you are using certain debit cards, you must enter 
this information. 

5. Click Charge. 
 

Managing Gateways and Plugins 

Aside from setting up payment gateways (on page 57) or bank transfer plugins (on page 61), 
you can do the following: 

 Change gateway or plugin settings. 

 Remove gateways or plugins. 

 To change gateway or plugin settings: 

1. Go to Business Setup > All Settings > Payment Gateways and click the gateway name in the 
list. 

2. Update the information, and click OK. 

 

 To remove a gateway or plugin: 

1. Go to Business Setup > All Settings > Payment Gateways and select gateways or bank 
transfer plugins you wish to remove. 

2. Confirm the removal, and click OK. 
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Setting Up Payment Queue 

If you are using a top-tier gateway such as Authorize.net or Bluepay to process your credit 
card or bank account transactions, the payment queue settings govern how and when 
invoices are added to and processed by the task ProcessPaymentQueue. 

 To set up a payment queue: 

1. Go to Business Monitoring > All Settings > Automatic Payments. 

2. Change the Common Settings. These settings include the following: 

 Process New Invoices. Do you want to process new invoices? If set to No, you will need 
to collect payments manually. For details on how to generate the list of payments to 
be processed, see Generating and Running Payment Queue (on page 162). 

 Process Declined Transactions. Do you want to process invoices with declined 
transactions? If set to Yes, the system will collect payments according to the failure 

retry time set in the file lib-billing/include/config/config.php. If set to 

No, Business Manager will never automatically retry collecting payments. You will 
have to do this manually. 

 Process Errored Transactions. Do you want to process invoices with errored 
transactions? If set to Yes, the system will collect payments according to the failure 

retry time set in the file lib-billing/include/config/config.php. If set to No, 

Business Manager will never automatically retry errored invoices. You will have to do 
this manually. 

 Charge On Due Date Only. Do you want to charge the invoices only on the date invoices 
are due? If this is set to Yes, invoices will only be added to the payment queue on their 
due date (the due date for invoices is set in Invoice Settings). If set to No, invoices will 
be added to the payment queue after they are created. 

 Clear The Payment Queue First. This should be set to Yes. If you do not clear the payment 
queue before a new one is generated, then invoices may be run multiple times. 

 Try Lesser Amounts. If set to Yes, the payment queue will start from the oldest invoice 
and will run till the first transaction declines.  If set to No, the payment queue starts 
from the invoice with the least amount. 
For example, we have invoice #1 for 20$ and invoice #2 for 10$, and 15$ is available 
on the customer's credit card. If you use lesser amounts, the system successfully 
charges 10$, and if you do not use them, the system fails to charge for invoice #1 and 
stops. 

 Pay for a subscription from multiple billing accounts. This feature allows you to assign 
several different billing accounts to pay a single subscription, and then assign custom 
“weights” to each of these. For example, if a customer wants to use three credit cards 
to pay for one subscription, and wants to have 75% charged to one card, 20% to 
another, and 5% to another, you will need to enable this setting to allow this. 

 Generate Batch Prior To Due Date (Number of Days). How many days before the due date 
do you want to generate the payment queue? A normal value for this is 1. 
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3. Set the Credit Card Processing. This includes the Payment Queue Action. It 
determines whether the items in the payment queue get sent to the gateway 

as Charge, also called AUTH_CAPTURE, or Authorization Only, which will 

require a payment capture at a later point in time. Generally, this item is set 
to Charge. If you wish to have the gateway just authorize transactions and 
collect payments later, then set this to Authenticate Only. Please be aware that 
if you do this, you will need to manually capture the funds for all recurring 
credit card transactions. For details on this operation, see Capturing Uncaptured 
Payment (on page 160). 

4. Set the Bank Transfers Processing. This includes setting the following 
parameters: 

 Start processing batch files automatically after (in days). How many days after the creating 
the batch file you want to start its processing automatically? The default value is 0. 

 Start processing batch files automatically on reaching this number of transactions. How many 
transactions must be in a batch file to start its processing automatically? The default 
value is 0. 

 Responsible Administrator. This parameter shows the administrator who is responsible 
for bank transfer processing. 

5. Click Save. 
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Configuring Taxation 

As you run a hosting business in a particular country, you should set taxes to conform to 
legal standards of your country. Parallels Customer and Business Manager lets you achieve 
this through tax rules and taxation policies. The diagram below  shows the relations between 
these entities and plans. 
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Tax Rules 

A tax rule defines a tax for a particular country or sub-national unit where you offer your 
plans. For example, if you serve the American customers from states with different sales tax 
rates, create a separate tax rule for each state and specify their rates in these rules. The 
rates can be either fixed ($10) or progressive (15%). Business Manager calculates fixed 
rates in the currency of the online store where you sell the plan. 

There are two types of tax rules: stackable and non-stackable. Stackable rules are applied to 
a subscription price, while non-stackable rules are applied to a total of the price and 
stackable tax rules values. To see an example of stackable and non-stackable rules 
application, refer to the Applying Taxation Policies section. 

A state or a province where the rule applies can be a two character state abbreviation or a 
combination of a two character state abbreviation and city. You can also add a county name. 
In this case, separate location parts by dashes (-). For example, use state-city to specify a 
particular city in a certain state. The other accepted locations are: state-county, state-city-
county, state. Set the state to asterisk (*) or leave the corresponding field blank to apply the 
rule to the whole country. 

Taxation Policies 

A taxation policy links together tax rules and plans to which you want to apply them. For 
example, to serve the American customers, create a taxation policy that contains all US tax 
rules and apply it to the plans you intend to sell in the US. If you offer the same plans to all 
customers, simply modify the default taxation policy and apply it to all plans. 

Note: Each plan can have only one taxation policy applied. If you apply a new taxation policy 
to a plan, the existing one will be replaced. 

To add new taxation policy or manage existing ones, go to the Business Setup > All Settings > 
Taxation Policies screen. 

Applying Taxation Policies 

If a plan is associated with a taxation policy, the system searches for matches between 
subscriber location and tax rules included in the policy. If the system finds the matches, it will 
calculate the total tax due from rates of matching tax rules. 

To calculate the total taxes due for a subscription to a plan, the system uses the following 
algorithm: 

1. Form a list of tax rules matching customer country and the selected plans. 

2. Sequentially apply each stackable tax rule to a subscription price. Add up all of the 
calculated tax values. 

3. Sequentially apply each non-stackable tax rule to the total of the price and the step two 
result. Add up all of the calculated tax values. 

4. Add up all of the tax amounts calculated at step two and step three. 
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For example, a subscription price is $100, and the matching tax rules are as follows: 

Rule 1: Apply 10% stackable 

Rule 2: Apply 20% stackable 

Rule 3: Apply 5% non-stackable 

Rule 4: Apply 10% non-stackable 

 

Then the total taxes due is calculated in the following way: 

$100 * 0.10 = $10 (for Rule 1) 

($100 * 0.20 = $20 (for Rule 2) 

$10 + $20 = $30 (subtotal for stackable rules) 

($100 + $30) * 0.05 = $6.5 (for Rule 3) 

($100 + $30) * 0.10 = $13 (for Rule 4) 

$6.5 + $13 = $19.5 (subtotal for non-stackable rules) 

$30 + $19.5 = $49.5 (total taxes due) 

 

To learn how to set up taxation for particular countries, see the examples below. 

In this section: 

The United States .............................................................................................. 70 
European Union ................................................................................................ 70 
Canada ............................................................................................................. 70 
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The United States 

If you sell your plans to the US market, apply the sales tax. The sales tax is non-stackable, 
and its rate differs depending on the state where you sell plans.  

To serve customers from the New York, Pennsylvania, and New Jersey states, create a 
taxation policy (for example, “USA Taxation”), apply it to the plans you are going to sell in the 
USA, and create a separate non-stackable tax rule for each state.  

 To set up a sales tax: 

1. Add a taxation policy and apply it to the plans you intend to sell in the USA. 

2.  Add a non-stackable tax rule for the New York sales rate with Country set to 
United States and State - to NY, and set the Rate to 4% . 

3. Add a non-stackable tax rule for the Pennsylvania sales rate with Country set 
to United States and State - to PA, and set the Rate to 6%. 

4. Add a non-stackable tax rule for the New Jersey sales rate with Country set to 
United States and State - to NJ, and set the Rate to 7% . 

5. Save the policy. 

Important: The rates in the example may differ from actual rates. To get the relevant 
information on taxation in the United States, consult your local authorities. 

European Union 

If your business is located in Germany and you serve customers from the European Union, 
apply the value added tax (VAT). The VAT is non-stackable, and its rate differs depending on 
the seller location.  

 To set up the VAT: 

1. Create a taxation policy (for example, “EU Taxation”) and apply it to the 
plans you intend to sell in the EU. 

2. Create a non-stackable tax rule with Country set to European Union and the 
asterisk (*) in the State field. Set the Rate to 19%. 

3. Save the policy. 

After you add the VAT, configure the Business Manager to comply with EU business 
standards as described in the section Achieving EU Business Compliance (on page 120). 

Important: The rate in the example may differ from actual rate. To get the relevant information 
on taxation in the European Union, consult your local authorities. 
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Canada 

If you run your business in the Quebec province, Canada, apply two taxes: 

 goods and services tax (GST) - the Canadian analog to VAT. 

 Quebec sales tax (QST) - a separate stackable tax applied in Quebec. 

 To set up the Quebec taxes: 

1. Create a taxation policy (for example, “Canadian Taxation”) and apply it to 
the plans you intend to sell in the Quebec. 

2. Create a non-stackable tax rule for the GST with Country set to Canada and 
the asterisk (*) in the State field. Set the Rate to 5%. 

3. Create a stackable tax rule for the QST with Country set to Canada and the 
State - to QC, and set the Rate to 8.5%. 

4. Save the policy. 

Important: The rates in the example may differ from actual rates. To get the relevant 
information on taxation in your province, consult your local authorities. 

Managing Online Stores 

Business Manager, unlike most host-based billing platforms currently available, provides 
online stores - automatically created websites. These websites display your plans, and also 
have a shopping cart with checkout to let customers subscribe to your plans. Customer 
payments are processed by a payment gateway associated with the store. You can have 
multiple online stores for different currencies, locales, and product lines. 

Business Manager ships with the default online store for the United States locale and USD 
currency. It is available at 

https://<host-name>:8443/<your-login>-store.html 

Online stores are completely customizable so you can template them to match the rest of 
your web site. 

In addition to online stores, Business Manager offers website widgets. These are little 
snippets of code you simply drop into your company web site that feature any subset of plans 
you want in any format you want (listing, drop-down, etc). Because widgets are small 
snippets of code, they can be dropped anywhere on your web site where you want to sell 
plans and they require no special templating because they are included in your existing web 
site. This gives you precise control of the way you like to sell plans. 

This chapter explains how to add or edit an online store, how to customize its look and feel, 
and how to manage blacklists of customers e-mail addresses. 

We do not provide store configuration instructions in this chapter, as the configurable options 
are self-explanatory, and you can easily find what you need by reading about these options 
when adding or editing online stores. 
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In this section: 

Adding an Online Store ..................................................................................... 72 
Editing an Online Store...................................................................................... 72 
Changing Online Store Appearance .................................................................. 73 
Using Website Widgets to Embed Stores into Websites .................................... 73 
 
 

Adding an Online Store 

If you are going to be charging your customers in more than one currency, then you need to 
have one online store for each currency. 

 To add a new online store: 

1. Go to Business Setup > Online Stores. 

2. This page lists your current online stores. From here, click Add New Store. 

3. Fill in the necessary information using the tips from the interface. 

4. Click Save. 
 

Editing an Online Store 

Use the instructions below to edit an online store. 

Tip: Assuming that you work with a single currency, you only need one online store to 
distribute your service plans. For these purposes, edit a default online store settings to match 
your needs instead of creating new stores. 

 To edit an online store: 

1. Go to Business Setup > Online Stores and click the store you want to edit. 

2. Fill in the necessary information. Use tips next to each of the fields and to 
understand what a field configures. 
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Changing Online Store Appearance 

You can perform the following changes of the Business Manager online store appearance 
through the GUI: 

 Set the custom header and footer for the store pages. To do it, click the Header and footer 
> [edit header and footer] link on the store’s page. 

 Choose the color theme of the store from built-in themes or create your own. To do it, 
click the Color theme > [change] link on the store’s page.  

 Change the store home page layout using landing page templates. Business Manager 
provides two templates:column and row. To change the layout, click Change Settings on 
the store’s page, choose the template from the Landing page template dropbox, and click 
Save. 

 

Using Website Widgets to Embed Stores into Websites 

A website widget is a piece of code that shows a part of an online store on your website. 
Widgets either list your plans (catalog widget) or let your customers check a domain name 
availability (domain widget) to further add this domain to their subscription. When customers  
select a plan or submit a domain name, they are forwarded to a particular online store where 
they can complete the order. 

To create a widget within an online store, go to the store page (Business Setup > Online Stores 
> store name) and click the Add Website Widget button. Then fill in the required fields and save 
the widget. 

To add a widget to your website, get the widget code by clicking Get Code in Available 
Operations list on the store page. A widget code may be server-side (written in PHP) or 
customer-side (written in JavaScript). After you get the code, add it to your website pages on 
which you want to show the widget. 
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Setting Up Invoicing 

To notify customers about future payments for services that they use, Business Manager 
generates and sends them invoices - financial documents that contain payment information: 
who should pay for provided services, when they should do it, and what is a payment 
amount. The system generates and sends invoices as PDF files, but you can also view 
invoice details from the page Business Operations > Invoices. 

Business Manager creates invoices for a subscription in the currency of the online store in 
which the subscriber purchased the subscription. For example, if your online store uses the 
euro currency for transactions, all invoices for the subscriptions purchased in this store will 
charge customers in the euro. You cannot change the currency of an existing subscription. 

You can define when the system should issue invoices by selecting an appropriate billing 
mode. To learn more about possible billing modes and decide which one suits you best, read 
the section Understanding Billing Modes (on page 76). 

An addition to the billing mode, you can configure the following aspects of invoicing:  

 The statuses of customers that will receive invoices. 

 Printable invoices appearance. 

 Invoice numbering, and other aspects. 

The tools to change these settings are located on the Business Setup > All Settings > Invoicing 
page. 

Printable Invoices Appearance 

Business Manager fills in printable invoices content (names and costs of the provided 
services, customer and provider information) according to the administrator's profile settings: 
country and language. For example, if the Admin user's country is Russia, the system will 
use the comma (“,”) as decimal part delimiter. If the country is the USA, the invoice will use 
the period (“.”). To learn how to change the administrator's profile settings, see the section 
Configuring Administrator Interface. 

The language of a PDF invoice form (names of the invoice fields) is the same as the 
language of the user who should pay this invoice. For example, invoices for customers from 
Germany will be written in German. 

You can also change the formatting, style, and predefined content of the invoices to your 
liking. This includes, for example, changing invoice title, adding company logo, or changing 
font size. To learn how to edit the appearance of printable invoices, refer to the section 
Customizing PDF Invoices (on page 81). 
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Invoice Numbering 

Each invoice has a unique identifier - an invoice number. The format of the invoice number is 
defined by the invoice number template. The template is a line of text in which you can 
include a set of variables such as an invoice ID number (%%ID%%), the current year 
(%%CURYEAR%%), month (%%CURMONTH%%), and day (%%CURDAY%%), and so on. 
The complete list of the variables is shown on the Business Setup > All Settings > Invoicing 
page. For example, if you want to see a creation date as a part of an invoice number, include 

the following line into the template: %%CURYEAR%%-%%CURMONTH%%-%%CURDAY%%. When 

the system issues an invoice, it replaces the variables with their current values, for example, 
2012-03-06. 

If you have moved to Business Manager from another billing solution and want to continue 
the invoice numbering that you used previously, you can do it with the variable %%SEQ%% 
(invoice sequence). This is an integer value that increases by one after issuing an invoice. To 
make the system use your previous numbering, assign the value that continues this 
numbering to this variable and include it into your invoice template. For example, if you used 
integer identifiers starting from 1 in your invoice numbers and you issued one hundred 
invoices, set the invoice sequence value to 101. 

Invoices and Accounting Entries 

Invoicing is one of the many features used by Business Manager to create accounting 
entries. The basic accounting entries that the system creates for an invoice are the following: 

 Income: The amount of money you have coming in from the invoice, excluding taxes. 

 Taxes Payable: The amount of money that you are going to pay in taxes for the invoice. 

 Accounts Receivable: The amount of money (income + tax) you will receive from the 
customer according to the invoice. 

You can define other accounting entries that the system will create after issuing an invoice. 
For example, the coupon cost: When someone uses a coupon, Business Manager will keep 
track of how much the plan they purchased would have cost without applying a coupon. The 
system creates the appropriate expense entries each time an invoice is created. Additionally, 
you can define the subscription cost to keep track of how much it costs you to create a 
subscription to a certain plan. For example, if a plan provides a dedicated IP address, your 
expenses on a subscription creation include the price of a new IP address. Business 
Manager will create these entries each time a new subscription to the selected plan is 
created. 

Achieving Tax Office Compliance 

For some organizations, it is obligatory to keep the originally generated invoices unchanged. 
However, when you re-send an existing invoice (from the invoice details page), the system 
re-generates the PDF invoice that may differ from the original file. The difference can be 
caused by changes to the system-wide settings like invoices language, or company details. 

If your local tax office requires that you do not change invoice content once it is generated, 
save PDF copies of original invoices before modifying one of the following settings: 

 Company details. 

 The appearance and language of printable invoices. 

 Administrator language. 
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Note: Your customers can change invoice content as well, for example, by modifying their 
contact information. 
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Understanding Billing Modes 

Business Manager is, at heart, a billing system. Because of this, it's important to understand 
how the billing process works, from beginning to end. There are two main billing modes in 
Business Manager: Anniversary Billing Mode and Monthly Billing Mode. We will outline the 
aspects of each of these separately, as there are some important differences between these 
two choices. 

In this section: 

Anniversary Billing Mode ................................................................................... 77 
Monthly Billing Mode ......................................................................................... 78 
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Anniversary Billing Mode 

As the name implies, anniversary billing mode involves billing customers on the anniversary 
of the day they signed up for the subscription. Broadly speaking, this has two major results: 

 Having invoice due dates spread throughout the month means that you will have a steady 
stream of income. It also means that if there is a problem with billing for any reason (your 
server goes down, your gateway is having trouble), only a small percentage of your 
customers may be affected. This makes recovering from such occurrences less painful. 

 If you generate invoices every day, customers with multiple subscriptions purchased on 
different dates will receive multiple invoices for their purchases. For customers who pay 
manually, this may be undesirable. It should not be an issue for customers who pay 
automatically. 

In addition to the above, it is important to consider scalability. Because anniversary mode 
results in a monthly billing workload divided between 28-31 days, you are much less likely to 
have problems with race conditions and other server-based limitations as your company 
grows. If you intend to have more than 20 customers, we recommend that you choose 
anniversary billing mode. 

What to Expect in Anniversary Billing 

Knowing what to expect from your billing system can help alleviate a lot of potential concern 
and confusion. Here we will walk through the life of a hypothetical customer, focusing 
specifically on how they will be billed. 

Say you have a customer, Alice. Alice would like to order hosting and purchase a domain 
name from you. She finds your plan listings on the web, and goes through your order 
process. This process will create a customer record in your Business Manager for Alice, and 
add two subscriptions to this account. Let's assume that Alice chose to pay for her hosting on 
a monthly billing cycle, and her domain on a yearly billing cycle and that she chose a plan 
called Personal Hosting. We will also assume that you have Business Manager set to 
generate invoices ten days before the subscription is set to renew. 

As part of the order process, the first invoice for Alice's subscriptions will be created. No 
matter how she chooses to pay, the system will automatically enter the date that each of 
these subscriptions renews. Say she signs up on June 15th, 2008. Her hosting subscription, 
which is on a monthly billing cycle, will renew again on July 15th, 2008. Her domain, which is 
on a yearly cycle, will renew June 15th, 2009. Because she subscribed on the 15th of the 
month, these subscriptions will always renew on the 15th. 

Now let's say that Alice has decided to open a small business, and she wants a separate 
hosting account for this business' website. She goes through your order process again, this 
time on the 20th of August. She buys your Business Hosting subscription. An invoice is 
automatically generated through the order process for this first month of hosting. Alice would 
already have paid for her Personal Hosting on August 15th. 

In September, Alice will get two invoices. She will get an invoice for her Personal Hosting 
that will renew on September 15th, and a second invoice for her Business Hosting, which will 
renew on September 20th. Now let's fast forward to May 2009. 
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By default, Business Manager is set to generate domain renewal invoices 30 days in 
advance, rather than the 5-10 days that other subscription invoices are usually set to be 
generated. This is to prevent people from losing their domains. Thirty days provides enough 
warning that a customer should have time to pay their bill on time, and allow the renewal to 
take place. Because of this, Alice will receive three invoices. On May 5th, Alice will get an 
invoice for her Personal Hosting subscription, which renews ten days later, on May 15th. On 
May 10th, she will get an invoice for her Business Hosting subscription, which renews May 
20th. On May 15th, Alice will get an invoice for her domain subscription, which renews June 
15th. 

This may sound like a lot of invoices. Keep in mind that if Alice is paying with a credit card 
that she keeps on file, or with PayPal subscriptions (the two most common payment 
methods), these payments will be made and logged by Business Manager without either you 
or Alice having to do any work. If Alice pays manually, she can write a single check for all 
three invoices and mail one payment. You can use the Quick Manual Payment feature to 
mark each of her invoices as paid. 

Monthly Billing Mode 

Like anniversary mode, monthly billing mode will invoice your customers on a regular billing 
cycle, usually once a month. Unlike anniversary billing, customer subscriptions will all renew 
on the first day of the month. Billing your customers once a month has a couple of main 
features: 

 No matter how many subscriptions a customer might have, they will receive a single 
invoice listing all subscriptions renewing in any given month. 

 If you choose to run your billing manually, you can set aside an afternoon to generate 
invoices and a second afternoon to run them through the gateway. 

Monthly billing often involves proration. If a customer would like to buy a subscription on the 
15th, you can either choose to have that subscription start on the first of the next month, or to 
prorate that first month. Proration adds another level of complexity to your billing, which can 
sometimes cause confusion for your potential customers. Because of this, and the scalability 
issues mentioned above, we recommend that companies do not use monthly billing unless 
they intend to have a small number of customers. 

However, it is possible to use monthly billing mode and set your plans to not prorate. This 
causes these plans to behave as if you were in anniversary mode. This is especially useful 
for selling items such as SSL certificates and domains. These items have fixed start and 
renewal dates determined by outside sources. Proration would result in subscription renewal 
dates that did not match the actual item's renewal date, and could cause problems. 

What to Expect in Monthly Billing 

We have already seen what the typical customer's invoicing will look like in anniversary 
mode. Now let's see what this system will look like in monthly mode. 

Meet Alice's friend Bob. On June 15th, 2008, Bob decides he wants to buy several 
subscriptions from you. He buys the Personal hosting plan on a monthly cycle and a domain 
on a yearly cycle. Your Personal hosting plan is set to prorate; your domain plan is not. Let's 
assume that you have your proration threshold set to the 15th. This means anyone who signs 
up on the 15th or later will pay for the rest of the month they are in, plus the next month. 
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As part of the order process, Bob paid the first invoices for these subscriptions. Like 
anniversary billing, no matter how Bob pays, his subscriptions will automatically be updated 
with their next renewal date. Because Bob's Personal Hosting subscription was set to 
prorate, his first invoice charged him for the rest of June and the whole month of July. The 
domain subscription was not set to prorate, so he was charged for a full year. 

At the end of July, Bob will get another invoice for his Personal Hosting subscription, due 
August 1st. This will cover the whole month of August. Say that Bob decides, after paying this 
bill, that he would like to buy a Business Hosting subscription for his new small business. On 
August 5th, Bob goes through your order process again, this time to purchase Business 
Hosting. Because the 5th is before your proration threshold of the 15th, Bob will simply pay for 
the rest of August in this first invoice. At the end of August, Bob will receive a single invoice. 
This invoice will carry charges for both the Personal Hosting and Business Hosting account. 

Fast-forward to May of 2009. Bob will again receive an invoice in late April for both the 
Personal Hosting and Business Hosting subscriptions. May 15th, Bob will receive a second 
invoice, this time for his domain which is set to renew June 15th. Remember, this subscription 
was set not to prorate, so it follows the anniversary billing behavior for subscription renewal 
dates. At the end of May, Bob will again be billed for his two hosting subscriptions on a single 
invoice. 

Just like in anniversary mode, Bob's invoices can be set to be paid automatically, with a 
credit card kept on file or via third party subscription accounts. 
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Setting Up Invoicing 

You can configure different aspects of invoicing: Who and when should receive invoices, how 
invoice numbers should look like, how much items to put into a single invoice, etc. The 
system generates invoices as PDF files, but you can also view the invoice details from web. 

PDF invoices are formatted to the locale you specified for the admin user profile. For 
example, if the admin user country is Russia, the invoice will use “,” for decimal part 
delimiter, and if the country is the USA, the invoice will use “.”. 

PDF invoice language is dictated by the user for whom the invoice was generated. For 
example, invoices generated for customers from Germany will be written in German. Invoices 
generated from the administrator interface will use the administrator's profile language 
settings. 

To change the administrator's country and language, go to Business Setup > All Settings > 
Administrators, click an administrator and Edit. To change the language for your profile, click 
Profile in the top of the page. 

For each subscription, Business Manager creates invoices in the currency of the online store, 
in which the subscription was ordered. For example, all invoices for the subscriptions ordered 
in a store with euro currency will charge subscribers in euro. You cannot change the 
currency of an existing subscription. 

As we already mentioned, you can customize the format of invoice numbers (invoice 
sequence). For example, you can start with “1” or “1000” or any number specific to your 
business needs. The system also allows you to select how you want to number your invoices 
such as: 

 YEAR-ID, example 2006-1234 

 YEAR-SEQ, example: 2006-1 

 VATYEAR-SEQ, example 2006-1 

Invoicing is one of the many features used by Business Manager to create accounting 
entries. The basic accounting entries that get created for an invoice are as follows: 

 Income: The amount of money you have coming in from the invoice in reference, not 
including taxes. 

 Taxes Payable: The amount of money that you are going to pay in taxes for the invoice in 
reference. 

 Accounts Receivable: The amount of money (income + tax) you will receive from the 
customer for the invoice in reference. 

There are other accounting entries that can be made during invoice creation, but those are 
controlled by you. For example, coupon cost. When someone uses a coupon, Business 
Manager will keep track of how much the plan they purchased would have cost without 
applying a coupon. The system creates the appropriate expense entries each time an invoice 
is created. 

In addition to coupon cost, there is subscription cost. You have the ability to associate 
generic accounting entries with each plan created. These entries are created each time a 
subscription of that plan type is included on an invoice. 
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To set up invoicing, go to Business Setup > All Settings > Invoicing. 

Customizing PDF Invoices 

The system provides means for modifying the look and feel of printable invoices. It is 
possible to change invoice style and formatting, modify heading labels, or add custom text. In 
addition, if you send invoices in windowed envelopes, you have the option to modify the 
address block position to fit the window size. 

Business Manager also helps you create printable invoices from PDF templates that include 
watermarks, images or other information. 

 To update the appearance of printable invoices: 

1. Go to Business Setup > All Settings > PDF Invoice Customization. 

2. Update the configuration parameters. 

3. Click Save Settings. 

If your printable invoice requires more advanced customization, you are able to directly 
modify the code responsible for generating invoices in PDF format. To generate PDF 
documents, the code uses the TCPDF library. Refer to http://www.tcpdf.org/ to learn how to 
modify PDF generation code. 

The invoice rendering code is located at <BM_dir>/lib-

billing/include/config/PDFInvoice.example.php directory. Here <BM_dir> 

stands for the directory to which Business Manager was installed. Typically, it is 

/usr/local/plesk-billing on FreeBSD and RPM-based Linux systems, and /opt/plesk-

billing on deb-based Linux systems. 

 To add a PDF template: 

1. Create a one-page PDF file that the system will further use as a template for 
invoices generation. 

2. Rename the file to stationery.pdf, and put it into one of these directories 

depending on your OS: 

 For Linux, it is /usr/local/share/plesk-billing/ 

The system searches for this file and uses it as a PDF template if it is found. 

For experienced administrators, Business Manager provides an option to deeply modify 
printable invoices appearance by editing the PHP script that generates them - 

PDFInvoice.php. To generate PDF invoices, the script uses the TCPDF and FPDI 

libraries. For more information on these libraries, refer to the following sites: 

 http://www.tcpdf.org/doc/ for TCPDF. 

 http://www.setasign.de/support/manuals/fpdi/ for FDPI. 

The PDFInvoice.php is located in the following directory: 

http://www.tcpdf.org/
http://www.tcpdf.org/doc/
http://www.setasign.de/support/manuals/fpdi/
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 On Linux systems: opt/plesk-billing /htdocs/lib-
billing/include/config/  

 On Windows systems: C:\Program 
Files\Parallels\Plesk\billing\htdocs\lib-billing\include\config\ 

 
 

Achieving Tax Office Compliance 

For some organizations, it is obligatory to keep the originally generated invoices unchanged. 
However, when you re-send an existing invoice (from the invoice details page), the attached 
PDF file is re-generated and might be modified. The modification can be caused by changes 
to system-wide settings like invoices language, or personal details. 

If your local tax office requires that you not change invoice content once generated, save 
PDF copies of original invoices before modifying one of the following: 

 Company details. 

 Printable invoice appearance and language. For the operation details, see Setting Up 
Invoicing (on page 80). 

 Administrator language. For the operation details, Editing Administrator Profiles. 

Your customers are also able to cause changes to invoices content by modifying their 
contact information. 
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Configuring Schet-Facturas 

Schet-factura is a financial document that certifies that you supplied a taxable service to 
another party. If your company is registered in Russia, the system will generate and send 
these documents to some of your customers. If you do not need to keep or send these 
documents, please skip this section. 

How to Start Issuing Schet-Facturas 

The system decides whether to generate schet-facturas basing on system configuration 
settings (Business Setup > All Settings > Schet-Facturas Issuing). The first option in the settings 
list controls the documents generation. If it is selected, schet-facturas are generated basing 
on the restrictions set by other options on the page. Otherwise, if the first option is cleared, 
schet-facturas are not generated at all, and you are unable to view or upload them. For 
Russian companies (company's country is Russia) this option is initially selected. If your 
company is not from Russia and you wish to use schet-facturas, select the first option. 

When the System Issues Schet-Facturas 

The system issues schet-facturas in two cases:  

 At the first day of each month. These schet-facturas include information about all services 
provided during the month. Particularly, it includes payments for the following services: 

 Subscriptions that were not completed or canceled during the previous month. For 
such subscriptions, schet-facturas include payments for the period from the 
subscription creation to the end of the month (if the subscription was created in the 
previous month) or for the whole month (if the subscription was created earlier). 

 Hosting resources used over plan limits during the month if you allow pay-as-you-go 
hosting. 

 In case of changes to provided services. These changes - subscriptions upgrade, 
downgrade, or add-ons adjustment - can be initiated either by administrators or by 
customers. Any of these changes signals the system to issue a new schet-factura. The 
rationale for generating the documents is that previous service (the one before changes) 
was supplied in full and not used anymore. Say, if a customer has subscribed to the 
Bronze hosting plan and then upgraded it to Silver, the new schet-factura will be issued 
for Bronze since this service is fully supplied and the customer does not use it anymore. 

   

Who Can View and Download Schet-Facturas 

Schet-facturas are available for viewing and downloading only to administrators. Other users 
receive them only by e-mail and only if you allowed them to do it in schet-factura settings. 
For details on how administrators can view and download schet-facturas, see Viewing and 
Downloading Schet-Facturas (on page 169). 

How to Customize Schet-Facturas Content 

If you issue schet-facturas, you are able to configure Business Manager to fill in some of 
schet-factura fields automatically. For example, you can define company head and chief 
accountant names. To view the full list of customizable schet-factura fields and set values for 
them, go to the Business Setup > All Settings > Schet-Facturas Customization. 
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Additionally, you can customize the number of schet-facturas you issue. To do this, use the 
schet-factura number template - a line of characters and variables that defines schet-facturas 
numbers. The rules of the schet-facturas numbering are the same as for invoices numbering. 
To learn more about invoices numbering, refer to the section Setting Up Invoicing (on page 74). 

Account Creation and Suspension Policies 

To prevent situations when customers use your resources without paying for them, set up the 
rules that Business Manager will use to define when customers will get access to resources 
they order. For example, you can make the system create new hosting accounts in Panel 
after the corresponding invoices are issued and paid. Otherwise, to make your business 
more customer-friendly, you can let subscribers log in right after they place the order. Find 
instructions on configuring these rules in the section Setting Up Provisioning Policy (on page 
85). 

However, to automate the processing of situations when your customers do not pay for the 
resources they use, define how the system should deal with such customers. You can 
specify when the system will send them notifications about due invoices, and block their 
access to the system. The section Defining How to Handle Unpaid Subscriptions (on page 85) 
explains how to set up these parameters. 

In this section: 

Setting Up Provisioning Policy ........................................................................... 85 
Defining How to Handle Unpaid Subscriptions .................................................. 85 
 
 



 

 Setting Up Your Hosting Offers 85 

 

Setting Up Provisioning Policy 

Provisioning policy is a set of rules that define when customers get access to resources that 
they order (a hosting subscription, a domain name, or an SSL certificate). By setting up the 
appropriate provisioning policy, you can eliminate the risk of serving customers that will 
never pay even the first invoice: Just configure the provisioning policy so that new customers 
get access to Panel only after they pay their invoices. On the other hand, if you want to make 
your business more customer-friendly, you can let them use ordered resources immediately 
after placing the order.  

You can change the Business Manager provisioning policy at the Business Setup > All Settings 
> Provisioning Policy page. 

Note: When provisioning a customer account to a Panel, the system attempts to create the 
account with the username that the customer has specified in an online store. If this is 
impossible (for example, this username is already taken in Panel), the system generates a 
random username. In addition, the system always generates random usernames for 
customers' access to the server over FTP, SSH, and RDP. So, if your customers experience 
problems with logging in to Panel using their credentials, check the credentials of their 
accounts in Panel. 

Returning Money for the Days Before Provisioning 

When a customer subscribes to your services through an online store, Business Manager 
starts the billing cycle of the corresponding subscription beginning from the order placement 
day. For example, if a customer subscribes to a plan with the 1 month billing cycle on the 1st 
of June, the first invoice will include the payment for the period from the 1st of June to the 1st 
of July. Regardless of when the subscriber pays the invoice, the first billing cycle will end on 
the 1st of July. Thus, if the customer pays on the 6th of June, they will use the subscription for 
25 days for the price of the whole month. 

If you want to return money paid for the days when customers did not have access to their 
subscriptions, switch on the option Return unused money to credits on the Business Setup > All 
Settings > Provisioning Policy page. In this case, once a subscriber pays the invoice, the 
system adds the amount of money paid for the period between placing the order and 
receiving the payment to the subscriber's credits. Thus, in the example above, the system 
will return money paid for the period from the 1st of June to the 5th of June. 

Defining How to Handle Unpaid Subscriptions 

You have the option to automatically handle situations when customers have overdue 
invoices: In a certain time, Business Manager starts sending such customers notifications 
that remind about overdue invoices. If the customers do not close the invoices, the system 
suspends their unpaid subscriptions. However, you can restrict suspending subscriptions of 
certain customers as described in the section Limiting Discounts and Exempting Subscriptions 
from Suspension (on page 169).  

Also, Business Manager checks automatically suspended subscriptions with a periodic task 
to see if the associated invoice has been paid. If it has been paid, the system will activate the 
subscription. 
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The settings that define how to handle unpaid subscriptions are available at the Business 
Setup > All Settings > Cancelation of Unpaid Subscriptions page. 

Changing Company Details 

Different system modules extract data from your company details. For example, the e-mail 
templates pull your company name and contact information when creating e-mails. It is 
important to keep this information up-to-date. These values are initially filled with information 
gathered during the installation process.  

 To change company details: 

1. Go to System > System Configuration and click Company Details. 

2. Change the following as needed: 

 Name. Enter the name of your company here, as you would like it to appear to your 
customers. 

 Short Description. Provide a brief description of what your company does. 

 Description. You may enter a longer description here. 

 URL. This is the URL to your company's web page. 

 Customer URL. If you have made any changes to your Business Manager directory 
structure, you will want to edit this entry to reflect these changes. This URL 
determines where the system tries to take you when you click Login as Primary Contact 
on the customer details screen. 

 Order URL. This is the URL to your main order page. Most customers use a custom 
order page, so this may need to be updated. 

 E-mail. Enter your company's main contact e-mail address. 

 Address 1. Enter the first address line of your company's physical address. 

 Address 2. Enter the second address line of your company's physical address, or a PO 
box if you use one. 

 City. Enter the city of your company's address. 

 State. Enter the state of your company's address. 

 Country. Enter the country of your company's address. 

 Phone 1. Enter a primary phone number, so your customers can contact you if they 
need to. 

 Phone 2. Enter a second phone number if you have one. 

 Fax. If you have a separate fax number, enter it here. 

 Tax ID Number. If you have a Tax ID Number, enter it here. 

3. Click Save Changes. 
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Applying Your Branding 

To improve the recognition of your company brand and disguise the fact that you are a 
hosting reseller, Business Manager offers a number of ways to apply your branding, namely: 

 Make Business Manager and Panel available at your domain name. When your 
customers access the Control Panel using your provider's domain name, they can find 
out that you resell hosting resources, and so they may want to rent the resources from 
the provider directly. To avoid such a situation, register your own domain name and make 
the Control Panel available at your own address. Find instructions on configuring the 
access to the Control Panel at your domain name in the section Using Your Own Domain 
Name to Access Panel and Business Manager (on page 88) 

 Add your company information to e-mails that Business Manager sends to customers. 
Business Manager automatically sends e-mails to your customers in certain situations, for 
example, when a subscription is activated or an invoice is issued. Include your company 
information and graphic elements in the templates of such e-mails to let customers see 
your company name each time they receive a letter from the system. Learn how to 
configure e-mail sending and define the content of the letters in the section Setting Up 
Automatic E-mails (on page 89). 

 Add your company information to invoices issued by Business Manager. The printable 
invoices that Business Manager issues for customers must contain your company 
information. You can change the look of these invoices, for example, insert a logo into 
them. Learn how to change the content and look of printable invoices in the section 
Customizing PDF Invoices (on page 81). 

 Place your company logo and information on the pages of your online stores. To help 
new customers remember your company, include your logo and company information in 
the pages of online stores where you offer your services. Instructions on branding online 
stores are provided in the section Changing Online Store Appearance (on page 73). 

In addition to these methods, you can apply branding to the Server Administration Panel and 
the Control Panel as described in the section Changing Interface Settings (on page 22). 

In this section: 

Using Your Own Domain Name to Access Panel and Business Manager ......... 88 
Setting Up Automatic E-mails ............................................................................ 89 
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Using Your Own Domain Name to Access Panel and Business 
Manager 

By default, your customers access Business Manager with your provider's domain name. 
Therefore, they can discover that you are reselling somebody else's hosting resources, and 
may want to subscribe to your provider's services instead of yours.  

To avoid this, you need to set up branded domain name as an access point to the system. 
This assumes that you: 

1. Provide the Business Manager administrator with your organization domain name and 
purchase an additional domain name if the administrator says that you need it. Your 
customers will see this  domain name when Panel redirects them from the Control Panel 
to Business Manager for authorization purposes. 

2. Cooperate with the administrator so that your domain names are resolved to the Panel 
and Business Manager IP addresses. To do this, use one of the following ways: 

 Ask the administrator to add your domain names to their nameservers and use these 
servers as your domain names' DNS servers. 

 Purchase the DNS service from your domain name registrar and map your domain 
names to Business Manager and Panel IP addresses on the registrar's nameservers. 

3. Ask the administrator to configure the branding for the authorization server. 

After you complete these steps, you can find the new URL that is used for your customers' 
access to Business Manager on the Business Setup > All Settings > Company Details page. 
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Setting Up Automatic E-mails 

This chapter focuses on setting up automatic e-mails sent to users upon particular events. 
Sending e-mails to customers 'manually' is discussed in the Sending Mass E-mails (on page 
146). 

E-mails are an integral part of the Business Manager system. They are a large part of what 
makes it possible to automate: when a customer needs information, the system will generate 
and send an e-mail automatically, letting customers know if there is something they need to 
do or know. Without e-mails, managers would need to do a lot more work to keep their 
system up and running. 

Business Manager provides an extensive e-mail system that allows you to send e-mails 
based on locale. There is a set of e-mail actions which are specific to each type of e-mail 
group you will use in your system. 

Note: E-mail actions are pre-defined and cannot be modified. 

In this section: 

Adding E-mail Templates .................................................................................. 90 
Setting Up Your Locales .................................................................................... 91 
Editing Template Content .................................................................................. 92 
Reloading E-mail Templates.............................................................................. 93 
Getting Your System Ready to Send E-mail Messages ..................................... 93 
Customizing E-mail Templates .......................................................................... 94 
E-mail Template Variables ................................................................................ 96 
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Adding E-mail Templates 

 To add an e-mail template group: 

1. Go to Business Setup > All Settings > E-mail Templates. 

2. Find the e-mail action you want to add an e-mail template to and click Add 
Template. 

3. Fill in the necessary information. 

4. Click Save. 

5. Click Add Locale button in the middle of the page. Set up the following:  

 Choose the language to associate with the template. 

 Choose how broadly you would like the template to apply. If you are making a 
Spanish template, for example, do you want it to be used by Spanish speaking people 
world-wide? Or just in Spain? 

 If this is going to be the default locale, check the box. The default locale will be 
applied if no other locale can be found that applies to the customer. 

 Enter a subject for the email template. This is the subject line that each e-mail will 
use. 

 E-mail Template HTML Body. Enter the body of your e-mail template in html format. 

 E-mail Template Text Body. Enter the body of your e-mail template in text format. 

Note: All contacts are set to receive HTML by default when they come through the online 
store. If you do not want a specific customer to receive HTML e-mails, go to the 
customer's account details page and click on the edit primary button. Uncheck HTML for 
the E-mail Format. Click edit contact. 

6. Reload Options: If you need to reload the original email templates, perform the 
following steps: 

1. Select the template you want to reload. 

2. Reload HTML. Select Yes. 

3. Reload Text. Select Yes. 

Caution: This will replace this existing template. Make a backup of your existing template 

if you do not wish to lose it. 

7. Scroll to the bottom of the page, and click Save. 
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Setting Up Your Locales 

Business Manager has the ability to send e-mails in various different languages. Each of 
these locales must be set up during the configuration process. By default, the system sets up 
templates of a single locale (usually English). 

 To set up additional locales: 

1. Go to Business Setup > All Settings > E-mail Templates. 

2. Choose the template you would like to add a locale to. Click on the green 
pencil icon to view the edit screen for this template. 

3. Click Add Locale button in the middle of the page. Fill in the following: 

 Choose the language to associate with the template. 

 Choose how broadly you would like the template to apply. If you are making a 
Spanish template, for example, do you want it to be used by Spanish speaking people 
world-wide? Or just in Spain? 

 If this is going to be the default locale, check the box. The default locale will be 
applied if no other locale can be found that applies to the customer. 

 Enter a subject for the e-mail template. This is the subject line that each e-mail will 
use. 

 E-mail Template HTML Body. Enter the body of your e-mail template in html format. 

 E-mail Template Text Body. Enter the body of your e-mail template in text format. 

Note: All contacts are set to receive HTML by default when they come through the online 
store. If you do not want a specific customer to receive HTML e-mails, go to the 
customer's account details page and click on the edit primary button. Uncheck HTML for 
the E-mail Format. Click edit contact. 

4. Reload Options: If you need to reload the original e-mail templates, perform the 
following steps: 

1. Select the template you want to reload. 

2. Reload HTML. Select Yes. 

3. Reload Text. Select Yes. 

Caution: This will replace this existing template. Please make a backup of your existing 
template if you do not wish to lose it. 

5. Scroll to the bottom of the page, and click Save. 
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Editing Template Content 

Whether you have just created a new locale or want to edit the defaults, you will follow the 
same general instructions. In addition to basic html and text content, you can use a number 
of predefined variables to populate the e-mails with information from the database. 

 To edit content of a template: 

1. Go to Business Setup > All Settings > E-mail Templates. 

2. Choose the template you would like to edit. Click on the green pencil icon to 
view the edit screen for this template. 

3. Click the green pencil icon for an existing locale or edit the content while 
adding a new locale. 

4. Here you have a couple of options: you can develop the content on your 
own, or load our default template and then edit it. If you are looking at using 
our default templates, we recommend that you reload them before editing to 
be sure you have the latest version. 

 If you choose to use your own content, you would enter it in the fields E-mail Template 
HTML Body and E-mail Template Text Body. As you edit, you can click preview on most 
templates and it will allow you to see how your work will be parsed by the system. 

 If you prefer to save time by editing our template, you can scroll to the bottom of the 
page, choose the template you would like to use, click Test for both the HTML and 
text e-mail, and then click reload. You can now edit the template as above. 

Note: All contacts are set to receive HTML by default when they come through the online 
store. If you do not want a specific customer to receive HTML e-mails, go to the 
customer's account details page and click Edit primary. Uncheck HTML for the E-mail 
Format. Click Edit contact. 

5. Reload Options: If you need to reload the original e-mail templates, perform the 
following steps: 

1. Select the template you want to reload. 

2. Reload HTML: Select Yes. 

3. Reload Text: Select Yes. 

Caution: This will replace this existing template. Please make a backup of your 

existing template if you do not wish to lose it. 

6. Click Save. 

7. You will see your new template added with the locale you want to use for the 
e-mail template group you selected. You can add as many e-mail templates 
to this group or any other group as you need based on your specific needs. 
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Reloading E-mail Templates 

 To reload e-mail templates: 

1. Go to Business Setup > All Settings > E-mail Templates. 

2. Click the pencil icon next to each email template you want to reload. 

3. E-mail templates for each locale you have setup will display at the bottom of 
the page. Click the pencil icon in the Available Operations column. 

4. At the bottom of the Edit E-mail Template page are the Reload Options. Select the 
template you want to reload from the drop-down box. 

5. Select Yes for both Reload HTML and Reload Text. 

6. Click reload. The template has now been reloaded. 

7. Repeat steps 2-6 for each email template you wish to reload. 

Tip: If you are reloading all 25 email templates, save time by opening each email template in 
step 2 in a new window or tab, and go through the remaining steps one screen at a time. 

Getting Your System Ready to Send E-mail Messages 

Some users have reported instances where the e-mail templates, particularly the lost 
password e-mails, are being sent with the content missing. Below are some points to 
consider to ensure that your system is set up properly to send e-mail messages. 

Are e-mail templates set? 

First, check to make sure you have an email template set for each template group and 
locale. 

 To do so, perform the following steps: 

1. Go to Business Setup > All Settings > E-mail Templates. 

2. Click the pencil icon next to each e-mail template you want to view. 

3. An e-mail template for each locale you have set up will display at the bottom 
of the page. Click the pencil icon in the Available Operations column. 

4. You will see an HTML e-mail template and plain text email template. If these 
fields are blank, you will need to reload your e-mail templates as described 
in Reloading E-mail Templates (on page 93). 

5. Test to see if the e-mail was sent out successfully. If it is still blank, see 
below. 
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Is the temp directory set properly in your smarty.php file? 

 To check, perform the following steps: 

1. Open up the file lib-billing/include/config/smarty.php. 

2. Find the line $CONF[”smarty”][”compileDirectory”] = 

3. Make sure the path to your temp directory is set correctly after the = sign. 

Examples are provided below: 

 On Linux, this is typically $CONF[”smarty”][”compileDirectory”] = 
“/tmp”; 

 On Windows, this is typically $CONF[”smarty”][”compileDirectory”] = 
“C:\Temp”; 

4. Find the line $CONF[”smarty”][”cacheDirectory”] = 

5. Make sure the path to your temp directory is set correctly after the = sign. 

Examples are provided below: 

 On Linux, this is typically $CONF[”smarty”][”cacheDirectory”] = “/tmp”; 

 On Windows, this is typically $CONF[”smarty”][”cacheDirectory”] = 
“C:\Temp”; 

6. Save the file and test it to see if your e-mails are being sent out successfully. 

 

 
 

Customizing E-mail Templates 

All email templates in the system have special variables that are parsed at run-time. This 
means that the variables are replaced with the data they represent prior to being sent to the 
customer. Some general customer variables may be shared and made available in all 
templates, however many specific variables are unique to a particular template set (invoice 
data, subscription data, etc). It is important to understand that not all variables can be used in 
all templates. To view a list of available variables and their meanings, refer to the E-mail 
Template Variables section (on page 96). 

The template files are found in the lib-themes/default/lib-

billing/templates/emails/widgets/ directory. 

In this section: 

Updating the E-mail Header .............................................................................. 95 
Updating the E-mail Layout ............................................................................... 96 
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Updating the E-mail Header 

 To update the e-mail header: 

1. Login to your server via SSH. 

2. Open the following file in your Business Manager file set: lib-
themes/default/lib-

billing/templates/emails/widgets/header.tpl 

3. The code below controls the header of the email. Modify it to fit your needs:  

{$smarty.const[$headerTitle]|default:$headerTitle} 

4. Save the file. 
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Updating the E-mail Layout 

The e-mail templates are made up of several template files which control the display and 
layout of all 25 default email templates. To see which template files are used by each e-mail 
template, click the pencil icon to edit an individual e-mail template and view the source of the 

Email Template HTML Body, and find the corresponding fragments in files within the lib-

themes/default/lib-billing/templates/emails/ directory. 

Each component of the HTML email templates has its own header and footer file to make it 
easy to update each instance of that component throughout the email template set. For 
example, if you would like to edit the display of the information boxes that appear in any 

subscription Info e-mail template, simply edit the boxHeader.tpl and boxFooter.tpl 

files and the change will take effect across the entire e-mail template system. Likewise, 
tables that use IF statements to display or hide information such as in the New subscription 

order can be customized by editing the codeBoxHeader.tpl and codeBoxFooter.tpl 

files, and so on. The default e-mail templates we provide are designed to serve as examples 
that can be used by any business. You are encouraged to edit the colors, font styles, and 
layout to match your specific needs. 

E-mail Template Variables 

Below is a list of e-mail variables organized by the templates in which you can use them. 
Please note that these variables are hard coded in the system, and cannot be changed. 

In this section: 

Subscription Info E-mail ..................................................................................... 96 
Invoice E-mail .................................................................................................... 98 
Credit Card Payment ......................................................................................... 99 
eCheck Payment ............................................................................................... 100 
Bank Draft Payment .......................................................................................... 101 
Off-site Gateway Payment ................................................................................. 102 
Declined Payment ............................................................................................. 103 
Payment Error ................................................................................................... 105 
Domain Renewal Notice .................................................................................... 106 
Domain Transfer - Success E-mail .................................................................... 107 
Domain Transfer - Failure E-mail ....................................................................... 108 
Credit Card Expiration Notification E-mail .......................................................... 108 
Subscription Suspension E-mails ...................................................................... 109 
Subscription Enable E-mail ............................................................................... 110 
 
 

Subscription Info E-mail 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 
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Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Subscription Name {$packageName} 

Subscription Price {$packagePrice} 

Subscription IP  {$packageIP} 

Subscriber's username {$packageUsername} 

Subscriber's password {$packagePassword} 

Domain Name {$domainSLD} 

Domain TLD {$domainTLD} 

Nameserver 1  {$nameserver1} 

Nameserver 1 IP {$nameserver1IP} 

Nameserver 2 {$nameserver2} 

Nameserver 2 IP  {$nameserver2IP} 

Nameserver 3 {$nameserver3} 

Nameserver 3 IP {$nameserver3IP} 

Nameserver 4 {$nameserver4} 

Nameserver 4 IP {$nameserver4IP} 

Contact customer URL {$companyClientURL} 
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Contact User Name {$contactUsername} 

Date {$currentDateTime} 

 
 

Invoice E-mail 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Invoice Number {$invoiceNumber} 

Invoice Date Entered {$invoiceDateEntered} 

Loop Line Items 
BEGINNING  

{loop=lineItems} 

Line Item Comments {$lineItem.packageComments} 

Line Item Quantity {$lineItemQuantity} 

Line Item Description {$lineItemDescription} 
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Line Item Price Amount {$lineItemPriceAmount} 

Line Item Discount 
Amount 

{$lineItemDiscountAmount} 

Line Item Tax Amount {$lineItemTaxAmount} 

Line Item Total Amount {$lineItemTotalAmount} 

Loop Line Items END {/loop} 

Invoice Amount {$invoiceAmount} 

Invoice Date Due {$invoiceDateDue} 

Invoice Comments {$invoiceComments} 

Date {$currentDateTime} 

 
 

Credit Card Payment 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 
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Invoice Number {$invoiceNumber} 

Invoice Amount {$invoiceAmount} 

Credit Card Type  {$billingCardType} 

Credit Card Number {$billingAccountNumLastFour} 

Transaction Date/Time {$transactionDateCreated} 

Transaction ID {$transactionCode} 

Auth Return {$authReturn} 

Auth Code {$authCode} 

AVS Code {$avsCode} 

Transaction Amount {$transactionAmount} 

Notes {$transactionNotes} 

Date {$currentDateTime} 

 
 

eCheck Payment 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 
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Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Invoice Number {$invoiceNumber} 

Invoice Amount {$invoiceAmount} 

Bank Name  {$billingBankName} 

Bank ABA Code {$billingBankAbaCode} 

Bank Account Number {$billingAccountNumLastFour} 

Transaction Date/Time {$transactionDateCreated} 

Transaction ID {$transactionCode} 

Auth Return {$authReturn} 

Auth Code {$authCode} 

AVS Code {$avsCode} 

Transaction Amount {$transactionAmount} 

Notes {$transactionNotes} 

Date {$currentDateTime} 

 
 

Bank Draft Payment 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 
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Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Invoice Number {$invoiceNumber} 

Invoice Amount {$invoiceAmount} 

Bank Name  {$billingBankName} 

Bank ABA Code {$billingBankAbaCode} 

Bank Account Number {$billingAccountNumLastFour} 

Transaction Date/Time {$transactionDateCreated} 

Transaction ID {$transactionCode} 

Auth Return {$authReturn} 

Auth Code {$authCode} 

AVS Code {$avsCode} 

Transaction Amount {$transactionAmount} 

Notes {$transactionNotes} 

Date {$currentDateTime} 

 
 

Off-site Gateway Payment 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 
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Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Gateway Name {$gatewayName} 

Transaction Date/Time {$transactionDateCreated} 

Transaction ID {$transactionCode} 

Auth Return {$authReturn} 

Auth Code {$authCode} 

AVS Code {$avsCode} 

Transaction Amount {$transactionAmount} 

Notes {$transactionNotes} 

Date {$currentDateTime} 

 
 

Declined Payment 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 
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Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Invoice Number {$invoiceNumber} 

Invoice Amount {$invoiceAmount} 

Credit Card Type {$billingCardType} 

Credit Card Number {$billingAccountNumLastFour} 

Transaction Date/Time {$transactionDateCreated} 

Transaction ID {$transactionCode} 

Auth Return {$authReturn} 

Auth Code {$authCode} 

AVS Code {$avsCode} 

Transaction Amount {$transactionAmount} 

Notes {$transactionNotes} 

Date {$currentDateTime} 
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Payment Error 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Invoice Number {$invoiceNumber} 

Invoice Amount {$invoiceAmount} 

Credit Card Type {$billingCardType} 

Credit Card Number {$billingAccountNumLastFour} 

Transaction Date/Time {$transactionDateCreated} 

Transaction ID {$transactionCode} 

Auth Return {$authReturn} 



 

106 Setting Up Your Hosting Offers 

 

Auth Code {$authCode} 

AVS Code {$avsCode} 

Transaction Amount {$transactionAmount} 

Notes {$transactionNotes} 

Date {$currentDateTime} 

 
 

Domain Renewal Notice 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Domain Name {$domainSLD} 

Domain TLD {$domainTLD} 

Invoice Number {$invoiceNumber} 

Invoice Amount {$invoiceAmount} 
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Invoice Date Entered {$invoiceDateEntered} 

Domain Expiry Date {$domainDateExpires} 

Date {$currentDateTime} 

 
 

Domain Transfer - Success E-mail 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Domain Name {$domainSLD} 

Domain TLD {$domainTLD} 

Date {$currentDateTime} 
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Domain Transfer - Failure E-mail 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Domain Name {$domainSLD} 

Domain TLD {$domainTLD} 

Date {$currentDateTime} 

 
 

Credit Card Expiration Notification E-mail 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 
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Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Credit Card Type {$billingCardType} 

Credit Card Number {$billingAccountNumLastFour} 

Expire Month {$billingCardExpMonth} 

Expire Year {$billingCardExpYear} 

Date {$currentDateTime} 

 
 

Subscription Suspension E-mails 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 
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Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 

Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Invoice Number {$invoiceNumber} 

Contact Customer URL {$companyClientURL} 

Contact User Name {$contactUsername} 

Date {$currentDateTime} 

 
 

Subscription Enable E-mail 

Name Variable 

Your Company Name {$companyName} 

Your Company URL {$companyURL} 

Your Company Address 
1 

{$companyAddress1} 

Your Company Address 
2  

{$companyAddress2} 

Your Company City {$companyCity} 

Your Company State {$companyState} 

Your Company Zip {$companyZip} 

Contact First Name {$contactFirstName} 

Contact Last Name {$contactLastName} 
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Contact Name {$clientCompany} 

Contact Address 1 {$contactAddress1} 

Contact Address 2 {$contactAddress2} 

Contact City {$contactCity} 

Contact State {$contactState} 

Contact Zip {$contactZip} 

Invoice Number {$invoiceNumber} 

Invoice Amount Paid {$invoiceAmountPaid} 

Invoice Date Paid {$invoiceDatePaid} 

Subscription Name {$packageName} 

Date {$currentDateTime} 
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Plans and Add-ons 

In Parallels Customer and Business Manager, hosting services and resources that you sell to 
your customers are organized into service plans. For example, you can offer a hosting plan 
with 1 GB of disk space and 50 GB of monthly traffic. The tools for managing the plans are 
available at the Business Setup > Plans page. 

If you are going to offer a new plan, you should perform the following steps: 

1. Define what to include into the plan. 

2. Set subscription prices and taxes to levy on subscribers. 

3. Choose extra services and resources to offer with the plan. 

4. Choose the online stores in which you will offer the plan. 

5. Specify available upgrades and downgrades. 

Next, we will discuss these steps in more detail. 

Define Resources to Include into the Plan 

To get started with subscribing customers to service plans, first, you should specify what plan 
subscribers will get, that is, an amount of disk space, traffic, and other resources or services. 
Find the full range of options you are able to offer on the each plan settings page. For details 
on getting ready to sell hosting and defining resources that you offer in the plan, refer to the 
section Preparing to Sell Hosting Services (on page 113). 

Set Subscriptions Prices and Taxes to Levy on Subscribers 

After you allocated resources to a plan, configure the plan pricing. Namely, specify prices for 
different subscription lengths, burstable plan prices, and taxes that subscribers should 
additionally pay. For more details on setting prices and applying taxes to plans, refer to the 
section Plans Pricing (on page 114). 

Choose Extra Services and Resources to Offer with the Plan 

The plan is ready for sale, but you might want to offer some extras like additional e-mail 
addresses or disk space together with your plan. To do it, use add-on plans (or add-ons). To 
know more about add-ons and how to attach them to service plans, refer to the section 
Offering Additional Services (on page 116). 

Choose the Online Stores in Which You Will Offer the Plan 

The last step is to specify in what stores you want to distribute the plan. You can select 
stores of your liking in the General tab of the plan settings page. For each kind of plan, you 
can choose stores of a single type – customer stores for service plans and reseller stores for 
reseller plans. To learn more about online stores, refer to the chapter Managing Online Stores 
(on page 71). 
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Specify Available Upgrades and Downgrades 

If you have multiple plans of the same type, you are able to specify plans to which the current 
plan can be upgraded or downgraded. Find more information on plan upgrades and 
downgrades in the section Upgrading and Downgrading Plans (on page 117). 

In this section: 

Preparing to Sell Hosting Services .................................................................... 113 
Plans Pricing ..................................................................................................... 114 
Offering Additional Services .............................................................................. 116 
Upgrading and Downgrading Plans ................................................................... 117 
 
 

Preparing to Sell Hosting Services 

To sell hosting services, use hosting plans. Getting ready to sell hosting services includes 
the following steps: 

1. Define how to process new hosting subscriptions. 

Just before creating the subscription, Business Manager checks that the subscriber 
meets certain requirements (for example, does not have unpaid invoices) and creates the 
subscription only if all requirements are met. The list of these requirements is called 
provisioning policy. Before you start selling hosting services, check that this policy meets 
your needs at Business Setup > All Settings > Provisioning Policy. 

2. Add a plan and select reseller subscriptions whose resources you will use to serve the 
plan subscribers. 

Available subscriptions are listed in plan settings, on the Properties tab. If you associate a 
plan with a reseller subscription, Business Manager will use resources of this subscription 
to serve accounts of the plan subscribers. 

3. Specify resources and services you want to include into the plan. 

Select the resources that you will offer to subscribers in plan settings, on the Properties 
tab. 

4. Restrict access to web applications. 

Your customers have the opportunity to quickly install and use blogs, forums, image 
galleries, and other web applications. You can restrict access to certain applications by 
defining application filters in plan settings, on the Applications tab. 
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Plans Pricing 

A plan price in Business Manager is a combination of the following values: 

 Subscription price. This is a price you charge your customers for using services during a 
billing cycle. You can set multiple billing cycles with different prices for a single plan. For 
example, set the price to $10 for a 6-months subscription and $15 for a 1-year 
subscription. 

You can also define one-time charge - setup fee - for your plans. For customers who 
upgrade or downgrade their subscriptions to other plans, you can also set upgrade and 
downgrade fees. 

 Tax. If your country's legislation implies levying taxes on customers, you can include 
these taxes in the plan price. Learn how to set up taxes for your services in Business 
Manager in the chapter Configuring Taxation (on page 67). 

After you create certain taxation policies and apply them to the plans, do not forget to 
configure online stores where you will sell these plans to display prices properly: including 
taxes (gross prices) or excluding them (net prices). You can do this at Business Setup > 
Online Stores > <store name> > Change Settings > Payment Options tab. 

 Burstable plan prices (for hosting plans). If you allow subscribers to use Panel resources 
beyond plan limits (or allow pay-as-you-go web hosting), the subscribers will pay these 
prices for each unit of a resource that they consumed over the limits during a month. To 
learn how Business Manager defines calculates the monthly costs of resources overage 
(usage charges), see the section Calculating Usage Charges (on page 115). To allow 
resources overage, choose the appropriate option for the Web Limits > Pay-as-you-go web 
hosting on the Properties tab of the plan settings page. 

The elements for setting subscription prices, taxes, and overuse fees are located in plan 
settings, on the Prices & Taxation tab. 

You can reduce plan prices for promotional purposes by using discounts, coupons, and 
customer groups. Find more information on using these mechanisms in the section Coupons 
and Discounts (on page 133) and the section Limiting Discounts and Exempting Subscriptions from 
Suspension (on page 169). 

If you use accounting facilities included in Business Manager, you can define what 
information to add to the ledger after generation and payment of each invoice. Learn how to 
define this format in the section Creating General Ledger Entries for a Plan (on page 115). 

In this section: 

Calculating Usage Charges ............................................................................... 115 
Creating General Ledger Entries for a Plan ....................................................... 115 
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Calculating Usage Charges 

If the pay-as-you-go web hosting is allowed for a plan, Business Manager calculates usage 
charges - total costs of hosting resources overage - for the plan's subscribers basing on 
resource usage statistics that Business Manager collects from the connected Panels on a 
daily basis. No matter what billing mode and billing cycles you use, this happen on the first 
day of each month: The system finds the average daily overage of each resource except 
traffic and multiplies it by the month length and the monthly usage price of this resource. 

Traffic 

The traffic usage charge is calculated in the following way: Business Manager counts the 
total traffic overage for a month and multiplies it by the monthly traffic usage price. Say, if 
subscribers download 10 GB of files during a month while the plan limit is 5 GB, then the 
traffic overage is 5 GB. Assuming that the traffic usage price is $1 for a 1 GB, such 
subscribers will pay (10 GB - 5 GB) * $1 = $5 traffic usage fee. 

Other Resources 

For calculation usage charges for other resources, Business Manager uses the average daily 
usage values. For example, if a customer uses 500 MB of disk space over the subscription 
quota for 15 days and then uses extra 700 MB for other 15 days, the average overage will be 
(500 * 15 + 700 * 15)/30 = 600 MB. If the disk space usage price is $1 for 1 GB, then the 
customer will pay $0.6 for disk space overage this month. 

Calculating Usage with Add-ons 

If a customer purchases additional resources in the middle of a month, then the system 
subtracts the resource amount provided by the add-on from the daily resource usage of each 
day starting from the add-on purchasing day. 

For example, if a customer uses 500 MB of disk space over the plan limit for a whole month 
and purchases the add-on that provides an additional 1 GB of disk space on the 7th day of 
the month, then the usage charge will include the payment for only 7 days of 500 MB of disk 
space overage. 

Creating General Ledger Entries for a Plan 

If you use Business Manager for accounting of your business, configure your plans to write 
information on performed business operations to the general ledger. 

For example, if you want to track the price of domain registration that you pay to the registrar, 
define the ledger entries for this plan as described below. 

 To create ledger entries: 

1. Go to Business Setup > Plans, and select a plan. 

2. Click Ledger Entries. 

3. Click the button Add Ledger Entry Group. 
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4. Set the following: 

 Ledger Group Name. Enter the name of the ledger group you are creating for this plan. 
For example, if this group covers the cost of this plan, you may want to name it 
Domain Registration Cost. 

 Filter Currencies. The ledger entries are created when the plan is ordered through your 
online store. If you have multiple currencies set up, such as USD and GBP, move the 
currencies from the Selectable list to the Selected list by double-clicking on each one or 
using the arrow buttons. 

 Filter Cycles. Similarly to Filter Currencies, you can select cycles for which you will create 
ledger entries. Move the cycles from the Selectable list to the Selected list by double-
clicking on each one or using the arrow buttons. 

 Currency of Ledger Entries. The currency you select will most likely be your native 
currency or the currency you use to set up your plans. You can still create ledger 
entries for any currency, but you will see the entries such as Domain Registration 
Cost in the currency you select from the menu. 

 Ledger Entries: 

a. Create two ledger entries for the GL Account (General Ledger) 
account by clicking the + Add Ledger Entry button. 

b. Select a ledger account to use such as 10000 - Cash 1 from the GL 
Account menu. 

c. Enter a description. 

d. Enter the cost of the plan in the Credits text box. 

e. Click the + Add Ledger Entry button again. 

f. Select a ledger account to use such as 50000 - Cost of Goods from 
the GL Account menu. 

g. Enter a description. 

h. Enter the cost of the plan in the Debits text box. 

Click Save. 

Offering Additional Services 

In Parallels Customer and Business Manager you can offer additional resources and 
services not included in service plans as add-on plans (or add-ons). Add-ons are listed 
together with plans on the Business Setup > Plans page. If a plan has add-ons, online stores 
show them on a separate store page, so customers are welcome to include add-ons into 
their order. The controls to attach add-ons to plans are available on the Add-ons tab of the 
plan settings page. 

Typically, an add-on provides a single resource: disk space, traffic, or other resource defined 
for the panel group you select for the add-on. You are also free to offer multiple resources 
and services as a single add-on. 
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To let your customers choose an add-on from a list of similar add-ons, say, different amounts 
of additional disk space, add-ons are organized into groups. Moreover, it is mandatory for an 
add-on to have a related group. When buyers subscribes to a plan, they see the names of 
add-on groups you attached to this plan and lists of groups items - add-ons - you selected for 
the plan. 

For example, this can look like the following: 

Would you like additional disk space? (add-on group) 

 1 Additional Gigabyte (add-on) 

 2 Additional Gigabytes (add-on) 

 5 Additional Gigabytes (add-on) 

To see a list of plans with which you offer an add-on, go to the Plans tab of the add-on 
settings page. 

Important: A service plan and attached add-on must have same billing cycles and 
currencies. Otherwise, customers will not be able to purchase this add-on.   

In addition to offering hosting add-ons, you can sell SSL certificates using add-ons. For 
instructions on how to set up the SSL certificates selling through an add-on, see the section 
Offering Hosting Plans with SSL Certificates (on page 129). 

Upgrading and Downgrading Plans 

Your customers may want to change plans to which they are subscribed, for example, if they 
need more resources that their current plans provide, or otherwise, if they do not want to pay 
extra money for resources that they do not use. For these cases, define available upgrades 
and downgrades for each plan. 

You can use plans upgrades and downgrades to create a hierarchy of plans. The table below 
shows an example of plans set with available upgrades and downgrades: 

Plan Description Available upgrades Available downgrades 

Bronze Hosting An affordable hosting for 
individuals. 

 Silver Hosting 

 Gold Hosting 

No 

Silver Hosting Hosting for small business.  Gold Hosting  Bronze Hosting 

Gold Hosting An ultimate hosting for 
business needs. 

No  Bronze Hosting 

 Silver Hosting 
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If you offer plan upgrading and downgrading, define how to process upgrade and downgrade 
requests for all plans, for example, when to perform requested upgrades: immediately after 
requests or and the end of current billing cycle. The section Configuring Upgrade and Downgrade 
Requests Processing provides a list of  system-wide properties related to upgrades and 
downgrades and description of these properties. 

Besides, Business Manager provides an option to charge customers  for upgrading or 
downgrading their subscriptions. Define upgrade and downgrade fees for each plan on the 
Prices tab of the plan settings page. 

Upgrade and Downgrade Requests Processing 

The Business Manager allows you to define what actions the system takes when upgrading 
or downgrading plans. This includes the following: 

 Who can initiate upgrades and downgrades. 

 How to perform upgrades and downgrades. 

 How to bill upgrades and downgrades. 

The controls to configure upgrade and downgrade requests processing are located at the  
Business Setup > All Settings > Upgrade/Downgrade Requests. 

Customer-Initiated Upgrades and Downgrades 

If you allow your customers to initiate upgrades and downgrades, define when to change 
their plans: immediately after request or at the end of current billing cycle. 

If you decide to perform upgrades and downgrades immediately, define what to do with 
unused money on customer's billing account: 

 Return the unused money to customers as credits. Choose this option, for example, for 
hosting plans. 

 Do not return the money, Do it, for example, for domain registration plans, when the 
registrar does not return the money if you stop using a domain name. 

 

Troubleshooting Delayed Upgrades and Downgrades 

If you configure your Business Manager to perform subscription upgrades and downgrades 
at the end of billing cycles (or perform delayed upgrades and downgrades), then upgrade 
and downgrade requests receives advanced handling. To help you troubleshoot potential 
issues with delayed upgrades and downgrades, below we will describe handling of such 
requests in details.  

For example, a customer has a Bronze hosting subscription and orders an upgrade to the 
Silver hosting plan. In this case, Business Manager will do the following: 

1. Immediately after triggering the upgrade request, the system creates a new subscription 
to Silver hosting with the Pending status. The Bronze hosting subscription remains 
Active. 

2. In a few days before the end of the current billing cycle, Business Manager issues an 
invoice for the Silver hosting subscription renewal. 
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3. At the first day of the next billing cycle, the system upgrades the subscription on Panel 
and removes the Bronze hosting subscription. If the upgrade was successful, Business 
Manager changes the Silver hosting subscription's status to Active.Otherwise, the Silver 
hosting subscription receives the Error status. 

Before the system issues an invoice for the upgraded subscription, either you or the 
subscriber can cancel the upgrade by clicking Cancel subscription upgrade or downgrade on the 
Bronze hosting subscription's page. If you do this, Business Manager cancels the Silver 
hosting subscription and issues the next invoice for the Bronze hosting as usual.  

After issuing the invoice for the upgraded subscription, neither you nor the subscriber can 
cancel the upgrade request. 
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Achieving EU Business Compliance 

If your Business is located in the European Union, it is subject to the European Union Value 
Added Tax (EU VAT) regulations. To learn more about the regulations, see the section 
European Union Business Compliance. 

To achieve EU business compliance, configure Parallels Customer and Business Manager to 
meet the following requirements: 

 Specify your VAT number in Business Setup > All Settings > Company Details. Business 
Manager will include it into all invoices. 
 

 Set up the VAT charging for your customers from EU countries. For detailed instructions, 
see the section European Union (on page 70).   
 

 Require VAT number from commercial companies. 

In your online stores, customers select whether they are individuals or commercial 
companies. In the latter case, they are required to provide a valid VAT number to define 
an applicable VAT rate. You should adjust your online stores to require this number from 
commercial companies and verify it. The respective option is available in the Business 
Setup > Online Stores > <store name> > Change settings > Taxes tab. The <online store> here is 
the store which you use to sell plans to EU customers. 

Note: If your company address is in the EU, these settings will be automatically applied to 
all new online stores. 

 Display either gross or net prices in your online stores. 

Each EU country follows one of two different rules for the way prices are displayed in 
your online stores. Depending on the location of your business, your online stores must 
display prices either with VAT included (gross) or before VAT is added (net). You can 
update your online stores to display prices accordingly on the  Business Setup > Online 
Stores > <store name> > Change settings > Payment Options tab. The <online store> here is the 
store which you use to sell plans to EU customers. 

Starting Business Without Business 
Manager 

If your provider does not offer Business Manager or another billing solution, you should take 
care of various aspects of your business on your own before you start serving customers. 
Some aspects, for example, financial ones, can be automated by means of the appropriate 
software. 

To start your hosting business in Panel without Business Manager or other automation 
solutions, do the following: 

 Rebrand Panel and prepare hosting plans. 

 Set up a website for your own company. 

After you complete these operations, you can start subscribing customers to your services. 
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Rebranding Panel and Preparing Hosting Plans 

Before you can start serving your customers, you should do the following: 

1. Adjust Panel branding and appearance as described in the section Changing 
Interface Settings (on page 22). 

2. On the Service Plans page, add service plans and add-ons that you will offer to 
your customers. 

 

Setting Up Your Company's Presence on the Web 

To let your prospective customers become acquainted with your offerings and contact you, 
set up a website and e-mail addresses for your company on the Panel-managed server. 

To set up your website, create your own hosting subscription by clicking  Subscriptions > 
Create New Subscription. This will enable you to log in to the Control Panel and manage your 
web hosting just as your customers do: you can create web pages and mailboxes, install web 
applications, secure access to websites with SSL certificates, and so on. For detailed 
information about using your hosting resources for your own needs, see the chapter Managing 
Web Hosting (on page 189). 

Subscribing Customers to Your Services 

After you set up hosting plans in Panel, you can start subscribing customers to your services. 
When a new customer subscribes to your services, create an account and a subscription for 
this customer in Customers > Add New Customer. You will be prompted to enter the following 
information: 

 The customer's contact information. 

 A username and a password that the customer will use to log in to the Control Panel. 

 Subscription details: 

 A domain name that the customer owns and will use for their website hosted in Panel. 

 An IP address used by the customer's website. 

 The customer's username and password that they will use to access their folders, for 
example, using FTP. 

 The service plan to which the customer subscribes. 

 (Optional) Add-ons that the customer wants to add to the subscription. 

If the plan selected by the customer does not completely meet their needs and you do not 
offer add-ons that could help, adjust the subscription settings by selecting the checkbox 
Proceed to customizing the subscription parameters after the customer account is created. 

Once you create the account and the subscription, pass on the Panel access credentials to 
the customer and they will be able to log in to Panel and create their website. 



 

122 Setting Up Your Hosting Offers 

 

Periodically, you will need to manually perform various operations on user accounts and 
subscriptions. For example, renew (prolong) subscriptions at the end of subscription periods, 
or suspend the accounts of customers who do not pay on time. To learn how to manage 
existing customer accounts and subscriptions in Panel if you do not have Business Manager, 
refer to the sections Managing Customer Accounts in Panel (on page 149) and Managing 
Subscriptions in Panel (on page 158). 

 

 

 



 

  
 

In addition to offering server resources, with Business Manager you can upsell services 
that traditionally accompany web hosting offers: domain name registration and SSL 
certificates. Thus, your customers can get all they need to establish their web presence 
in a single package. 

For selling domain name registration services and SSL certificates in your online 
stores, you will need to create separate service plans. Below, you will find information 
about how to do this. 

Selling Domain Names 

To start offering domain names in your online stores, you should have a merchant 
account at a domain name registrar supported by Business Manager. If you have such 
an account, then all you need is to configure the registrar module in the system and 
create a domain name registration plan. Learn more about setting up domain name 
selling in the section Domain Name Registration (on page 124). 

Selling SSL Certificates 

To let customers order SSL certificates through your online stores, configure Business 
Manager to offer certificates from certain vendors that Business Manager supports, and 
create corresponding SSL certificate plans. For detailed instructions on setting up SSL 
certificate offerings, refer to the section SSL Certificate Selling (on page 128). 

In this chapter: 

Domain Name Registration ............................................................................... 124 
SSL Certificate Selling ....................................................................................... 128 
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Domain Name Registration 

Business Manager supports integration with a variety of domain registration services. 
We assume that you have a merchant account with one of the registrars supported by 
Business Manager. To start selling domain names from this registrar in your online 
stores, take the following steps: 

1. Set up a registrar module and define which domain names you will register with this 
registrar. 

For each registrar, you should define which top level domains (or TLDs - domain 

name extensions such as .net or .com) your customers will buy from this 

registrar. Learn how to configure domain name registrar modules in the section 
Setting Up Accounts with Registrars (on page 125). If a TLD that you want to offer is 
not present in Business Manager, you can add it manually. To find out how to add 
new TLDs or change the properties of existing ones, refer to the section Managing 
TLDs (on page 126). 

2. Add a domain registration plan and define which of the supported TLDs you will 
offer within it.  

To sell domain names, create domain name registration plans on the Plans page. 
For each plan of this type, select TLDs that you will offer within this plan on the TLDs 
tab of the plan settings page. 

3. Define domain registration options for online stores. 

During the domain name ordering process, potential customers are prompted to 
choose from the three options: purchase a new domain name, transfer an existing 
one to another registrar, or use an existing domain name. You are able to change 
the list of available options at the Business Setup > Online Stores > <store name> > 
Change Settings > Domain Registration/Transfer tab. 

Important: Not all domain registrars support domain transfer. To find out if a 

particular registrar supports the transfer, contact the registrar's customer support. 

Offering Domain Name Registration in the Control Panel 

If you offer domain name registration services, Business Manager can help you 
promote them to your hosting customers. Particularly, Panel shows customers links 
that let them register their domain names through your online stores. These links are 
displayed in the domain names list on the Websites & Domains tab. When a customer 
follows a link, Panel takes them to the online store where they purchased their hosting 
subscription and automatically adds a domain name registration subscription to their 
cart.  

Note: If you have several online stores, the links will lead a customer to the online 

store where they purchased their hosting subscription. 
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Panel offers customers to register only those domain names that were not purchased 
in your online store, particularly: 

 Domain names that customers specify as existing ones when purchasing hosting 
subscriptions. 

 Additional domain names that customers create in the Control Panel. 

If you have at least one domain name registration plan, Panel will automatically add 
corresponding links to the Control Panel. If you offer several domain name registration 
plans in a store, put the plan you want to promote above other plans of this type in the 
store's plans list. You can find the list on the Offered Plans tab of the store settings page. 

In this section: 

Setting Up Accounts with Registrars ................................................................. 125 
Managing TLDs ................................................................................................. 126 
 
 

Setting Up Accounts with Registrars 

If you wish to resell domain names with a certain registrar, you should add information 
about your merchant account to Business Manager. The system will resell domain 
names on behalf of this account. 

Some domain name registrars require you to do additional actions to start reselling. 
These particularities are described in corresponding subsections of this section. 

 To add information about your account with a registrar: 

1. Go to Business Setup > All Settings > Domain Registrars and click Add New 
Registrar. 

2. Select the registrar at which you have a merchant account and click 
Select. 

3. Specify your account credentials, TLDs that you will register at this 
registrar, and other settings. 

4. Click OK. 
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Wild West Domains (GoDaddy) 

Only certified accounts are able to resell domain names with the Wild West Domains 
registrar, so you should pass the certification to start reselling. 

The certification procedure verifies that your software is capable of using the registrar's 
API. You can proceed to the certification as soon as you add the registrar's module and 
specify your reseller account details. When this data is provided, the system will display 
the link Learn how to complete the certification here with detailed instructions on how to get 
certified.  

Openprovider 

When you configure this registrar, set Remote host to 

http://www.openprovider.nl/incoming_custxml.php. 

Managing TLDs 

The system ships with a predefined set of TLDs that you can sell to your customers. If 
this set does not contain a TLD that you want to offer, add this TLD by clicking Add TLD 
on the Business Setup > All Settings > Supported TLDs page. 

In your domain name registration plans, you can sell only active TLDs. Initially, all TLDs 
are inactive. To make a TLD active, configure a module of a domain name registrar 
and select this TLD on the registrar module settings page. Otherwise, you can make a 
TLD active by editing its settings on the Business Setup > All Settings > Supported TLDs 
page. 

Checking Domain Names Availability 

When a customer tries to register a new domain name through your online store, 
Business Manager first checks whether this name is available. By default, the system 
can check the availability of domain names only in TLDs that are included in the 
Supported TLDs list shipped with Business Manager. When you add a new TLD to the 
system, you should configure its checking parameters as described below. 

For each TLD, there is a server on the Internet that provides information about domain 
names in this TLD. To check the availability of a domain name, Business Manager 
sends a request to the corresponding server and defines the availability depending on 
the server's response. For most TLDs, such servers use the whois protocol that defines 
the format of a request you send to this server. 
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If the server that checks domain names availability in your TLD uses this protocol, 
specify the server's domain name and, optionally, port (if it differs from the standard 43 
port) in the Whois server field. If the server uses the HTTP protocol, you should explicitly 
specify the format of requests that you will send to the server. In this request, you can 
use the following variables:  

 %%domain%% - a domain name that you want to check. For example, domain-

sld.tld. 

 %%domainSLD%% - a part that precedes the period in the domain name - second 

level domain name (SLD). domain-sld in the example above. 

 %%domainTLD%% - a TLD. tld in the example above. 

Then, for both protocols, specify the values that indicate the domain name availability 
in the Whois response fragment indicating that domain name is available and Whois match rule 
fields.  

The examples below show how to configure checking domain names in a TLD with the 
whois and HTTP protocols: 

 Whois protocol:  

 Whois server: whois.centralnic.net 

 Whois response fragment indicating that domain name is available: DOMAIN NOT 
FOUND 

 Whois match rule: Should contain fragment. 

 HTTP:  This example show the settings for the tj TLD: 

 Whois server: 
http://www.nic.tj/cgi/lookup3?domain=%%domainSLD%% 

 Whois response fragment indicating that domain name is available: available for 
registration 

 Whois match rule: Should contain fragment. 
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SSL Certificate Selling 

Business Manager supports integration with SSL certificate providers. The integration 
supposes that customers purchase certificates in Business Manager, and the latter 
acquires the certificate through the provider API. 

To acquire an SSL certificate, a customer submits the initial information to Business 
Manager, which forwards it to a provider. The certificate provider analyzes the 
information and queries for additional details if necessary through Business Manager. 
The interaction is repeated until the provider has enough information to issue the 
certificate. 

Customers are notified about these additional requests by notifications in the Account 
tab of the Panel. Until the certificate is issued, the subscription status is user input 
required. 

To sell SSL certificates to your customers, use SSL certificate plans. Configuring SSL 
certificate selling includes the following steps: 

1. Configure an SSL certificate provider plugin. 

This will allow you to sell certificates from this provider. Learn how to do it in the 
chapter Configuring SSL Certificate Providers (on page 129).  

2. Add an SSL Certificate plan and set up the certificate types you will sell. 

Do this from the Properties tab of the plan settings page. 

You can also configure the system to automatically offer SSL certificates to hosting 
plan subscribers in online stores. This way is natural and convenient: when customers 
subscribe to a hosting plan, the online store offers them the chance to purchase an 
SSL certificate to protect their websites. To learn how to set up the SSL certificates 
offering, see the section Offering Hosting Plans with SSL Certificates (on page 129). 

In this section: 

Configuring SSL Certificate Providers ............................................................... 129 
Offering Hosting Plans with SSL Certificates ..................................................... 129 
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Configuring SSL Certificate Providers 

If you want to sell SSL certificates, first add and configure a plugin that will interact 
between Business Manager and one of the certificate providers (authorities). After you 
add a plugin, it is possible to edit the plugin properties, enable or disable it. If a plugin is 
enabled, you can associate it with SSL certificate plans. 

Note: Disabling a plugin associated with existing plans leads to malfunctioning of the 
system. 

 To create a plugin: 

1. Go to Business Setup > All Settings > SSL Certificate Providers and сlick Add 
New Plugin. 

2. Fill in the necessary parameters in the opened wizard and click OK. 

This will open the list of plugins containing the newly created one. 

 To edit a plugin: 

1. Go to Business Setup > All Settings > SSL Certificate Providers and click the 
plugin you wish to edit. 

2. Update the necessary parameters and click OK. 

This will open the list of plugins. 

 To enable or disable a plugin: 

1. Go to Business Setup > All Settings > SSL Certificate Providers and select the 
plugins you wish to enable or disable. 

2. Click the Enable or Disable item below the search bar. 

This will open the updated list of plugins. 

Note: Disabling a plugin associated with existing plans leads to malfunctioning of 

the system. 

Offering Hosting Plans with SSL Certificates 

If you resell SSL certificates through your online stores, you can configure the system 
to automatically offer SSL certificates to customers who subscribe to hosting plans. 
This is more convenient for subscribers since this allows them to purchase hosting 
resources and protection for their websites in bundle: online stores prompt them to 
secure their websites with SSL certificates and then, if they agree, they automatically 
order an SSL certificate of the selected type. 
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 To set up a secure hosting offering: 

1. Create SSL certificates plans that will offer SSL certificates of the 
needed types. 

2. Select a hosting plan with which you will offer SSL certificates or add a 
new one. 

3. Go to the tab SSL Certificates of the hosting plan settings page and add 
the SSL certificate plans to the Available list. 

If a customer purchases a hosting package with an SSL certificate that you order from 
the eNom, the system automatically install the certificate to the customer's website. 
Otherwise, subscribers should configure the website protection with their certificate in 
the Control Panel manually. 



 

  
 

When you configure the system and start serving your customers, Business Manager 
creates new customer accounts, issues invoices, and performs most of other provider's 
tasks automatically. However, you might still need to perform some operations in 
Business Manager and Panel. For example, change system security settings of 
Business Manager or define content to include in new websites created in Panel. 

This section explains how to perform the following tasks related to maintaining and 
growing your hosting business with Business Manager and Panel. 

Section Description 

Promoting Your Plans Explains how to promote your business using 
Business Manager marketing tools. 

Administering Customers Explains how to perform different tasks related to 
customer accounts management. 

Managing Subscriptions Provides instructions that you may need to 
manage your customers' subscriptions. 

Managing Invoices and Payments Provides instructions on managing invoices in 
Business Manager management tasks manually. 

Limiting Discounts and Exempting Subscriptions 
from Suspension 

Explains how to set up special conditions of 
services for certain customers in Business 
Manager. 

Managing Security Settings Provides instructions on enhancing the Business 
Manager security using integrated tools. 

Performing Manual Payments Describes available ways of charging your 
customers manually in Business Manager. 

Managing Bank Transfers Explains how to process bank transfers in 
Business Manager. 

Viewing and Running Scheduled Tasks Describes the concepts of automatic task 
scheduling and running and explains how to run 
tasks manually. 

Viewing Accounting Information Introduces the Business Manager accounting 
mechanism. 

Viewing Statistics Explains how to view information about the current 
usage of your resources and your customers' 
connections to Panel. 

Presetting Content of Customer Websites Describes the mechanism that allows you to 
predefine content of new websites that you 
customers create. 
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Promoting Your Plans 

Promotion is an important aspect of every business nowadays. Effective promotion can 
make your business more successful in different ways, for example, improve the 
recognition of your brand, attract new customers, and increase the loyalty of existing 
customers. 

Business Manager contains a set of strategies that will help you promote your 
business. Particularly, you can use the following options:  

 Discounts  - reduce prices of certain plans in you online stores for everybody. 

 Coupons  - reduce order price for their owners. 

 Affiliate programs  - let your subscribers earn money by bringing new customers. 

The controls to configure these marketing tools are available to you on the Business 
Setup > Marketing Tools page. To learn when and how to apply these tools, read the 
corresponding subsections of this section. 

In this section: 

Coupons and Discounts .................................................................................... 133 
Affiliate Programs .............................................................................................. 134 
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Coupons and Discounts 

Business Manager contains two mechanisms to reduce prices of your offerings - coupons 
and discounts.  

Use discounts if you want to promote a subscription for a certain billing cycle, say, 1-year 
subscription. A discount targets all online stores but only particular billing cycles of plans.  

Use coupons to organize promotional actions among your customers. With coupons, your 
customers are able to reduce subscription price by entering in a coupon code during the 
ordering process. Coupons are best for promoting specific plans in a certain store. Say, if 
you sell a plan in two stores, US Store and EU Store, you have the option to lower the 
subscription price only in EU Store. 

To create limited offerings, for example, discounts for the first 100 subscriptions to a new 
plan, create a coupon and set it to be automatically applied. In this case, online stores show 
new prices of the plans as if the coupon was already applied to the plans. 

The table below describes the differences between discounts and coupons: 

 
Discounts Coupons 

Availability to 
customers 

Lower prices for all customers Lower prices for those who have 
coupon codes (unless the coupons 
are applied automatically) 

Apply to a specific 
store 

No Yes 

Reduce price for a 
certain billing cycle 

Yes No 

Cut-off amount Percentage of subscription 
price 

 Percentage of subscription 
price 

 Fixed amount 

Period of action Unlimited  A number of billing cycles 

 Unlimited 

Validity period: Unlimited  Limited 

 Unlimited 
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To create and manage discounts and coupons, use the controls on the Business Setup > 
Marketing Tools page. 

Affiliate Programs 

Business Manager enables you to involve your customers in promoting your plans: Affiliate 
programs let customers earn money by bringing new customers to you. Customers 
participating in your affiliate programs (your affiliates) distribute links to your websites and 
earn a commission for each sign-up under these links. Later, you pay out this money to 
affiliates as credits so they can use it to pay for existing subscriptions or order new services 
in your online stores.  

Affiliate programs have a great advantage over traditional advertising: they allow you to pay 
for promotion only when it brings the result you want. In this section, we will explain how to 
promote your business with affiliate programs in Business Manager. 

Setting Up Affiliate Programs 

Each affiliate program promotes a single online store. Affiliate links point to the store, and 
affiliates receive commissions in the store’s currency. If you decide to promote two stores, 
use multiple affiliate programs. The tools to create and manage affiliate programs are 
available on the tab Affiliate Programs of the Business Setup > Marketing Tools page. 

Affiliate programs in Business Manager use the pay-per-sale principle. This means that an 
affiliate's commission for each sing-up is a certain percentage of the order price (the 
commission rate).  

To define how much a program participant should earn to receive their commissions to 
credits, specify the program's payment threshold. This threshold shows the affiliate when to 
expect the payout; However, you can still pay out affiliate earnings whenever you want. 

Viewing Affiliates List 

After you set up your affiliate programs, customers can join them by clicking the 
corresponding links on the Account tab of the Control Panel. You can view the list of your 
affiliates on the Affiliates tab of the Business Operations > Customers page.  

The system accumulates an affiliate's commissions on their affiliate balance. You can see 
the balances of your affiliates in the corresponding column of the affiliates list. Additionally, 
the System Overview widget on your Home page contains the Total affiliates commission - the sum 
of your affiliates' current balances. 

Affiliates cannot use the credits on their affiliate balances for any purposes. To let them use 
the credits, you should pay out the commissions. 

Paying Out Commissions 

When an affiliate's balance exceeds the payment threshold of an affiliate program, the 
system adds this balance to the Above threshold value on your Home page. From time to time 
(usually, upon reaching payment thresholds), you should perform payouts to transform 
affiliates' commissions to their credits. For this, select them in the affiliates list and click Pay 
Out: The system will pay out the entire affiliate balance to credits and reset it to zero. 
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Affiliate Program Example 

For example, you have an affiliate program that allows participants to earn the 10% 
commission for each sign up in the Default store and receive credits when the affiliate 
balance exceeds $20. 

Meet Jerry, he is an affiliate. He invited 3 friends and each of them placed an order for $50 in 
the Default store. Jerry earns the commission of $15, but he cannot receive the payout 
because his affiliate balance is less than $20. Jerry invites more people so that the balance 
exceeds $20. Now you can pay out his commission. 

After the commission is paid out, Jerry receives $20 of credits, his affiliate balance is reset to 
$0, and he continues inviting people to your stores to earn more money. 

Administering Customers 

Here you will find a one-stop shop for customer management. You can approve new 
customers, view your archived and non-archived customers, or add new customers. You can 
also view statistics about your customers and access customer details. 

In this section: 

Adding New Customers ..................................................................................... 136 
Managing Existing Customers ........................................................................... 136 
Managing Customer Accounts in Panel ............................................................. 149 
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Adding New Customers 

There are two main methods for new customer records to be added to your Business 
Manager system: through the administrator interface (available for Business Manager 
administrators) and through the order process. 

Adding customers through the administrative interface is a one-step procedure that involves 
adding customer details, contact details, and billing account.  Each customer account can 
have several contacts tied to it. In this step you will specify the first of these contacts. 

 To add a customer account: 

1. Go to Business Operations > Customers and click Add New Customer. 

2. Enter General Settings, and Primary Contact Information. 

3. Set up a Billing Account for the customer. 

4. Click Add Customer. 

You have completed the process of adding a customer account. You can now view the 
details of this account and begin to add subscriptions and generate invoices by clicking the 
Customer ID. 

Managing Existing Customers 

Business Manager allows managing your customers through the Customer Summary page 
which you can access at Customers > select specific customer. The Customer Summary page 
lists contact details, various billing information, subscriptions details, and notifications sent to 
customers. 

To manage the details of a customer account, go to Business Operations > Customers, find the 
customer you want to view, and click Full Name corresponding to an account. 

In this section: 

Managing Billing Accounts and Details .............................................................. 137 
Managing Customer Invoices ............................................................................ 139 
Managing Customer Details .............................................................................. 141 
Taking Administrative Actions............................................................................ 142 
Adding Credits to Customer Account ................................................................. 143 
Viewing FraudGuardian Check Results ............................................................. 143 
Managing Invoices ............................................................................................ 143 
Adding Notes ..................................................................................................... 144 
Viewing Statistical Information ........................................................................... 145 
Viewing Customer Accounts .............................................................................. 145 
Verifying New Customer Accounts .................................................................... 145 
Viewing Subscription Details ............................................................................. 146 
Sending Mass E-Mails ....................................................................................... 146 
Sending Custom E-mails ................................................................................... 148 
 
 



 

 Maintaining and Growing Your Business 137 

 

Managing Billing Accounts and Details 

In this section: 

Adding Billing Accounts ..................................................................................... 137 
Editing Billing Accounts ..................................................................................... 138 
Viewing Accounting Totals ................................................................................ 138 
Viewing Billing Account Summary ..................................................................... 139 

 
 

Adding Billing Accounts 

 To add a billing account to a customer account: 

1. Go to Business Operations > Customers > click a specific account. 

2. Click Show All Billing Accounts in the Billing Account Summary section 

3. Find the contact you want to add a new billing account for and click Add Billing 
Account to Primary Contact. 

4. Select the type of billing account you want to add for this customer. 

5. Fill out the details section according to the type of billing account you chose 
in Step 4 above. 

6. Click Save Billing Account. 
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Editing Billing Accounts 

You can edit any billing accounts associated with a customer's account. 

 To edit a billing account: 

1. Go to Business Operations > Customers > click a specific account. 

2. Click Show All Billing Accounts in the Billing Account Summary section. 

3. You will see a list of all billing accounts (if available) and their associated 
contacts. 

4. Find the billing account you want to modify in the list and click its name. 

5. Edit the account details. 

6. If encryption is turned on, enter your Encryption Passphrase. 

7. Click Update Billing Account. 

Note: To remove the billing account, click Remove in the Available Operations list. 

Viewing Accounting Totals 

This section outlines the following account and balance information available at a customer 
summary page (accessed from Business Operations > Customers > click a customer name.). 

Accounts Receivable - money owed to you by the customer. Here you can also view the 
detailed Customer Payment History if you click the Accounts Receivable link. 

Credit. This option allows you to credit your customers. 

Accounts payable. This is the money to be paid by you to the customer. 

Refunds. This field shows you the total refunds. 

Expenses. This shows the expenses. 
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Viewing Billing Account Summary 

The Billing Account Summary counts the number of billing accounts by type.  In this section you 
can also Add Billing Account to Primary Contact.  See the Adding Billing Accounts (on page 137). 

It is also possible to see all billing accounts of this customer. For this, click the Show All Billing 
Accounts link. You will see the list of all billing accounts for this customer account. 

You can also view a callback log by clicking the Show Callback History link. 

Managing Customer Invoices 

In this section: 

Viewing Invoice History ..................................................................................... 139 
Generating Invoices .......................................................................................... 139 
Adding Custom One-Time Invoice ..................................................................... 140 
Taking Customer Payment ................................................................................ 140 

 
 

Viewing Invoice History 

The invoices history displays invoices due and invoices paid. This page also allows you to 
view all invoices for this customer, to generate invoices, to take customer payment, and to 
add single invoice. 

 To view all invoices: 

1. Go to Business Operations > Customers > click a certain account. 

2. Click the Show All Invoices link in the Invoice Summary section. 

You will see a list of invoices (assuming invoices have been generated). 

Generating Invoices 

 To generate an invoice: 

1. Go to Business Operations > Customers > click a certain account. 

2. Click the Generate Invoice link in the Invoice Summary section. 

3. Specify the generation settings and click on the continue button. 

4. If you selected to preview invoices, review them and click the Proceed with 
invoice generation button. 
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Adding Custom One-Time Invoice 

Business Manager allows you to create and generate a single (one-off) invoice for one-time 
charges. 

 To generate a single invoice: 

1. Go to Business Operations > Customers > click a certain account. 

2. Click the Add Custom Invoice link in the Invoice Summary section. 

3. On the form that appears, enter appropriate information: 

1. Enter a short description for the invoice. 

2. You can also add a Long Description. 

3. Set the Invoice Date. 

4. Enter the Invoice Amount. 

5. Tick the box, if you would like to send your customer an e-mail with invoice. 

6. Set the period to defer revenue. 

4. Tick the box next to the Apply a payment as well, if you would like to take manual 
payment for the service provided. Enter all necessary information. 

5. Click Process Invoice. 
 

Taking Customer Payment 

 To take customer payment: 

1. Go to Business Operations > Customers > click a certain account. 

2. Click the Take Customer Payment link in the Invoice Summary section. 

3. Choose the invoice to be charged. 

4. If the encryption is on, enter your LEK PIN. 

5. Click Charge account. 
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Managing Customer Details 

From the Customer Summary page you can edit customer details, manage customer account 
properties, add new primary/additional contact, or edit existing contacts. 

In this section: 

Editing Customer Details, Status and Billing Account ........................................ 141 
Managing Contacts ........................................................................................... 141 
Editing Customer Account Properties ................................................................ 142 
 
 

Editing Customer Details, Status and Billing Account 

 To Edit Customer Details: 

1. Go to Business Operations > Customers > Click a customer's full name. 

2. Click Edit Details in the Customer Details section and update the details. 

3. Click Save. 
 

Managing Contacts 

One customer in Business Manager can have several contacts. One of the contacts will be 
set as a primary contact, all the other will be additional contacts. The Customer Summary page 
allows adding new contacts, editing existing contacts, logging in as primary contact, and 
resetting and resending password. 

 To add a new contact: 

1. Go to Business Operations > Customers and click a customer's full name. 

2. Click Add New Contact in the Customer Primary Contact section. 

3. Specify the contact information and click Save. 

 To edit a contact: 

1. Go to Business Operations > Customers and click a customer's full name. 

2. Click Edit Contact Info link. 

3. Edit all necessary information and click Save. 
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Editing Customer Account Properties 

The Customer Summary page lists the customer-related properties. The system uses them to 
apply a special logic to customers who have these properties. For example, it is possible to 
apply discounts using properties. You are also able to edit the properties for a customer. 

 To edit the properties: 

1. Go to Business Operations > Customers and click a customer's full name. 

2. Scroll down to the Properties section. 

3. Click the Edit Customer Account Properties link. 

4. Specify if the attribute is active or not. 

5. Set the internal value. 

6. Click Save All. 
 

Taking Administrative Actions 

Administrative Actions are a collection of actions that help you quickly manage a customer’s 
account. The current administrative actions include: 

 Suspend Customer Account. Select this option if you would like to suspend a customer’s 
account. Such customers will be unable to log into the customer area. 

 Cancel Customer Account. You can use this for customers who let you know they would like 
to terminate their service. They are also unable to log into the customer area. 

 Archive Customer Account. Archiving a customer essentially makes the customer non-
functional. Archived customers do not count against your license limit. The records 
associated with the customer will be present, but you will not be able to perform any 
functions on the customer, such as collecting payment for outstanding balances. 
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Adding Credits to Customer Account 

You can deposit funds (credits) into a customer account. The credits are utilized first to pay 
for subscriptions. When a credit balance is exhausted, the customer’s default payment 
method is used to pay for the services. 

 To add a credit: 

1. Go to Customers and click a customer’s full name. 

2. Click the Add Credit link in the Accounting Totals section.  

3. Fill in the form and click Add Credit. 

After you update a customer credit balance, you are able to see the customer’s credit 
balance changes history by locating the customer summary page and clicking Credits. 

Viewing FraudGuardian Check Results 

Business Manager allows you to check your incoming orders for fraud. You can view the 
results of this check per each customer per order at the Customer Summary page. 

 To view FraudGuardian results: 

1. Go to the Customer Summary page accessed at Business Operations > Customers > 
click a certain account. 

2. Click the Display/Hide Additional Data link next to the subscription you want to 
edit in the Fraud Results section. 

The page section will show you the total Fraud Score for each order, and the other information 
such as IP, customer bank, e-mail, proxy, etc.  

Managing Invoices 

The customer summary page allows you to view invoices for a particular customer. The 
system lists the Recent Invoices and gives you the option to show all invoices by clicking a 
respective link. From this section you can view basic details on the invoice, such as the 
Invoice Number, the Amount of money, the dates Entered and Due, and the Status. The Available 
Operations column gives you the option to manage and print the invoice.  

 To manage the invoice: 

1. Go to the Customer Summary page accessed at Business Operations > Customers > 
Click a customer’s full name. 

2. Click the Details link next to the invoice you want to edit in the  Recent invoices 
section. 

Note: You will be taken to invoices management (on page 163), which can also be accessed 

from the Finances > Invoices of the particular invoice. 
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Adding Notes 

The Recent Notes section of the Customer Summary page shows you the recent notes you 
added for this particular customer. These notes are strictly internal, and provide only the 
administrator with additional information. 

 To add a new note: 

1. Go to the Customer Summary page accessed at Business Operations > Customers 
and click a customer's full name. 

2. Click the Read/Add Notes link of the Recent Notes section. 

3. Add any information in the Note text box. 

4. Add Note. 
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Viewing Statistical Information 

Quick Stats has two main sections: Customers by Status and Trend Reports. The top section lists 
the possible status that a customer may have, and below each status, the number of 
customers in each category. This number is a link; clicking on it will take you to a screen 
listing all customers of that type. For example, if you would like to see a list of all your 
pending customers, you can click on the number underneath the title Pending. Below the 
actual count is the percentage each category comprises of the total number of customers. 
Trend Reports actually lists just one report. This report will show all new signups over the last 
year. 

To view the customer statistics, go to  Business Operations > Customers > Quick Stats. 

The page also shows a pie chart and a key representing each of the numbers and their 
specific categories. 

Viewing Customer Accounts 

There are two types of customer accounts in Business Manager - non-archived and archived. 
You can filter the customer accounts by this status. 

Customers is where you will find information about the vast majority of the customers entered 
in your Business Manager system. All customers count against your license limit. Initially, the 
page displays a list of all customers with the status of Pending, Active, Canceled, Fraudulent, 
Suspended, Inactive, and Declined, from newest to oldest. Clicking on one of the column 
headers will sort your customer data by the relevant heading. 

 To view customer accounts: 

Go to the Business Operations > Customers. This will open a list of accounts. 

You can access the customer details screen for each customer listed by either clicking the 
Customer ID or the Details link. 

Clicking the e-mail address in the Customers list will enable you to send an e-mail directly to 
this customer. You can format these e-mails using various rich text tools. 

Verifying New Customer Accounts 

To prevent your business from frauds, you can confirm or cancel each registration of a 
customer account by hand. If you choose Manual approval of all incoming orders in as fraud 
protection policy, you will see a list of all new customer accounts pending approval in the New 
Customers group on the Home page.  

Click the Review link to see more information about a particular order. Once you have verified 
the order, check the Activate or Cancel check box and click Submit. 

Note: If you choose the Cancel option, remember to select the appropriate cancelation 
function in the Define policy on canceling subscriptions for this customer drop down menu at 
the bottom of the list prior to clicking the Submit button. 



 

146 Maintaining and Growing Your Business 

 

If you do not want to verify new accounts manually, change the fraud protection policy on the 
page All Settings > Fraud Protection Settings. 
 

Viewing Subscription Details 

Business Manager allows you to manage customer subscriptions from two sections at 
Customer Summary page: from Subscription Details and Recent Subscriptions sections. The first of 
them shows the number of subscriptions the customer owns and allows the administrator to 
add a subscription to a customer. The Recent Subscriptions section provides details on each 
particular subscription and allows the administrator to manage the subscription. For more 
details on subscription management, see Managing Subscriptions (on page 149). 

Sending Mass E-Mails 

Along with the automatic e-mails (on page 89) sent by Business Manager when particular 
events happen, you can also manually send e-mails to selected customers. This is useful 
when, for example, you need to send an announcement to all, or to selected customers. 

If required, you can always re-send an e-mail to all its recipients, be it an automatic e-mail or 
the one sent manually. 

In this section: 

Sending E-Mail .................................................................................................. 147 
Resending E-Mails Sent Previously ................................................................... 147 
Viewing Latest Correspondence ........................................................................ 148 
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Sending E-Mail 

 To send an e-mail: 

1. Go to the Sending E-mail Wizard: Business Monitoring > Emails > Send Emails. 

2. Specify recipients of the e-mail: 

a. Define the target customers by using Customers Filter: enter the 
customers IDs separated with commas and/or filter them by Status, 
Customer Group, Server, Panel Group and Plan if required. 

b. Select the customer's contacts to which the e-mail should be sent, 
either all or only the primary one. 

3. Under Email Template, select a template. 

Note that the templates list contains only templates from the group User Defined Emails. 

4. Click Next. 

A list of e-mail accounts filtered according to the specified parameters (customer filter and 
contact) is displayed. 

5. Verify that the list of contacts is correct and click Next. 

Alternatively, click Back to go to the previous step and change customer filter or contact 
settings. 

6. On the final screen showing all of the information on the e-mail you are 
about to send, check the e-mail properties (recipients, e-mail properties, e-
mail message body) and click Send. 

The e-mail will be sent, and will appear in the Show Emails list. 

Resending E-Mails Sent Previously 

 To resend e-mails: 

1. Go to Business Monitoring > E-mails. 

2. Find the e-mail you want to send again and click Resend. 
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Viewing Latest Correspondence 

The Recent E-mails section of the Customer Summary page shows a list of the last five e-mails 
sent to the client. Each of the entries shows the following information: 

Subject: Click the name and id to view, edit or resend the e-mail. 

 Timestamp: Includes date and time the e-mail was sent to the client. 

 The system also allows you to Resend and Edit Email the e-mails on the page that 
appears when you click the e-mail subject. 
 

Sending Custom E-mails 

 To send a custom e-mail: 

1. Go to the customer's details page for the customer you want to send an e-
mail to. 

2. Click the e-mail address of a customer in the customers list available from 
Business Operations > Customers. 

3. By default, the customer's e-mail address will already be in the Contacts list. If 
this is not correct, make the necessary changes accordingly. 

4. Next, if this e-mail requires a copy e-mail, enter it in the CC addresses field. 

5. If this e-mail requires an additional copy e-mail (unseen by the recipient), 
enter it in the BCC addresses field. 

6. Enter a subject in the Message subject field. 

7. Enter your e-mail message in the Message body field. 

8. Click Send. 
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Managing Customer Accounts in Panel 

If you use Panel without Business Manager or other software that automates creating and 
managing customer accounts, manage these accounts in Panel manually. 

To view the details of a customer account, click the customer's name on the Customers page. 
To change these details, use the buttons on the page: 

 Edit Contact Info lets you update the customer's contact information: name, e-mail, 
address, phone, and so on. 

 Edit Login Info lets you change the customer's username and password. 

If you want to stop serving a customer, for example, if they do not pay for your services, you 
may suspend the customer's accounts - block access to the Control Panel for this customer 
and users that they created. To suspend an account, click Suspend on the customer details 
page. In addition to suspending the account, this will suspend all its subscriptions making the 
customer's websites, FTP and mail services unavailable to the Internet users. 

Later you will be able to cancel the suspension by clicking Activate on the customer details 
page.  

You can also suspend multiple accounts at once or activate multiple suspended accounts. To 
do this, select the accounts that you want to suspend or activate at the Customers page and 
choose the appropriate action from the More Actions menu. 

To remove customer accounts and all subscriptions belonging to them, select these accounts 
at the Customers page and click Remove. 

Managing Subscriptions 

The services or resources you sell to your customers are organized into plans. A subscription 
is basically a permission to use the services or resources for a particular period of time. 

Subscriptions also serve as a connection point in Business Manager. Invoices are tied to 
subscriptions. So are add-ons. A customer may stay the same, but they may have different 
subscriptions, and thus different add-ons and invoices, at various times in their life cycle. 
Subscription to a plan is a prerequisite for billing a customer. You cannot bill a customer 
unless they have at least one subscription tied to their account. 

Business Manager handles subscriptions in two broad categories: domain subscriptions and 
all others. Domains subscriptions are created when a customer either purchases or transfers 
a domain through Business Manager. 
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Adding New Subscriptions to Customer Accounts 

Usually, customers subscribe to your plans in online stores and Business Manager creates 
these subscriptions automatically. However, you may need to add a customer's subscription 
by yourself, for example, if you want to move an existing subscription from one Business 
Manager server to another. 

To add a subscription to a customer account, go to Business Operations > Customers > 
<customer_name> and click Add New Subscription. The system will ask you to choose a service 
plan and a billing cycle and then to provide the subscription's details depending on the 
selected plan.  

Viewing Subscriptions Details 

 To view subscription details: 

1. Go to Business Operations > Subscriptions. 

2. Click the name of a subscription you wish to view. 

The page that shows will show you Subscription Details, including general information, 
subscription status, pricing information, policy on canceling subscriptions, subscription dates, 
and payment information. Here you can also view the Comments for the plan, the information 
on Last Invoice, and Subscription Add-ons and Properties and change the server associated with 
the subscription.  Note that reassigning will tie this subscription to a different panel. It will not 
move the actual hosting account. 

Changing Subscription Status 

Business Manager allows for a number of different kinds of subscription statuses. These 
statuses can be divided into groups based on their behavior: 

 Active. By far the most common status for a subscription. Active subscriptions are those 
that, as the name implies, are being actively used by a customer. This might be a current 
hosting subscription, software license, or service subscription. Subscriptions marked 
Active will be invoiced. 

 Pending. The first status after a subscription is purchased. Pending subscriptions will be 
invoiced only once. 

 Canceled.  If a subscription is canceled, it is removed or suspended on the server which 
stores this subscription. These subscriptions are not invoiced. 

Important: If you manually change the subscription status to Canceled, it will not be 
canceled. To cancel the subscription, use the policy on canceling subscriptions. 

 Suspended. If a subscription is suspended, the subscriber is not able to access service 
plan resources. These subscriptions are invoiced if it is defined in the server-wide settings 
(on page 80). 
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 Pending Renewal. Applies only to subscriptions which include domain registration. When a 
domain is approaching its renewal date, and an invoice is sent to the customer, the 
subscription status is set to this value. Once the customer pays, the invoice and the 
domain are actually renewed with the registrar, the subscription status again changes to 
Active. Subscriptions marked as Pending Renewal will not be invoiced. 

 Completed. This status is assigned when a subscription is available only for a limited 
number of billing cycles, and this number is reached. 

 Transferred. If you transfer a subscription from one customer to another, this subscription 
will be marked as Transferred. These subscriptions are not invoiced. 

 Failed. Generally, this status is set when provisioning of a subscription fails. 

 Fraudulent. The FraudGuardian module assigns this status to a subscription if it considers 
that customer details are fraudulent. 

 Expired. Subscriptions marked Expired will not be invoiced. 

 Submitted. Subscriptions marked Submitted will not be invoiced. 

You can create an invoice for a subscription with a status other than active or suspended by 
manually generating an invoice through the customer summary page. 

The system also includes the following statuses that are not set automatically: 

 Stopped. Subscriptions marked Stopped will not be invoiced. 

 Started. Subscriptions marked Started will not be invoiced. 

 Collections. Assign this status to suspended subscriptions that were not debited for a long 
period of time. This will simplify the search for problem subscribers and the work of 
collection departments. 

 In Progress. Subscriptions marked In Progress will not be invoiced. 

Why have many different kinds of status, when they all behave about the same? For 
example, if you are using Business Manager to sell web design in addition to hosting, you 
may want to set the web design subscription as something other than just Active or Completed. 
You may want to Start the subscription, it may be In Progress, you may have to Stop the project 
for some reason, and the project may become Inactive, without ever being completed. These 
extra status designations allow you to keep track of general information in Business 
Manager. You can change the status of a subscription at any time. 

 To change the status of a subscription: 

1. Go to Business Operations > Subscriptions. The page displays all subscriptions in 
the system. 

2. Find the subscription you want to edit and click its name. 

3. Click Edit in the Available Operations row. 

4. Find the Subscription Status Options section. Fill in the corresponding fields with 
the new status and change reason. 

5. Click Save. 

Note: You can also navigate to a subscription page from Customer Summary Page of the 
customer to whom this subscription belongs. Click Show All Subscriptions in the Subscription 
Details box and find the subscription you wish to edit. 
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Activating or Suspending Subscriptions 

Note: The customer subscription should be tied to a control panel in order to 
suspend/activate the subscription, otherwise the function to perform this action will not 
appear in the interface. 

 To suspend or activate a subscription: 

1. Go to Business Operations > Subscriptions. 

2. Click the name of a subscription you want to suspend or activate. 

3. Click Suspend or Activate depending on the current subscription status. 

4. When the events queue runs, the subscription will be set to Suspended or 
Activated on a corresponding server. 

 

Canceling Hosting Subscriptions 

If a subscription is tied to a panel group, meaning the hosting account is created, follow the 
instructions in Method 1 below. If the subscription is not tied to a panel group, skip down to 
the second method. 

 To cancel a subscription tied to a panel group: 

1. Go to Business Operations > Subscriptions. 

2. Click the name of a subscription you want to cancel. 

3. When the Available Operations items appear, click the Edit link. 

4. Find a Servers section, and click the pencil icon in the Available Operations 
column. 

5. When a window appears, select Canceled from the drop down menu and click 
the Edit button. 

A system event will be created. The event will be run automatically if you have your system 
set up for automation. Otherwise, run the event. 

 To cancel a subscription tied to a panel group: 

1. Go to Business Operations > Subscriptions. 

2. Click the name of a subscription you want to cancel. 

3. When the Available Operations items appear, click the Edit link. 

4. Select Canceled from the Status drop down menu. 

5. Click the Save button. 
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Running Subscription Tasks 

There are two ways you can run subscription tasks: 

 All at once. 

 One by one. 

To run subscription tasks all at once, click the Run All link on the Business Monitoring > Tasks 
page. 

Note: Running all tasks at the same time will process everything, not just subscription related 
tasks. 

To run a single subscription task, find this it in the list on the One-time Tasks tab of Business Monitoring > 
Tasks and click the Run Now link in the Available Operations menu for this task. 
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Editing Subscriptions 

Normally Business Manager creates subscriptions automatically basing on plan settings and 
the information provided by a subscriber, but you can change certain settings of each 
subscription manually. For example, you can specify a custom name for a subscription or 
change its status.  

To make your business more flexible, Business Manager allows overwriting some plan 
settings by customer values for each subscription separately. This is useful, for example, to 
set up more strict rules in the cancelation policy or change the billing cycle. To see the full list 
of subscription settings and change them, click the Change Settings link of the subscription 
page.  

Editing Subscription Prices 

A price of a new subscription is equal to the plan price with applied discounts and coupons. 
However, in some situations it is necessary to specify a custom price or apply a custom tax, 
coupon, or discount to a subscription. You can achieve this by editing prices of a subscription 
available on the Subscription Prices page (from the subscription overview page, click Edit Prices 
in the Available Operations). 

Additionally, if a hosting plan settings allow scalable web hosting (using resources over plan 
limits), you can set custom resources usage prices on this page as well. 

To prevent overwriting custom subscription prices when changing plan settings, lock prices 
of this subscription by selecting the appropriate checkbox on the Subscription Prices page.  

Note: You still have the option to overwrite prices of both locked and unlocked subscriptions 
if you specify this option when changing plan settings. 

Upgrading and Downgrading Subscriptions 

Before you upgrade or downgrade a subscription, make sure you have your plans configured 
to upgrade. Refer to the section Upgrading and Downgrading Plans (on page 117) for details. 

 To upgrade a subscription: 

1. Go Business Operations > Customers and click a customer's full name. 

2. Click the name of a subscription you want to upgrade to. 

3. Click the Upgrade link in the Available Operations form that appears. 

 To downgrade a subscription: 

1. Go to Business Operations > Customers > Click a customer's full name. 

2. Click the name of a subscription you want to downgrade to. 

3. Click Show/Hide Operations Menu, and click the Downgrade link in the Available 
Operations form that appears. 
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When you upgrade or downgrade a subscription, you can choose between the three options 
described below. 

 Upgrade/Downgrade now and apply proration credits. If this is selected, the system performs 
the following: 

 Adds money for the remaining number of days till the end of the current billing cycle 
as credits to the customer account. 

 Creates a subscription of type Upgrade Fee or Downgrade Fee. The subscription 
price is the price of a plan the customer upgrades or downgrades to respectively for 
the remaining number of days till the end of the billing cycle. 

 If Generate invoice immediately is selected, the system creates an invoice for this 
subscription for the current billing cycle. The next invoice (for the new plan) will be 
generated as usual before the next billing cycle. If Generate invoice immediately is not 
selected, the invoice will be generated in the next run of “ProcessInvoices” event. 
Typically, this event runs daily. 

 Applies the credits to the new invoice. 

 Creates the event to provision the upgraded or downgraded subscription to the Panel. 

 Upgrade/Downgrade now and DO NOT apply proration credits. If it is selected, the system 
performs the following: 

 Creates the event to provision the upgraded or downgraded subscription to the Panel. 
The next invoice (for the new plan) will be generated as usual before the next billing 
cycle. Option Generate invoice immediately is not taken into account in this case. 

Note: It is not possible to upgrade or downgrade this subscription again till the end of 

the current billing cycle. 

 End of current cycle. If it is selected, the system performs the following: 

 Upgrades or downgrades the subscription in Business Manager, but sets it to be 
provisioned only in the next billing cycle. The next invoice (for the new plan) will be 
generated as usual before the next billing cycle. Option Generate invoice immediately is 
not taken into account in this case. 

 

Adding an Add-on to a Subscription 

 To add an add-on to a subscription: 

1. Go to Business Operations > Subscriptions. 

2. Click the name of a subscription to which you want to add an add-on. 

3. Click Add-ons in the Available Operations column. 

4. Click Add New Add-on. 

5. Select an add-on you want to attach to the customer account from the plans 
list. 

6. Update the pricing if necessary. 

7. Click the Add button. 
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Viewing Add-ons with Their Properties 

 To view the subscription add-ons: 

1. Go to Business Operations > Subscriptions and click a subscription name. 

2. Click Add-ons in the Available Operations form that appears. 

On the page that loads, you will see the add-ons for the given subscription and their details. 
Here you can also Edit the add-ons and see the add-on Properties by clicking the respective 
icons next to each add-on. 

Here you can also add or change Subscription add-ons (on page 156). 

Viewing Subscription Properties 

 To view the subscription properties: 

1. Go to Business Operations > Subscriptions and click a subscription name. 

2. Click the Properties link in the Available Operations form that appears. 

The page that lists subscription properties opens. 

On this page, you can do the following: 

 View details of a property. 

 Edit a property or its value by clicking the Edit icon next to the given value. 
 

Transferring a Subscription 

Business Manager allows administrators to transfer a subscription from one customer to 
another. 

 To transfer a subscription: 

1. Go to Business Operations > Subscriptions and click the name of a subscription 
you want to transfer. 

2. Click the Transfer Subscription link in the Available Operations form that appears. 

3. In the form that appears, enter the ID of the customer you want to transfer a 
subscription to. 

4. Specify the billing account to pay for this subscription and confirm the 
transfer. 
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Managing Subscriptions in Panel 

In Panel, you can do the following with existing subscriptions belonging to your customers 
and yourself: 

 Change hosting settings of a subscription. 

That is, the IP address on which the subscription's websites are hosted, and credentials 
of system user account linked with the subscription (used to manage files and folders of 
websites within the subscription, and to access the server via SSH or Remote Desktop). 
To change a subscription's hosting settings, go to Subscriptions > subscription's name, and 
click Change Hosting Settings. 

 Transfer one or several subscriptions to another user. 

This means that you change owner of subscriptions, or, in other words, reassign 
subscriptions to another user: another customer or yourself. In this case, the 
subscriptions are automatically unbound from their plans and become custom. To 
transfer one or several subscriptions to another user, go to Subscriptions, select the 
corresponding checkboxes and click Change Subscriber. 

 Suspend subscriptions. 

Websites, FTP and mail services of suspended subscriptions are no longer accessible to 
the Internet users. Suspending a subscription manually may be useful in cases when a 
website hosted within the subscription gets attacked or the subscriber does not pay for 
the services. 

To suspend one or several subscriptions, go to Subscriptions, select the corresponding 
checkboxes and click Suspend. 

 Activate suspended subscriptions. 

Once a subscription is activated, all the services provided with it resume operation. 
Activation is only useful for subscriptions that were suspended manually: if you activate a 
subscription that was expired, Panel will automatically suspend it again on the next day. 
To make an expired subscription active, renew it as described below. 

To activate one or several subscriptions, go to Subscriptions, select the corresponding 
checkboxes and click Activate. 

 Renew an expired subscription. 

When a subscription's expiration date comes, Panel suspends it. In such cases, you 
should renew subscriptions manually.  

To renew a subscription, go to Subscriptions > subscription's name, click Activate, and then 
set a new expiration date (it may be unlimited). Then apply the new settings by clicking 
Update & Lock. 

Note: After this step, the system will not apply further changes of the plan settings to this 
subscription. If you try to sync this subscription with the plan, the subscription will expire 
again unless you set the Unlimited validity period for this plan. 

 Remove subscriptions. 

To remove subscriptions, go to Subscriptions, select the corresponding checkboxes and 
click Remove. 
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Performing Manual Payments 

In this section: 

Using a Credit Card to Pay an Invoice ............................................................... 160 
Capturing Authentication-only Payments ........................................................... 160 
Capturing Uncaptured Payments ....................................................................... 160 
Issuing Refunds................................................................................................. 161 
Generating and Running Payment Queue ......................................................... 162 
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Using a Credit Card to Pay an Invoice 

 To pay an invoice using a credit card: 

1. Select the invoice from the list available at Business Operations > Invoices. 

2. When the invoice page is displayed, click the Take Credit Card Payment link in 
the Quick Links section at the top of the page. 

3. Select the gateway you want to use to pay this invoice and click Next. 

4. Enter all the payment information accordingly. 

5. Click Charge. 

Note: Payments of this kind are performed using the virtual terminals feature. Find more 
information about it in the section Testing Gateways Using Virtual Terminals (on page 63). 

Capturing Authentication-only Payments 

 To capture Authentication-only payments: 

1. Select the invoice from the list available at Business Operations > Invoices. 

2. When the invoice page is displayed, click the Take Credit Card Payment link in 
the Tools section at the top of the page. 

3. Select the gateway you want to use for an authenticate-only charge and click 
Next. 

4. Enter all the payment information accordingly. 

5. Select Authenticate Only in the Charge Action drop down menu. 

6. Click the Charge button. 

This transaction will just validate the card and will not take the money. 
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Capturing Uncaptured Payments 

 To capture uncaptured payments: 

1. Go to Business Monitoring > Payments > Uncaptured Funds tab. 

2. Click each check box next to the records you want to capture funds from. 
The checked records are highlighted in red. 

3. Click Capture funds. 

Note: There is no confirmation screen after clicking the Capture funds button. The funds will 
be captured automatically. 
 

Issuing Refunds 

 To issue refunds: 

1. Go to the invoice (on page 164) you want to issue a refund for. 

2. Click on the Refund button in the Status column located in the Transactions 
section. 

3. Verify that the refund details are correct. If passphrase encryption is used, 
enter it in the corresponding field. 

4. Click the Yes, process this refund button. Otherwise, click Cancel. 
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Generating and Running Payment Queue 

If you want to confirm all payments from credit cards and bank accounts, generate and run 
the payment queue. When you click to generate the queue, the system analyses the list of 
existing invoices and creates tasks to pay them. Next, depending on the configuration, the 
system runs the tasks or not. 

 To generate and run payment queue: 

1. Go to Business Monitoring > Payments > Payment Queue tab and click Generate 
Payment Queue. 

2. Set the following: 

Invoice Options: 

 Clear all items currently in Payment Queue. Check the box to avoid replicating the 
same items. 

 Generate. Select from one of the following: New, Declined, or Errored. 

 Generate Due Date Only. Select Yes if you want to generate payments based on 
invoice due dates only. Select No if you want to generate payments regardless of 
invoice due dates. 

 Due on or before. Select from the drop down menu the date you want to generate 
payments on or before or click the ... button to set the date using the built-in 
calendar. 

 Number of invoices to generate payments for. Enter the number or leave it as 0 to 
generate payments for all invoices. 

Run Options: 

Try charging lesser amounts on failed accounts. Check the box if you want the system to 
automatically charge less amounts for invoices IF they fail on the initial payment 
processing. 

Run Payment Queue. Select one of the following: Don't Run or Run at a later date/time. 

Date to run Payment Queue. Set the date to run the payment queue in the drop down 
menu or click on the ... button to select the date using the built-in calendar. 

Transaction Type. Select one of the following: Charge or Authenticate Only. 

Enter your Credit Card Encryption Key. Enter the key you generated when you set up your 
encryption settings. 

3. Click Continue. 
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Managing Invoices and Payments 

In this section: 

Generating Invoices Manually ........................................................................... 164 
Viewing Invoices................................................................................................ 164 
Editing Invoices ................................................................................................. 165 
Taking Credit Card Payments............................................................................ 165 
Applying Payments Manually ............................................................................ 166 
Paying by Credits .............................................................................................. 167 
Voiding Invoices ................................................................................................ 167 
Printing Invoices ................................................................................................ 168 
Manually Paying an Invoice Using Saved Credit Card Information .................... 168 
Viewing Transactions List .................................................................................. 169 
Re-sending Invoices .......................................................................................... 169 
Viewing and Downloading Schet-Facturas ........................................................ 169 
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Generating Invoices Manually 

You are able to generate invoices that include payments for previous or next billing cycles 
depending on the parameters you specify before starting the generation. For a single 
customer, the system generates only a unified invoice per currency. For example, if your 
customer ordered a monthly subscription in EUR and USD online stores, and requires an 
invoice for the next four months, the system will generate two invoices - one for the EUR and 
one for the USD subscription. Each of the invoices aggregates amounts for the four months. 

Prior to generating invoices in your system, you should set up invoicing (on page 80). 

 To generate invoices manually: 

1. Make sure there are Active or Suspended subscriptions in the system. 

2. Go to Business Operations > Invoices > Generate Invoices. 

3. Specify the invoice generation parameters and click Continue. 

4. Click Business Monitoring > Tasks. 

5. You will see a list of events specific to the invoices that will be generated. 

At this point you have two options: 

 Process all the events at one time by clicking Run All. 

 Run invoice entities one by one by clicking Run Now for each task. 

Make your selection and proceed forward with generating your invoices. 

Viewing Invoices 

 To view invoices for your customer accounts: 

1. Go to Business Operations > Invoices. 

The list of all invoices issued by the system will be opened. 

2. Click the invoice ID in the Invoice No. column for the invoice you wish to view. 
(You can also access an invoice by clicking the magnifying glass icon in the 
Available Operations column.) The invoice details will appear. 

 



 

 Maintaining and Growing Your Business 165 

 

Editing Invoices 

There are several ways to get to the edit screen for any invoice in your system. The easiest 
way to edit invoices for your customer accounts is to follow the instructions below. 

 To edit an invoice: 

1. Go to Business Operations > Invoices. 

2. You will be presented with a list of all invoices issued by the system. Click 
the invoice id in the Invoice No. column for the invoice you wish to view. 
(You can also access an invoice by clicking the magnifying glass icon in the 
Available Operations column.) 

3. Click Edit. 

4. Update the invoice information according to your needs and click Save. 

Note: Some organizations require you not to modify the existing invoices. For details, see 

Achieving Tax Office Compliance (on page 82). 

Taking Credit Card Payments 

Business Manager allows administrators to take credit card payments from their customers 
for unpaid invoices. 

 To take a credit card payment: 

1. Go to Business Operations > Invoices. 

2. Locate the invoice with Due status to which you want to apply payment 
manually and click its ID. 

3. The invoice details will appear below the record of the invoice you are 
viewing. The other option is to click on the magnifying glass icon in the 
Available Operations column to view the invoice details. 

4. Click the Take Credit Card Payment link in the Tools section of the page. 

5. Choose the Gateway and click Next to proceed. 

6. Enter the billing account details. 

7. Click the Charge button 
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Applying Payments Manually 

 To apply payments to any invoice manually: 

1. Go to Business Operations > Invoices. 

2. Locate the invoice with Due status to which you want to apply payment 
manually and click its ID. 

3. The invoice details will appear below the record of the invoice you are 
viewing. The other option is to click on the magnifying glass icon in the 
Available Operations column to view the invoice details. 

4. Click the Quick Manual Payment link in the Tools section of the page. 

5. Set the following: 

 Choose Billing Account. Select the billing account you want to use for this payment in 
the drop down menu. 

 Payment Method. Select the payment method you want to use for this payment in the 
drop down menu. 

 Check Number. If payment is being made by check, enter the check number. 

 Apply Payment To. Select Entire Invoice or Selected Line Items. If you choose the Selected 
Line Items option, it will list the line items available for this invoice. Choose accordingly. 

 Amount of Payment. Enter the payment amount that you are applying to this invoice. 

 Payment Comments. Enter comments according to your specific needs. 

6. Click Apply Payment. 
 



 

 Maintaining and Growing Your Business 167 

 

Paying by Credits 

You can utilize customer credits to pay for subscriptions. When a credit balance is 
exhausted, the customer's default payment method is used to pay for the services. 

 To apply credits to any invoice manually: 

1. Go to Business Operations > Invoices. 

2. Locate the invoice to which you want to apply credit and click its ID. 

3. The invoice details will appear below the record of the invoice you are 
viewing. The other option is to click on the magnifying glass icon in the 
Available Operations column to view the invoice details. 

4. Click Apply Credit in the Tools section of the page. 

5. Set the following: 

 Apply Credit To. Select Entire Invoice or Selected Line Items. If you choose the 

  Selected Line Items option, it will list the line items available for this invoice. Choose 

 accordingly. 

 Amount of Payment. Enter the payment amount that you are applying to this invoice. 

 Credit Comments. Enter comments according to your specific needs. 

6. Click Apply Credit. 
 

Voiding Invoices 

 To void any invoice manually: 

1. Go to Business Operations > Invoices. 

2. Locate the invoice that you want to void and click its ID. 

3. The invoice details will appear below the record of the invoice you are 
viewing. The other option is to click on the magnifying glass icon in the 
Available Operations column to view the invoice details. 

4. Click Create an Invoice Reversal in the Tools section of the page. 

5. Click Yes, create a credit note and void this invoice. 

6. Go to Finances > Invoices again. You will see two entries for each invoice. 
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Printing Invoices 

 To print an invoice: 

1. Go to Business Operations > Invoices, and find the invoice you want to print. 

2. Click Print next to the invoice. 

A new window with the invoice in PDF format opens. You can print the invoice from this 
new window using your browser's print function or save it to your computer. 

Manually Paying an Invoice Using Saved Credit Card 
Information 

Business Manager gives you the flexibility to manually pay an invoice using saved credit card 
information. This document explains how to decrypt saved credit card information to 
manually pay an invoice. 

 To decrypt credit card information: 

1. Go to Business Operations > Customers. 

2. Locate the customer whose invoice you want to pay by clicking the customer 
ID. 

3. Click the link Show All Billing Accounts in the Billing Account Summary panel in the 
center of the screen. 

4. All billing accounts associated with this customer will now be displayed. Click 
the blue arrow icon for the credit card account you would like to use, which 
will expand with several options. 

5. Click the magnifying glass icon next to the Account Last Four digits. A box will 
pop up prompting you to enter the encryption key you chose when 
configuring your Business Manager (for more information on encryption, view 
the Encryption Settings section). 

6. Enter your encryption key and click the Submit button. The decrypted credit 
card number will be displayed. 

7. Copy the credit card number. 

8. Go back to the customer summary page and locate the invoice you wish to 
pay. 

9. Make a credit card payment according to the instructions in the Using a Credit 
Card to Pay an Invoice (on page 160) section. 
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Viewing Transactions List 

The transactions list displays the operations performed from customer billing accounts. The 
list excludes bank transfer transactions that are available at bank transfers manager. 

To view the transactions list, go to Business Monitoring > Payments. 

Re-sending Invoices 

In Business Manager, PDF versions of invoices are attached to each invoice e-mail. If you 
need to re-send an invoice, you can either re-generate PDF invoice or take the existing PDF 
attachment. 

To re-send an invoice with a renewed PDF attachment, go to Business Operations > Invoices > 
choose the invoice you need and click Resend. To re-send an invoice with a former PDF 
attachment, see Re-sending E-Mails Sent Previously (on page 147). 

Viewing and Downloading Schet-Facturas 

If your company is located in Russia and sells services to companies or individual 
entrepreneurs, the accounting policy requires you to send schet-facturas to them each time 
you supplied a taxable service. Although the system sends these documents automatically, 
there can be cases when you might need to re-send a schet-factura or to view it. To carry out 
these operations, go to Business Operations > Invoices > tab Schet-Facturas and follow on-
screen instructions. 

If you do not see the Schet-Facturas tab, the documents issuing is not configured. For details 
on how to configure it, see Configuring Schet-Facturas (on page 83). 

Limiting Discounts and Exempting 
Subscriptions from Suspension 

Business Manager allows you to limit discounts for certain customers or exempt their 
subscriptions from suspension. To do it, create a customer group (or modify the default one) 
and add the certain customer accounts to it. Customer groups set the following properties for 
their members: 

 Maximum discount defines the maximum discount that group members can get when 
they subscribe to a plan. For example, if you provide a 20% discount on a plan, the 
member of a group with maximum discount 10% will get a 10% discount on this plan. 

 Guaranteed discount defines the discount that group members will get in addition to other 
discounts when they subscribe to any plan. For example, if you provide a 5% discount on 
a plan, the member of a group with guaranteed discount 10% will get a 15% discount on 
this plan. If you do not provide discounts on a plan, a member of this group will still get a 
10% discount. 
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 Exempt from suspension. If this option is enabled, Business Manager does not 
automatically suspend the subscriptions of the group members if they do not pay in time. 

If you change these properties for a group, Business Manager automatically applies them to 
existing members. Besides, you can override the group properties by custom values for each 
member. Changing properties of a group does not affect member with custom values of 
these properties. 

To add new or manage existing customer groups, go to the Business Setup > All Settings > 
Customer Groups screen. 

To add a customer account to a group or override group properties for a customer, go to the 
customer Business Operations > Customers > <customer name> > Edit Customer Account Properties. 

Managing Bank Transfers 

This section explains how bank transfers processing is organized in Parallels Customer and 
Business Manager, lists the bank transfers management operations, and addresses the 
processing automation. For details on these topics, refer to the corresponding subsections of 
this section. 

To read the introduction to bank transfers processing, refer to the section Bank Transfers 
Processing. 

In this section: 

How Bank Transfer Processing Works .............................................................. 171 
Supported Operations ....................................................................................... 173 
Configuring Automatic Processing ..................................................................... 175 
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How Bank Transfer Processing Works 

This section discusses bank transfers processing and explains what operations Business 
Manager provides to manage bank transfers. 

Bank transfers processing works as follows: 

1. Customer submits an order at one of your online stores using the bank transfer payment 
method. 

2. Business Manager creates a new transaction that keeps the payment details. 

3. The transaction is appended to an open batch. Batches are specifically formatted files 
that comprise orders to transfer funds from one bank account to another. The batch 
format is dictated by a transfer plugin (on page 61) associated with the online store. Each 
plugin has a single open batch which status is always Open. If the batch does not exist, 
the system creates it and opens. 

4. After an open batch reaches a certain number of transactions, or after a certain period of 
time, the system starts processing this batch file. This includes closing the batch, giving it 
a unique name, setting the transaction statuses within the batch to pending, and opening 
a new batch. 
You can manually request the system to start processing a batch. 

 For details on how to configure automatic processing, see Configuring Automatic Processing 
(on page 175). 

Note: The financial information of the receiving party is extracted from the profile of an 
administrator responsible for batch processing. You can change the administrator in the 
bank transfers manager settings. 

5. If the batch is in the processing status, it is possible to download and submit it to a bank 
to perform transfers. 

6. When you receive the bank response, either approve or decline the transactions included 
in the batch to activate paid subscriptions. If there is at least one approved transaction, 
the batch status is set to completed. This does not affect the statuses of included 
transactions. 

After a transaction is either approved or declined, the only way to modify this is to remove a 
batch that includes the transaction. The removal is possible only if the batch contains at least 
one pending transaction. If you remove a batch, the transactions within the batch are 
included in a corresponding new batch. 

You are able to exclude transactions from new batches or include transactions in new 
batches. This is useful when you balance the amount of funds included in a batch or wish to 
reorganize transactions. 

Business Manager imposes the following constrains on manipulations with transactions: 

 It is only possible to adjust the number of transactions in new batches (the batches under 
processing, completed, or declined are not modified). 

 You can include only transactions that are not bound to any batch. To unbound 
transactions, remove the new batch that contains them. 

 It is not possible to move transactions between new batches corresponding to different 
plugins. 
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Finally, Business Manager provides total amounts of transactions by statuses. This may be 
useful for statistical or auditing purposes. 

For details on how to perform a particular operation, see Supported Operations (on page 173). 
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Supported Operations 

This section lists the operations on batches and transactions available in Business Manager. 
For details on routine bank transfer processing and operation descriptions, see How Bank 
Transfer Processing Works (on page 171). 

 To view the list of batches: 

1. Go to Business Monitoring > Payments > Bank Transfers on the Transactions tab. 

2. Select tab Batch Files. 

This will open the batch files list. 

View included transactions to approve or decline them. 

 To view the transactions included in a batch: 

1. Go to Business Monitoring > Payments > Bank Transfers on the Transactions tab. 

2. Select tab Batch Files. 

3. Click the batch file. 

This will open the list of transactions included in the batch. 

Start processing a batch file to be able to download it. 

 To start processing a New batch file: 

1. Go to Business Monitoring > Payments > Bank Transfers on the Transactions tab. 

2. Select tab Batch Files. 

3. Click Start Processing next to the batch file (column Available Operations). 

This will change the batch file status to Processing. 

Download a batch file to send it to a bank. 

 To download a batch file: 

1. Go to Business Monitoring > Payments > Bank Transfers on the Transactions tab. 

2. Select tab Batch Files. 

3. Click Download next to the batch file (column Available Operations). 

This will start the downloading process. 

 To remove a batch file: 

1. Go to Business Monitoring > Payments > Bank Transfers on the Transactions tab. 

2. Select tab Batch Files, and click the batch you wish to remove. 
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3. Click Remove Batch File and Unbound Transactions, and confirm the operation. 

This will remove the batch from the batches list. 

View total amounts of transactions by statuses for statistical, auditing, or other purposes.  

 To view the total amount of transactions by status: 

1. Go to Business Monitoring > Payments > Bank Transfers on the Transactions tab. 

2. Select tab Transactions. 

This will open the statistics followed by the transactions list. 

Include or exclude transactions to balance the amount of funds included in a batch, 
reorganize transactions or for other purposes. 

 To include or exclude a transaction: 

1. Go to Business Monitoring > Payments > Bank Transfers on the Transactions tab. 

2. Select tab Transactions. 

3. Click the particular action next to the transaction (column Available Operations) 
and confirm the operation. 

This will change the action name to the opposite (for example, display Include instead of 
Exclude). 

Approve or decline the transaction to update the associated subscription status. 

 To approve or decline a transaction in a batch: 

1. Go to Business Monitoring > Payments > Bank Transfers on the Transactions tab. 

2. Select tab Batch Files. 

3. Click the batch containing the transaction. 

4. Click either Approve or Decline. 

This will change the transaction status. 

Note: You can change the transaction status directly from the transactions list. 

 To change a responsible administrator: 

1. Go to Business Setup > All Settings > Automatic Payments > Bank Transfers on the 
Transactions tab. 

2. Set the appropriate administrator in the Responsible Administrator field and click 
Save. 

This will change the responsible administrator. 
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Configuring Automatic Processing 

The bank transfer processing settings are available at Finances > Manage Billing > Bank 
Transfers Manager, tab Settings. You can adjust the following settings: 

 Process After XX days. This instructs the system to start batch processing in a certain 
number of days after a batch file is created. Use 0 to turn the feature off. 

 Process After XX transactions included. This instructs the system to start batch processing 
after reaching a certain number of transactions. Use 0 to turn the feature off. 

For details on routine bank transfer processing and operation descriptions, see How Bank 
Transfer Processing Works (on page 171). 

Viewing and Running Scheduled Tasks 

Business Manager automates a number of business routines such as issuing invoices, 
processing payments, creating customer accounts and subscriptions, and many others. 
However, the system does not do these routines instantly; Instead, it adds them to a queue 
and then runs them by schedule. To do this, Business Manager employs the task manager - 
a scheduler that defines when to perform each routine. For example, when a new customer 
subscribes to your services, Business Manager schedules and attempts to run a task to 
create a Panel account for the customer. 

The list of tasks that should be executed only once, such as creating subscriptions and 
accounts or registering domain names, is available to you on the Business Monitoring > Tasks 
page. Each of these tasks has a timestamp that shows when the task manager will execute 
the task. If the system cannot run a task at the time due to the provisioning policy, it will retry 
to run this task in a period specified in the provisioning policy. To learn more about the 
provisioning policy, see the section Setting Up Provisioning Policy (on page 85).  

Additionally, Business Manager periodically runs tasks that perform repeating routines, for 
example, generating invoices, suspending debtors, and charging credit cards. Since these 
tasks process subscriptions of all customers and resellers together, you cannot view or run 
these tasks. 
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Viewing Accounting Information 

In this section: 

Generating Accounting Reports ......................................................................... 176 
Generating Daily Journals ................................................................................. 177 
Viewing General Journal ................................................................................... 178 
Generating General Ledgers ............................................................................. 178 

 
 

Generating Accounting Reports 

Business Manager allows you to generate the following types of accounting reports: 

 The Balance Sheet Report is a summary of your assets, liabilities, and equity account 
balance. 

 The Profit and Loss Report is a summary of your revenue, cogs, and expense account 
balance. 

 The Accounts Receivable Aging Report shows what is owed to you and how long it has 
been owed. 

 The Ranged Cash Flow Report shows you the change (and gives you small explanations 
of what they mean to your business) for a few important accounts. 

 The Ranged Plan Revenue Report shows us the amount of revenue generated on a per 
plan basis for a given date range. 

 The Daily Invoice Sheet is the list of invoices and their respective amounts and 
customers for a given day. 

 The Ranged Daily Signup Report is a list of the customers that signed up in a particular 
date range, grouped by day, and totaled daily, and for the range. The revenue from their 
signup invoices is also included. 

 To generate a report: 

1. Go to Business Monitoring > Accounting > Reports. 

2. Click the type of report you need. 

3. Choose a date range. 

4. Click Generate. 
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Generating Daily Journals 

With Business Manager you can keep two types of daily journals: 

 Sales & Receipts Journal includes all daily sales and payments received. 

 Purchases Journal includes all daily cash disbursements. 

Note: The Purchases Journal is currently not being used. 

 To generate a daily journal: 

1. Go to Business Monitoring > Accounting > Daily Journals. 

2. Click the type of report you need. 

3. Choose a date range. 

4. Click Generate. 
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Viewing General Journal 

The General Journal report includes a list of all debits and credits in the system. 

To view the General Journal, go to Business Monitoring > Accounting > General Journal. 

Generating General Ledgers 

Business Manager supports the following types of general ledgers: 

 The General Ledger is a permanent summary of all supporting daily journals. Financial 
statements are generated from this ledger. 

 The Accounts Receivable Ledger is a special general ledger used only for posting 
accounts receivable journal entries. Monthly customer statements are generated from this 
ledger. 

 The Accounts Payable Ledger is a special general ledger used only for posting accounts 
payable journal entries. Monthly statements for companies you owe are generated from 
this ledger. 

 The Tax Payable Ledger is a special general ledger used only for posting tax payable 
journal entries. Annual statements for the taxes you owe are generated from this ledger. 

 To generate a ledger: 

1. Go to Business Monitoring > Accounting > General Ledgers. 

2. Click the type of ledger you need. 

3. Choose a date range. 

4. Click Generate. 
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Viewing Statistics 

 To view a summary report on your account: 

1. Go to Tools & Utilities > Summary Report. 

2. To view a summary on bandwidth usage by months, click View Traffic History. 

Operations on reports: 

 To obtain more details, select the Full Report option from the menu. 

 To adjust the amount of information presented in a report, edit an existing report 
template or create a new one. To edit a template, click Properties, and then modify the 
report template. 

To create a new template, go to Report Layouts > Create Report Layout, and specify how 
much information you want in each section of the report: select None if you do not 
want any information, select Summary if you want a concise overview, or select Full, if 
you need a detailed report. Select the Use as default report checkbox and click OK. 

To delete a custom report layout, select the checkbox corresponding to the report 
layout name and click Remove.  

 To print the report, click Print. A report will open in a separate browser window. Select 
the File > Print option from the browser's menu to print the report. 

 To send the report by e-mail, type the recipient's e-mail address into the input box 
located to the right of the Report group and click Send by E-Mail. If you are the recipient, 
then you do not need to specify an e-mail address: the system assumes by default 
that you are the report recipient and specifies your e-mail address registered with your 
Panel account. 

 To have the reports automatically generated and delivered by e-mail on a daily, 
weekly, or monthly basis, click Delivery Schedule and follow the instructions supplied in 
the section Automating Report Generation and Delivery by E-mail. 

 To view a report on resource usage by users and sites: 

1. Click Tools & Utilities. 

2. Do any of the following: 

 To view reports on the amount of traffic used by customers, click Traffic Usage By 
Customers. 

 To view reports on the amount of disk space used by sites, click Resource Usage By 
Domains. 

 To view reports on the amount of traffic used by domains (websites), click Traffic Usage 
By Domains. 
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In this section: 

Automating Report Generation and Delivery by E-mail ...................................... 180 
Monitoring Connections to the Control Panel and FTP Services ........................ 181 
 
 

Automating Report Generation and Delivery by E-mail 

 To schedule a report delivery on a regular basis: 

1. Go to Tools & Utilities > Summary Report > Delivery Schedule. 

2. Click Add Report Delivery Schedule. 

3. To send reports to your e-mail address registered with the system, select the 
reseller value from the Deliver to menu. To send reports to another e-mail 
address, select the e-mail address I specify option and type the e-mail address. 

4. In the Delivery frequency menu, select how often the report should be sent: 
daily, weekly, or monthly. 

5. Click OK. 

 To change the delivery schedule for an account status report: 

1. Go to Tools & Utilities > Summary Report > Delivery Schedule. 

2. Under the Frequency column, click a link corresponding to the delivery 
schedule you would like to change. 

3. Adjust the settings as required and click OK. 

 To stop receiving the account status reports: 

1. Go to Tools & Utilities > Summary Report > Delivery Schedule. 

2. Select a check box corresponding to the delivery schedule and click Remove. 

3. Confirm removal and click OK. 
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Monitoring Connections to the Control Panel and FTP 
Services 

This chapter describes how to view and close users' connections to the Control Panel and 
FTP accounts. 

In this section: 

Monitoring Connections to the Control Panel ..................................................... 181 
Monitoring Connections to FTP Service ............................................................ 182 
 
 

Monitoring Connections to the Control Panel 

 To find out who of your customers is logged in to the Control Panel at the 
moment: 

1. Go to Tools & Utilities > Active Sessions. All sessions including yours will be 
presented and the following details will be displayed: 

 Type. A type the user who established the session:  

 for customer. 

 for mailbox owner. 

 Login. The login name the user is logged in as. 

 IP address. The IP address from which the Control Panel is accessed. 

 Logon time. The date and time when the user logged in to the Control Panel. 

 Idle time. The time that user was not doing anything in the Control Panel while being 
logged in. 

2. To refresh the list of user sessions, click Refresh. 

3. To end a user session, select the respective check box and click Remove, 
then confirm removal and click OK. 
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Monitoring Connections to FTP Service 

Your Panel can show active FTP sessions only when any of the following FTP server 
programs is installed on the hosting server: 

 Microsoft FTP 7.0 (Windows hosting) 

 Gene6 FTP Server (Windows hosting) 

 Serv-U FTP Server (Windows hosting) 

 ProFTPd (Linux/UNIX hosting) 

 To find out who is connected to your server via FTP, in what directories they 
currently are and what files they are uploading to or downloading from the 
server: 

1. Go to Tools & Utilities > Active Sessions. 

2. Click the FTP Sessions tab. All sessions including yours will be presented and 
the following details will be displayed: 

 Type. The type of user who established the session:  

 for users not registered with Control Panel. 

 for anonymous FTP users. 

 for subdomain administrators. 

 for Web users (owners of personal Web pages without individual domain names). 

 Status. The current status of FTP connection. 

 FTP user login. The login name used for access to FTP account. 

 Domain name. The domain the FTP user is currently connected to. 

 Current location. The directory the FTP user is currently at. 

 File name. The file name being operated on. 

 Speed. Transfer speed in kilobytes. 

 Progress, %. The file transfer operation progress in percentage. 

 IP address. The IP address from which the FTP account is accessed. 

 Logon time. The time lapsed since the moment user logged in. 

 Idle time. The time that user was not doing anything while being connected to the 
server through FTP. 

3. To refresh the list of FTP sessions, click Refresh. 

4. To end a session, select the respective check box and click Remove. 

 

ftp://ftp 7.0/
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Presetting Content of Customer Websites 

You can configure the Panel to automatically include specific files and directories into 
webspaces created for newly hosted websites. This can be a set of useful scripts, custom 
error messages, a placeholder index.html page, or any other files of your choice. These files 
can then be replaced, edited or removed on a per-site basis. 

 To set up the Panel so as to automatically include your Web content into 
webspaces: 

1. On your local file system, create the required directories: httpdocs, cgi-

bin, anon_ftp, error_docs. 

2. Place the files you need into the directories you have created: Place Web 

pages into httpdocs directory, scripts to cgi-bin directory, and custom 

error messages to error_docs directory. 

3. Pack the directories and files into an archive fi le in tgz, tar, tar.gz, or zip 
format.  

Make sure that the directories are in the root of the archive file and not in a subdirectory. 

4. Log in to your Parallels Plesk Panel. 

5. Go to Tools & Utilities > Virtual Host Template. 

6. Click the Browse button to locate the archive file on your local computer, 
select the file, and click the Send File button. 

 To revert back to the original structure of Web server directories and files: 

1. Go to Tools & Utilities > Virtual Host Template. 

2. Click the Default button. 

 



 

  
 

With the data backup and restore functions provided by your Parallels Plesk Panel, you 
can perform the following operations: 

 Back up your account with all domains. The backup archive will include all settings and 
data related to your account and your domains (websites). 

 Back up individual domains (websites). The backup archive will include all data related 
to a website and mail services, including the contents of mailboxes, address book 
contact lists, antispam and antivirus settings. The instruction for backing up a 
certain website is provided in the section Backing Up and Recovering Websites (on 
page 395). 

 Schedule backups. Scheduling backup can be done both for your account and your 
domains. 

 Restore your data from backup archives. 

Your customers granted with the permission to use the backup and restore functions 
can back up and restore their own account settings and websites through the Panel. 

In this chapter: 

Configuring the Control Panel for Using FTP Repository ................................... 185 
Backing Up Your Account with Your Sites ......................................................... 185 
Scheduling Backups .......................................................................................... 186 
Restoring Data From Backup Archives .............................................................. 187 
Downloading Backup Files from Server ............................................................. 188 
Uploading Backup Files to Server ..................................................................... 188 
Removing Backup Files from Server ................................................................. 188 
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Configuring the Control Panel for Using 
FTP Repository 

 If you are going to use an FTP server for storing backup files, you should 
set up the Control Panel appropriately: 

1. Go to Tools & Utilities > Backup Manager > Personal FTP Repository Settings. 

2. Specify the following settings: 

 FTP server's IP address or host name. 

 Directory on the server, where you want to store backup files. 

 User name and password for access to the FTP account. 

3. Click OK. 
 

Backing Up Your Account with Your Sites 

 To back up your account with domains: 

1. Go to Tools & Utilities > Backup Manager, and click Back Up. 

2. Specify the following: 

 Backup file name prefix and description. You cannot specify an arbitrary file 
name, however, you can set the control panel to add a prefix to backup file 
names. Note that the control panel automatically adds the date and time of 
backup file creation (in Universal Time) to backup file names. 

 Splitting of the backup file. To create a multivolume backup, select the 
respective check box and specify volume size in megabytes. 

 Location where to store the backup file. Select the repository where you would 
like to store the backup file. 

 What data to back up. You can back up only the settings related to the user 
accounts and Web sites, or the settings with all user data. 

 E-mail notification on backup completion. If you want to be notified of the 
backup completion, type your e-mail address. 

3. Click Back Up. The backup process will start and the progress will be 
shown under the Current Back Up Tasks tab. You can use the Refresh button 
to update the information on the screen. When backing up is finished, 
the backup file will be saved to the repository you selected. 
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Scheduling Backups 

 To schedule backing up of data: 

1. Go to Tools & Utilities > Backup Manager. 

2. Click Scheduled Backup Settings. 

3. Select the Activate this backup task checkbox and specify the following: 

 When and how often to run the backup. 

 Backup file name. 

 Splitting of the backup file. To create a multivolume backup, select the 
respective check box and specify volume size in megabytes. Note that volume 
size cannot exceed 4095 megabytes. 

 Location where to store the backup file. Select the repository where you would 
like to store the backup file. 

 Maximum number of backup files stored in the repository. Type a number if you 
want to recycle backup files: When this limit is reached, the oldest backup files 
are removed. 

 E-mail notification on backing up errors. If you want to send an e-mail notice 
when something goes wrong during backing up, type the e-mail address you 
need. 

 What data to back up. You can back up only settings, or settings and user data. 

4. Click OK. 
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Restoring Data From Backup Archives 

You can restore data from backup files kept in Panel's repository on the server, a 
custom FTP repository (on page 185), and you can upload a backup file (on page 188) 
in a ZIP archive (on Windows systems) or tar archive (on Linux systems), and then 
restore data from it. 

 To restore data from a backup file: 

1. Go to Tools & Utilities > Backup Manager. 

2. Click the backup file name. 

3. Specify the following settings: 

 Types of data to be restored. 

 Suspend domain (Web site) until restoration task is completed. Select this if you want 
to avoid possible conflicts that may occur when users modify site content or 
settings while they are being restored. 

 Send an e-mail notice when restoration task is completed. Type your e-mail address if 
you want the Control Panel to notify you when restoring is completed. 

 Conflicts resolution policy. Specify what to do if any conflicts occur during 
restoration. 

4. Click Restore. 

In case if any errors or conflicts occur during restoration of data, the wizard will 
prompt you to select an appropriate resolution. Follow the instructions provided on 
the screen to complete the wizard. 

Note: The Overwrite data restoring mode means that all objects will be restored 
from the backup files regardless of their current presence in the system. The 
Overwrite mode works as follows: 

 If an object or settings from the backup file are not present in Parallels Plesk 
Panel, then they are created or set in Parallels Plesk Panel. 

 If an object or settings from the backup file are present in Parallels Plesk Panel, 
then the object or settings from the backup file replace the corresponding object 
or settings that are present in Parallels Plesk Panel. 

 If an object or settings are present in Parallels Plesk Panel, but are missing from 
the backup file, then the object or settings currently present in Parallels Plesk 
Panel are not changed. 
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Downloading Backup Files from Server 

 To download a backup file from a backup repository within the Panel: 

1. Go to Tools & Utilities > Backup Manager. 

2. Click the icon  corresponding to the backup file you want to download. 

3. Select the location where you want to save the backup file and click 
Save. 

The backup file will be downloaded from the backup repository. 
 

Uploading Backup Files to Server 

 To upload a backup file to a backup repository within the Panel: 

1. Go to Tools & Utilities > Backup Manager. 

2. Click Upload Files to Server Repository. 

3. Click Browse and select the required backup file. 

Note: Make sure you select the appropriate backup file format, which depends on 
the operating system on which Parallels Plesk Panel is installed. On Linux/Unix 
systems, you should upload tar or zipped tar archives, and on Windows, ZIP 
archives. 

4. Click OK. 

The backup file will be uploaded to the backup repository. 

Removing Backup Files from Server 

 To remove a backup file from the backup repository in the Panel: 

1. Go to Tools & Utilities > Backup Manager. 

2. Select a checkbox corresponding to the backup file you want to remove. 

3. Click Remove. 

4. Confirm removal and click OK. 

 



 

  
 

The Panel's main function is simplified administration of hosted websites, mailboxes, 
and other network resources. As a reseller, you can use leased hosting resources for 
your own needs as well as for selling these resources to customers. For example, you 
can set up your corporate website or mailbox on the Panel server. To set up your own 
hosting account, create a subscription in Panel by clicking Subscriptions > Add New 
Subscription. Then provide a domain name for this subscription, specify access 
credentials, and choose a service plan and add-ons if you need them. The subscription 
will appear in the list on the Subscription page together with your customers' 
subscriptions. To start creating your website or to edit the subscription settings, click 
the Open in Control Panel link next to the subscription's name. A list of operations 
available to you in the Control Panel is provided in the table below. 

Helping Customers Manage Their Subscriptions 

Your customers will have different levels of technical expertise and, therefore, may 
have problems with managing certain settings of their subscriptions. To assist your 
customers, you can log in to the Control Panel under a customer's account and edit 
their websites and subscription properties as if they were your own. To start managing 
a customer's subscription in the Control Panel, find the subscription in the list on the 
Subscriptions page and click Open in Control Panel. 

Operating in Control Panel 

Operations related to managing hosting accounts, such as managing website content, 
adding and removing mailboxes, changing hosting settings, and so on, are available to 
you in a separate interface called the Control Panel. 

The sections of this chapter explain how to perform hosting operations in the Control 
Panel. The instructions are applicable to your own subscriptions and subscriptions of 
your customers. This means that when we say your website, your subscription, and so 
on, we imply both your own and your customers' websites or subscriptions. The table 
below lists the sections of this chapter and briefly describes what you can learn from 
them. 

Section Description 

Quick Start with Parallels Panel Explains the workflow of setting up a website 
and a mail account in the Control Panel. 

Customer Account Administration Explains how to view and manage account 
settings, subscriptions, invoices, and 
resources in the Control Panel. 

Websites and Domains  Explains how to create websites, fill them 
with content, add applications, and configure 
subscription properties related to websites 
and domain names. 
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Building Websites with Web Presence Builder Provides instructions on creating websites 
using Web Presence Builder - a visual 
website editor coming in a bundle with Panel. 

FTP Access to Your Websites Explains how to set up access to websites 
using FTP for subscribers and auxiliary 
users. 

Mail Describes how to set up mail accounts and 
configure mail settings under subscriptions. 

Scheduling Tasks Provides instructions on configuring Panel to 
automatically run scripts at specific times. 

Using Databases Explains how to use databases under 
subscriptions: create new databases, import 
existing ones, or access external databases. 

Backing Up and Restoring Hosting Accounts 
Data 

 

Provides instructions on backing up and 
restoring the data of certain hosting 
subscriptions on behalf of subscribers. 

 

In this chapter: 

Quick Start with Parallels Panel......................................................................... 191 
Customer Account Administration ..................................................................... 215 
Websites and Domains ..................................................................................... 241 
Building Websites with Web Presence Builder .................................................. 325 
FTP Access to Your Websites ........................................................................... 368 
Mail ................................................................................................................... 372 
Scheduling Tasks .............................................................................................. 383 
Using Databases ............................................................................................... 389 
Backing Up and Recovering Websites............................................................... 395 
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Quick Start with Parallels Panel 

According to the latest studies, the Internet has become the most popular source of 
information in the world, leaving far behind all traditional media such as TV or 
newspapers. Nowadays, the first thing people do when trying to find services is to 
searching for them on the web. Thus, a proper web presence is vital for every 
business. There are a number of ways you can present your company on the Web. A 
web presence may be as simple as a contacts page, or as complex as a large 
company website with access to an ERP system. In both cases, you should perform 
the same steps to get your business online. 

Before proceeding any further, you will need to take the following two essential steps: 

 Purchase a customer account from a hosting provider. 
Your customer account provides access to the services that are vital for a web 
presence - Internet connectivity, disk space to store your website content, and so 
on. For more information about customer accounts in Panel, refer to the chapter 
Customer Account Administration. 

 Register a domain name. 
This is the name people will use to access your site from their browsers. For 

example, www.example.com.  

These two elements - an account for web hosting management and a domain name 
make up your website. 

In this chapter, we will explain how to create your first website, fill it with content, create 
mailboxes for users of the site, and, finally, view the site visits statistics. 

Advanced Hosting Features 

Once you are comfortable with basic Panel capabilities, try out some advanced hosting 
features: Expand website functionality by installing web applications (on page 279), 
secure your sites with SSL certificates (on page 287), employ databases, and much 
more. Note that hosting providers can turn off some of the advanced features to make 
your Control Panel look simple and user friendly. We have used the (Advanced) prefix to 
designate the sections about features that may be turned off. If you require one of the 
advanced options, contact your hosting provider. 

In this section: 

Set Up Your First Website ................................................................................. 192 
Set Up Mail Accounts ........................................................................................ 197 
View Site Visit Statistics .................................................................................... 215 
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Set Up Your First Website 

Now that you have a customer account and a domain name, the first thing you will want to do 
is create a website. The information about the possible ways to do it is provided in the 
section 1. Create Your Site (on page 192) 

When your site is ready, you may want to take a look at the result in your browser. Learn 
how to do it in the section 2. Preview your Site (on page 195). 

Even a perfectly designed site will not be effective if no one knows about it. When all the 
design work is done, you need to submit your site to popular search engines. The 
corresponding instruction is located in the section 3. Submit Your Sites to Search Engines (on 
page 196). 

In this section: 

1. Create Your Site ............................................................................................ 192 
2. Preview Your Site .......................................................................................... 195 
3. Submit Your Sites to Search Engines ............................................................ 196 
 
 

1. Create Your Site 

There are three general ways to create a website: 

 Employ a web design studio to create a site for you, and then you will just maintain its 
content.  

 Create a site by yourself using Web Presence Builder - the powerful tool that allows you 
to create professional-looking websites in a few mouse clicks. Learn more in the section 
Web Presence Builder (on page 193). 

 Create your website in a third-party Content Management System - an editor that allows 
you to easily create and edit website content such as pages, scripts, applications, and so 
on. To learn more about creating sites in third-party content management systems, see 
the section Content Management Systems (on page 193). 

If you have purchased a ready-made site or created it by yourself, you should upload the site 
content to your account to make the site visible on the web. There are two ways to upload 
content: 

 Using FTP. Learn more in the section Uploading Content Using FTP (on page 195).   

 Using an integrated <filemng>. Learn more in the section Uploading Content with <filemng> 
(on page 195). 

In this section: 

Web Presence Builder ...................................................................................... 193 
Content Management Systems ......................................................................... 193 
Uploading Content ............................................................................................ 194 
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Web Presence Builder 

Web Presence Builder is a tool that enables users with no knowledge of HTML markup or 
graphic design skills to create professional-looking sites. This tool provides a simple visual 
editor and a huge set of templates for different websites. The editor allows you to create web 
pages, add content of different types (text, images, video, scripts), and edit website settings 
such as website name, keywords, icons, and so on. 

To create websites in Web Presence Builder, ensure that your hosting subscription includes 
this option. If it does not, choose another way or upgrade your subscription. 

 To create a website with Web Presence Builder: 

1. Go to either the Home tab or the Websites & Domains tab, and click the link 
Launch Web Presence Builder. 

2. Select a topic that best suits your website. 

3. Edit the website: 

a. Structure: add more pages, remove the predefined pages that you do 
not need. 

b. Content: change the predefined content to your own, add text, 
images, videos, scripts, and other required elements. 

c. Design: change the layout and color scheme. 

4. Publish the website. 

Find more information about creating websites with Web Presence Builder in the section 
Building Websites with Web Presence Builder (on page 325). 

Content Management Systems 

Content Management Systems (or CMS) are applications that provide a graphical user 
interface for adding and editing website content: pages, scripts, files, multimedia content, and 
so on.  

Before you can create a website in a third-party CMS, you should install the CMS on your 
hosting account. Note that you can install the CMS only if your hosting subscription allows it. 

 To create a website using a CMS: 

1. Go to the Applications tab.  

2. Find the CMS you need in the list of available applications, and install it as 
described in the section Using Website Applications (on page 279). 

3. Create your website in the CMS. For information about creating websites 
with your CMS, refer to the relevant documentation. 
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Uploading Content 

If you already have a website created by yourself or a web design studio, just upload the 
website files and folders to your provider's server. You can do this in one of the following 
ways: 

 Using FTP. This way is better when several people manage a website's content because 
it does not require access to your customer account. You can just create FTP users for 
them. Learn more about this method in the section Uploading Content Using FTP (on page 
195). 

 Using Control Panel File Manager. This way is more convenient since it uses the Control 
Panel GUI and provides a set of useful features, for example, a visual HTML editor and a 
file permissions manager. Find more information on the features of content manager in 
the section Uploading Content with File Manager (on page 195). 

In this section: 

Uploading Content Using FTP........................................................................... 195 
Uploading Content with File Manager ............................................................... 195 
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Uploading Content Using FTP 

 To publish a website using FTP: 

1. Connect to your webspace on the server with an FTP client program, using 
your FTP account username and password. 

You can change your username and password in the Panel at the Websites & Domains tab 
> Web Hosting Settings. 

The FTP address should be ftp://your-domain-name.com, where your-domain-name.com 
is your site's Internet address. 

Enable the passive mode if you are behind a firewall. 

2. Upload the files and directories of your site to the httpdocs directory. If you 

use CGI scripts, place them in the cgi-bin directory. 

3. Close your FTP session. 

You can also set up additional FTP accounts if you need to collaborate on website content 
with other users. For more information, see the section Adding FTP Accounts (on page 369). 

Uploading Content with File Manager 

To upload a website from your computer to Panel server with File Manager, open the Files 
tab of Control Panel and drag the website folder to the central area of this tab. You can also 
upload your website as a compressed ZIP file and then extract the contents using the 
archiver integrated in File Manager.  

With File Manager, you can also do the following: 

 Edit HTML files in the visual editor. 

 Preview website pages. 

 Edit files in the text editor. 

 Manage the files' access permissions. 

Learn more about uploading and editing website files and folders with File Manager in the 
section Managing Website Content (on page 269). 
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2. Preview Your Site 

After you uploaded website files to the webspace, you can check how your site will look in a 
web browser, even before the information about the new site has spread in the Domain 
Name System. 

 To preview a site:  

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. In the list of domain names at the bottom of the screen, locate the website 

that you want to preview and click the corresponding icon . 

You site will open in a new browser window. 

Note: For sites created with Web Presence Builder, protected access to site pages can work 

incorrectly in Preview mode. 

Sometimes, you may need to show your site to someone when your domain name is not 
registered yet. There are several ways to do it without giving a person access to your 
customer account. Learn more in the section Previewing Websites (on page 278).  

3. Submit Your Sites to Search Engines 

To gain more visitors and drive traffic to your site after you publish it on the Internet, you 
need to submit it to search engines. Before the site submission, you can improve the site 
ranking in search results by the following content optimizations: 

 Include in the text contained in your web pages the frequently searched keyword 
phrases, which are relevant to the topic of your site. For example, mention your product 
or a topic of your interest several times in the text on a web page. 

 Add relevant keywords to the <title> and <meta> tags. Some search engines look for 

keywords and descriptions in meta tags placed within web pages, and present these 
keywords in search results. 

For example, if you are selling hosting automation software, then you can include the 
following tags in HTML pages of your website:  

<HEAD> 

<TITLE>Ordering hosting automation software 

</TITLE> 

<META name="keywords" content="order,hosting,software"> 

<META name="description" content="Ordering Hosting Automation Software"> 

</HEAD> 

Separate the keywords with a comma without white spaces. 
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After you optimize the website and publish it to your customer account, submit it to search 
engines, such as Google, Yahoo, Bing, and other engines that you know to be popular in 
your country.  

 To submit a site to Google, visit http://www.google.com/addurl/. 

 To submit a site to Yahoo, visit https://siteexplorer.search.yahoo.com/submit. 

 To submit a site to Bing, visit https://ssl.bing.com/webmaster/SubmitSitePage.aspx. 

 
 

Set Up Mail Accounts 

Once your website is ready, you can start creating mail accounts. You can choose, for 
example, to create mail accounts for all users within your organization. Note that the number 
and size of mailboxes is limited by your hosting plan. 

In this section: 

1. Create Mail Account ...................................................................................... 197 
2. Access Your Mailbox ..................................................................................... 198 
 
 

1. Create Mail Account 

 To create an e-mail address: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Mail tab. 

3. Click Create E-mail Address. 

4. Type the left part of the e-mail address before the @ sign, and, if you have 
several domain names on your account, select the domain name under 
which the e-mail address will be created. 

5. Leave the Mailbox checkbox selected. 

Clearing this checkbox makes sense only if you want to use this address as a mail 
forwarder, which will forward all incoming mail to another address. 

6. Specify the mailbox size or use the default size defined by the provider's 
policy or your service plan. 

7. Specify a password consisting of five or more Latin characters. 

8. Click OK. 

 

 
 

http://www.google.com/addurl/
https://siteexplorer.search.yahoo.com/submit
https://ssl.bing.com/webmaster/SubmitSitePage.aspx
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2. Access Your Mailbox 

There are two ways to access a mailbox for sending and receiving e-mail messages: 

 Set up and use an e-mail client program on your computer. Typically, in such programs 
you should specify the following settings: 

 Username. In this field, specify your full e-mail address. for example, 
johndoe@example.com. 

 Password. Most likely, the password to your e-mail account. 

 Mail server protocol. This property defines whether you want to keep copies of 
messages on the server or not.  To keep the copies on the server, select the IMAP 
option. If you do not want to keep them on the server, select POP3. Selecting IMAP will 
also allow you to train the SpamAssassin spam filter on e-mail messages you receive, 
if SpamAssassin is enabled on the server. 

 Incoming mail server (POP3/IMAP). Type your domain name. For example, 
example.com. The POP3 port is 110. The IMAP port is 143. 

 Outgoing mail server (SMTP). Type your domain name. For example, example.com. 
The SMTP port is 25. This server requires authentication. 

To get detailed instructions on configuring popular e-mail clients to work with your 
mailbox, see subsections of this section. 

 Use a web browser to connect to the webmail interface. Webmail interface is provided by 
Horde IMP Webmail software, which is installed by default. You can either use the default 
Horde IMP Webmail, or install Atmail Webmail Lite software. 

 

In this section: 

Access from Webmail ........................................................................................ 198 
Access from Microsoft Office Outlook ................................................................ 199 
Access from Microsoft Outlook Express ............................................................ 203 
Access from Mozilla Thunderbird ...................................................................... 207 
Access from Apple Mail ..................................................................................... 210 
 
 

Access from Webmail 

 To access your mailbox through webmail, do any of the following: 

 In a Web browser, visit the URL webmail.example.com, where example.com is the 

Internet address of your website. When prompted, specify your full e-mail address as the 

username (for example, mail@example.com), and specify the password that you use 

for logging in to the Panel. 

 When logged in to the Panel, click the Mail tab, and in the list of e-mail addresses, click 

an icon  corresponding to the e-mail address you need. 
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Access from Microsoft Office Outlook 

 To set up Microsoft Office Outlook 2010: 

1. Open Microsoft Office Outlook. 

2. Go to File > Info > Add Account. 

3. Select the checkbox Manually configure server settings or additional server types. 
Click Next. 
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4. Select the Internet E-mail option and click Next. 
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5. Specify the following: 

 Your name. 

 Your e-mail address. 

 Account type. If you want to keep copies of messages on the server, select the IMAP 
option. If you do not want to keep any messages on the server, select the POP3 
option. Selecting IMAP will also allow you to train the SpamAssassin spam filter on e-
mail messages you receive, if SpamAssassin is enabled on the server. 

 Incoming mail server. Type your domain name. For example, example.com. 

 Outgoing mail server (SMTP). Type your domain name. For example, example.com. 

 User Name. Specify your full e-mail address. Example: johndoe@example.com. 

 Password. Most likely, this password coincides with the password you use for logging 
in to Panel. 

 Require logon using Secure Password Authentication (SPA). Leave this option cleared. 
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6. Click More Settings, open the Outgoing Server tab and check My outgoing server 
(SMTP) requires authentication. 

 

7. Click Next. 

8. Click Finish. 
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Access from Microsoft Outlook Express 

The instructions provided in this section were verified against Microsoft Outlook Express 6. 
They might not work with earlier or later versions of Microsoft Outlook Express. 

 To set up Microsoft Outlook Express: 

1. Open Microsoft Outlook Express. 

2. Go to Tools > Accounts. 

3. Click the Add button and select the Mail item. 

4. Enter your name as you want it to appear in any messages you send, and 
click Next. 
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5. Type your e-mail address, and click Next. 
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6. Specify the following settings: 

 Protocol of your incoming mail server. 

If you want to keep copies of messages on the server, select the IMAP option. If you 
do not want to keep any messages on the server, select the POP3 option. Selecting 
IMAP will also allow you to train the SpamAssassin spam filter on e-mail messages 
you receive, if SpamAssassin is enabled on the server. 

 Incoming mail server. Specify your website's Internet address. 

 Outgoing mail server. Specify your website's Internet address. 
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7. Click Next. 

8. Specify the following: 

 Your account name. Type your e-mail address in the Account name box. 

 Your password. Most likely, this password coincides with the password you use for 
logging in to the Panel. 

 Remember password checkbox. Leave it selected if you do not want to be prompted to 
enter password each time your e-mail program connects to the mail server to check 
for new mail, and click Next. 

 

9. To complete setting up your e-mail program, click Finish. 
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Access from Mozilla Thunderbird 

The instructions provided in this section were verified against Mozilla Thunderbird 12. They 
might not work with earlier or later versions of Mozilla Thunderbird. 

 To set up Mozilla Thunderbird: 

1. Open Mozilla Thunderbird. 

2. Go to Tools > Account Settings > Account Actions > Add Mail Account. 

3. Specify the following: 

 Your name, as you want it to appear in any messages you send. 

 Your e-mail address and password. 

 



 

208 Managing Web Hosting 

 

4. Click Continue. 

5. If Thunderbird fails to find the settings automatically, specify the following:  

 Account type. If you want to keep copies of messages on the server, select the IMAP 
option. If you do not want to keep any messages on the server, select the POP3 
option. Selecting IMAP will also allow you to train the SpamAssassin spam filter on e-
mail messages you receive, if SpamAssassin is enabled on the server. 
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6. Click Create Account. 

 

If you set up a mail account manually, please use the following typical combinations of 
connection security and authentication method settings. If the settings do not work for you, 
ask your hosting provider about the correct combination. 

On Linux: 

 Connection security: STARTTLS 

 Authentication method: Encrypted password 

 

On Windows, IMAP: 

 Connection security: None 

 Authentication method: Encrypted password 

 

On Windows, POP3: 

 Connection security: None 

Authentication method: Password, transmitted insecurely Other parameters that you may need 
when configuring your account manually: 

 POP3 port: 110 

 IMAP port: 143 

 SMTP port: 25  

 Username. Your full e-mail address. For example: johndoe@example.com. 

 Incoming server address (POP3/IMAP). Specify your website's Internet address. Example: 
example.com 

 Outgoing server address. Specify your website's Internet address. Example: example.com 
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Access from Apple Mail 

The instructions provided in this section were verified against Apple Mail 3.6 (Leopard). They 
might not work with earlier or later versions of Apple Mail. 

 To set up Apple Mail: 

1. Run Apple Mail. 

If you run it for the first time and do not have any mail accounts configured in it, skip the 
next step: Apple Mail will take you directly to creating one. 

2. Open the Adding Mail Account wizard: 

a. Click Mail > Preferences.... 

b. Select the Accounts tab. 

c. Click the + button at the bottom left corner. 

3. Enter the account information: 

 Your full name 

 Your full e-mail address 

 The password you use to log in to the Panel.  
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4. Click Continue. 

5. Fill in the following incoming mail server information: 

 Account Type: select whether you want to use IMAP or POP protocol. 

We recommend selecting IMAP if you use SpamAssassin as a spam filtering solution: 
IMAP account is a requirement for SpamAssassin learning which messages are spam 
and which are not. 

 Incoming Mail Server: type in the name of domain which serves your mail (which follows 
the @ sign in your e-mail address). 

 User Name: enter your full e-mail address.  

 Password: leave it auto-completed (Apple Mail takes it from the previous step). 
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6. Click Continue. 

7. (Optional) Specify the incoming mail security options: 

a. Select the Use Secure Sockets Layer (SSL) checkbox. 

b. Select the authentication method. 

Keep the default method if you are not sure which to select. 

Apple Mail displays this setup screen only if a mail server bundled with Parallels Small 
Business Panel supports SSL for the selected account type (POP or IMAP). 
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8. Click Continue. 

9. Fill in the following outgoing mail server information: 

 Outgoing Mail Server: type in the name of domain which serves your mail (which follows 
the @ sign in your e-mail address). 

 Use only this server: selected. 

 Use Authentication: selected. 

 User Name: enter your full e-mail address.  

 Password: leave it auto-completed (Apple Mail takes it from the previous step). 
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10. Click Continue. 

Apple Mail displays overall description of the mail account that is going to be created. 

11. Select the Take account online checkbox and click Create. 
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View Site Visit Statistics 

Finally, when your site works fine and search engines return it in search results, it is the best 
time to evaluate site efficiency by viewing the visits statistics. 

 To find out how many people visited a site, from what countries, and what 
pages of the site they viewed: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Web Statistics. 

The site visitor statistics will show in a new browser window. 

3. To view statistics for web pages viewed from the SSL-secured area of your 
site, select SSL Web Statistics in the menu. 

4. To view statistics for files downloaded over the file transfer protocol (FTP), 
select FTP Statistics in the menu. 

Alternately, you can view the visits statistics for a site by visiting the following URL: 
https://your-domain.com/plesk-stat/webstat. When prompted for username and password, 
specify your FTP account username and password. 

You have successfully completed the quick start part of the guide. Feel free to read about 
other features that are available to you in the Control Panel. 

Customer Account Administration 

As described in the section Quick Start with Parallels Panel, the first step in establishing your 
company's web presence is signing up to the services provided by a hosting company 
(hosting provider). After you subscribe to a hosting plan, a customer account in Panel is 
created to enable you to log in to Panel and use the hosting services and resources like 
mailboxes, disk space, and bandwidth. 

Customer Account and Multiple Subscriptions 

Panel allows you to subscribe to as many hosting plans as you need. For example, if you do 
not want your main site to share hosting resources with a company's branch site you can 
subscribe to another hosting plan under the same customer account. In other words, a 
customer account is a personalized access to all your subscriptions (see the picture below). 
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Another reason for using multiple subscriptions is that subscription is limited to only one IPv4 
and one IPv6 address. Thus, all domains within a subscription share the same IP address 
(v4 or v6). If you need to host sites on different IP addresses, you should additionally order 
the same plan for as many IP addresses as you need. This can be useful, for example, if you 
want to secure connections to each of your sites with a separate SSL certificate. For 
information on how to purchase an additional subscription, refer to the section Ordering More 
Resources (on page 230). 

If you have multiple subscriptions under a single customer account, you can easily switch 
among them from the Account tab. To be more specific, the Account tab provides access to 
operations that apply to all your subscriptions. All other tabs (like Mail, Users, or Domains & 
Websites) are, on the contrary,  subscription-wide. This means that to change mail settings on 
a particular subscription, you should first switch to it before clicking Mail.  

Adding Resources to a Subscription 

Purchasing a new subscription for extending hosting resources is not always necessary. You 
can always improve just one of your subscriptions. For example, add extra disk space or SSL 
support. This can be done by switching to another hosting plan or by purchasing hosting plan 
add-ons. Learn more in the section Ordering More Resources (on page 230). 

Managing Customer Account 

In Panel, you can perform a number of administrative operations on your customer account:   

 Change an account password and personal information. Learn more in the section 
Changing Your Password and Contact Information (on page 219). 

 View the list of services and resources provided by subscription on the Account tab. For 
detailed information about all subscription features, refer to the section Viewing 
Subscription Summary (on page 220). 

 Make payments to renew your subscription. Learn more in the section Managing Account 
Balance and Invoices (on page 227). 

 View statistics on your account: For example, disk space or traffic usage. Learn more in 
the section Viewing Statistics (on page 232). 

  

Allow Other Users to Access Your Account 

If the number of hosting maintenance operations is too large to be handled by one person, 
you can delegate some of them to other people. For this purpose, you can create auxiliary 
user accounts grouped by means of user roles. For example, you can create a group that is 
allowed to only upload content to websites. Users in this group will not be able to perform 
any operations except for managing website content. For more information about auxiliary 
users, refer to the section (Advanced) Managing Auxiliary User Accounts (on page 234). 
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Changing Your Password and Contact Information 

 To change your password for access to Control Panel: 

1. Click a link with your name at the top of the screen. 

2. Type a new password, and click OK. 

 To change a username or password that you use for connecting to your 
webspace: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen. 

2. Click the Websites & Domains tab. 

3. Click Web Hosting Settings. 

4. Type the new username or password, and click OK. 

 To change your contact information: 

1. Click a link with your name at the top of the screen. 

2. Click the Contact Details tab. 

3. Update your contact information and click OK. 
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Viewing Subscription Summary 

When you subscribe to hosting services, a user account is created in the Panel to allow you 
to manage your websites and mailboxes on your own. 

You can view the following information about your account: 

 Current subscriptions to service plans. 

You can be subscribed to a number of service plans at once, and, therefore, can have 
several subscriptions associated with your account. If a billing system is connected to the 
Panel, then you can also purchase additional subscriptions, upgrade or downgrade them, 
and pay your invoices.   

 Allocated and consumed resources. 

 Hosting features available for your websites. 

 Operations you can perform in your Panel. 

 Account balance, unpaid invoices, and monthly fee for your hosting package. 

 To view the information about your account and your current subscriptions: 

1. Click the Account tab. 

A list of your current subscriptions is shown. 

2. If the billing system is integrated with the Panel, then the following 
information is shown: 

 Account credit balance. This is how much money is available in your billing account. 

 Due invoices balance. This is how much money you owe to your provider. Here, you can 
pay all invoices at once by clicking Pay All Outstanding Invoices, or pay one of invoices 
by clicking a Pay Now link in the list titled Latest Outstanding Invoices. You can also view 
all invoices by clicking the link Show all invoices, or print an invoice by clicking an 
invoice number and then clicking Print. 

 Latest to-do items. This shows reminders from the system about the actions you need to 
take. 

 List of all your subscriptions. You can use links in the list to perform the following 
operations: 

 View subscription properties by clicking a link with subscription name. 

 Select a subscription that you want to manage through the Control Panel by 
clicking the corresponding link Switch to Subscription. 

 Order an SSL certificate for a site by clicking Request SSL Certificate. This operation 
is described in the section Ordering SSL Certificates (on page 288). 

 View properties of already ordered SSL certificates by clicking Show Certificate Info. 

 View or change domain information, contact information, and DNS settings 
specified at a registrar's site, by clicking Show Domain Info. These operations are 
described in the section Registrar's DNS Settings in Panel (on page 256). 

3. To view detailed information about resource allotments, available hosting 
options, and permissions for operations, click a subscription's name. 
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4. Do any of the following: 

 To view a list of allocated and consumed resources, click the Resources tab.  

 To view a list of hosting features available for your account, click the Hosting Options 
tab. 

 To view a list of operations that you can perform in your Hosting Panel, click the 
Permissions tab. 

 

 

In this section: 
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Allocated and Consumed Resources 

If you are subscribed to a number of service plans at once, then you have several 
subscriptions. For each subscription, the following types of allocated resources are listed in 
the Panel at the Account tab > subscription name > Resources tab: 

 Disk space. This is the total amount of disk space allocated to your account with 
subscription. This amount includes all data related to your websites, e-mail accounts, 
applications, backups, and log files. 

 Traffic. This is the total amount of data in megabytes that can be transferred monthly from 
all your websites. 

 Domains. This is the number of websites that can have separate second-level domain 
names, such as, for example, example.com. 

For information about setting up websites, refer to the sections Set Up Your First Website 
(on page 192) and Adding Domains (on page 243). 

 Subdomains. This is the number of additional websites that can have third-level domain 
names, such as, for example, news.example.com. 

For information about setting up subdomains, refer to the section Adding Subdomains (on 
page 245). 

 Domain aliases. This is the number of additional domain names that can be set up to point 
to one of your sites. For example, example.fr and example.de can both point to 
example.com. 

For information about setting up domain aliases, refer to the section Adding Domain Aliases 
(on page 247). 

 Mailboxes. This is the number of mailboxes that can be created under all your websites. 

For information about creating mailboxes, refer to the chapter Mail. 

 Mailbox size. This is the amount of disk space that can be occupied by a mailbox. 

 Total mailboxes quota. This is the total amount of disk space that can be used by all 
mailboxes under all your domains. This option is available only on Windows-based 
customer accounts. 

 Mailing lists. This is the total number of mailing lists that can be set up under all your 
websites. Note that there are mailing lists and mail groups, which serve the same 
purpose, but are slightly different in functionality. Mailing lists support archiving and pre-
moderation of messages, while mail groups can only be used for sending one message to 
a number of recipients at once. 

For information about setting up and using mailing lists, refer to the section Using Mailing 
Lists (on page 382). 

 Additional FTP accounts. This is the number of FTP accounts that can be set up for 
accessing the webspace, in addition to the main FTP account that was created when your 
subscription was activated. 

For information about setting up FTP accounts, refer to the sections Changing FTP Access 
Credentials (on page 368) and Adding FTP Accounts (on page 369).  

 Databases (Linux). This is the number of databases that can be hosted for all your 
websites. Databases are a standard means of organizing data storage that allows 
dynamic websites, web applications, and their users to store, search, and retrieve 
information. 

For information about working with databases, refer to the chapter (Advanced) Using 
Databases. 
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 MySQL databases and Microsoft SQL Server databases (Windows). This is the maximum 
number of MySQL and Microsoft SQL Server databases respectively that can be created 
on the Panel database servers and used by the subscription's websites. 

 MySQL databases quota and Microsoft SQL databases quota (Windows). This is the maximum 
amount of disk space (in megabytes) that the subscription's MySQL and Microsoft SQL 
Server databases respectively can occupy. 

 Java applications. This is the number of Java applications packaged in WAR format that 
you can install on your sites. 

 Sites published with Web Presence Builder. This is the number of sites that you can create 
and publish using Web Presence Builder, if Web Presence Builder option is included in 
your hosting package. 

 Mobile sites.This is the total number of websites that you can host with the UNITY Mobile 
online service, which optimizes sites for viewing on mobile devices. 

 Web users. This is the number of user accounts that you can create for hosting web pages 
for other users under your domains. 

 FrontPage accounts. This is the number of Microsoft FrontPage user accounts that you can 
create for collaboration on site content using FrontPage. This option is available only for 
Windows-based customer accounts. 

 Shared SSL links. This is the number of websites that you can secure with an SSL 
certificate shared by your provider. This option is available only for Windows-based 
customer accounts. 

 ODBC DSN connections. This is the number of connections to external databases that you 
can create for web applications running on your customer account. This option is 
available only for Windows-based customer accounts. 

 ColdFusion DSN connections. This is the number of connections to external databases that 
you can create for web applications written in Adobe ColdFusion, which are running on 
your customer account. This option is available only for Windows-based customer 
accounts. 
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Hosting Features Available for Your Websites 

Depending on your service plan, the following hosting features may be available for your 
websites (listed at the Account tab > subscription name > Hosting Options tab): 

 SSL support. This allows you to secure connections to websites with SSL encryption. 

For information about securing sites with SSL, refer to the section Securing Connections 
with SSL Certificates (on page 287). 

 Web statistics. This allows you to view website visits statistics presented in diagrams and 
charts. 

For information about viewing website visits statistics, refer to the section Viewing Statistics 
(on page 232). 

 Custom error documents. This allows you to create custom HTML pages and configure web 

server to show them instead of typical error messages, such as 404 Not Found. 

For information about setting up custom error documents, refer to the section Setting Up 
Custom Error Pages (on page 295).   

 Support for programming and scripting languages, such as PHP, CGI, Perl, Python, Microsoft 
ASP, ASP.NET, Adobe ColdFusion, SSI.  

 Microsoft FrontPage support and Microsoft FrontPage over SSL support. These allow you to use 
Microsoft FrontPage to create and edit website content. These options are available only 
for Windows-based customer accounts. 

 Remote Microsoft FrontPage authoring (Windows). This allows you to use Microsoft 
FrontPage to create and edit website content directly on the server. This option is 
available only for Windows-based customer accounts. 

 Dedicated IIS application pool (Windows). This provides isolation and improved stability for 
web applications working on sites. 

 Additional write/modify permissions (Windows). This option allows the web applications to 

use a file-based database (like Jet) located in the root of httpdocs folder. 

 Allow web users to use scripts. This allows scripting at web pages available at URLs like 
http://example.com/~<username>/<webpage>, where <username> refers to a web user. 
Web users are individuals who do not need their own domain names. This service is 
popular with educational institutions that host non-commercial personal pages of their 
students and staff. 

  

The following is a list of permissions for operations that you can perform in your Panel 
(shown at the Account tab > subscription name > Permissions tab): 

 DNS zone management. Manage resource records in the DNS zones of websites. DNS 
stands for Domain Name System. It is a service that enables web browsers to locate 
websites by domain names. 

For information about configuring DNS settings for your websites, refer to the section 
(Advanced) Configuring DNS for a Domain (on page 250). 

 Hosting settings management. Manage web hosting settings, such as support for scripting 
languages. 
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 PHP safe mode management. This option is available only for Linux-based customer 
accounts. It allows you to switch PHP safe mode on or off for websites. Safe mode is a 
security restriction that does not allow scripts written in PHP to perform potentially 
dangerous operations on the server. You might need to switch off the safe mode for PHP 
if you use some web applications written in PHP and if they do not function properly. 

 Management of access to the server over SSH and Management of access to the server over Remote 
Desktop. Securely upload web content to the server through Secure Shell (Linux) or a 
Remote Desktop connection (Windows).  

 Anonymous FTP management. Set up a folder on the server which should be accessible to 
the Internet users over FTP protocol. This folder can have an address like, for example, 
ftp://downloads.example.com. This feature is called anonymous FTP because the users 
will not need to specify a username and password to browse, download, or upload files. 

For information about setting up FTP folder with unrestricted access, refer to the section 
Setting Up Anonymous FTP Access (on page 371). 

 Scheduler management. Schedule execution of programs or scripts in the server's operating 
system. 

For information about scheduling tasks, refer to the chapter Scheduling Tasks. 

 Spam filter management. Set custom settings for protection from unsolicited commercial e-
mail, also known as spam. 

For information about setting up spam filtering, refer to the section Protecting Mailboxes 
from Spam. 

 Antivirus management. Set custom settings for protection from viruses and other malicious 
software that spreads itself through e-mail. 

For information about setting up virus protection, refer to the section Protecting Mailboxes 
from Viruses. 

 Data backup and restoration using the server repository. Use the backup and restore functions 
of the Panel to back up and restore websites, mail accounts, settings, and keep your 
backup files on the server. 

For information about backing up and restoring data, refer to the chapter (Advanced) Back 
Up and Restore Data.  

 Data backup and restoration using a personal FTP repository. Use the backup and restore 
functions of the Panel to back up and restore websites, mail accounts, settings, and save 
your backup files to an FTP folder on another server. 

For information about backing up and restoring data, refer to the chapter (Advanced) Back 
Up and Restore Data.  

 Web statistics management. Set custom preferences for visitor statistics reports. 

For information about configuring and viewing website visitor statistics, refer to the 
section Viewing Statistics (on page 232).  

 Log rotation management. Set custom preferences for recycling (rotation) of web server 
logs. Web server records information about connections to your sites and errors occurred 
on attempts to retrieve missing files. You can use these log files for website debugging 
purposes. 

For information about working with web server access logs, refer to the section Log Files 
(on page 233). 

 Access to Application Catalog. View and install applications on websites. For information 
about applications, refer to the section Employing Website Applications (on page 279). 

 Setup of potentially insecure web scripting options that override provider's policy. This allows you 
to override the hosting security policy, if it is applied by the provider. 
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 Domain creation. Set up and manage new websites. 

For information about setting up websites, refer to the sections Set Up Your First Website 
(on page 192) and Adding Domains (on page 243). 

 Subdomains management. Set up and manage new websites with addresses like 
forum.example.com. 

For information about setting up subdomains, refer to the section Adding Subdomains (on 
page 245).  

 Domain aliases management. Set up and manage additional domain names for a site. 

For information about setting up domain aliases, refer to the chapter Adding Domain Aliases 
(on page 247). 

 Additional FTP accounts management. Set up and manage additional FTP accounts. To 
enable collaboration on website content, you can set up FTP accounts for other users 
and specify which directories of the site should be accessible to them. 

For information about setting up FTP accounts, refer to the section Adding FTP Accounts 
(on page 369).  

 Java applications management. Install and manage Java applications distributed in WAR 
archives and obtained separately from third-party vendors or application developers. 

For information about installing Java applications, refer to the section Installing Java 
Applications.  

 Mailing lists management. Set up and manage mailing lists. 

For information about setting up and using mailing lists, refer to the section Using Mailing 
Lists (on page 382). 

 Hosting performance settings management. Limit the bandwidth and number of connections to 
websites. 

For information about restricting bandwidth usage for sites, refer to the section Limiting 
Bandwidth and Number of Connections to Websites (on page 304). 

 IIS application pool management. Set custom preferences for IIS application pool (available 
only on Windows-based customer accounts). 

For information about setting up IIS application pool, refer to the section Setting Up IIS 
Application Pool (Windows) (on page 322). 

 Additional write/modify permissions management. Set additional write/modify permissions for 
websites that use file-based databases (available only on Windows-based customer 
accounts). 

 Shared SSL management. Secure connections to your sites with SSL protection by using an 
SSL certificate shared by your provider. 

For more information, refer to the section Using Shared SSL Certificates (Windows) (on page 
290). 

 Hard disk quota assignment. Adjust hard quotas on disk space if that is supported by your 
customer account. 

 Database server selection. Select a database server for creating databases, if multiple 
database servers are available. 
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Managing Account Balance and Invoices 

The operations described below are available if your Control Panel is integrated with a billing 
system. 

 To view your account balance and pay for hosting services: 

1. Click the Account tab. 

2. The following information is shown: 

 Account credit balance. This is how much money is available in your account. 

 (Optional) Usage charge. If your subscription allows consuming hosting resources 
over the plan limit, this number shows how much money you should pay for these 
resources in addition to your subscription price. To view the detailed information about 
how much resources you used over limits, click the link See details below the charge 
amount. To learn how the system calculates usage charges, see the section 
Calculating Usage Charges (on page 115). 

 Due invoices balance. This is how much money you owe to your provider. Here, you 
can pay all invoices at once by clicking Pay All Outstanding Invoices, or pay one of 
invoices by clicking a Pay Now link in the list titled Latest Outstanding Invoices. 

 Latest to-do items. This shows reminders from the system about actions you need to 
take. 

 (Optional) Affiliate programs. Your provider may let you earn money for promoting 
their plans. To start earning, you should join their affiliate programs. Here you can find 
the link to join affiliate programs or the info about your money you earn if you already 
joined the programs. To learn how to get profit from affiliate programs, see the section 
Earning Credits for Promoting Provider's Plans (on page 229).  

 List of all your subscriptions. You can use links in the list to perform the following 
operations: 

 To view subscription properties, click a link with subscription name. 

 To select a subscription that you want to manage through the Control Panel, click 
the corresponding link Switch to Subscription. 

 To order an SSL certificate for a site, click Order a Certificate. For more information 
about this operation, see the section Ordering SSL Certificates (on page 288). 

 To view properties of already ordered SSL certificates, click Show Certificate Info. 

 To view or change domain information, contact information, and DNS settings 
specified at a registrar's site, click Show Domain Info. For more information about 
these operations, see the section Registrar's DNS Settings in Panel (on page 256). 
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 To choose a payment method that you would like to use for paying for 
services: 

1. Go to the Account tab > Billing Accounts. 

A record about the payment method that you used for purchasing the services for the first 
time is shown. 

2. Do any of the following: 

 To view or change settings for a billing account, click the corresponding link in the 
Billing account name column, specify the information about your bank card or account, 
and select the subscriptions that should be paid by it. Click OK. 

 To add a new billing account, click Add New Billing Account, select the payment method, 
click Next, specify the required information about your bank card or account, and 
select the subscriptions that should be paid by it. Click OK. 

 To remove a billing account, click the corresponding Remove link. 

 

In this section: 

Calculating Usage Charges ............................................................................... 229 
Earning Credits for Promoting Provider's Plans ................................................. 229 
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Calculating Usage Charges 

If the pay-as-you-go web hosting is allowed for a plan, Business Manager calculates usage 
charges - total costs of hosting resources overage - for the plan's subscribers basing on 
resource usage statistics that Business Manager collects from the connected Panels on a 
daily basis. No matter what billing mode and billing cycles you use, this happen on the first 
day of each month: The system finds the average daily overage of each resource except 
traffic and multiplies it by the month length and the monthly usage price of this resource. 

Traffic 

The traffic usage charge is calculated in the following way: Business Manager counts the 
total traffic overage for a month and multiplies it by the monthly traffic usage price. Say, if 
subscribers download 10 GB of files during a month while the plan limit is 5 GB, then the 
traffic overage is 5 GB. Assuming that the traffic usage price is $1 for a 1 GB, such 
subscribers will pay (10 GB - 5 GB) * $1 = $5 traffic usage fee. 

Other Resources 

For calculation usage charges for other resources, Business Manager uses the average daily 
usage values. For example, if a customer uses 500 MB of disk space over the subscription 
quota for 15 days and then uses extra 700 MB for other 15 days, the average overage will be 
(500 * 15 + 700 * 15)/30 = 600 MB. If the disk space usage price is $1 for 1 GB, then the 
customer will pay $0.6 for disk space overage this month. 

Calculating Usage with Add-ons 

If a customer purchases additional resources in the middle of a month, then the system 
subtracts the resource amount provided by the add-on from the daily resource usage of each 
day starting from the add-on purchasing day. 

For example, if a customer uses 500 MB of disk space over the plan limit for a whole month 
and purchases the add-on that provides an additional 1 GB of disk space on the 7th day of 
the month, then the usage charge will include the payment for only 7 days of 500 MB of disk 
space overage. 

Earning Credits for Promoting Provider's Plans 

Panel lets you earn money for promoting your provider's service plans. Particularly, you can 
get a certain commission for each order placed in the provider's online stores by people who 
signed up using your referral link.  

Participants of affiliate programs (affiliates) distribute links to their provider's online stores. 
Each link is unique, so the system defines who brought a new customer and adds the 
commission to the link owner's affiliate balance. This commission is defined by the terms of 
the affiliate program and may vary depending on an online store. Affiliates can use money 
they earn only after the provider pays these money to their account credit balance. Normally, 
the provider pays out affiliates' commissions when they exceed the affiliate program's 
payment threshold. However, affiliates can ask the provider to pay out their commission 
before their balances exceed the threshold or, alternatively, delay payments and generate 
more credits. 
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Becoming an Affiliate 

To start earning money, click the link Become an Affiliate on the Account tab. Once became an 
affiliate, you will get the access to the list of the provider's affiliate programs and your affiliate 
links. To see the programs list and your links, click the Affiliate Programs list on the Account 
tab. 

Tracking Your Earnings 

To see your current affiliate balance, go to the Account tab and find the balance in the Affiliate 
Programs group. If you want to see detailed information about your earnings, click the link 
Revenue from Referrals. 

Example 

For example, your provider offers you an affiliate program with 10% commission rate and 
$20 payment threshold. You share your affiliate link with your friends, and three of them 
subscribe to a web hosting plan which costs $50. The total commission that you get to your 
affiliate balance is $50 * 3 * 10% = $15. This amount is less than the program's payment 
threshold, so to receive credits, you should bring more customers to the online store with 
your link. When you do this and your balance exceeds the payment threshold which is $20, 
the provider will add this balance to your credits. When you receive them, you can use them 
to pay for your subscriptions or subscribe to new services in the provider's online stores. 

Participating in Multiple Programs 

Your hosting provider may have multiple online stores with different currencies. If the 
provider offers affiliate programs for stores with different currencies, you will receive separate 
commissions in the corresponding currencies. For example, if you distribute links to stores 
with USD and EUR currencies, your affiliate balance contains two separate affiliate balances, 
one for each currency. Your provider pays out the commissions separately as well. For 
example, your affiliate balance is USD 50 and EUR 40 and the payment thresholds of the 
corresponding programs are USD 40 and EUR 45, your provider will pay out USD 50 to your 
credits and your affiliate balances will be USD 0 and EUR 40.  

Ordering More Resources 

The operations described below are available if your Control Panel is integrated with a billing 
system. 

 To add more resources to your subscription or upgrade to another service 
plan: 

1. Click the Account tab. 

2. In the list of subscriptions, locate the subscription that you want to upgrade 
to another service plan, and click a link with the currently used plan's name. 

3. Click Upgrade. 

If there is no Upgrade link, then it means that you cannot upgrade to another hosting plan 
from your Control Panel, and you need to contact your provider. 
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4. Do any of the following: 

 To add resources to your subscription without upgrading to another plan, select the 
options you would like to add and click Adjust Add-ons. 

 To upgrade to another service plan, click Order Upgrade. 

 To reduce the amounts of resources or downgrade to another service plan: 

1. Click the Account tab. 

2. In the list of subscriptions, locate the subscription that you want to 
downgrade to another service plan, and click a link with the currently used 
plan's name. 

3. Click Downgrade. 

If there is no Downgrade link, then it means that you cannot downgrade to another hosting 
plan from your Control Panel, and you need to contact your provider. 

4. Do any of the following: 

 To reduce the amounts of allocated resources without downgrading to another plan, 
select the options you would like to reduce and click Adjust Add-ons. 

 To downgrade to another service plan, click Order Downgrade. 

 To subscribe to a hosting plan in addition to your main plan: 

1. Go to the Account tab and click the Add Subscription link. 

2. Select the hosting plan to which you want to subscribe, and click Buy Now. 
Follow the instructions on the screen to complete the order. 
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Viewing Statistics 

 To view the reports on disk space and traffic usage by your account: 

1. If you have several subscriptions associated with your account, in the 
Subscription menu at the top of the screen, select the required subscription.     

2. Click the Statistics tab. 

The following information is presented in charts: 

 Disk space used by websites, mail accounts, databases, and other files located in 
your webspace. 

 Traffic used by FTP, web, and mail services during the current month. 

FTP field shows the information about the total size of files transferred to and from the 
webspace over the file transfer protocol. 

HTTP field shows the information about the total amount of data transferred from all of 
your websites over HTTP protocol, that is, retrieved by web browsers. 

POP3/IMAP field shows the total amount of data received by all mail accounts under 
your domains. 

SMTP field shows the total amount of data sent by all mail accounts under your 
domains. 

3. Do any of the following: 

 To view a report on the amount of data transferred to and from your sites over FTP, 
click FTP Statistics. 

 To view a report on the amount of data transferred to and from your FTP directory, 
which is accessed without authorization, click Anonymous FTP statistics. 

 To view a report on the amount of traffic used by services during a certain month, click 
Data Transfer Statistics, and select the required month from the menu. 

 

In this section: 

Log Files ........................................................................................................... 233 
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Log Files 

All connections to the web server and requests for files that were not found on the server are 
registered in log files. These log files are analyzed by the statistics programs running on the 
server, which then present graphical reports on demand. You may want to download these 
log files to your computer for processing by third-party statistics programs, or view their 
contents for web server debugging purposes. 

 To prevent these log files from growing too large, you should enable automatic 
cleanup and recycling of log files: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 

the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Logs (in the Advanced Operations group) > Log 
Rotation. 

3. Click Switch On. If you see only the Switch Off button there, this means that log 
recycling is already switched on. 

4. Specify when to recycle log files and how many copies of each log file to 
store on the server. Also specify whether they should be compressed and 
sent to an e-mail address after processing. 

5. Click OK. 

 To view the contents of a log file or download it to your computer: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Logs (in the Advanced Operations group). A list 
of log files opens. 

3. Do any of the following: 

 To view all entries in a log file, click the log file name. If you want to view only a few 
last lines from the log file, type the number of lines into the input box under the Settings 
group, and then click the log file name. 

 To download a file to your computer, click the corresponding icon .  

 To remove a processed log file from the server, select the corresponding checkbox 
and click Remove. Confirm removal and click OK. 
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 To download log files to your computer via FTP: 

1. Connect to the Panel server via FTP and log in using access credentials of 
the subscription logs of which you want to download. 

2. Go to the /statistics/logs directory and copy the log files to you 

computer. 
 

(Advanced) Managing Auxiliary User Accounts 

If you want to allow other users to access the Panel for managing websites and installed 
applications, or to use e-mail services under your domains, then you need to create user 
accounts for them. 

Auxiliary Users and User Roles 

Auxiliary user accounts are created based on user roles. The roles include privileges to 
access certain areas of the Panel and perform operations in the Panel. There are several 
predefined user roles, namely: Accountant, Application User, Owner, and Webmaster. You 
can review and modify the Accountant, Application User, and Webmaster roles to suit your 
needs, or you can create your own custom roles. For more information on user roles and 
user account creation, refer to the sections User Roles (on page 235) and Auxiliary User 
Accounts (on page 237) correspondingly. 

After auxiliary user accounts are created, the users will be able to log in to their accounts in 
Panel and use shortcuts in their Panels to access their mailboxes and work with applications. 
In addition, you can extend the list of links available to your auxiliary users with your custom 
links. These can be links to corporate resources, sites on the web, and so on. Learn more in 
Custom Links (on page 239).  

Auxiliary Users and Multiple Subscriptions 

Since Panel 10.4, if your customer account includes more than one subscription, you can 
allow auxiliary users to access only a specified subscription. If the Access to subscriptions 
property of a user account is set to a certain subscription, the user will always log in to this 
subscription and will not be able to switch to other subscriptions. 

In this section: 

User Roles ........................................................................................................ 235 
Auxiliary User Accounts ..................................................................................... 237 
Custom Links .................................................................................................... 239 
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User Roles 

 To create a user role: 

1. Go to the Users tab > User Roles tab > Create User Role. 

2. Specify the following: 

 User role name. 

 Access to Panel services. Grant the required permissions for operations to the user: 

 Manage users and roles. Add, modify, and remove user accounts and roles. Note that 
even if this permission is not granted to a user, the user will be able to browse 
contact information of other users after logging in to the Panel. 

 Create and manage sites. Set up, modify, remove domain names and subdomains, 
host websites and change web hosting settings. 

 Configure log rotation. Manage settings for recycling of web server access and error 
log files. View, download, and remove log files. 

 Configure anonymous FTP service. Set up a directory accessible to all Internet users 
over FTP without authorization. 

 Create and manage scheduled tasks. Schedule execution of scripts or programs on 
your customer account. 

 Configure spam filter. Set up spam protection for mailboxes. 

 Configure antivirus. Set up virus protection for mailboxes. 

 Create and manage databases. Add, modify, and remove databases stored on your 
customer account. 

 Configure and perform data backup and restoration. Back up and restore data related to 
your customer account, websites, and mailboxes under your domains. 

 View statistics. View reports on disk space and traffic usage by your websites, and 
website visits. 

 Install and manage applications. Install applications on websites and manage them. 

 Design sites in Web Presence Builder. Create websites using Web Presence Builder. 

 Upload and manage files. Manage files and directories located in the webspace by 
using the Panel's file manager. 

 Create and manage additional FTP accounts. Set up additional FTP accounts for other 
users. 

 Manage DNS settings. Manage DNS settings for domains. 

 Install and manage Java applications. Install on websites third-party Java applications.  

 Create and manage mail accounts. Create, modify, and remove e-mail accounts. 

 Create and manage mailing lists. Create, modify, and remove mailing lists. 
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 Access to apps. Select the applications that the user should be able to access and use. 
All web applications installed on the server are listed in this area. 

For more information about installing applications and providing access to users, refer 
to the section Granting Auxiliary Users Access to Apps (on page 281). 

3. Click OK. 

 To modify user role properties: 

1. Go to the Users tab > User Roles tab. 

2. Click a link with the role name that you want to change. 

3. Change the role properties as required and click OK.  

 To remove a user role: 

1. Go to the Users tab > User Roles tab. 

2. Select a checkbox corresponding to the role you want to remove and click 
Remove. Note that it is impossible to remove the Owner role and other roles 
that are assigned to one or more users. 

3. Click Yes to confirm the removal. 
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Auxiliary User Accounts 

 To create a user account: 

1. Go to the Users tab > Create User Account. 

2. Specify the following: 

 Contact name. 

 E-mail address. The e-mail address will be used as a username for logging in to the 
Panel. 

 To create a new e-mail address for the user, select the option Create an e-mail 
address under your account,    

type the desired left part of the address which goes before the @ sign, and, if you 
have a number of domains on your account,  select the domain name under which 
the e-mail address should be created. 

 To associate with this user account an external e-mail address, select the option 
Use an external e-mail address, and specify an existing external e-mail address. 

 User role. Select the required user role from the menu. 

 Access to subscriptions. Allow a user to access only a specified subscription. The All 
value grants them access to all subscriptions within your customer account. 

 Password. Type the password for access to the Panel. 

3. Leave the User is active checkbox selected. Otherwise, the user will not be 
able to access the Panel and use applications on your customer account.  

4. Click OK. 

5. Now, if you want to add contact information for the user, click a link with the 
user's name, and then click the Contact Details tab, and specify the user's 
contact information. 

6. Click OK. 

Now you can notify the user about creation of his or her account and ability to access the 
Panel. Provide the user with the address to open in his or her browser, the username (which 
is the user's e-mail address), and the password that you specified in the account settings. 

 To change user account properties: 

1. Click the Users tab. 

2. Click a link with the user's name. 

3. Make the required changes and click OK. 

 To suspend or activate a user account: 

1. Click the Users tab. 

2. Click a link with the user's name. 
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3. Do any of the following: 

 To suspend a user account, clear the User is active checkbox. The user will no longer 
be able to log in to the Panel and access applications. 

 To activate a user account, select the User is active checkbox. 

4. Click OK. 

 To remove a user account: 

1. Click the Users tab. 

2. Select a checkbox corresponding to the user account you want to remove, 
and click Remove. Note that you cannot remove your own account. 

3. Click Yes to confirm the removal. 
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Custom Links 

You can add custom hyperlinks to the Panel and make them visible for your users. The links 
may lead to web resources, such as your corporate site, or to a web application that can 
process online requests and accept additional information about the users who click these 
links. 

You can specify what information about users should be passed: 

 Subscription ID. 

 Primary domain name associated with a subscription. 

 FTP account username and password. 

 Customer's account ID, name, e-mail, and company name. 

You can place the links in the following locations of the Control Panel, and decide who 
should be able to see them: 

 On the Home page in the Control Panel, visible only to you. This is achieved by selecting 
the Customer's Home page option in the link properties. 

 On the Home page in the Control Panel, visible to you and your users who are allowed to 
log in to the Control Panel. This is achieved by selecting the Common access option in the 
link properties. 

 On the Websites & Domains tab in the Control Panel, visible to you and your users who are 
allowed to log in to the Control Panel. This is achieved by selecting the Websites & Domains 
page of Subscription option in the link properties. 

 To add a custom hyperlink to the Control Panel: 

1. Go to the Account tab > Additional Services, and click Add Link to Service. 

2. Specify the following settings: 

 Type the text that will show on your button in the Button label box. 

 Choose the location for your button. 

 Specify the priority of the button. Your custom buttons will be arranged in the Panel in 
accordance with the priority you define: the lower the number, the higher the priority. 
Buttons are placed in the left-to-right order. 

 To use an image for a button background, type the path to its location or click Browse 
to browse for the desired file. It is recommended that you use a 16x16 pixels GIF or 
JPEG image for a button to be placed in the navigation pane, and 32x32 pixels GIF or 
JPEG image for buttons placed in the main frame or desktop. 

 Type the hyperlink of your choice to be attached to the button into the URL box. 

 Using the checkboxes, specify whether you want the customer information and other 
data to be transferred within the URL. These data can be used for processing by 
external web applications. 

 In the Tooltip text input field, type in the help tip that will be displayed when the users 
place the mouse pointer over the button. 
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 Select the Open URL in Parallels Panel checkbox if you want the destination URL to be 
opened in the main frame of the Panel, otherwise, leave this checkbox cleared to 
open the URL in a separate browser window or tab. 

 If you want to make this button visible only to you, select the Show to me only checkbox. 

3. Click Finish to complete creation. 

 To remove a hyperlink button from the Panel: 

1. Go to the Account tab > Additional Services. 

2. Select a checkbox corresponding to the link that you want to remove and 
click Remove. 
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Websites and Domains 

As described in the chapter Quick Start with Parallels Panel, creating your web presence always 
starts with purchasing a domain name. The domain name (or simply, domain) is the name 

people use to access your site from their browsers, for example, www.example.com. The 

domain registration is carried out by authorized companies - domain name registrars. 
Hosting providers often carry out this function. For detailed information about how to manage 
domains in Panel, refer to the section Domains and DNS (on page 242). 

However, a domain is not a website. To make it accessible from the web and fill it with 
content, you should subscribe to hosting services (obtain a customer account). That is to 
supplement your domain with Internet connectivity, some disk space to store your content, 
mail services, and so on. Thus, a website is a domain with provided hosting services.  

Panel provides a full range of operations in regard to domains and websites: 

 Adding and removing domains, subdomains, and aliases. 

 Managing the content of your websites. 

 Installing various web apps. 

 Securing connections to your websites and much more. 

This chapter provides detailed information on all the possible operations on websites and 
domains in Panel. Note that some of these operations may be unavailable according to your 
hosting plan. 

In this section: 

Domains and DNS ............................................................................................. 242 
Changing Hosting Settings ................................................................................ 259 
Suspending and Activating Websites ................................................................. 267 
Managing Website Content ............................................................................... 269 
(Advanced) Restricting Access to Content......................................................... 276 
Previewing Websites ......................................................................................... 278 
Using Website Applications ............................................................................... 279 
(Advanced) Securing Your Websites ................................................................. 286 
(Advanced) Extended Website Management ..................................................... 291 
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Domains and DNS 

As described above, a domain name is the name that people type in their browsers to access 
your website.  

A domain name is hierarchical and may consist of a number of parts called labels: 

 The label furthest to the right is called the top-level domain. For example, com is the top-

level domain of www.example.com. The number of top-level domains is limited and all of 

them are managed by separate international authorities. 

 The second-level domain is the label that we mainly use to imply the purpose of our 

website. In www.example.com it is the example part. The combination of the second-

level and top-level domain names specifies the exact location of your website. 

 Each label to the left is a subdomain of the domain to the right. For example, www is the 

subdomain of example.com. Subdomains can be convenient when you want to isolate 

some content from the main site, e.g. you can organize your personal blog on 

myblog.example.com. For information on how to add subdomains in Panel, refer to the 

section Adding Subdomains (on page 245). 

If you want to host more than one website under your subscription, you can register more 
domains and add them to your subscription. Registering new domains may be available to 
you in the Control Panel if your hosting provider allows this. For information on how to 
purchase and add domains in Panel, refer to the section Adding Domains (on page 243). 

In fact, domain names exist only for convenience; the real communication between browser 
and web servers uses IP addresses - the numerical host identifiers. For example, the real 

address of www.example.com may be 192.0.2.12 (IPv4). To resolve domain names into IP 

addresses, web hosts use DNS technology. For more details about how DNS is implemented 
in Panel, refer to the section (Advanced) Configuring DNS for a Domain (on page 250).   

DNS allows several domains to be resolved into one IP address. Such additional names are 
called domain aliases. This is convenient when you have purchased several domains that 
you want to point to the same website. For information on how to add aliases to existing 
domains, refer to the section Adding Domain Aliases (on page 247).  

In this section: 

Adding Domains ................................................................................................ 243 
Adding Subdomains .......................................................................................... 245 
Adding Domain Aliases ..................................................................................... 247 
Adding Wildcard Subdomains (Linux) ................................................................ 249 
(Advanced) Configuring DNS for a Domain ....................................................... 250 
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Adding Domains 

If your hosting package includes more than one domain name (website), then you can easily 
add new domains to the server. Before you start adding a new domain that will use a 
second-level domain name, like example.com, be sure to register this domain name. If your 
hosting provider provides the domain name registration service, you can do this from the 
Control Panel as described below. Otherwise, you should register your domain name with 
another domain name registration authority. 

You can set up the following types of site configurations through Panel: 

 Website addressed by a second-level domain name. The following services are available for 
websites: 

 A unique Internet address (domain name), like example.com. 

 Additional domain names (domain aliases). 

 Subdomains - divisions of a site accessible by easy-to-remember addresses that are 
added to the main site, like mail.example.com. 

 Separate FTP accounts for collaboration on the site content. For every FTP account, 
you can specify which directories can be accessed. 

 Creating content using Web Presence Builder. 

 Simplified deployment of applications, such as content management systems, photo 
galleries, shopping carts, blogging platforms, and many more.  

 Secure data exchange implemented by SSL protocol. This requires that a site be 
hosted on a dedicated IP address, which is not shared among other users and sites. 

 Mailboxes and mailing lists. 

 Viewing statistics on site visits. 

 Website or a division of a website addressed by a third-level domain name (subdomain). This is 
usually a division of an existing site. It has an Internet address comprising of three parts 
separated by dots. The following services are available for subdomains: 

 Separate document root from the main site. Document root is a directory on the server 
where web pages of a site are stored. 

 Access over FTP for content management. 

 Creating content using Web Presence Builder. 

 Simplified deployment of applications. 

 Secure data exchange implemented by SSL protocol.  

 Viewing statistics on site visits. 
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 Adding More Domains 

 To host a new website with a second-level domain name: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab, click Add New Domain and follow on-screen 
instructions. 

Note: If you select the recommended option, you should connect the DNS settings 
related and your domain name with the domain name at the registrar's side. To achieve 
this, enter the Panel name server IP address into the respective NS record of the 
registrar. The instruction on how to obtain the IP is as follows: go to Websites & Domains > 
DNS Settings, find the NS record, and then find the A record corresponding to the NS 
record value. 
For example, if your NS record is 
example.com. NS ns.example.com, 
find the A record with ns.example.com, say,  
ns.example.com. A 192.0.2.12 

The resulting value, 192.0.2.12, is the Panel name server IP you need. 

3. Click OK. 

The new domain name is now shown in the list at the bottom of the screen. 

4. If the operation of changing hosting settings is available for your account, 
then you can click the domain name of the new website to view or change 
the hosting settings, as described in the section Changing Hosting Settings (on 
page 259). 

You can now start creating your website with Web Presence Builder or upload your web 
content to the webspace of the new website, as described in the section Managing Website 
Content (on page 269). 

 Registering Domains 

If your service provider offers the domain name registration service as well as web hosting, 
you can initiate a domain registration directly from Panel. To register a domain name, add it 
as described above and then click the link register it now beside the new domain name in the 
domains list on the Websites & Domains tab. This will redirect you to the provider's online store 
where you can complete the registration. 

After you register a domain name, it appears in the Registered domain names list on the 
Websites & Domains tab. To get information about a domain name registration, for example, 
the registration price and next renewal date, click the domain name in this list. 

Removing Domains 

When you delete a domain from Panel, all data related to the corresponding site are deleted 
from the server. The first domain name (default domain) that was created for your account 
cannot be deleted; however, it can be renamed.  
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 To remove a domain: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. In the list of domain names, select the domains or subdomains that you want 
to remove and click Remove. 

4. Confirm removal and click OK. 

Note: Removing domain names from the Control Panel does not cancel the registration of 
these names. If you registered these domains name, you still can use them for your 
websites. 

Adding Subdomains 

If your hosting package includes subdomains, which are additional third-level domain names, 
then you can use them to: 

 Organize logically the structure of your site. 

 Host additional websites or parts of a website on the same server without the need to pay 
for registration of additional domain names. 

An example of using subdomains: 

You have a website your-product.com dedicated to promoting and selling your product. For 
publishing information related to customer service and online order tracking, you can 
organize the subdomain "orders" so that your users will be able to access this information 
directly by visiting the Internet address "orders.your-product.com".  

As subdomains have the same status with the additional domains, you can use the same set 
of tools and services for working with subdomains. For example, SSL protection, Web 
Presence Builder, web statistics, and so on. 

 To set up a subdomain for a site division or a separate site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click Add New Subdomain. 

4. Specify the following: 

a. In the Subdomain name box, type the portion of address that will be 
added to the domain name of your main site. 
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b. In the Document root box, type the desired location of the directory 
where all files and subdirectories of this site will be kept. You can 
use the default directory of the main site, called httpdocs, or specify 
another directory. 

5. Click OK. 

The new subdomain name is now shown in the list at the bottom of the screen. 

You can now upload your web content to the subdomains webspace (directory on the 
server), as described in the section Uploading Content over FTP (on page 272). 

Wildcard Subdomains 

If you enter the asterisk (*) symbol as a subdomain name, Panel will create a so-called 
wildcard subdomain.When site visitors enter any subdomain name that is not registered in 
Panel, they will be redirected to this wildcard subdomain. You can create wildcard 
subdomains on any domain name level. For example, you can create the 
*.mystore.example.com subdomain. Learn more about wildcard subdomains in the section 
Adding Wildcard Subdomains (Linux) (on page 249). 
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Adding Domain Aliases 

If you have registered with a domain name registrar several domain names that you would 
like to point to the same website that you host on this server, you should set up domain 
aliases. 

 To set up a domain alias: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab. 

3. Click Add New Domain Alias above the list of domain names. 

4. Type the desired domain alias name, for example alias.com.  

Domain aliases can comprise letters, digits and hyphens. Each part of the domain alias 
between dots should not be longer than 63 symbols. 

5. Select the Synchronize DNS zone with the primary domain checkbox if you want the 
domain alias to use the same DNS zone resource records as in primary 
domain. With this setting, any subsequent changes in resource records of 
the primary domain's zone will be applied to the DNS zone of this domain 
alias.    

6. Select the Mail service checkbox, if you want e-mail directed at the e-mail 
addresses under the domain alias to be redirected to the e-mail addresses 
under your original domain name. 

Example: You have an e-mail address mail@yourdomain.com. You have set up an alias 
for your domain name, for example, alias.com. If you want to receive mail to your mailbox 
mail@yourdomain.com when it is sent to mail@alias.com, select the Mail service 
checkbox. 

7. Select the Web service checkbox. Otherwise, the web server will not serve the 
web content to users coming to your site by typing the domain alias in their 
browsers. 

8. If you use hosting services based on a Linux platform, and you have Java 
applications installed on your site that you want to make accessible through 
the domain alias, select the Java web applications checkbox. 

9. Click OK. 

 To change the properties of an alias: 

1. Go to the Websites & Domains tab. 

2. In the list of domain names, click the alias name you need. 

3. Click Settings in the Tools group. 

4. Modify the domain alias properties as required and click OK. 
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 To modify resource records in the DNS zone of a domain alias: 

1. Go to the Websites & Domains tab. 

2. In the list of domain names, click the alias name you need. 

3. Click DNS. 

4. Add, edit or remove the resource records as required: 

 To add a resource record to the zone, click Add New Record. Specify the required 
values and click OK to write the values to the zone. 

 To modify a resource record, under the Host column, click a hyperlink corresponding 
to the record you need. 

 To remove a record, select a checkbox corresponding to the record you wish to 
remove and click Remove. 

 To remove an alias from a domain: 

1. Go to the Websites & Domains tab. 

2. Select a checkbox corresponding to the domain alias that you want to 
remove. 

3. Click Remove. 

4. Confirm removal and click OK. 
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Adding Wildcard Subdomains (Linux) 

Use wildcard subdomains to redirect visitors from non-existent subdomains to one of your 
websites, commonly, to your main website. The typical use cases of this feature are: 

 Improve website organization and run marketing campaigns. 

For example, you do not have the vps-limited-offer subdomain but wish to forward users 
from limited-vps-offer.example.com to example.com. 

 Help users reach your website even if they mistyped a subdomain name. 

It is a widespread mistake to mistype a website name if it has the leading www prefix (for 
example, typing ww.example.com). 

 Finally, some website applications (WordPress) use wildcard subdomains to create 
dynamic subdomains for convenience and better user experience. 

Note: Traffic to existent subdomains will not be affected in any way if you add a wildcard 
subdomain. 

How to Add Wildcard Subdomains 

You can add one wildcard subdomain per each of domain names under a subscription. For 
this, go to the Websites & Domains tab and add a new subdomain which name is "*" to one of 
your domain names. Example: *.example.com. If you wish this subdomain to have a custom 
set of scripts or website content, specify a custom document root for this subdomain. 

Limitations of Wildcard Subdomains 

Wildcard subdomains act like typical subdomains with the following exceptions: 

 Linux-only feature. Currently, wildcard subdomains are supported only on Panel for 
Linux. 

 Renaming is not available. It is not possible to rename such subdomains. 

 No DNS zone. This type of subdomains does not have own zone record in the Panel's 
DNS server. Instead, they have the A record that points to the IP address associated with 
a corresponding domain name. 

 Installation of APS apps is not allowed. Panel users are unable to install APS apps to 
wildcard subdomains. 

 No Web Presence Builder sites. Panel users are unable to edit and publish sites to these 
subdomains. 
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(Advanced) Configuring DNS for a Domain 

The Domain Name System (DNS) is a hierarchical naming system that translates 
understandable domain names into the numerical identifiers (IP addresses) associated with 
web hosts. Such translation is called resolving. When you add a domain name (using 
Websites & Domains > Add New Domain), you should choose the role of Panel in resolving your 
resources: It can directly process all translation requests, be a backup server, or pass the 
translation requests to a remote server. This role can be changed for existing domain names 
(Websites & Domains > click a domain name> DNS Settings). We discuss details about each of 
the roles and provide instructions how to assign them next in this section. 

DNS Name Resolving 

DNS is based on a hierarchical tree structure called the domain namespace. This global 
namespace contains all possible domain names and is divided into logical parts - domain 
zones (see the picture below). A domain zone is a part of the namespace that contains the 
addresses of particular domains. Addresses are stored in a file on a separate name server 
with authority for that zone. For example, when a browser tries to access 

www.example.com, it gets the site's IP address from a server with authority for the 

example.com zone. For more information about how DNS works, refer to the respective 

documentation. You can find it in numerous sources on the Internet, for example, Microsoft 
TechNet. 

 



 

 Managing Web Hosting 251 

 

When you purchase a domain, a registrar gives you access to the settings for the DNS zone 
responsible for your domain and its subdomains. You can either allow the registrar to 
manage the zone, or delegate the zone to Panel. The latter option gives you the ability to 
manage a zone directly from your customer account. For information about how to delegate 
your zone to the Panel, refer to the section Panel as a Master DNS Server (on page 252). 

If you are an advanced user and already have a DNS server that you want to give authority 
for your zone, you can set up Panel to be a slave (also called secondary) DNS server. In this 
case, Panel just stores a copy of your zone and you do not have the option to manage it from 
the Control Panel. The Panel DNS server will be used only if your primary name server 
becomes inaccessible or inoperable. For information about how to make Panel act as a 
secondary DNS server, refer to the section Panel as a Slave DNS Server (on page 256). 

If you decide not to use Panel as a DNS server, all zone management should be performed 
on a domain registrar's site. Some registrars provide support for remote DNS zone 
management. If your hosting provider uses this feature, you will still be able to modify the 
DNS zone from the Control Panel regardless of where your authoritative name server is 
located. For information about how to switch off the Panel's DNS server and manage your 
zone remotely, refer to the section Registrar's DNS Settings in Panel (on page 256). 

In this section: 

Panel as a Master DNS Server .......................................................................... 252 
Panel as a Slave DNS Server............................................................................ 256 
Registrar's DNS Settings in Panel ..................................................................... 256 
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Panel as a Master DNS Server 

For each new domain name, the Panel automatically creates a DNS zone in accordance with 
the settings configured by your service provider. The domain names should work fine with 
the automatic configuration, however, if you need to perform custom modifications in the 
domain name zone, you can do that through your Panel. 

 To view the resource records in a DNS zone of a domain: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to view. 

A screen will show all resource records for a given domain. 

 To add a new resource record to the zone: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Add Record. 

4. Select a resource record type, and specify the appropriate data: 

 For an NS record, which specifies the domain name of a name server that is 
responsible for a DNS zone of a domain, you need to specify the domain name (or a 
subdomain), and then the corresponding name server's domain name. If you are 
defining an NS record for your main domain, then you should leave the domain name 
field empty. If you are defining a name server for a subdomain, then type the 
subdomain into the domain name field. After that, type the appropriate name server's 
domain name into the name server field. For example: ns1.mynameserver.com. 

 For A and AAAA records, which associate IP addresses with domain names, you 
need to specify the domain name and IP address. If you are simply defining a record 
for your main domain, then you should leave the domain name field empty. If you are 
defining a record for a name server, then type ns1 or ns2 into the domain name field. 
Then specify the appropriate IP address with which to associate the domain name. 

 For a CNAME record, which specifies which subdomains (or domain aliases that look 
like subdomains, for example, www) should be associated in the Domain Name 
System with the main domain address, you need to type the subdomain name or www 
alias, and then, the main domain name. 

 For an MX record, which specifies the host name of the preferred mail server for the 
given domain, you need to specify the mail domain (or subdomain), the domain name 
of the mail exchange server responsible for receiving e-mail, and the server's priority. 
For the main domain, you would simply leave the available field blank. Then type the 
domain name of your mail server. If you are running a remote mail server named 
'mail.myhostname.com', then simply type 'mail.myhostname.com' into the Mail 
exchange server field. After that, specify its priority: 0 is the highest and 50 is the lowest. 
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 For a PTR record, which is required for reverse DNS lookup (an IP address is 
translated to domain name), you need to enter the IP address/mask, and then type 
the appropriate domain name for this IP address to be translated to. 

 For a TXT record, which is used for specifying arbitrary human-readable text, you can 
type an arbitrary text string, or an SPF record. 

 For an SRV record, which is used for specifying location of services other than mail, 
you will need to enter the service name, protocol name, port number, and target host. 
You can also specify the priority of the target host, and relative weight (for records 
with the same priority) in the appropriate fields.  

   4. Click OK, and then click Update. 

 To modify the properties of a resource record: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click the hyperlink in the Host column corresponding to the resource record 
you want to modify. 

4. Modify the record as required, click OK, and then click Update. 

In addition to the resource records described above, there is also a Start of Authority record. 
This record indicates that this DNS name server is responsible for the domain's DNS zone. It 
also contains settings that affect propagation of information about the DNS zone in the 
Domain Name System. 

 To modify the entries in the Start of Authority (SOA) record for a domain: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click SOA Record. 

4. Specify the required values: 

 Refresh interval. This is how often the secondary name servers check with the master 
name server to see if any changes have been made to the domain's zone file. The 
Panel sets the default value of three hours. 

 Retry interval. This is the time a secondary server waits before retrying a failed zone 
transfer. This time is typically less than the refresh interval. The Panel sets the default 
value of one hour. 

 Expire interval. This is the time before a secondary server stops responding to queries, 
after a lapsed refresh interval where the zone was not refreshed or updated. The 
Panel sets the default value of one week. 

 Minimum TTL. This is the time a secondary server should cache a negative response. 
The Panel sets the default value of three hours. 
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 Default TTL. This is the amount of time that other DNS servers should store the record 
in a cache. The Panel sets the default value of one day. 

5. Click OK, and then click Update. 

Usage of serial number format recommended by IETF and RIPE is mandatory for many 
domains registered in some high-level DNS zones, mostly European ones. If your domain is 
registered in one of these zones and your registrar refuses your SOA serial number, using 
serial number format recommended by IETF and RIPE should resolve this issue. 

The Panel-managed servers use UNIX timestamp syntax for configuring DNS zones. UNIX 
timestamp is the number of seconds since January 1, 1970 (Unix Epoch). The 32-bit 
timestamp will overflow by July 8, 2038. 

RIPE recommends using YYYYMMDDNN format, where YYYY is year (four digits), MM is 
month (two digits), DD is day of month (two digits) and NN is version per day (two digits). 
The YYYYMMDDNN format will not overflow until the year 4294. 

 To change the Start of Authority (SOA) serial number format to YYYYMMDDNN 
for a domain: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click SOA Record. 

4. Select the Use serial number format recommended by IETF and RIPE checkbox. 

Note: See the sample of SOA serial number generated with the selected format. If the 
resulting number is less than the current zone number, the modification may cause 
temporary malfunction of DNS for this domain. Zone updates may be invisible to the 
Internet users for some time. 

5. Click OK, and then click Update.  

 To remove a resource record from the zone: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Select a checkbox corresponding to the record you want to remove. 

4. Click Remove. 

5. Confirm removal, click OK, and then click Update. 
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 To restore the original zone configuration in accordance with the default DNS 
template settings used on the server: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Restore Defaults. 

4. In the IP address menu, select the IP address to be used for restoring the 
zone. 

5. Specify whether a www alias is required for the domain. 

6. Select the Confirm the restoration of the DNS zone checkbox, and click OK. 

 To restore the default Start of Authority (SOA) serial number format (UNIX 
timestamp) for a domain: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click SOA Record. 

4. Clear the Use serial number format recommended by IETF and RIPE 
checkbox. 

Note: See the sample of SOA serial number generated with the selected format. If the 
resulting number is less than the current zone number, the modification may cause 
temporary malfunction of DNS for this domain. Zone updates may be invisible to the 
Internet users for some time. 

5. Click OK, and then click Update. 

By default, transfer of DNS zones is allowed only for the name servers designated by NS 
records contained within each zone. If you are using a Windows-based account, then you 
can change zone transfer settings. 

 If your domain name registrar requires that you allow transfer for all zones you 
serve: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Zone Transfers. A screen will show all hosts to which DNS zone transfers 
for all zones are allowed. 

4. Specify the registrar's IP or network address and click Add Network. 
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Panel as a Slave DNS Server 

If you host websites on your account and have a standalone DNS server acting as a primary 
(master) name server for your sites, you may want to set up the Panel's DNS server to 
function as a secondary (slave) name server. 

 To make the Panel's DNS server act as a secondary name server: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Switch DNS Service Mode. 

4. Click Add Record. 

5. Specify the IP address of the primary (master) DNS server. 

6. Click OK, and then click Update. 

7. Repeat steps from 2 to 6 for each website that needs to have a secondary 
name server on your server. 

 To make the Panel's DNS server act as a primary back: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Switch DNS Service Mode. 

The original resource records for the zone will be restored. 

Registrar's DNS Settings in Panel 

If you have external primary and secondary name servers that are authoritative for some of 
your websites, switch off the Panel's DNS service for each of these sites. 

 To switch off the Panel's DNS service for a site served by external name 
servers: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 
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3. Click Switch Off the DNS Service. 

Turning the DNS service off for the zone will refresh the screen, so that only a list of 
name servers remains. Note that the listed name server records have no effect on the 
system. They are only presented on the screen as clickable links to give you a chance to 
validate the configuration of the zone maintained on the external authoritative name 
servers. 

4. If you want to validate the configuration of a zone maintained on 
authoritative name servers, do the following: 

a. Add to the list the entries pointing to the appropriate name servers 
that are authoritative for the zone: Click Add Record,  specify a name 
server, click OK, and then click Update. 

b. Repeat the step a for each name server you would like to test. The 
records will appear in the list. 

c. Click the records that you have just created. 

The Panel will retrieve the zone file from remote name servers and will check the resource 
records to make sure that domain's resources are properly resolved. The results will be 
interpreted and displayed on the screen. 

If your Control Panel is integrated with a billing system, then the following operations on 
domains might be available from the Panel: 

 Setting a password for access to domain management panel at a registrar's site. 

 Locking and unlocking domain name for transferring to another provider. 

 Changing domain registrant and other contact information. 

 Changing DNS settings for domain zones served by a domain registrar. 

 Configure automatic renewal of the domain account at the domain name registration 
company. 

 To set a new password for access to your domain management control panel at 
a registrar's site: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and click the 
link Show Domain Info next to it. 

3. Click Change Domain Password. 

4. Type a new password and click OK. 

 To lock or unlock domain name for transferring to another provider: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and click the 
link Show Domain Info next to it. 
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3. Click Change Registrar Lock Setting. 

4. To allow domain name transfer, clear the Lock checkbox and click OK. 

 To change domain owner's contact, technical, administrative, or billing 
information: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and click the 
link Show Domain Info next to it. 

3. Click Edit Contact Info. 

4. Make the necessary changes and click OK. 

 To change DNS settings for a domain: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and click the 
link Show Domain Info next to it. 

3. Click Edit DNS Settings. 

4. Specify the domain name servers that serve the DNS zone for your website 
and IP address of the server where the website is hosted. 

5. If the DNS zone of your website is served by your domain name registrar, 
then you can also specify other resource records that affect how your 
website's services are accessible over the Internet. 

6. To save your changes, click OK. 

 To configure automatic renewal of the domain name: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and click the 
link Show Domain Info next to it. 

3. Click Automatic Domain Renewal. 

4. To allow auto renewal of the domain registration, select the Turn on auto 
renewal checkbox and click OK.  
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Changing Hosting Settings 

Panel allows you to manage a number of various hosting settings: 

 Basic settings, like a domain name or hosting type. 

 Security settings. To secure connections to your site with SSL certificates, you should 
activate the SSL support first. 

 Scripting settings. You can specify what scripting languages your site will support. Learn 
more in the section Web Scripting Settings (on page 261). Moreover, Panel supports custom 
per-site (per-subdomain) configuration for the PHP and ASP.NET languages. To learn 
more about the adjustable settings, see the sections PHP Settings and ASP.NET Settings 
(Windows) (on page 265). 

 If you want to review the hosting settings or select the hosting features and 
scripting languages that should be supported on your site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the webspace where the website is hosted.     

2. Click the Websites & Domains tab. 

3. In the list of websites at the bottom of the screen, click the website address. 

4. Review or change the following hosting settings and options: 

 Hosting type. The type of hosting configuration selected by default is website hosting, 
which means that the website is hosted on this server. You can also choose to 
redirect visitors to another website (this setup is also known as web forwarding); 
switch off web hosting service if you need to host only mailboxes and mailing lists 
under that domain; or suspend the website and all mailboxes and mailing lists hosted 
under the website's domain name. 

 If you want to redirect visitors to another site, click the Change link, select the 
Forwarding option, type the destination site address, select the forwarding scheme, 
and click OK. 

 If you want to switch off web service and use only e-mail services under that 
domain, click the Change link, select the No web hosting option, and click OK. 

 If you want to suspend the website and all services associated with it, including 
mail, click the Suspend link. When you need to bring that domain or website back 
online, return to the Websites & Domains tab > domain name, and click the Activate 
link.    

 Document root. The location of the directory where all files and subdirectories of the site 
will be kept. You can use the default directory called httpdocs or specify another 
directory.  
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 Enable SSL support. Secure Sockets Layer encryption is generally used for protecting 
transfer of sensitive data during online transactions on e-commerce websites that run 
on dedicated IP addresses. SSL certificates that participate in the encryption process 
are usually applied to a single domain name on a single IP address, therefore, each 
site that needs SSL protection must be hosted on a dedicated IP address. An 
exception to this is subdomains, which you can protect with a wildcard certificate. 
Installing an SSL certificate on a web server that hosts several websites with different 
domain names on a single IP address is technically possible, however, it is not 
recommended: the encryption will be provided, but users will get warning messages 
on attempt to connect to the secure site. To allow SSL encryption for the website, 
select the Enable SSL support checkbox. 

 Scripting languages. Specify which of the following programming and scripting 
languages should be supported by the web server: Active Server Pages (ASP), 
Microsoft ASP.NET,  Server Side Includes (SSI), PHP hypertext preprocessor (PHP), 
Common Gateway Interface (CGI), Fast Common Gateway Interface (FastCGI), Perl 
and Python. By default, PHP is configured to operate in safe mode, with functional 
restrictions that strengthen hosting security. To learn more about PHP safe mode, 
refer to http://php.net/features.safe-mode. 

 Microsoft FrontPage settings. Microsoft FrontPage is a popular website authoring tool. To 
enable content creation and publishing  through Microsoft FrontPage, select the 
options Microsoft FrontPage support, Microsoft FrontPage over SSL support, and Remote 
FrontPage authoring allowed. 

 Web statistics. Select the web statistics software that you want to use for viewing 
graphical reports and charts on website visitors. Also, select the corresponding 
checkbox if you want to be able to access the statistical reports by visiting the 
password-protected directory http://your-website/plesk-stat/webstat.  

 Custom error documents. When visitors coming to a site request pages that the web 
server cannot find, the web server generates and displays a standard HTML page 
with an error message. If you want to create your own error pages and use them on 
the web server, select the Custom error documents checkbox. 

 Additional write and modify permissions (available only for Windows hosting). This option 
is required if web applications on the site will be using a file-based database (like Jet) 
located in the root of httpdocs directory. Note that selecting this option will seriously 
compromise the website security. 

5. When finished with viewing or changing hosting settings, click OK. 

 

The Location of the cgi-bin Directory 

When creating a domain, you may see different possible locations of your cgi-bin directory 

(the CGI support checkbox). Let us discuss them on samples. 

A typical domain files organization in Panel 11 is as follows: 

 /var/www/vhosts/webspace1.com/example1.com/ 

 /var/www/vhosts/webspace1.com/example2.com/ 

 /var/www/vhosts/webspace1.com/example3.com/ 

Here example domains are created under the webspace1.com webspace. 

http://php.net/features.safe-mode
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If you specify that the cgi-bin directory for a domain example3.com is the root directory of 
webspace, its absolute path will be 

/var/www/vhosts/webspace1.com/cgi-bin/ 

If you specify that the directory is the document root of this domain, its absolute path will be 

/var/www/vhosts/webspace1.com/example3.com/cgi-bin/ 

If you specify old-style root of this domain (this option is available only after upgrading Panel 
from previous versions), the absolute path will be 

/var/www/vhosts/domain3.com/cgi-bin  

This option provides the compatibility with the obsoleted organization of domain files on the 
file system. 

In this section: 

Web Scripting Settings ...................................................................................... 261 
 
 

Web Scripting Settings 

For each website in your subscription you can specify which of the following programming 
and scripting languages should be supported by the web server: Active Server Pages (ASP), 
Microsoft ASP.NET,  Server Side Includes (SSI), PHP hypertext preprocessor (PHP), 
Common Gateway Interface (CGI), Fast Common Gateway Interface (FastCGI), Perl and 
Python. Since Panel 10.4, you are able to configure PHP settings individually for each 
website (or subdomain) in your subscription. This is possible only if your subscription have 
the corresponding permissions. To get the details about custom PHP configuration, refer to 
the section PHP Settings. 

In this section: 

PHP Settings ..................................................................................................... 262 
ASP.NET Settings (Windows) ........................................................................... 265 
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PHP Settings 

PHP is one of the most popular scripting languages for creating dynamic web pages. The 
majority of today's websites and web applications are based on PHP scripts. Thus, site 
administrators should clearly understand how they can control the execution of PHP scripts.  

There are two main aspects that completely define how PHP scripts will be executed for a 
certain website: The PHP handler type and values of PHP settings for the site. You can set 
up these parameters for a certain website by selecting the site from the list in Websites & 
Domains. 

PHP Handler 

When a visitor accesses a site based on PHP scripts, a web server interprets site scripts to 
generate a page that will be shown to the visitor. PHP handler calls PHP libraries needed for 
this interpretation. You can choose from a number of PHP handlers: ISAPI (Windows), 
Apache module (Linux), FastCGI, or CGI application. The decision on what PHP handler to 
choose should depend on a number of factors like security considerations, script execution 
speed, and memory consumption. 

Choose one of the following PHP handlers at the Websites & Domains > select a website > 
General tab > PHP support: 

 
 

Performance 
 

Memory 
Usage 

Security 
 

Apache 
module (Linux 
only) 

High. 

Runs as a part of the 
Apache web server. 

Low This handler (also known as mod_php) 
is the least secure option as all PHP 
scripts are executed on behalf of the 

apache user. This means that all files 

created by PHP scripts of any plan 
subscriber have the same owner 

(apache) and the same permission 

set. Thus, a user has a theoretical 
possibility to affect files of another user 
or some important system files. 

Note: You can evade some 
security issues by turning the PHP 
safe_mode option on. It disables a 
number of PHP functions that bring 
potential security risk. Note that this 
may lead to inoperability of some 
web apps. The safe_mode option is 
considered to be obsolete and is 
deprecated in PHP 5.3. 
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ISAPI 
extension 
(Windows 
only, not 
supported 
since PHP 
5.3) 

High. 

Runs as a part of the 
IIS web server. 

Low The ISAPI extension can provide site 
isolation in case a dedicated IIS 
application pool is switched on for 
subscriptions. Site isolation means that 
sites of different customers run their 
scripts independently. Thus, an error in 
one PHP script does not affect the 
work of other scripts. In addition, PHP 
scripts run on behalf of a system user 
associated with a hosting account. 

Note: The ISAPI extension handler 

is not supported since PHP 5.3. 

CGI 
application 

Low. 
Creates a new 
process for each 
request and closes it 
once the request is 
processed. 

Low The CGI handler provides PHP script 
execution on behalf of a system user 
associated with a hosting account. On 
Linux, this behavior is possible only 
when the suEXEC module of the 
Apache web server is on (default 
option). In other case, all PHP scripts 

are executed on behalf of the apache 

user. 

We recommend that you use the CGI 
application handler only as a fall-back. 

FastCGI 
application 

High (close to 
Apache module and 
ISAPI extension). 

Keeps the 
processes running to 
handle further 
incoming requests. 

High The FastCGI handler runs PHP scripts 
on behalf of a system user associated 
with a hosting account.  

Note: Switching PHP from Apache module to FastCGI application may break functionality of 
existing PHP scripts. 

If you use Windows hosting, you can additionally choose a PHP version. Always use PHP 
5.x except the cases when you need PHP 4.x to host some old PHP apps. 

PHP Settings 

PHP behavior is defined by a number of configuration settings. These settings specify 
various script execution aspects, like performance (for example, the amount of memory a 
script can use), security (for example, access to file system and services), and so on. You 
may adjust these settings for a number of reasons: 

 Preventing a memory leak or server hang-up by poorly written scripts. 

 Protecting data from malicious scripts. 

 Meeting the requirements of a certain web app. 

 Testing own scripts and other. 
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All customizable PHP settings are located in the Control Panel, Websites & Domains > select a 
website >  PHP Settings tab. For convenience, all PHP settings are divided into three groups: 

 Performance settings.  
These settings define how scripts work with system resources. For example: Use the 

memory_limit parameter to limit the amount of memory for a script  to prevent a 

memory leak. In addition, you can prevent scripts from tying up the server by limiting the 

maximum time scripts are allowed to run in max_execution_time. 

 Common settings.  
This group contains other commonly used PHP settings. Generally, these are: Security 
settings (for example, the PHP safe mode toggle or the permission to register global 
variables), error reporting settings (for example, the directive to log errors), and others. 

 Additional configuration directives.  
If you cannot find particular parameters among performance or common settings, add 
them to the Additional configuration directives field. All directives from that field will be 
included in the final PHP configuration. For example, if you want PHP to log errors to your 

own file, add the line: error_log=/tmp/my_file.log.  

You can set the value of each parameter in PHP Settings either by selecting a value from a 
preset, typing a custom value, or leaving the Default value. In the latter case, Panel uses the 
values defined by the server-wide php.ini file. For information about certain PHP settings, 
refer to the respective documentation. For example, http://php.net/manual/en/ini.list.php.  

It is possible to use three placeholders in parameter values:  

 {DOCROOT} for the document root directory of a domain that gets custom PHP 

configuration. 

 {WEBSPACEROOT} for the root directory of a subscription (webspace). 

 {TMP} for the directory which stores temporary files. 

Note: Custom PHP configuration of a website acts as a preset for all subdomains of this site. 
You can perform further per-subdomain PHP configuration in the same way as for the 
websites.  
 

http://php.net/manual/en/ini.list.php
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ASP.NET Settings (Windows) 

 To configure ASP.NET Settings for a site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > ASP.NET Settings (in the Advanced Operations 
group). 

3. Set up the strings that determine database connection data for ASP.NET 
applications that use databases. This option is available only for ASP.NET 
2.0.x. 

When you open the ASP.NET configuration screen for the first time, sample 
connection parameters with common constructions are displayed. You can delete 
them and specify your own strings. 

 To add a string, enter the required data into the Name and Connection Parameters input 

fields and click  next to them. 

 To remove a string, click  next to it. 

4. Set up custom error messages that will be returned by ASP.NET applications 
in the Custom Error Settings field: 

 To set the custom error messages mode, select an appropriate option from the Custom 
error mode menu: 

 On - custom error messages are enabled. 

 Off - custom error messages are disabled and detailed errors are to be shown. 

 RemoteOnly - custom error messages are displayed only to remote clients, and 
ASP.NET errors are shown to the local host users. 

 To add a new custom error message (which will be applied unless the Off mode was 

selected), enter the values in the Status Code and Redirect URL fields, and click . 

 Status Code defines the HTTP status code resulting in redirection to the error page. 

 Redirect URL defines the web address of the error page presenting information 
about the error to the client. 

Due to possible conflicts, you cannot add a new custom error message with an error 
code that already exists, but you can redefine the URL for the existing code. 

 To remove a custom error message from the list, click  next to it. 

5. Configure compilation settings in the Compilation and Debugging field: 

 To determine the programming language to be used as default in dynamic compilation 
files, choose an entry from Default web page language list. 
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 To enable compiling retail binaries, leave the Switch on debugging checkbox empty. 

 To enable compiling debug binaries, select the Switch on debugging checkbox. In this 
case, the source code fragments containing error will be shown in a diagnostic page 
message. 

Note. When running applications in debug mode, a memory and/or performance 
overhead occurs. It is recommended to use debugging when testing an application and to 
disable it before deploying the application into production scenario. 

6. Configure encoding settings for ASP.NET applications in the Globalization 
Settings section: 

 To set an adopted encoding of all incoming requests, enter an encoding value into the 
Request encoding field (default is utf-8). 

 To set an adopted encoding of all responses, enter an encoding value into the 
Response encoding field (default is utf-8). 

 To set an encoding which must be used by default for parsing of .aspx, .asmx, and 

.asax files, enter an encoding value into the File encoding field (default is Windows-

1252). 

 To set a culture which must be used by default for processing incoming web requests, 
select an appropriate item from the Culture list. 

 To set a culture which must be used by default when processing searches for a 
locale-dependent resource, select an appropriate item from the UI Culture list. 

7. Set a code access security trust level for ASP.NET applications in the Code 
Access Security field. 

CAS trust level is a security zone to which applications execution is assigned, defining 
what server resources the applications will have access to. 

Important: When an assembly is assigned a trust level that is too low, it does not 
function correctly. For more information on the permissions levels see 
http://msdn.microsoft.com/library/en-
us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010. 

8. Enable the usage of the auxiliary scripts in the Script Library Settings field. 
Specifying the script library settings is necessary if the validation web 
controls are used on your web site. This option is available only for ASP.NET 
1.1.x. 

 If you need to use auxiliary scripts (specifically, scripts implementing objects for 
validating input data), provide the settings for .NET framework script library. To do so, 
enter the path beginning with the domain root directory preceded by the forward slash 
into the Path to Microsoft script library field, or click the folder icon next to the Path to 
Microsoft script library field and browse for the required location. 

 To initiate the auto-installation of files containing the scripts to the specified location, 
select the Install checkbox. If the files already exist there, they will be rewritten. 

 

 

 

http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
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9. Set client session parameters in the Session Settings field: 

 To set up the default authentication mode for applications, select an appropriate item 
from the Authentication mode list. Windows authentication mode should be selected if 
any form of IIS authentication is used. 

 To set up time that a session can remain idle, type the number of minutes into the 
Session timeout box. 

10. Click OK to apply all changes. 

 
 

Suspending and Activating Websites 

When a website is suspended, it becomes inaccessible over the Internet, and e-mail 
addresses under the site's domain name stop working. 

 To suspend a website: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click the domain name of the site that you want to suspend. 

4. Click the Suspend link next to the Hosting type field. 

 To activate a website: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click the domain name of the site that you want to activate. 

4. Click the Activate link next to the Hosting type field. 

 

In this section: 

Suspending Websites for Maintenance ............................................................. 268 
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Suspending Websites for Maintenance 

If you want to shut down a site for maintenance and let your visitors know that it is 
temporarily unavailable and will be back online later, switch on the site maintenance mode. 
When a site is in the maintenance mode, the "503 Service Unavailable" error document is 
shown to website visitors instead of the actual site pages.  

If your hosting plan provides the option to customize web server error documents (the 
"Custom error pages" option), then you can use File Manager to open and customize the 
error page: Instead of the "Service Temporarily Unavailable" message, you can write your 
own message like "The site is temporarily down for maintenance, it will be up soon." 

When maintenance work is finished, switch the maintenance mode off for the site to make it 
available to the visitors. 

 To switch on the maintenance mode for a website: 

1. Go to the Websites & Domains tab. 

2. Click Website Maintenance Mode (in the Advanced Operations group). 

3. If you have several websites, locate the site you want to temporarily 
suspend, and click the corresponding Manage link. 

4. Select the Switch on the maintenance mode for website checkbox. 

5. Click OK. 

If the custom error documents option is switched on for the site, then you can edit the "503 
Service Temporarily Unavailable" document to include your own text. For information about 
customizing error pages, refer to the section Setting Up Custom Error Pages (on page 295). 

 To switch off the maintenance mode and put a site back online: 

1. Go to the Websites & Domains tab. 

2. In the list of your websites, locate the website you want to put back online. It 
should be accompanied by the Switched off for maintenance status indicator. 

3. Click the corresponding Change link. 

4. Clear the Switch on the maintenance mode for website checkbox. 

5. Click OK. 
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Managing Website Content 

To create your website and fill it with the content you need (text, images, videos, and so on), 
use one of the methods provided by the Panel: 

 Using website creation and management tools. If you do not have a website yet, consider 
setting one up by yourself with a tool for creating, editing, and publishing websites. You 
can do this even if you do not possess the necessary web programming and design skills. 
The best tools of this sort are the following: 

 Web Presence Builder - a website editor integrated with the Control Panel.  

 Third-party Content Management Systems (CMS) - web applications for creating and 
editing websites.  

 Uploading existing websites to your hosting account using one the following methods: 

 FTP client program. You can obtain a free FTP client from the Internet, or, if you are 
using Windows, use Windows Explorer. This enables you to access your directory on 
the hosting server and manage your files. If you collaborate with other people when 
managing your website (say, programmers or designers), you can provide them with 
access to your directory using FTP to let them edit the website by themselves. 

 File Manager. A tool for uploading and managing website files and directories through 
the Panel web interface.  

Note: if you have a website created in Microsoft FrontPage editor, refer to the section Working 
with Microsoft Frontpage Websites (Windows) (on page 305) for details on managing this site in 
Panel. 

Below you will find detailed descriptions of the ways to manage your content. 

Web Presence Builder 

Web Presence Builder is a great tool that enables users with no knowledge of HTML markup 
or graphic design skills to create professional-looking sites. Just pick a suitable page design 
and content template, add your text to the pages, and publish the site. 

You can create and publish websites using Web Presence Builder if your hosting 
subscription provides this option. If it does not, or if you have already created and published 
the allowed number of sites, you still can create a new website with Web Presence Builder 
and edit it. However, to publish this website, you will need to upgrade your hosting plan. 

To start creating a website using Web Presence Builder or edit an existing Web Presence 
Builder site, go to either the Home tab or the Websites & Domains tab, and click Launch Web 
Presence Builder. If you have several domain names or subdomains, click the corresponding 
link Edit in Web Presence Builder. Find more information on creating and editing websites in 
Web Presence Builder in the chapter Building Websites with Web Presence Builder. 
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Third-Party Content Management Systems 

To create and maintain a website, you can use third-party Content Management Systems 
(CMS) - web applications that let you easily edit a website's structure and content with a 
graphical user interface. Examples of such systems are Drupal and Joomla. 

CMS are usually server applications, so to start using one of them you should install it on 
your hosting account. Hence, if you plan to use a CMS, ensure that your hosting subscription 
allows such applications to be installed. 

 To create a website using a CMS: 

1. Go to the Applications tab.  

2. Find the CMS you need in the list of available applications, and install it as 
described in the section Employing Website Applications (on page 279). 

3. Create and edit your website in the CMS. For information on how to create 
websites with your CMS, refer to the relevant documentation. 

 

Uploading Using FTP 

If you already have all your website files and directories, consider uploading them to your 
hosting account using FTP. This is the quickest way for simple uploading of files when you 
do not need to edit or manage them on the server. 

 To upload files using FTP: 

1. Connect to your site's domain name with an FTP client program using your 
FTP access credentials. Learn how to configure these credentials in the 
section Adding FTP Accounts (on page 369).  

2. Copy the website files and directories to your directory on the server. 

 

File Manager 

Another way to publish a website created outside the Panel is File Manager - a tool that 
provides a set of file management functions through the web interface. File Manager is 
available from the Websites & Domains tab of the Control Panel.  

To upload a website from your computer to Panel server with File Manager, go to the Website 
& Domains > File Manager page, click Add New Directory, and upload the directory containing your 
website to Panel. If your website is compressed to a ZIP file, you can upload this file by 
clicking Add New File and then extract it by clicking Extract Files. 

If you want to edit pages of your website, you can do it in File Manager. It provides an HTML 
editor that allows visual editing of HTML pages (without needing to manually type HTML 

tags). To edit a file in the HTML editor, click the button  in the Tools column next to the 
file's name. 
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You can also edit files in File Manager's text editor if you like. To open a file in the text editor, 

click the corresponding  button  in the Tools column. 

If you have files or web pages that you want to make inaccessible on the Internet, change 
these files' access permissions in File Manager. To edit access permissions for a file or a 
directory, click the corresponding link in the Permissions column. To learn how to review and 
edit the permissions, refer to the sections Setting File and Directory Access Permissions. 

In this section: 

Creating Websites with Web Presence Builder .................................................. 271 
Uploading Content over FTP ............................................................................. 272 
Using Content Manager ..................................................................................... 273 
 
 

Creating Websites with Web Presence Builder 

 To start creating a website using Web Presence Builder: 

1. Go to either the Home tab or the Websites & Domains tab, and click Launch Web 
Presence Builder. 

If you have only one domain name configured, Web Presence Builder will open in a new 
browser window or tab. 

2. If you have several domain names or subdomains, click the corresponding 
link Edit in Web Presence Builder. The Web Presence Builder wizard will open in 
a new browser window or tab. 
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Uploading Content over FTP 

 To publish website through FTP: 

1. Connect to your webspace on the server with an FTP client program, using 
your FTP account username and password. 

You can change your username and password in the Panel at the Websites & Domains tab 
> Web Hosting Settings. 

The FTP address should be ftp://your-domain-name.com, where your-domain-name.com 
is your site's Internet address. 

Enable the passive mode if you are behind a firewall. 

2. Upload the files and directories of your site to the httpdocs directory. If you 

use CGI scripts, place them into the cgi-bin directory. 

3. Close your FTP session. 

You can also set up additional FTP accounts if you need to collaborate on website content 
with other users. For information, see the section Adding FTP Accounts. 
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Using Content Manager 

 To upload files through the Panel's file manager: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click File Manager. 

4. Create or upload files and directories. 

Place the files and directories of your site to the httpdocs directory. If you use CGI 

scripts, place them into the cgi-bin directory. 

 To upload a file from your computer, click Add New File, click the Browse button to 
locate the file, or specify the path to its location in the Path to file box, and then click 
OK. 

 To upload a ZIP archive to the server and then extract its contents, click Add New File, 
click the Browse button to locate the archive file, and click OK. After the file is 
uploaded, select the corresponding checkbox on the left, and click Extract Files. 

 To create a new directory within your current location, click Add New Directory. 

 To create new files in the required directory, click Add New File, select the Create a file 
option, specify the file name, select the Use html template checkbox, if you want file 
manager to insert some basic HTML tags into the new file, and click OK. A page will 
open allowing you to enter the content or HTML-formatted source of a new file. After 
you finished, click OK.  

 To add files to a ZIP archive, select the files you want to pack, click Add to Archive, and 
specify the name of your archive file. 

When you upload web content through File Manager or FTP, the Panel automatically sets 
the appropriate access permissions for files and directories. On Linux-based servers, the 
permissions are represented as three sets of symbols, for example, 'rwx rwx r--'. The first set 
tells what the owner of the file or directory can do with it; the second tells what the user 
group, the file or directory belongs to, can do with the file or directory; the third set indicates 
what other users (the rest of the world, that is, Internet users visiting a site) can do with the 
file or directory. R means the permission to read the file or directory, W means the 
permission to write to the file or directory, and X means the permission to execute the file or 
look inside the directory. 

To modify permissions for a file or directory on a Linux-based account, click a hyperlink 
representing the set of permissions in the Permissions column. If you use a Windows-based 

account, click the icon . Modify the permissions as desired and click OK. 

To edit the source code of a file, click . 

To edit the Web page in the built-in visual editor (available only to users of Microsoft Internet 

Explorer), click . When editing an HTML file, the Panel opens internal WYSIWYG editor by 
default. If you want to edit the source code of the HTML file, click HTML. To return back to 
WYSIWYG mode, click Design. 
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To view the file, click . 

To rename a file or directory, click . Type in a new name and click OK. 

To copy or move a file or directory to another location, select the required file or directory 
using the appropriate checkbox, and click Copy/Move. Specify the destination for the file or 
directory to be copied or renamed to, then click Copy to copy, or Move to move it. 

To update the file or directory creation date, click Change Timestamp. The time stamp will be 
updated with the current local time. 

To download a file, click the corresponding icon . 

To remove a file or directory, select the corresponding checkbox, and click Remove. Confirm 
removal and click OK. 

Setting File and Directory Access Permissions (Linux Hosting) 

 To review or change the permissions set for files and directories: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click File Manager. 

The permissions set for files and directories are shown in the Permissions column. They 
are represented as three sets of symbols, for example, 'rwx rwx r--'. The first set tells 
what the owner of the file or directory can do with it; the second tells what the user group, 
the file or directory belongs to, can do with the file or directory; the third set indicates what 
other users (the rest of the world, that is, Internet users visiting a site) can do with the file 
or directory. R means the permission to read the file or directory, W means the 
permission to write to the file or directory, and X means the permission to execute the file 
or look inside the directory. 

4. Locate the file or directory for which you want to modify permissions and 
click a hyperlink in the Permissions column. 

5. Modify the permissions as desired and click OK. 

  

Setting File and Directory Access Permissions (Windows Hosting) 

 To set access permissions for a file or directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > File Manager. 
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3. Locate the file or directory for which you want to set access permissions, and 

click the corresponding icon . 

4. Do the following: 

 To make the file or folder inherit permissions from a parent folder (if it does not), 
select the checkbox Allow inheritable permissions from the parent to propagate to this object 
and all child objects. Include these with entries explicitly defined here. 

 To make the files and folders, which are contained in this folder, inherit the folder 
permissions you define, select the checkbox Replace permission entries on all child objects 
with entries shown here that apply to child objects. 

 To change or remove permissions from a group or a user, click the required name in 
the Group or user names list. If the group or user is not listed in the Group or user names 
list, select the required user or group name from the menu located above the list and 

click : the user/group appears in the list. Select it. 

To allow or deny permissions to a selected group/user, select the Allow or Deny 
checkboxes corresponding to permissions listed under Permissions for <user/group 
name>. If the checkboxes in the Allow or Deny columns are shown in grey, it means that 
the corresponding permissions are inherited from a parent folder. 

 To deny the permissions, which are inherited from a parent object as allowed, select 
the required checkboxes under Deny. This will override inherited permissions for this 
file/folder. 

 To allow the permissions, which are inherited from a parent object as denied, clear the 
Allow inheritable permissions from the parent to propagate to this object and all child objects. 
Include these with entries explicitly defined here checkbox: this removes the inherited 
permissions. Then select the required checkboxes under Allow and Deny. 

 To remove access permissions from a group or user, select the required name in the 

Group or user names list and click the icon  next to it. 

5. If you need advanced fine-tuning of permissions, click the Advanced button, 
and do the following: 

 To create a permission entry for a group or user, select the required name from the 

Group or user names list and click . 

 To set or change file/folder permissions for a group or user, select the required name 
from the Group or user names list, select the required Allow and Deny checkboxes 
corresponding to permissions listed under Permissions for <user/group name>. 

 To remove a permission entry for a group or user, select the required name from the 

Group or user names list and click . 

 To make child objects of a folder inherit its permissions defined under Permissions for 
<user/group name>, select the Replace permission entries on all child objects with entries 
shown here that apply to child objects checkbox, and select checkboxes in the Apply to list 
which correspond to the objects that must inherit the permissions. 

6. Click OK. 
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(Advanced) Restricting Access to Content 

If you have directories in a site that only authorized users should see, restrict access to these 
directories with password protection. 

 To protect a directory in your site with a password and to specify authorized 
users: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced 
Operations group). 

3. Click Add Protected Directory. 

4. In the Directory name box, specify the path to the directory that you want to 
protect with a password.   

This can be any directory existing in the site, for example: /private. If the directory that 

you would like to protect has not yet been created, specify the path and the directory 
name – the Panel will create it for you. 

5. If you are using a Linux-based account, you can also protect your CGI 

scripts stored in the cgi-bin directory. To do this, leave '/' in the Directory 

name box and select the cgi-bin checkbox. 

6. In the Title of the protected area box, type a resource description or a welcoming 
message that your users will see when they visit the protected area. 

7. Click OK. The directory you specified will be protected. 

8. To add authorized users, click Add New User. 

9. Specify the username and password that will be used for accessing the 
protected area. The password should be from 5 to 14 symbols in length. 
Click OK. 

 To add an authorized user of a protected directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced 
Operations group). 

3. Click on the name of the directory you need. 

4. Click the Add New User icon. 
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5. Specify the username and password that will be used for accessing the 
protected area. The password should be from 5 to 14 symbols in length. 

6. Click OK. 

 To change password for an authorized user of a protected directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced 
Operations group). 

3. Click on the name of the directory you need. A list of authorized users will 
open. 

4. Click on the user’s name. 

5. Specify the new password and re-type it for confirmation. 

6. Click OK. 

 To revoke a permission to access the protected directory from a user: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced 
Operations group). 

3. Click on the name of the directory you need. A list of authorized users will 
open. 

4. Select a checkbox corresponding to the user’s name. 

5. Click Remove. Confirm the operation and click OK. 

 To remove password protection and make the resource available to the public: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced 
Operations group). 

3. Select a checkbox corresponding to the name of the directory, from which 
you want to remove protection. 

4. Click Remove Protection. The protection will be removed and the contents of 
the directory will be accessible to the public without restrictions. 
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Previewing Websites 

After you purchase a domain, its registration can require some time. The reason for the delay 
is that name servers update their zone information periodically. Thus, until all name servers 
have received information about your zone, you will not be able to access your site by its 
domain name. Nevertheless, you can always access your site during domain name 
propagation using the button on the Websites & Domains tab. 

During domain name propagation other people can access your site too. For this purpose, 
Panel registers your website as a subdomain of one of the provider's sites. For example, if 
your website is my-domain.tld and a provider has configured the preview service on provider-
domain.tld, you can access your site on my-domain.tld.192-0-2-12.provider-domain.tld. Here 
192-0-2-12 is the site's IP address where dots are replaced with dashes. 

Note: If you do not have the site preview button on the Websites & Domains page, contact your 
hosting provider. 
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Using Website Applications 

You can significantly increase your website functionality by using different web apps. Apps 
being installed on a website can perform a number of tasks. If you are an individual, you can, 
for example, present yourself with a blog or organize online storage of your media files. 
Companies can move part of their business online by using the e-commerce or CRM web 
apps. All these apps are available for installation right from your Control Panel, the 
Applications tab. 

The list of available apps is governed by your hosting plan. For example, it might include only 
free apps or no apps at all. For more information on available apps, refer to your hosting 
provider. 

App Types 

There are two types of web apps: 

 Apps that are installed directly on a website (say, the WordPress blogging platform or the 
Joomla! content management system). 

 Apps installed on external servers and provided by third-parties. 

Regardless of the installation type, apps can be either free or commercial. Commercial apps 
require you to provide a license key to start working with them, and in the Applications tab 
they are accompanied by the Buy Now button instead of Install Now. If you decide to use 
commercial apps, read the Managing Commercial Apps Licenses section (on page 282) to 
familiarize yourself with acquiring and managing app licenses.  

App Installation and Maintenance 

The process of installation does not require any specific skills. You just fill in app settings 
(such as, administrator credentials), and Panel installs the app for you. Further app 
management is also facilitated as you can update or remove apps directly in Panel. 
Moreover, you can access some functions that apps reveal to the Control Panel (without the 
need to log in to an app). For example, you can add SugarCRM user account right from your 
Control Panel. Such app functionality is a service provided by the app. 

After you install an app, grant other auxiliary user accounts access to it if you want them to 
be able to use the app. To get started with managing apps, see the section Managing Apps.   

Access to Apps 

Make your apps available to certain auxiliary users by adjusting their permissions. Once you 
allow a user to access an app, a link to the app appears on their Home page. Note that you 
can control app access only for user groups, so you should either modify the permissions of 
an existing group or create a new one, and then assign users to it. For details on access to 
apps, refer to the section Granting Auxiliary Users Access to Apps (on page 281). 

By default, the app administrator in Panel is a user with the Owner role. As well as accessing 
apps from the Home page, this user can also install and manage apps within a subscription. 
These administrative tools are found in the Applications tab which is available only to app 
administrators. You can grant access to these tools to other subscription users. For details 
on this operation, refer to the section Granting Auxiliary Users Access to Apps (on page 281). 
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Apps and Auxiliary User Accounts 

Some apps let you create and manage user accounts directly in Panel. For example, the 
SugarCRM app allows you to add SugarCRM users without logging in to the app. All apps 
with such "account services" can associate their accounts with users of a Panel subscription 
(auxiliary users). To perform such an association, you should grant the auxiliary users 
access to that account service (in the same way as you grant access to apps). For details on 
account association, refer to the section Linking Apps and Auxiliary  (on page 281)User Accounts. 

You can install, configure, update, and remove apps right from the Control Panel. 

In this section: 

Configuring Apps ............................................................................................... 280 
Granting Auxiliary Users Access to Apps .......................................................... 281 
Linking Apps and Auxiliary User Accounts......................................................... 281 
Updating Installed Apps ..................................................................................... 282 
Managing Commercial Apps Licenses ............................................................... 282 
 
 

Configuring Apps 

Generally, all apps allow the configuration of their main parameters directly in the Control 
Panel. You can access app settings by selecting the app from the list in Applications > Manage 
Installed Applications. After you select an app, you can configure the following: 

 General settings. 
These are basic app settings (say, administrator password) that can be changed with 
Change Settings. 

 Service settings. 
If an app provides a part of its functionality to Panel by means of services, you have the 
option to configure them. For example, the SugarCRM app allows the creation of user 
accounts and provides this ability as a service in the Control Panel. After you select this 
service in Provided services, you can view all app user accounts and create new ones. 
For some apps, you can associate the app accounts with auxiliary user accounts. Learn 
more about account association in the section Linking App and Auxiliary  (on page 281)User 
Accounts. 
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Granting Auxiliary Users Access to Apps 

By default, after you install an app, only users with the Owner role can access it. To allow 
other subscription users to access the app: 

 Grant permission to access the app to a certain user group in Users > User Roles. 

 Be sure to add users of your choice to the group. 

Once you allow users to access the app, a link to the app appears on their Home page. 

By default, the app administrator is a subscription user with the Owner role. As well as 
accessing the apps from the Home page, this user can also install and manage apps within a 
subscription. For these purposes, their interface has the additional Applications tab. You can 
provide the same administrative privileges to other subscription users by granting the Install 
and manage applications permission to their role in Users > User Roles. This gives users full 
administrative access to all apps within a subscription. As well as the administrator, the users 
with this permission can install, configure, update, and remove apps through the Applications 
tab in their Control Panel. 
 

Linking Apps and Auxiliary User Accounts 

Some apps let you create and manage user accounts without logging in to the app. If an app 
provides such an account service, you can link users of a Panel subscription with accounts in 
the app. To perform such an association: 

1. Organize the users into a certain group (Users > User Roles). 

2. Grant one of these group permissions: 

 Public access. 
If granted, all users in the group will have access to the app through the link on the 
Home page. 

 Personal access. 
If granted, the app will automatically create accounts for all users in the group. After 
that, the users' Home page will contain an additional link that allows logging in to a 
personal account in the app. Note that if you deny the Personal access permission, the 
app will automatically remove all accounts associated with this group. 

 
 



 

282 Managing Web Hosting 

 

Updating Installed Apps 

Basically, your service provider is in charge of app updates. If the update is available, your 
provider can get it for you, or you can do it, yourself. The last case is relevant if you want to 
review the changes available in the new version and decide whether to update the app or 
continue with the current version. The update link appears in Applications > Manage Installed 
Applications. 

Managing Commercial Apps Licenses 

If you decide to buy an application license in the Control Panel and click the corresponding 
button on the Applications tab, you will be forwarded to Storefront, the online store where you 
complete your order. Actually it is not only a store, it also includes its own web interface to 
help you perform various operations with the licenses you own. For example, from this web 
interface you can renew a license, cancel it, change your payment methods and so on. This 
section explains how to carry out these operations. 

Storefront Basics 

When you order a first license in Storefront, it creates an account for you. This account 
contains your personal and financial information; if you log in to Storefront under this 
account, you will be able to do various operations with your licenses.  

Each time you successfully check out in Storefront, a purchase order is generated. It is a 
document that lists the cart items you ordered. Storefront assigns different statuses to 
orders. These statuses explain the current state of your purchase - whether it is unpaid, 
canceled, or successfully delivered.  

Storefront and Panel share the service plans business model. In Storefront, each application 
is presented by a separate service plan, and when you order an application license you 
subscribe to one of the service plans. In other words, each license you purchase is shown as 
a subscription in the web interface. For instance, if you would like to view a license price, 
terms, or an expiration date, you should open the corresponding subscription. 

How to Get a License File or Key 

After you order a license and pay for it, Storefront sends you an e-mail with your license file 
or key. We recommend that you keep the information in a safe place because there is no 
way to request it again or view it from the web interface. If you did not receive the e-mail with 
a license file or key, contact us at https://support.parallels.com/.  

Available Operations 

The operations you can carry out in Storefront fall into three groups: 

 Operations with your user account. These operations include viewing and modifying your 
personal information and preferences and changing the password to your user account. 

 Operations with payments and payment methods. This group comprises operations with 
your credit cards, payments, and orders. 

 Operations with subscriptions. Use them to acquire new licenses, obtain information 
about your existing licenses, and check the subscription renewal method for a particular 
subscription. 

https://support.parallels.com/
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Learn more about these operations in the subsections of this section. 

In this section: 

User Account ..................................................................................................... 284 
Payments and Payment Methods ...................................................................... 285 
Subscriptions ..................................................................................................... 286 
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User Account 

You can do the following operations with your user account. 

View and Change Your Account Information 

The system uses your account information to add your personal and financial details into 
invoices. If you see that you need to update your details, open the My Contact Info submenu 
on the Navigation menu and select Account Info.  
 

View and Change Your Personal Information 

Your personal information mostly duplicates the account information. It does not appear in 
financial documents, but some services use this information as technical contact details. For 
example, it is possible to order a domain name through Storefront, and if you do so, 
Storefront will send your personal information (as the technical contact) to a domain name 
registrar. 
To view user personal information, open the My Contact Info > Personal Info menu on the left 
panel. Here you can also edit your personal information and change password to your 
Storefront account. 
 

Configure e-mail notifications 

E-mail notifications are sent on different events to your account contact e-mail address. They 
fall into a number of categories. For example, subscription renewal and expiration, your 
credit card(s) expiration, etc. You can select messages format for every group of messages 
and decide whether to send certain messages or not. To configure messages types to 
receive, open My Contact Info > Notification Methods.  
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Payments and Payment Methods 

This section describes operations with payments and credit cards available to you in 
Storefront. 

Registering a Credit Card 

Before a credit card becomes available for making online payments, it is necessary to 
register it in Storefront. To register a credit card, open Billing Manager > My Financial Info > 
Payment Methods and click the appropriate button.  

Configuring Automatic Payments 

You can assign one of the registered credit cards to be used for paying orders automatically. 
In this case, you will not need to pay each order manually. If you assign a payment method 
to be used for automatic payments, the previous default one is unselected automatically. 
Thus, only one payment method can be used for automated payments. 

To turn on automatic payments from a card, go to Billing Manager > My Financial Info > Payment 
Methods, select the card  by clicking on its ID or Type, and, finally, enable automatic payments 
on the card properties screen. 

Making a Payment 

To add new payment, open the Billing Manager > New Payment link on the dashboard. The 
adding new payment wizard starts. The list of pending documents appears on the screen. If 
there are no pending documents, click Cancel to finish the wizard. Otherwise, walk through 
the wizard by providing the payment settings. 

Viewing Open Orders 

Your open orders are available in the Billing Manager > My Financial Info > Open Orders 
submenu. 
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Subscriptions 

Storefront offers you a powerful and comprehensive mechanism of subscriptions (licenses) 
management, allowing you to perform the following operations. 

Buying a Subscription 

If you want to purchase one more app license or another service offered by Storefront, there 
is no need for you to go to the Control Panel. The Storefront web interface provides all 
facilities for making the purchase. To start the subscription ordering wizard, open Billing 
Manager > Subscription Management and click Buy New Subscription.  

Renewing a Subscription Manually 

If you did not configure the auto renewal feature, your subscription will expire unless you do 
not renew it manually. The auto renewal setup instructions are given later in this section. To 
renew a subscription manually, open Billing Manager > Subscription Management > Renew 
Subscription and follow the wizard steps. 

Renewing Subscriptions Automatically 

Configuring a subscription for auto renewal helps renewing your subscriptions in time. To 
allow the auto renewal, open Billing Manager > Subscription Management > Renew Subscription, 
click a subscription for which you want to turn the option on, and click Turn On AutoRenew 
Option. Clear the option to cancel the auto renewal. 

Canceling a Subscription 

A subscription cancelation results in termination of the subscription services and money 
refund. To cancel a subscription, open Billing Manager > Subscription Management > Renew 
Subscription, click a subscription you want to cancel, and start the cancelation wizard by 
clicking Cancel Subscription. 

(Advanced) Securing Your Websites 

In this section: 

Securing Connections with SSL Certificates ...................................................... 287 
Protecting Sites from Hotlinking (Windows) ....................................................... 291 
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Securing Connections with SSL Certificates 

If your website transfers private data, for example, visitors' credit card numbers, we 
recommend that you use the SSL secure channel for this website. To set up such a channel, 
you should purchase an SSL certificate for your website. 

SSL certificates are used not only for establishing secure communication channels on the 
Internet but also for verifying a website's identity as well. When users visit your secure online 
store, they are notified that your website is really what it claims to be and that all sensitive 
data, such as credit card numbers, will be transferred over a secure channel.  

SSL certificates are issued by specific organizations - SSL certificate providers. However, 
some hosting providers allow customers to purchase SSL certificates directly from Panel.  

Purchasing SSL Certificates 

Depending on your hosting provider, you can have the following ways of purchasing SSL 
certificates: 

 Order an SSL certificate from Panel. This way is available to you if your provider 
configures the corresponding Panel settings. The links for purchasing SSL certificates 
from Panel may let your purchase certificates either from your provider in their online 
store or from Parallels in the MyPlesk outlet. To learn how to order an SSL certificate 
through Panel, see the section Purchasing SSL Certificates through Panel. 

 Order an SSL certificate from the SSL certificate provider you like. In this case, you 
should create a certificate signing request (CSR) for your website in Panel and submit it 
to an SSL certificate provider. To learn how to create such request and purchase a 
certificate with it, refer to the section Generating Certificate Signing Requests. 

 

Securing Websites 

After you obtain a certificate for your website, you should secure the connection to the 
website with the certificate. The section Securing Websites explains how to do this. 

 

Securing Websites with Shared SSL Certificates 

On Windows systems, you may be able to secure your websites without purchasing your 
own SSL certificates. This feature is available to you if your hosting provider offers shared 
SSL certificates. The section Using Shared SSL Certificates (Windows) (on page 290) explains 
how to secure a website with a shared SSL certificate. 

In this section: 

Ordering SSL Certificates .................................................................................. 288 
Using Shared SSL Certificates (Windows)......................................................... 290 
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Ordering SSL Certificates 

If your Control Panel is integrated with Business Manager and your provider sells SSL 
certificates, you are able to purchase an SSL certificate from the provider directly from the 
Control Panel. 

 To purchase an SSL certificate and install in on a site: 

1. Go to the Account tab. 

2. In the list of subscriptions, click the Add Subscription link. 

3. Select the option or plan related to SSL certificates and click Buy Now. Follow 
the instructions on the screen to complete the order. 

4. Go to the Websites & Domains tab > Secure Your Sites, select the domain name 
you need, and click Add SSL Certificate. 

5. Specify the certificate properties: 

 Certificate name. This will help you identify this certificate in the repository. 

 Encryption level. Choose the encryption level of your SSL certificate. We recommend 
that you choose a value more than 1024 bit. 

 Your location and organization name. The values you enter should not exceed the 
length of 64 symbols. 

 The domain name for which you want to purchase an SSL certificate. This should be a 
fully qualified domain name. Example: your-domain.com. 

 The website administrator's e-mail address. 

6. Make sure that all the provided information is correct and accurate, as it will 
be used to generate your private key. 

7. Click Request. Your private key and certificate signing request will be 
generated and stored in the repository. 

8. In the list of certificates, click the name of the certificate you need. A page 
showing the certificate properties opens. 

9. Locate the CSR section on the page, and copy the text that starts with the line 
-----BEGIN CERTIFICATE REQUEST----- and ends with the line -----END CERTIFICATE 
REQUEST----- to the clipboard. 

10. Return to the Account tab. 

11. In the list of subscriptions, locate the link Request SSL Certificate and click it. 

12. In the Certificate signing request field, paste the text from the clipboard that you 
previously copied at the step 9. 

13. Click Next. 

14. Verify that the information in your request is correct and click Next. 
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15.  Select the administrative contact e-mail and click Next. 

16. Specify technical and billing contact information and click Next. 

17. Review the information presented on the screen and click Submit Certificate 
Request. 

18. After you receive your certificate by e-mail, return to the Websites & Domains 
tab > Secure Your Sites, and select the domain name for which you ordered the 
certificate. 

19. Upload the SSL certificate to the Panel: Click Browse in the middle of the 
screen and navigate to the location of the saved certificate. Select it, and 
then click Send File. 

This will upload and install the certificate against the corresponding private key. 

20. To install the certificate on a site, return to the Websites & Domains tab, and 
click the domain name of the website that you want to to secure. 

21. To switch on SSL protection, select the Enable SSL support checkbox. 

22. From the SSL certificate menu, select your SSL certificate and click OK. 
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Using Shared SSL Certificates (Windows) 

If your hosting service provider offers shared SSL for securing access to sites, then you can 
switch on SSL encryption without purchasing your own SSL certificate. 

 To secure connections to a site by using an SSL certificate shared by your 
provider: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Shared SSL (in the Advanced Operations group). 

3. Select the domain name of the site that you want to secure. 

4. Select the Switch on shared SSL checkbox. 

5. Specify the virtual directory name in the corresponding input field. The virtual 
directory with the supplied name will be created under the domain whose 
SSL certificate is shared (called master SSL domain). This directory will be 
used for accessing your site through SSL. 

For example, let us suppose that you have a domain named mydomain.com, the master 
SSL domain is defined as master_ssl_domain.com, and the virtual directory name you 

supplied is my_virtual_dir. In this case, to access your site through SSL, you need to 

use the following address: https://master_ssl_domain.com/my_virtual_dir.  

Note: You cannot use your domain name (for example, mydomain.com) to access your 
site via SSL if you are using shared SSL. 

6. Select the directory where protected content is located under your website. 
The documents within the specified directory will be accessible only through 
SSL. 

7. To make your domain accessible via SSL only, select the checkbox Make this 
website accessible only through secure connections. 

8. Click OK. 
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Protecting Sites from Hotlinking (Windows) 

Hotlinking (also called file leeching, remote linking, direct linking, bandwidth stealing or 
bandwidth banditism) is a term used for describing a situation when a web page of one 
domain owner is directly linking to images (or other multimedia files) on the web pages of 
another domain owner, usually using an <IMG> tag. If your domains are hotlinked, you may 
face the problem of excessive bandwidth usage.  

 To protect a website from hotlinking:  

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Hotlink Protection (in the Advanced Operations 
group). 

3. Click Switch On to enable the protection from hotlinking.  

4. Specify the extensions of files that you want to protect from hotlinking (for 
example, jpg, bmp, and so on) in the Protected files extensions field. When 
listing several file extensions, separate them with white spaces. 

5. If you want to allow direct linking to your files from certain sites, type the 
website addresses into the Addresses of friendly websites field, and click Add. 

6. Click OK. 

 
 

(Advanced) Extended Website Management 

Panel provides a number of operations on websites and domains for advanced users: 
Working with third-party applications and services, fine tuning of some system services, and 
much more. This section contains the detailed instructions on all these operations. 

In this section: 

Working with a Staging Site ............................................................................... 292 
Setting Up Mobile Sites ..................................................................................... 294 
Setting Up Custom Error Pages ........................................................................ 295 
Adding a Domain Forwarder .............................................................................. 297 
Using Google Services ...................................................................................... 300 
Hosting Personal Web Pages Under Your Domains .......................................... 302 
Limiting Bandwidth and Number of Connections to Websites ............................ 304 
Working with Microsoft Frontpage Websites (Windows) .................................... 305 
Using Virtual Directories (Windows) .................................................................. 310 
Setting Up IIS Application Pool (Windows) ........................................................ 322 
Web Publishing with Web Deploy (Windows) .................................................... 324 
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Working with a Staging Site 

If you have a production website and are planning major site changes, consider setting up a 
staging site — a separate location on the server where you can conveniently update and test 
a copy of the site before putting it into production. 

We recommend that you work with a staging site in the following way: 

1. Decide where you want to host the development copy and prepare the development 
environment. You can choose to host it in the same webspace, in a separate webspace 
on the same server, or upload it to an FTP account on another server. 

If you choose the same webspace, then you first need to set up a new website by adding 
a domain or a subdomain. 

2. (Optional step.) If you set up your development environment under your account in the 
Panel and your production site has APS applications installed via the Panel (at the 
Applications tab), install the desired site applications in your development environment in 
the same subdirectory as you have on your production site. This step is optional; 
however, it will help you avoid changing manually database connection settings in the 
application scripts.  

3. Make a copy of the website and place it in the staging environment. 

4. Make copies of the databases used by the site and deploy them in the staging 
environment. 

5. Change database connection settings in the scripts to point at the databases in the 
staging environment. 

6. (Optional step.) Complete APS applications setup. Go to the Applications tab for your 
development site, locate the application in the list of installed applications, open its 
Settings screen and re-save the parameters. With this operation, the APS scripts should 
stop pointing at the production database and reconnect the application to the database 
copy. This step is needed if your production site has APS apps installed via the Panel 
and you performed Step 2 of the current instruction.  

7. Make the required changes to the site copy in the staging environment, and test them to 
make sure everything works as intended. 

8. Publish the updated site. This is done by pointing the document root of the production 
site to the staging site location. 

 To set up a site for staging purposes: 

1. Go to the Websites & Domains tab. 

2. Click either Add New Domain or Add New Subdomain. 

We recommend that you use a subdomain for staging purposes. 

3. Proceed as described in Adding Domains (on page 243) or Adding Subdomains 
(on page 245). 

If you do not want your staging site to be accessible to the Internet users, do not register the 
newly added domain or subdomain name with a domain name registrar, or use an 

.htaccess file (on Linux hosting) to restrict access to it. 



 

 Managing Web Hosting 293 

 

 To make a copy of website files: 

1. Go to the Websites & Domains tab. 

2. Click Website Copying (in the Advanced Operations group). 

3. If you have several websites, select the one you need and click Manage. 

4. To copy website files to the document root of an existing site: 

a. Select the option Website in the Panel. 

b. Select the destination site from the Site name menu. 

c. Specify what to do with the files that might already be present in the 
destination directory. 

5. To copy website files to an FTP account on this or another server:  

a. Select the option FTP storage. 

b. Specify the server's host name and credentials for connecting to the 
FTP account. 

c. In the FTP connection method field, leave the Active mode option selected. 
If the Panel fails to connect to the external FTP account, select the 
Passive mode option here. 

6. Click OK. 

If the site uses scripts that work with a database, copy the database to the staging 
environment: 

 If the database is hosted on the same server managed by Panel 10, use the procedure 
below to copy it. 

 If the database is hosted on a server which is not managed by Panel 10, use the 

mysqldump utility to export the database, move the resulting data dump file to the 

staging environment and deploy it there. Modify the site's scripts in the staging 
environment so that they connect to the copied database. 

 To make a copy of a database from the Panel-managed server: 

1. Go to the Websites & Domains tab > Databases > database name. 

2. Click Make a Copy. 

3. Specify the following: 

 Destination database server. You can select the same Panel-managed database server, 
or a database server located elsewhere. For an external database server, specify the 
host name or IP address, and access credentials: the username and password of a 
database management system user authorized to create new databases and 
database tables. 

 Destination database. You can choose to create a new database or copy the data to an 
existing database. 

 Create a full copy. Leave this option selected to copy the database structure and all 
data. 
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4. Click OK. 

The copy of the database will be deployed on the destination server. 

5. Modify the site's scripts in the staging environment so that they connect to 
the copied database. 

When the site copy in the staging environment is updated and ready to go live, publish it as 
described in the following steps. 

 To publish the updated site to the production environment: 

1. Go to the Websites & Domains tab. 

2. In the list of domain names, locate the address of your production site and 
click it. 

3. In the Document root box, specify the document root directory of the staging 
site. 

4. Click OK. 

This will make the updated site copy in the staging site location accessible to visitors of your 
production site address. 

Setting Up Mobile Sites 

Your service plan may include the option to create website copies optimized for viewing on 
mobile devices. The copies are hosted with external UNITY Mobile online service. 

Important: In Panel 10.4, if a customer ordered the Unity Express offering from the 
Applications tab, the system could confuse the offering with Unity One. If you faced this 
problem, we recommend that you remove the site created with Unity One and create the 
new one in order to get Unity Express. 

 To create a copy of your website optimized for viewing on mobile devices, or 
set up a new mobile website: 

1. Go to Websites & Domains tab > Mobile Websites. 

2. Click the corresponding Create Mobile Site link. 

3. Specify an address for the mobile site. 

If your site is accessible, for example, by domain name example.com, you can type a 

prefix like mobile, and then the optimized copy of your website will be accessible by the 

address mobile.example.com.  

4. Click OK. 

5. Click Edit Site Content. A UNITY Mobile site opens in a new browser window or 
tab, and you are logged on under your account. 
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6. In the Import from the web section showing your main website’s domain name, 

click the button . 

7. Complete the website import wizard by following instructions presented on 
the screen.  

After the mobile site is created, you can add a link to it to your main site. 

You can now perform the following operations on the mobile site using links in Control Panel: 

 Open site editor. 

 Remove mobile site. 

 
 

Setting Up Custom Error Pages 

When visitors coming to a site request pages that the web server cannot find, the web server 
generates and displays a standard HTML page with an error message. You may want to 
create your own error pages and use them for your sites or individual virtual directories. The 
following error messages are the ones customized most often: 

 400 Bad File Request. Usually means the syntax used in the URL is incorrect (for 
example, uppercase letter should be lowercase letter; wrong punctuation marks). 

 401 Unauthorized. Server is looking for some encryption key from the client and is not 
getting it. Also, wrong password may have been entered. 

 403 Forbidden/Access denied. Similar to 401; a special permission is needed to access 
the site – a password or username, if it is a registration issue. 

 404 Not Found. Server cannot find the requested file. File has either been moved or 
deleted, or the wrong URL or document name was entered. This is the most common 
error. 

 500 Internal Server Error. Could not retrieve the HTML document because of server 
configuration problems. 

 503 Service Temporarily Unavailable. The site is temporarily unavailable due to 
maintenance. 

 

In this section: 

Setting Up Custom Error Pages on Windows Servers ....................................... 296 
Setting Up Custom Error Pages on Linux Servers ............................................. 297 
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Setting Up Custom Error Pages on Windows Servers 

 To configure the web server to show custom error pages for a site or a 
directory within a site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Switch on support for custom error documents.  

a. Go to the Websites & Domains tab and in the list of domains, click the 
domain name you need.  

b. Select the Custom error documents checkbox. 

c. Click OK. 

3. Go to the Websites & Domains tab > Virtual Directories to see the list of error 
documents for the root web directory. Error documents located here are 
used for all web pages of the selected site. If you want to customize error 
pages for a specific virtual directory, navigate to that directory.  

4. Click Error Documents tab and click the required error document in the list. 

 To use the default document provided by IIS for this error page, select Default in the 
Type menu. 

 To use a custom HTML document already located in the error_docs directory in the 

virtual host directory of the domain, select File in the Type menu and specify the file 
name in the Location field.  

 To use a custom HTML document located in a directory other than error_docs on 

a domain, select URL in the Type menu and enter the path to your document in the 
Location field. The path should be relative to the virtual host root (that is, 

<vhosts>\<domain>\httpdocs). 

For example, you have created a file forbidden_403_1.html and saved it in the 

my_errors directory located in the httpdocs. To use this file as an error document, 

you need to type the following path into the Location field: 

/my_errors/forbidden_403_1.html. 

Note: You can use a connection over FTP or File Manager in the Panel to upload your 
custom error document to the server. By default, all error documents are stored in the 

/vhosts/your-domain.com/error_docs/ directory (located in C:\InetPub by 

default). 

5. Once the web server is restarted, it will start using your error documents.  
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Setting Up Custom Error Pages on Linux Servers 

 To configure the web server to show custom error pages for a site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Switch on support for custom error documents.  

a. Go to the Websites & Domains tab and in the list of domains, click the 
domain name you need.  

b. Select the Custom error documents checkbox. 

c. Click OK. 

3. Connect to your FTP account, and go to the error_docs directory. 

4. Edit or replace the respective files. Be sure to preserve the correct file 
names: 

 400 Bad File Request - bad_request.html 

 401 Unauthorized - unauthorized.html 

 403 Forbidden/Access denied - forbidden.html 

 404 Not Found - not_found.html 

 405 Method Not Allowed - method_not_allowed.html 

 406 Not Acceptable - not_acceptable.html 

 407 Proxy Authentication Required - proxy_authentication_required.html 

 412 Precondition Failed - precondition_failed.html 

 414 Request-URI Too Long - request-uri_too_long.html 

 415 Unsupported Media Type - unsupported_media_type.html 

 500 Internal Server Error - internal_server_error.html 

 501 Not Implemented - not_implemented.html 

 502 Bad Gateway - bad_gateway.html 

 503 Service Temporarily Unavailable - maintenance.html 

The web server will start using your error documents in a few hours, after it is restarted. 
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Adding a Domain Forwarder 

You can set up a new domain name or reconfigure an existing domain name so that it will 
redirect visitors to another website.   

 To add a new domain forwarder: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click Add New Domain. 

4. Specify the following: 

a. In the Domain name box, type the domain name that you have 
registered with your service provider or a domain name registration 
company. 

b. Under DNS server configuration, select the option Keep master DNS zone on 
this server. 

c. Under Hosting type, select the Forwarding option. 

d. In the Destination address box, type the Internet address to which you 
want to redirect visitors. 

e. Under Forwarding type, select the preferred type of forwarding. With 
standard forwarding, a user is redirected to the site and the actual site's 
address is shown in the user's browser, so the user always knows 
that he or she is redirected to another address. With frame forwarding, 
a user is redirected to the site without knowing that the site actually 
resides at another location, therefore, frame forwarding should be 
preferred. 

5. Click OK. 

 To reconfigure an existing domain and make it a domain forwarder: 

1. Go to Websites & Domains tab > domain name. 

2. Click the Change link next to the Hosting type field. 

3. Specify the following: 

a. Under Hosting type, select the Forwarding option. 

b. In the Destination address box, type the Internet address to which you 
want to redirect visitors. 
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c. Under Forwarding type, select the preferred type of forwarding. With 
standard forwarding, a user is redirected to the site and the actual site's 
address is shown in the user's browser, so the user always knows 
that he or she is redirected to another address. With frame forwarding, 
a user is redirected to the site without knowing that the site actually 
resides at another location, therefore, frame forwarding should be 
preferred. 

4. Click OK. 
 



 

300 Managing Web Hosting 

 

Using Google Services 

Using links in the Panel, you can generate code for inserting a custom Google search engine 
into your site, submit your website to Google through Webmaster Tools area, enroll in the 
AdSense program, embed YouTube videos, Google Translate service, or other Google 
products into your site. 

Google Custom Search is a search engine provided by Google. It adds search functions to 
your site and allows you to apply your website's look and feel to the search results page. It 
can be used for free on websites of individuals and non-profit organizations. Websites related 
to for-profit businesses can either use a Custom Search Engine that will show 
advertisements from Google, or purchase a subscription to Google Site Search service, 
which starts from $100 per year. To learn more about Google Site Search and current prices, 
visit http://www.google.com/sitesearch.   

Google Webmaster Tools allow webmasters to submit a website to Google and view search 
statistics. To learn more about Webmaster Tools, visit 
http://www.google.com/support/webmasters/?hl=en.  

Google AdSense allows webmasters to earn money for displaying targeted Google ads on 
their websites. To learn more about AdSense, visit 
https://www.google.com/adsense/login/en/. 

Google Web Elements allows webmasters to easily add their favorite Google products to 
websites. Embed content, such as news, maps, YouTube videos, and social conversations 
from Google Friend Connect to Web pages with simple cut-n-paste. To learn more about 
Google Web Elements, visit http://www.google.com/webelements/. 

Before you start using Google services, you need to confirm acceptance of Google Terms of 
Services, and then confirm ownership for your sites. 

 To confirm acceptance of Google terms of service and then confirm ownership 
of your sites: 

1. Go to either the Home tab or the Websites & Domains tab, and click the Google 
Services for Websites link. 

2. Click the appropriate links in the Panel to open and read the Terms of 
Service documents. 

3. To confirm that you accept the Terms of Service, select the checkbox and 
click Confirm. 

Now you can do the following: 

 Submit your site to Google and improve site visibility in search results by clicking Google 
Webmaster Tools. 

 Add search functions to a site by clicking Add New Custom Search Engine. 

 Enroll in the AdSense program by clicking Google AdSense. 

 Embed Google products into your site by clicking Google Web Elements. 

http://www.google.com/sitesearch
http://www.google.com/support/webmasters/?hl=en
https://www.google.com/adsense/login/en/
http://www.google.com/webelements/
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 To submit a site to Google: 

1. Go to either the Home tab or the Websites & Domains tab, and click the Google 
Services for Websites link. 

2. Click Google Webmaster Tools. 

The Google Webmaster Tools area opens in a new browser window or tab. 

3. Create a Sitemap and submit it to Google by following instructions at 
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=1
56184.  

 To add a custom search engine to a site: 

1. Go to either the Home tab or the Websites & Domains tab, and click the Google 
Services for Websites link. 

2. Click Custom Site Search. 

3. Click Add New Custom Search Engine. 

4. Type a search engine name and select the website you need. 

5. Select the checkbox to confirm your acceptance of Terms of Service, and 
click OK. 

The record corresponding to the new search engine is added to the Panel. 

6. Click the corresponding Get Code link, copy the generated code to the 
clipboard and paste it into the source code of your website pages.  

The other links in the list of Custom Search Engines will help you perform the following 
operations: 

 Make Money. Connect your Custom Search Engine to a Google AdSense account. You 
make money when users click on an ad they see in your search results. If you have more 
than one Custom Search engine, all of your search engines will automatically be 
associated with the same AdSense account. 

 Manage. Manage your Custom Search Engines. 

 Look and Feel. Adjust the appearance of search box and search results page. 

 Upgrade. Upgrade a Custom Search Engine to ads-free Google Site Search. 

 Statistics. Review site search reports. 

 Delete. Delete a Custom Search Engine. 

 To participate in the Google AdSense program: 

1. Go to either the Home tab or the Websites & Domains tab, and click the Google 
Services for Websites link. 

2. Click Google AdSense. 

3. Click Google AdSense account. 

http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=156184
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=156184
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4. Fill in all the required fields to create a new AdSense account, or select an 
existing account, and click OK. 

A confirmation e-mail with further instructions will be sent to your e-mail address. 

Hosting Personal Web Pages Under Your Domains 

You can host on your web server personal web pages for users who do not need their own 
domain names. These pages usually have web addresses like http://your-
domain.com/~username. 

 To accommodate a personal web page under your domain and set up an FTP 
account for publishing: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Web Users (in the Advanced Operations group). 

3. Click Settings. 

4. If you want to allow execution of scripts embedded in personal web pages, 
select the Allow web users to use scripts checkbox. 

5. Click OK. 

The settings you have defined at the step 4 are common for all personal web pages you 
might host on your account. Therefore, you will not need to perform the steps from 3 to 5 
next time you set up a new web user account. 

6. Click Add New Web User. 

7. Specify a username and a password that will be used for accessing the 
webspace through FTP and publishing the web pages.  

You can use only lower-case alphanumeric, hyphen and underscore symbols in the 
username. The username should begin with an alphabet character. It cannot contain 
white spaces. The password cannot contain quotation marks, white space, username, 
and should be between 5 and 14 characters in length.   

8. If you want to limit the amount of disk space that can be occupied by the web 
page content, type the desired value in megabytes into the Hard disk quota 
box. 

When the specified limit is exceeded, the web page owner will not be able to add files to 
his or her webspace. 

9. Specify the programming languages that should be supported for the web 
page.  

For example, if the web page is written in PHP, select the PHP support checkbox. 

10. If you use a Windows-based hosting account and this personal web page's 
applications need to use a file-based database (like Jet) located in the root 

of httpdocs directory, select the Additional write/modify permissions option. Note 

that selecting this option might seriously compromise the website security.  
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11. Click OK. 

Now you can tell your user the FTP account credentials, so that he or she can publish their 
web page. 

 To change FTP password for a web page owner: 

1. Go to the Websites & Domains tab > Web Users. 

2. Click the user name you need. 

3. Type the new password into the New password and Confirm password boxes. 

4. Click OK. 

 To allocate more disk space to the web page owner: 

1. Go to the Websites & Domains tab > Web Users. 

2. Click the user name you need. 

3. Type the amount of disk space in megabytes into the Hard disk quota box. 

4. Click OK. 

 To remove a web page owner’s account together with their web page: 

1. Go to the Websites & Domains tab > Web Users. 

2. Select a checkbox corresponding to the user account you want to remove 
and click Remove. 

3. Confirm removal and click OK. 
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Limiting Bandwidth and Number of Connections to Websites 

To avoid excessive usage of bandwidth, and protect your site from Denial Of Service attacks, 
you can limit bandwidth usage for a site and number of simultaneous connections. 

 To limit bandwidth usage and number of connections to a site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Bandwidth Limiting (in the Advanced Operations 
group). 

3. Select the Switch on bandwidth limiting checkbox. 

4. In the Maximum bandwidth usage (KB/S) box, specify the maximum speed, 
measured in kilobytes per second, that a website can share among all its 
connections. 

5. Select the Switch on connections limiting checkbox. 

6. In the Connections limited to box, specify the maximum number of simultaneous 
connections to the site. 

7. Click OK. 
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Working with Microsoft Frontpage Websites (Windows) 

Microsoft FrontPage deals with two kinds of websites: disk-based and server-based. In short, 
a disk-based site is a FrontPage website you create on your local hard disk and then later 
publish to the server. A server-based site is one you create and work with directly on the 
server, without the extra step of publishing. This section provides you with instructions on 
publishing only disk-based websites. 

You can publish disk-based websites either through FTP or HTTP. If your hosting server is 
running FrontPage Server Extensions, you would publish your site over HTTP. For example: 
http://your-domain.com/MyWebSite. If your hosting server supports FTP, you would publish 
to an FTP location. For example: ftp://ftp.your-domain.com/myFolder. 

After publishing, you can manage your site through FrontPage Server Extensions.  

 To access FrontPage Server Extensions management interface: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. In the Advanced Operations group, click FrontPage.  

4. Do either of the following: 

 To manage a site over HTTP connection, click Frontpage Webadmin. 

 To manage a site over a secure SSL connection, if SSL support is enabled for the 
site, click Frontpage SSL Webadmin. 

5. Type your FrontPage administrator’s username and password, and click OK. 

For instructions on using FrontPage server extensions, see online help (Frontpage Webadmin > 
Help) or visit Microsoft website. 

The following FrontPage settings are changeable through the Panel: 

 The use of Microsoft FrontPage IIS Index Server for building the full-text index of your 
website. 

 SMTP mail server and sender's e-mail address. These options are applicable if you 
use FrontPage forms that submit information from your site by e-mail. By default, 
SMTP server specified in the domain's DNS zone is used for sending mail. If no 
SMTP server is specified in the zone, then FrontPage uses the mail service running 
on the server where the domain (site) is hosted. 

 To change any of these settings: 

1. Go to the Websites & Domains tab > FrontPage > Settings. 

2. Make the required changes and click OK. 
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In this section: 

Publishing FrontPage Websites ......................................................................... 307 
Adding FrontPage Accounts .............................................................................. 309 
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Publishing FrontPage Websites 

 To publish files through FTP: 

1. Open your FrontPage program. 

2. Open a FrontPage website: open File menu and select the Open Site item. 

3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web Site 
button at the bottom of the window. 

4. Set up your Remote Web Site Properties: 

 Click the Remote Web Site Properties button in the upper-right corner of the window. 

 Select FTP as the remote Web server. 

 In the Remote Web site location box, type your host name (for example, ftp://ftp.your-
domain.com) 

 In the FTP directory box, type your FTP directory if your hosting company provided one. 
Leave it blank if they did not specify one. 

 Select the Use Passive FTP check box if your computer or network is protected by a 
firewall.  

5. Click OK to connect to the remote site.  

The Remote Web site view will show files that you have in your local and remote sites. 

6. Click the Publish Web site button in the lower-right corner of the window.  

 To publish files through HTTP on a server that supports FrontPage Server 
Extensions: 

1. Open your FrontPage program. 

2. Open a FrontPage website: open File menu and select the Open Site item. 

3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web Site 
button at the bottom of the window. 

4. Click the Remote Web Site Properties button in the upper-right corner of the 
window. 

5. On the Remote Web Site tab, under Remote Web server type, click FrontPage or 
SharePoint Services. 

6. In the Remote Web site location box, type the Internet address, including the 
protocol, of the remote website that you want to publish folders and files to, 
for example, http://www.your-domain.com, or click Browse to locate the site. 
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7. Do any of the following:  

 To use Secure Sockets Layer (SSL) for establishing a secure communications 
channel to prevent the interception of critical information, click Encryption connection 
required (SSL). To use SSL connections on your web server, the server must be 
configured with a security certificate from a recognized certificate authority. If the 
server does not support SSL, clear this check box. Otherwise, you will not be able to 
publish folders and files to the remote website. 

 To remove specific types of code from web pages as they are being published, on the 
Optimize HTML tab, select the options you want. 

 To change the default options for publishing, on the Publishing tab, select the options 
you want. 

8. Click OK to connect to the remote site.  

The Remote Web site view will show files that you have in your local and remote sites. 

9. Click the Publish Web site button in the lower-right corner of the window. 
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Adding FrontPage Accounts 

If you are using Microsoft FrontPage for collaborating on website content with other users, 
then you need to create additional Microsoft FrontPage accounts. 

 To create an additional Microsoft FrontPage account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. In the Advanced Operations group, click FrontPage.  

4. Click Add New FrontPage Account. 

5. Specify the following: 

 Username and password for the account. 

 Limit on disk space. If you wish to limit the amount of disk space that can be used by 
this account, clear the Unlimited check box and type the desired value in megabytes 
into the Hard disk quota box. 

When the specified limit is exceeded, the user will not be able to upload more files to 
the webspace. 

6. Click OK. 

 To change settings for an additional Microsoft FrontPage account: 

1. Go to the Websites & Domains tab > FrontPage. 

2. Click the required account name in the list. 

3. Adjust the settings as necessary and click OK to save changes. 

 To remove an additional Microsoft FrontPage account: 

1. Go to the Websites & Domains tab > FrontPage. 

2. Select the checkbox corresponding to the account you want to remove. 

3. Click Remove. 

4. Confirm the removal and click OK. 
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Using Virtual Directories (Windows) 

A virtual directory is a link to an existing physical directory that is present on the server's hard 
disk. Virtual directories can have a number of specific settings like custom ASP.NET 
configuration, access permissions, and protection with a password. 

Because any virtual directory can have its own settings, including customized ASP.NET 
configuration, virtual directories are very useful in setting up your web applications, especially 
those written in ASP.NET. For example, if you have three web applications that use 
ASP.NET version 1.1, and you need to install one web application that uses ASP.NET 
version 2.0, you can create a virtual directory for the ASP.NET 2.0 application, configure 
ASP.NET settings for this directory so as to enable support for version 2.0, and then 
successfully install the required application. 

Virtual directories can also be used as aliases. For example, you have a web application 
installed on your domain "example.com" in the physical directory 

"/my_data/web_apps/forum". To access this web application, users need to type 

"example.com/my_data/web_apps/forum", which is hard to remember and too long to 

type. You can create virtual directory called forum in the root of your virtual host, and link 

this virtual directory to "/my_data/web_apps/forum", so the users who want to access 

the web application will need to type "example.com/forum", which is much shorter and 

easier to remember. 

In this section: 

Creating Virtual Directories ................................................................................ 311 
Configuring ASP.NET for Virtual Directories ...................................................... 313 
Configuring PHP for Virtual Directories .............................................................. 315 
Setting Up Access to Virtual Directories ............................................................ 316 
Changing Virtual Directory Settings ................................................................... 318 
Adding and Removing MIME Types .................................................................. 320 
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Creating Virtual Directories 

 To create a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). You are in your web site root now. 

3. Navigate to the directory in which you want to create a new virtual directory.  

4. Click Create Virtual Directory. 

Note: To create a physical directory instead of virtual directory, click Create Directory, 
specify the name of the directory and click OK. 

5. Specify the required parameters: 

 Name - specify the virtual directory name. 

 Path - specify the virtual directory path: 

 Select the Create physical directory with the same name as virtual directory checkbox to 
automatically create a physical directory with the same name as the virtual 
directory you are creating. 

 Clear the Create physical directory with the same name as virtual directory checkbox and 
specify the path in the field to select a  physical directory that already exists. 

 Script source access - select this checkbox to allow users to access source code if 
either Read or Write permissions are set. Source code includes scripts in ASP 
applications. 

 Read permission - select this checkbox to allow users to read files or directories and 
their associated properties. 

 Write permission - select this checkbox to allow users to upload files and their 
associated properties to the virtual directory or to change content in a write-enabled 
file. Write access is allowed only if browser supports the PUT feature of the HTTP 1.1 
protocol. 

 Directory browsing - select this checkbox to allow users to see a hypertext listing of the 
files and subdirectories in the virtual directory.  

 Log visits - select this checkbox if you want to store the information about visits of the 
virtual directory. 

 Create application - select this checkbox to make the directory an IIS application. The 
directory becomes logically independent from the rest of the website. 

 Execute permissions - select the appropriate program execution level allowed for the 
virtual directory. 

 None - allow access only to static files such as HTML or image files. 

 Scripts only - allow running scripts only, not executables. 
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 Scripts and Executables - remove all restrictions so that all file types can be 
executed. 

 ASP Settings - set specific settings for ASP-based web applications. 

 If you are using ASP-based applications that cannot operate correctly under data 
transfer restrictions currently set by IIS, clear the Defined by parent directory 
checkbox corresponding to the field you want to change and type in the required 
number. 

 If you want to enable debugging of ASP applications on the server side, clear the 
corresponding Defined by parent directory checkbox and select the Enable ASP server-
side script debugging checkbox.  

 If you want to enable debugging of ASP applications on the client side, clear the 
corresponding Defined by parent directory checkbox and select the Enable ASP client-
side script debugging checkbox.  

Note that if you are trying to change ASP Settings for the root virtual directory, the 
default checkbox names will be Defined by IIS instead of Defined by parent directory. 

6. Click OK. 

  

 To remove a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Select the checkbox corresponding to the directory you want to remove. 

4. Click Remove. 

5. Confirm the removal and click OK. 
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Configuring ASP.NET for Virtual Directories 

 To configure ASP.NET settings for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Browse to the required directory and click a link with its name.  

4. Click ASP.NET Settings. 

5. Set up the strings that determine database connection data for ASP.NET 
applications that use databases. This option is available only for ASP.NET 
2.0.x. 

When you open the ASP.NET configuration page for the first time, sample connection 
parameters with common constructions are displayed. You can delete them and 
specify your own strings. 

 To add a string, enter the required data into the Name and Connection Parameters input 

fields and click  next to them. 

 To remove a string, click  next to it. 

6. Set up custom error messages that will be returned by ASP.NET 
applications: 

 To set the custom error messages mode, select an appropriate option from the Custom 
error mode menu: 

 On - custom error messages are enabled. 

 Off - custom error messages are disabled and detailed errors are to be shown. 

 RemoteOnly - custom error messages are displayed only to remote clients, and 
ASP.NET errors are shown to the local host. 

 To add a new custom error message (which will be applied unless the Off mode was 

selected), enter the values in the Status Code and Redirect URL fields, and click . 

 Status Code defines the HTTP status code resulting in redirection to the error page. 

 Redirect URL defines the web address of the error page presenting information 
about the error to the client. 

Due to possible conflicts, you cannot add a new custom error message with an error 
code that already exists, but you can redefine the URL for the existing code. 

 To remove a custom error message from the list, click  next to it. 
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7. Configure compilation settings in the Compilation and Debugging field: 

 To determine the programming language to be used as default in dynamic compilation 
files, choose an entry from the Default web page language menu. 

 To enable compiling of retail binaries, leave the Switch on debugging checkbox empty. 

 To enable compiling of debug binaries, select the Switch on debugging checkbox. In this 
case, the source code fragments containing error will be shown in a diagnostic 
message. 

Note: When running applications in debug mode, a memory and performance overhead 
occurs. We recommended that you use debugging when testing an application, and 
disable it before deploying the application into production scenario. 

8. Configure encoding settings for ASP.NET applications in the Globalization 
Settings section: 

 To set an adopted encoding of all incoming requests, enter an encoding value into the 
Request encoding field (default is utf-8). 

 To set an adopted encoding of all responses, enter an encoding value into the 
Response encoding field (default is utf-8). 

 To set an encoding which must be used by default for parsing of .aspx, .asmx, and 

.asax files, enter an encoding value into the File encoding field (default is Windows-

1252). 

 To set a culture which must be used by default for processing incoming web requests, 
select an appropriate item from the Culture list. 

 To set a culture which must be used by default when processing searches for a 
locale-dependent resource, select an appropriate item from the UI Culture list. 

9. Set a code access security trust level for ASP.NET applications in the Code 
Access Security field. 

CAS trust level is a security zone to which applications execution is assigned, defining 
what server resources the applications will have access to. 

Important: When an assembly is assigned a trust level that is too low, it does not 
function correctly. For more information on the permission levels, see 
http://msdn.microsoft.com/library/en-
us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010. 

10. If you are using ASP.NET 1.1.x, then you can enable the usage of the 
auxiliary scripts in the Script Library Settings field. Specifying the script library 
settings is necessary if the validation web controls are used on your web 
site.  

 If you need to use auxiliary scripts (specifically, scripts implementing objects for 
validating input data), provide the settings for .NET framework script library. To do so, 
enter the path beginning with the domain root directory preceded by the forward slash 
into the Path to Microsoft script library field, or click the folder icon next to the Path to 
Microsoft script library field and browse for the required location. 

 To initiate installation of files containing the scripts to the specified location, select the 
Install checkbox. If the files already exist there, they will be rewritten. 

 

http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
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11. Set client session parameters in the Session Settings field: 

 To set up the default authentication mode for applications, select an appropriate item 
from the Authentication mode list. Windows authentication mode should be selected if 
any form of IIS authentication is used. 

 To set up the allowed session idle time, enter appropriate number minutes into the 
Session timeout field. 

12. Click OK to apply all changes. 
 

Configuring PHP for Virtual Directories 

To be able to use web applications that require PHP4 or PHP5, you can select the required 
PHP version for individual virtual directories. 

 To select PHP version for a virtual directory:  

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Browse to the required directory and click a link with its name.  

4. In the Tools group, click PHP Settings. 

5. Select the required version of PHP and click OK. 
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Setting Up Access to Virtual Directories 

 To set access permissions for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. To set access permissions for the current virtual directory, in the Tools group, 
click Directory Access Permissions. If you want to set permissions for a 
subdirectory located within the current directory, click the corresponding icon 

. 

4. Do the following: 

 To make the file/folder inherit permissions from a parent folder (if it does not), select 
the checkbox Allow inheritable permissions from the parent to propagate to this object and all 
child objects. Include these with entries explicitly defined here. 

 To make the files and folders, which are contained in this folder, inherit the folder 
permissions you define, select the checkbox Replace permission entries on all child objects 
with entries shown here that apply to child objects. 

 To change or remove permissions from a group or a user, click the required name in 
the Group or user names list. If the group or user is not listed in the Group or user names 
list, select the required user or group name from the menu located above the list and 

click : the user/group appears in the list. Select it. 

To allow or deny permissions to a selected group/user, select the Allow or Deny 
checkboxes corresponding to permissions listed under Permissions for <user/group 
name>. If the checkboxes in Allow or Deny columns are shown in grey, it means that the 
corresponding permissions are inherited from a parent folder. 

 To deny the permissions, which are inherited from a parent object as allowed, select 
the required checkboxes under Deny. This will override inherited permissions for this 
file/folder. 

 To allow the permissions, which are inherited from a parent object as denied, clear the 
Allow inheritable permissions from the parent to propagate to this object and all child objects. 
Include these with entries explicitly defined here checkbox: this removes the inherited 
permissions. Then select the required checkboxes under Allow and Deny. 

 To remove access permissions from a group or user, select the required name in the 

Group or user names list and click the icon  next to it. 
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5. If you need advanced fine-tuning of permissions, click the Advanced button, 
and do the following: 

 To create a permission entry for a group or user, select the required name from the 

Group or user names list and click . 

 To set or change file/folder permissions for a group or user, select the required name 
from the Group or user names list, select the required Allow and Deny checkboxes 
corresponding to permissions listed under Permissions for <user/group name>. 

 To remove a permission entry for a group or user, select the required name from the 

Group or user names list and click . 

 To make child objects of a folder inherit its permissions defined under Permissions for 
<user/group name>, select the Replace permission entries on all child objects with entries 
shown here that apply to child objects checkbox, and select checkboxes in the Apply to list 
which correspond to the objects that must inherit the permissions. 

6. Click OK. 

 

 To restrict access to files and directories located within a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Websites & Domains tab > Virtual Directories. 

3. Navigate to the directory you want to protect and click the Protection tab. 

4. Click Protect. 

5. To specify users who will be able to access the directory, click Add User, 
specify username and password, and click OK. 

6. If you want to specify a title for the protected area that will be shown to users 
when they attempt to access the directory, click Settings, specify a title, and 
click OK. 

 To revoke a permission to access a directory from a user: 

1. Go to the Websites & Domains tab > Virtual Directories > the Protection tab. 

2. Select the checkbox corresponding to the user's name and click Remove.  

 To remove protection from a directory and allow the general public to see the 
directory contents without restrictions: 

1. Go to the Websites & Domains tab > Virtual Directories > the Protection tab. 

2. Click Remove Protection. 

3. Click OK to confirm removal. 
 



 

318 Managing Web Hosting 

 

Changing Virtual Directory Settings 

 To change settings of a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Browse to the directory whose preferences you want to change, and click the 

corresponding icon , or click Directory Properties when inside the required 
directory. 

4. Change the settings as required: 

 Name - specify virtual directory name. 

 Path - specify the path to the physical directory to which the virtual directory is linked. 

 Script source access - select this checkbox to allow users to access source code if 
either Read or Write permissions are set. Source code includes scripts in ASP 
applications. 

 Read permission - select this checkbox to allow users to read files or directories and 
their associated properties. 

 Write permission - select this checkbox to allow users to upload files and their 
associated properties to the virtual directory or to change content in a write-enabled 
file. Write access is allowed only if browser supports the PUT feature of the HTTP 1.1 
protocol. 

 Directory browsing - select this checkbox to allow users to see a hypertext listing of the 
files and subdirectories in the virtual directory.  

 Log visits - select this checkbox if you want to store the information about visits to the 
virtual directory. 

 Create application - select this checkbox to make the web directory an IIS application. 
The directory becomes logically independent from the rest of the website. 

 Execute permissions - select the appropriate program execution level allowed for the 
virtual directory. 

 None - allow access only to static files such as HTML or image files. 

 Scripts only - allow running scripts only, not executables. 

 Scripts and Executables - remove all restrictions so that all file types can be 
executed. 

 Allow to use parent paths - select this checkbox to allow using double period in the path 
name when referring to a folder above the current directory. This enables users to 
move up the folder tree without knowing the folder name or the whereabouts in the 
hierarchy. If the option is selected, parent path directories should not have the Execute 
permission checkbox selected in their properties, so that applications do not have the 
ability of unauthorized running of programs in the parent paths. 
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 Allow application execution in MTA (multi-threaded apartment) mode - select this checkbox to 
allow the application execution in multi-threaded apartment (MTA) mode. Otherwise, 
the application will run in a single-threaded apartment (STA) mode. Using STA, each 
application pool is executed in a dedicated process. With MTA, several concurrent 
application pools are executed in one thread which can increase performance in some 
cases. 

 Use default documents - select this checkbox to allow the use of default documents for 
the current directory. The default document is sent when users access the directory 
on the web without a specific file name (for example, using http://www.example.com 
as opposed to http://www.example.com/index.html). If this checkbox is cleared and 
the Directory browsing checkbox is selected, the web server returns a folder listing. If 
this checkbox is cleared and the Directory browsing checkbox is cleared as well, the 
web server returns an "Access Forbidden" error message. 

 Default documents search order - specifies the order in which IIS searches for the default 
document, sending user the first available file it finds. If no match is found, IIS 
behaves as in the cases when the default content page is disabled. 

 Allow anonymous access - select this checkbox if you want to make the directory public 
so that the Internet users could access it without authentication. 

 Require SSL - select this checkbox to enable access to the folder only via SSL-
encrypted connections. 

 ASP Settings - set specific settings for ASP-based web applications. 

 If you are using ASP-based applications that cannot operate correctly under data 
transfer restrictions set by IIS, clear the Defined by parent directory checkbox 
corresponding to the field you want to change and type in the required number. 

 If you want to enable debugging of ASP applications on the server side, clear the 
corresponding Defined by parent directory checkbox and select the Enable ASP server-
side script debugging checkbox.  

 If you want to enable debugging of ASP applications on the client side, clear the 
corresponding Defined by parent directory checkbox and select the Enable ASP client-
side script debugging checkbox.  

Note that if you are trying to change ASP Settings for the root directory, the default 
checkbox names will be Defined by IIS instead of Defined by parent directory. 

5. Click OK to save changes. 
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Adding and Removing MIME Types 

Multipurpose Internet Mail Exchange (MIME) types instruct a web browser or mail application 
how to handle files received from a server. For example, when a web browser requests an 
item on a server, it also requests the MIME type of the object. Some MIME types, like 
graphics, can be displayed inside the browser. Others, such as word processing documents, 
require an external application to be displayed. 

When a web server delivers a web page to a client web browser, it also sends the MIME type 
of the data it is sending. If there is an attached or embedded file in a specific format, IIS also 
tells the client application the MIME type of the embedded or attached file. The client 
application then knows how to process or display the data being received from IIS. 

IIS can only operate files of registered MIME types. These types could be defined both on 
the global IIS level and on the website or virtual directory level. Globally-defined MIME types 
are inherited by all websites and virtual directories while ones defined on the website main or 
virtual directory level are used only for the area where they are defined. Otherwise, if the web 
server receives request for a file with unregistered MIME type, it returns the 404.3 (Not 
Found) error. 

 To add a new MIME type for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Navigate to the required virtual directory and click the corresponding link 
with its name. 

4. Click the MIME Types tab. 

5. Click Add MIME Type. 

6. Specify the following: 

 Type the file name extension in the Extension field. File name extension should begin 
with a dot (.), or a wildcard (*) to serve all files regardless of file name extension. 

 Specify the file content type in the Content field.  

 You can either select the appropriate value from the list or define a new content type. 
To do this, select Custom and enter the content type in the input box provided. 

7. Click OK to finish the creation. 
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 To edit a MIME type for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Navigate to the required virtual directory and click the corresponding link 
with its name. 

4. Select the MIME Types tab. 

5. Select the required MIME type in the list. 

 Type the file name extension in the Extension field. File name extension should begin 
with a dot (.), or a wildcard (*) to serve all files regardless of file name extension. 

 Specify the file content type in the Content field.  

 You can either select the appropriate value from the list or define a new content type. 
To do this, select Custom and enter the content type in the input box provided. 

6. Click OK to save changes. 

 To remove a MIME type for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Navigate to the required virtual directory and click the corresponding link 
with its name. 

4. Select the MIME Types tab. 

5. Select the checkbox corresponding to the MIME type you want to remove.  

6. Click Remove. 

7. Confirm removal and click OK. 

 
 



 

322 Managing Web Hosting 

 

Setting Up IIS Application Pool (Windows) 

IIS Application Pool contains all web applications installed on your sites. If your service 
provider allocated a dedicated IIS application pool for your sites, then you can have a level of 
isolation between web applications used by your sites and web applications used by other 
hosting users who host their websites on the same server. Because each application pool 
runs independently, errors in one application pool will not affect the applications running in 
other application pools. 

Once you switch on the application pool, all web applications on your websites will be using 
it. 

 To switch on dedicated IIS application pool for your websites: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

3. Click Switch On. 

4. To limit the amount of CPU resources that this application pool can use, 
select the Switch on CPU monitoring checkbox and type a number in percents 
into the Maximum CPU use (%) box. 

5. Click OK. 

 To stop all applications running in the application pool: 

1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

2. Click Stop. 

 To start all applications in the application pool: 

1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

2. Click Start. 

If you run applications that are known to have memory leaks or become unstable after 
working for a long time, then you might need to restart them from time to time. 

 To restart all applications running in the application pool: 

1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

2. Click Recycle. 
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 To switch off the dedicated IIS application pool for your websites: 

1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

2. Click Switch Off. 
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Web Publishing with Web Deploy (Windows) 

Web Deploy (Web Deployment Tool) is a Microsoft tool that significantly simplifies the 
migration, management, and deployment of your websites and web applications. More 
precisely, you can write a code in your local environment, for example, in Visual Studio® 
(IDE) or WebMatrix® (development tool), and then periodically publish the updates to your 
production server by means of Web Deploy.  

Differences Between Visual Studio® and WebMatrix® 

If you are looking for an environment that lets you seamlessly publish code updates to your 
account, it is likely you will choose between Visual Studio® and WebMatrix®.  

 Visual Studio® is a classic integrated development environment (IDE) for writing .NET 
applications and sites of any scale. It has a variety of plugins that extend its basic 
functionality. However, to run and debug your applications in Visual Studio®, you should 
perform extra configuration (such as preparing a database and environment settings). 
Thus, this tool is more suitable for advanced users. 

 With WebMatrix® you have a built-in set of application templates and even working 
applications (WordPress, Joomla) right out of the box. If you wish to instantly add an app 
to your customer account or run it, you just need to select the app from the list and 
WebMatrix® will transparently configure it for you. Moreover, you can promptly find and 
subscribe to a hosting plan for your project without leaving WebMatrix®. Summing up, 
this tool is suitable even for novice users and encourages fast development by using 
ready-to-run applications and templates. The details on how to install and use 
WebMatrix® are available at http://www.microsoft.com/web/webmatrix/. 

It is up to you to decide which is better for your project. 

How to Configure Web Publishing in Visual Studio® and WebMatrix® 

Generally, to set up web publishing in your environment, you should open the publishing 
settings and specify the IP address of your customer account and the username and 
password you use to log in to the Control Panel. 

In WebMatrix®, the publishing settings are found in Home > Publish. You can provide these 
settings either manually or as an XML file; Panel automatically generates it. To download the 
file for a certain website, click on a corresponding Download link in Websites & Domains > 
Advanced Operations > Web Deploy Publishing Settings. The settings are only available if Web 
Deploy is installed on the Panel server and is running. If you do not see these settings, 
contact your hosting provider. 

For a step-by-step instruction on how to set up web publishing in WebMatrix®, see 
http://www.microsoft.com/web/post/how-to-publish-a-web-application-using-webmatrix. 

To learn more about publication settings in Visual Studio®, see 
http://msdn.microsoft.com/en-us/library/7z83t16a.aspx. 

Note: You can decide whether to transfer updates securely to your customer account by 
selecting the corresponding option in the publication settings. If your hosting provider does 
not have a valid SSL certificate, you will receive an error message on attempting publication. 
To resolve the problem, contact your hosting provider for assistance or avoid using the 
secure connection. 

http://www.microsoft.com/web/webmatrix/
http://www.microsoft.com/web/post/how-to-publish-a-web-application-using-webmatrix
http://msdn.microsoft.com/en-us/library/7z83t16a.aspx
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Securing WebMatrix® Publishing Settings 

An XML file which keeps WebMatrix® publishing settings may include the password to a 
customer's account. Administrators have the option to configure Panel so that it excludes 
these passwords from the XML files. If the administrators wish to improve the security of the 
system and prevent stealing the passwords, they can specify to exclude the password from 
the XML file. The customers then will have to enter the password directly in WebMatrix®. 
The option is available on the Tools & Settings > Server Settings page. 

Building Websites with Web Presence 
Builder 

Parallels Web Presence Builder (also referred to as editor) is a visual editor that lets small 
business owners and individuals create their websites quickly and easily. With Web 
Presence Builder, you do not have to write code or configure servers to start a blog, open an 
online store, or set up any other form of website. You just add the content blocks that 
comprise your site (text, image gallery, online store) by dragging them to pages, fill these 
blocks with your content, and publish the result. That’s it! 

Start Creating a Website 

When you start working on your website, you do not have to write text, search for the 
images, and adjust the site look. Just choose a topic that best suits your website, and Web 
Presence Builder will generate a site template that already contains a set of pages, pictures, 
and text relevant to the selected topic. Each time Web Presence Builder generates a 
website, it uses a random set of element designs, so you can be sure that your website 
design is never repeated.  

Once you have selected the topic, you will be prompted to enter some additional information 
that Web Presence Builder will add to the website's pages, for example, your phone number, 
which will appear on the Contact Us page. 

For more details on how to start creating your website, see the section Creating a Website (on 
page 329). 

Import Websites Created in SiteBuilder 4.5 

If you already have a website created with SiteBuilder 4.5 and hosted elsewhere, you can 
import your website to your new customer account. Learn how to move your SiteBuilder 4.5 
website to Web Presence Builder in the section Importing Sites from SiteBuilder 4.5 (on page 
330). 

Fill the Site with Content 

As soon as Web Presence Builder creates your website, you can fill it with your content. Your 
main editing tool is the Web Presence Builder's main menu. You can do the following by 
using the menu: 

 Change the structure of your site: Add or remove pages. 

 Edit the website design: Change colors and layout. 
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 Fill the site with your content: Remove unused predefined content and add your own 
elements: 

 Text 

 Images and image galleries 

 Videos 

 Scripts 

 Blogs 

 Search boxes  

 Other elements 

 Let your visitors share the information in your website in social media such as Facebook 
or Twitter: Add the corresponding buttons to the pages of your site. 

To learn more about actions available to you in the editor, refer to the section Getting Familiar 
With the Web Presence Builder Editor (on page 327). 

Find instructions on managing website look and content in the section Editing a Website (on 
page 331). 

Make the Site Available on the Internet 

After you finish editing the website, make it available on the Internet. To let people see your 
site at your domain name, publish the website by clicking the corresponding button in the 
main menu. When you click this link, Web Presence Builder generates the static pages and 
scripts that comprise your website and places them in the appropriate locations on the server 
so that people see them when they enter your domain name in their browsers. Learn more 
about publishing websites in the section Publishing a Website to the Internet (on page 363). 

You can also attract more visitors to your sites by placing a site copy on Facebook - a 
popular social network. Refer to the section Publishing a Website Copy to Facebook (on page 
364) for detailed instructions on how to do this. 

In this section: 

Getting Familiar With Web Presence Builder ..................................................... 327 
Creating a Website ............................................................................................ 329 
Importing Sites from SiteBuilder 4.5 .................................................................. 330 
Editing Websites................................................................................................ 331 
Saving and Loading Copies of a Website .......................................................... 361 
Publishing a Website to the Internet .................................................................. 363 
Publishing a Website Copy to Facebook ........................................................... 364 
Viewing Site Visits Statistics, Comments, and New Orders on the Dashboard .. 366 
Deleting Websites ............................................................................................. 368 
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Getting Familiar With Web Presence Builder 

The interface of the Web Presence Builder editor has two main parts: your website and the 
main menu. 

A website consists of a number of elements, or modules. Each module can be edited 
separately. Here we will familiarize you with the basic principles of website module editing. 
These are similar for all modules. 

When adding a module to a page, you can choose whether it should be shown only on the 
current page (page-specific module) or on all pages of the site (site-wide module). The only 
exceptions are the Search, Advertisement, Site Logo, Navigation, and Breadcrumbs modules: 
when you add them, they are placed on all pages of the website. 

To place a module only on the current page, select the module under the Modules tab, and 
drag it to any of the areas marked with the text PAGE-SPECIFIC AREA. Such areas are located 
within the main content block and near the top of each sidebar. 

To place a module on all pages of the website, select the module under the Modules tab, and 
drag it to any of the areas marked with the text SITE-WIDE AREA. Such areas are located 
above and below the main content block, in sidebars, header, and footer. 

To locate or edit a website module, hover the mouse pointer over the part of the website you 
want to change. A dotted frame will appear around the module. A control panel prompting 
you to move, edit, or remove the module will appear next to the dotted frame. 

The dotted frame around page-specific modules is green, but around site-wide modules it is 
blue. 

The editor's main menu offers website editing options grouped under five tabs: 

 Modules. Here you can choose necessary modules and drag them to any place on the 
page to fill your website with content.  

 Design. Here you can select the layout and general color scheme for your website, 
change colors of different elements, and select fonts and border style. 

 Pages. Here you can add and delete pages, rename them, edit page meta information 
such as descriptions and keywords for use by search engines, or mark a page as hidden 
so that your visitors cannot access it from the site menu. 

 Documents. Here you can upload documents, images, and other files in various formats to 
your hosting account. You can then easily insert links to these documents into your 
website pages. Or, you can just keep the files on the hosting account for your own needs. 

 Settings. Here you can edit your website name, description and keywords for search 
engines, upload a site icon (favicon), optimize the ranking of your website in search 
engine results, connect your site to Google Analytics, and add a copy of your site to a 
Facebook page. 

 

 

 



 

328 Managing Web Hosting 

 

From the main menu, you can also do the following: 

 Access the Dashboard to perform the following operations: 

 View statistics on website visits. The statistics are provided by Google Analytics. 

 View new comments left by site visitors on your website pages. The commenting 
functionality is provided by Disqus. 

 View new orders from customers visiting your online stores. The online store 
functionality is provided by Ecwid. 

 Save and load copies of your website by using the Save and Revert options. 

 Access Web Presence Builder Getting Started video tutorial, view User’s Guide, or send us your 
feedback. To do this, select the corresponding option from the Help menu. 

 Publish your website by using the Publish button. 

 Discard any changes made to a site and start creating the site anew by selecting More > 
Start Over. This does not delete your already published site copy. 

 Delete a current website draft from the editor by selecting More > Remove Site. This does 
not delete your already published site copy. 

You can drag the main menu to any place on the page for your convenience, or minimize it. 

You can also access all options of the main menu in the context menu at any place on the 
page. To open the context menu, click the right mouse button. 
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Creating a Website 

To minimize your efforts when creating a website, Web Presence Builder offers you a set of 
predefined website topics. When you start creating a website, choose a topic that is most 
appropriate for you, and Web Presence Builder will generate a website with the content 
relevant to this topic. For example, it will include a price list template for a retail store or an 
image gallery for an artist's site. If you cannot find a suitable topic, you can contact your 
service provider to ask them to create the corresponding template and add it to the list of 
available topics. 

When you start creating a website, Web Presence Builder also prompts you to provide 
information about yourself or your company. Web Presence Builder will automatically add 
this information to certain pages as appropriate, for example, to the About Us and Contact 
Us pages. 

Note: Web Presence Builder will not store or use the information you provide anywhere 
except for your website pages. You can change or remove this information later. 

 To start creating a website in Web Presence Builder: 

1. Launch Web Presence Builder by clicking the corresponding link:  

 If you have only one domain name in the subscription, click Launch Web Presence 
Builder on the Home tab or the Websites & Domains tab. 

 If you have several domain names, click the corresponding link Edit in Web Presence 
Builder in the list of available domain names. 

2. Select a website topic.  

3. Type the website name and select website language. 

4. Provide the information to pre-fill your website. 

5. Click Submit and Create Site. 
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Importing Sites from SiteBuilder 4.5 

If you have a site created with SiteBuilder 4.5, you can import it to Web Presence Builder. 

Note: The import of sites from earlier versions of SiteBuilder or other content management 
systems is not supported. 

If your site was created with an earlier version of SiteBuilder (4.4 or earlier), and you would 
like to transfer your site, you can do the following: 

 Contact your hosting provider and ask them to upgrade your account to the latest version 
of Web Presence Builder. 

 Transfer your site manually by copying and pasting the content. 

During site import, most parts of the site structure and content can be transferred 
successfully. However, we cannot guarantee that all content will be transferred. 

In most cases, the following elements are imported successfully: 

 Site map. 

 Static pages, including links and images in text modules. Note that text blocks exceeding 
30 kilobytes may be cut; therefore, some parts of the text may be missing.   

 Banner (if it is not a custom image). 

 Slogan, site title. 

 Logo (if it is not a custom image). 

 Footer text. 

 Meta info (keywords, description). 

The other modules can be imported only as text widgets with static content, links and 
images. Buttons will not work. The image gallery structure can be imported without images. 

 To import a site from SiteBuilder 4.5: 

1. Open the Web Presence Builder editor, and on the topic selection screen, 
click Import Site from SiteBuilder 4.5. 

2. Type the Internet address (domain name) of the site that you want to import. 

For example: http://example.com. 

3. Select the checkbox to confirm that you are aware of possible import issues,  
and click Import Site. 

4. After the site is imported, review and edit it as required (on page 331). You 
can compare the imported site version with your original site and add the 
missing information manually. 

5. When finished with editing, publish the site to your customer account (on 
page 363).  

If you are publishing your new site to the same webspace on which your site created with 
SiteBuilder 4.5 was hosted, the old site will be overwritten. 
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Editing Websites 

In Web Presence Builder, you can change almost any element of your website. Most of the 
elements are changed in place - you open a page where the element is used, edit it and see 
the result right away. Site-wide elements, such as Search block and Advertisement block are 
changed in one place but the changes are applied to each page of your website. 

Note: If you are using Internet Explorer, we strongly recommend that you avoid using 
browser zoom to change the size of text displayed in your browser window. Please note that 
websites in Web Presence Builder will perform and look best at normal zoom (100%). 

In this section: 

Structure: Pages and Navigation ....................................................................... 331 
Design: Layout, Styles, Color Scheme, and Header .......................................... 334 
Content: Text, Tables, Images, Video, Forms, and Scripts ................................ 340 
Settings and Tools for Webmasters ................................................................... 358 
 
 

Structure: Pages and Navigation 

This section describes how to add pages to a site, set their location in the site structure, and 
add navigation links. 

In this section: 

Adding and Removing Pages ............................................................................ 332 
Adding and Removing Navigation Links ............................................................ 333 
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Adding and Removing Pages 

Your site can have two levels of nested pages. 

 To add a new page to your website: 

1. Go to the Pages tab. 

2. Click Add page. The new page appears highlighted in green. 

3. Position the new page by dragging it to the right place or by clicking the 
arrows. 

4. Specify the page title. 

5. Give a concise description of the page content that will be displayed on 
search engine results pages and the keywords by which the page will be 
found by search engines. 

Note: Page name and Page link name are required fields. Description and Keywords are 
optional fields. If you specify keywords for a page, they should be separated by commas 
without white spaces. 

6. If you want to make the page invisible to your website visitors, select the 
Hidden page checkbox. 

7. If you want to restrict access to the page with password authentication, 
select the Protected page checkbox and specify a username and a password. 

8. Click OK to save changes. 

 To change the location or properties of a page: 

1. Go to the Pages tab. 

2. Select the page you want to edit. 

3. Change the page position by dragging it to the right place or by clicking the 
arrows. 

4. Edit the page title. 

5. Edit or remove the concise description of the page content that will be 
displayed on search engine results pages and the keywords by which the 
page will be found by search engines. 

Note: Page name and Page link name are required fields. Description and Keywords are 
optional fields. If you specify keywords for a page, they should be separated by commas 
without white spaces. 

6. If you want to make the page invisible to your website visitors, select the 
Hidden page checkbox. 
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7. If you want to restrict access to the page with password authentication, 
select the Protected page checkbox and specify a username and a password. 

8. Click OK to save changes. 

 To delete a page from your website: 

1. Go to the Pages tab. 

2. Select the page you want to delete. 

3. Click Delete page. 

4. Click OK to save changes. 

 
 

Adding and Removing Navigation Links 

By default, a horizontal navigation bar with links to site pages is inserted below or above the 
header of your site. It is automatically updated every time you add, change, move, or remove 
pages from the site. 

If you use sidebars on the site, then the horizontal bar under the header includes only links to 
the first level pages, and the sidebars show the links of the second and third levels. 

You can move navigation blocks by dragging them to other areas of the site. 

For each navigation block, you can specify what levels of pages should be included in the 
menu, change menu alignment (for example, show it in the middle of the page instead of the 
default alignment to the left), and change the color, style, and size of the font used for the 
links. To change any of these settings, place the mouse pointer over a navigation block and 
click Edit. 

If you occasionally remove a navigation block, you can re-insert it. To do this, go to the 
Modules tab, select Navigation, and drag the block to the area on the page where you want to 
add it. The navigation block will be inserted into all pages of the website. 

For the convenience of your site visitors, you might also want to add breadcrumb navigation 
blocks. Breadcrumb navigation is a chain of links that represents the user's path from the 
site's main page to a current page. To add a breadcrumb navigation block, go to the Modules 
tab, select Breadcrumbs, and drag the module to the area on the page where you want to add 
it. The navigation block will be inserted into all pages of the website. 
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Design: Layout, Styles, Color Scheme, and Header 

This section describes how to change the layout, color scheme, and header elements of the 
site. 

In this section: 

Changing Your Website Layout ......................................................................... 335 
Selecting Website Colors, Fonts, and Styles for Borders and Corners .............. 337 
Changing the Website Header Elements ........................................................... 339 
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Changing Your Website Layout 

The layout of your site can consist of the following elements: 

 Header. This is the topmost area where a banner image and a company logo are usually 
placed. You can do the following to the header: 

 Move the banner image and logo from the header area to any place on the page. 

 Reduce the header height to 25 pixels by removing all elements from it. 

 Change the header width from the default size to 100 percent, so that it is expanded 
to fit the page width. 

 Content area. This is the main part of a webpage where most of the content is placed. You 
can do the following to the content area: 

 Adjust the height of the content area. 

 Divide the content area into several columns. You can do this by dragging new 
modules to the left or right edge of the content area and inserting them. 

 Change location of the columns in the content area by moving the content to the left 
or to the right.  

 Sidebars. These are vertical columns that can be used for placing all kinds of modules, 
site-wide and page-specific. You can do the following to sidebars: 

 Add one sidebar and place it to the left or to the right of the content area. 

 Add two sidebars. They will be placed to the left and to the right of the content area. 

 Adjust the height and width of the sidebars. 

 Move the sidebars to the top of the page and place them to the left or to the right of 
the header area.  

 Switch places of the sidebars. 

 Footer. This is the lowest area where the company name, contact information, or a 
copyright notice are usually placed. You can do the following to the footer: 

 Reduce the footer height to 25 pixels by removing all elements from it. 

 Change the footer width from the default size to 100 percent, so that it is expanded to 
fit the page width. 

 To change the layout of your site: 

1. Go to the Design tab > Layout tab. 

2. Select the number of sidebars: Under Sidebars, select No, One, or Two. 

3. Select the locations of sidebars: 

 To move a sidebar to another side of your website, or to switch places of sidebars (if 
you have two sidebars on your site), click Switch sidebars. 

 To move the sidebars to the top of the page, click them in the layout model. 
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4. Set the size of page elements: 

 To set the total width of the website pages, under Website width, select either of the 
following: 

 Fixed layout: your website will be of a specific size regardless of the size of the 
browser window viewing the page. In this case, specify your website width in 
pixels. 

 Liquid layout: based on percentages of the current browser window's size. In this 
case, specify your website width as a percentage of the browser window's size.  

 To change the width of the header and footer areas to fit the page width, click the 
corresponding elements in the layout model. 

 Under Minimal column height in pixels, specify the height of the main content area and 
each sidebar, if you have chosen to use them. 

This value shows the height of your website elements without content. When you add 
content to the main content area and to the sidebars, they will stretch in height to fit 
the content. 

 To ensure that the sidebars and the content area are vertically aligned, select the 
checkbox Stretch the sidebars and the content area down to the footer. 

 If you use one or two sidebars, under Sidebar width in pixels, specify the width of each 
sidebar. The size of the main content area will be determined automatically. 

 Under Margin sizes in pixels, specify the size of vertical and horizontal margins. A 
margin is the space between the edges of neighboring elements. 

5. Click OK to save changes. 
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Selecting Website Colors, Fonts, and Styles for Borders and Corners 

The general color scheme, or styleset, of your website comprises four colors. Each color is 
used for several website elements at once. You can adjust colors of individual elements on 
the Design tab > Colors tab. 

 To select the general color scheme for your website: 

1. Go to the Design tab > Scheme tab. 

2. Select the color scheme, or styleset, of your website in the menu. 

You will see the four colors used in the color scheme of your website. 

3. To adjust one of the colors of your website color scheme, click the respective 
color field and change the hexadecimal color code value or select a color 
with the color picker. 

Note: These changes will override any previous changes of individual elements' colors 

made on the Colors tab. 

4. Click OK to save changes. 

 To select colors of individual website elements: 

1. Go to the Design tab > Colors tab. 

2. Select the website element in the menu. 

3. Adjust the element's background color by clicking the background color field 
and editing the hexadecimal color code value or by selecting a color with the 
color picker. 

4. If you want to use gradient filling, select the Gradient option, and then select 
the pattern from the menu.  

5. For an element with text, adjust font colors by clicking the respective color 
field and editing the hexadecimal color code value or by selecting a color 
with the color picker. 

Note: Modifying the styleset on the Scheme tab will override the changes made on the 
Color tab. 

6. Click OK to save changes. 

 To select fonts for headings and body text of your website: 

1. Go to the Design tab > Fonts tab. 

2. For each font type, select the font face and size in the menus. 
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3. For headings, select the font decoration. You can use bold (the B icon) and 
italics (the I icon).  

Note: The settings made here define only general rules for your website fonts. You can 
always adjust fonts of individual elements in place. 

4. Click OK to save changes. 

 To select the shape of corners (square or rounded) for website elements: 

1. Go to the Design tab > Corners tab. 

2. In the Page area menu, select the element whose corners you want to change. 

3. Do any of the following: 

 To make rounded corners, select the corresponding checkboxes. 

 To make square corners, clear the corresponding checkboxes. 

4. Click OK to save changes.  

 To select borders for website elements: 

1. Go to the Design tab > Borders tab. 

2. Select the border type for elements inside your website from the Internal 
containers border menu. 

3. Select the elements that will have the border. 

Note: You can select only one internal border type for all elements on your website, but 

you can select whether this border will be used for certain elements. 

4. Select the external border for your website from the External site border menu.  

5. Click OK to save changes. 
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Changing the Website Header Elements 

The site header consists of the following elements: 

 Banner. You can do the following to the banner: 

 Upload your own banner image. 

 Select and apply a banner from the Web Presence Builder library. 

 Remove the banner and use a background filled with a color or images. 

 Remove the banner and all other elements from the header area to reduce its height 
to 25 pixels. 

 Move the banner to the content area and insert it into a specific page or into all pages 
of the website. 

Note: You can use only one banner per site. If you choose to insert it into a specific 

page, you will not be able to add it to other pages of the website. For this reason, 
we recommend that you place it into the site-wide areas. 

 Logo image. You can do the following to the logo: 

 Upload your own logo image. 

 Move the logo from the header area to other parts of webpages, such as sidebars and 
content area.  

 Insert any number of logo images into the site-wide areas. 

 Remove the logo. 

 Site name. This usually contains a company name or a brief site description like, for 
example, "John Doe's Recipes". 

 Site slogan. This usually includes a description of your site or a company slogan. 

 To change the banner image or other elements of the header (logo, site name, 
or slogan): 

1. Click the banner image. 

2. Do any of the following: 

 To use an image from the Web Presence Builder's library, select the option Selection 
from our library, and then select an image from the Image list menu. To help you find an 
appropriate image, select the Recommended option or type a keyword in the input box. 

 To use your own image, select the option Selection from own file, click Browse, and 
select the image you want to use. You should use only images in the GIF, JPEG, and 
PNG formats, preferably not wider than 900 pixels. 

 To remove an image, select the option no image and specify the height of the header 
block in pixels. 

3. If you want to scale a banner to fit the header area, select the Fit image size 
checkbox. 

4. Under Show banner elements, select the checkboxes corresponding to the 
elements that you want to show in the header. 
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5. If you want to remove a logo image or upload your own logo, cl ick the logo 
image. 

6. If you want to change the site name or slogan, click the corresponding fields 
on the header and change them as you want. 

To make it easier to see the site name or slogan, select the Outline checkbox. This adds a 
black or white outline around text, one pixel in width. If the font color in site title or slogan 
is black, then the outline is white, and vice versa. 

Note that you can freely move the blocks with website name, description, and logo within 
the header area. 

If you occasionally remove the banner, you can re-insert it. 

 To insert a banner: 

Go to the Modules tab, select Banner, and drag the module to any of the site-wide areas on the 
page where you want to add it. 

 To insert a logo image: 

Go to the Modules tab, select Site Logo, and drag the module to any of the site-wide areas on 
the page where you want to add it. You can upload a new logo image and align it to the left, 
center, or right. 

Content: Text, Tables, Images, Video, Forms, and Scripts 

This section describes how to fill your site with content and enhance it with useful functions 
provided by the editor's modules. 

When adding a module to a page, you can choose whether it should be shown only on the 
current page (page-specific module) or on all pages of the site (site-wide module). The only 
exceptions are the Search, Advertisement, Site Logo, Navigation, and Breadcrumbs modules: 
when you add them, they are placed on all pages of the website. 

 To place a module only on the current page, select the module under the Modules tab, 
and drag it to any of the areas marked with the text PAGE-SPECIFIC AREA. Such areas are 
located within the main content block and near the top of each sidebar. 

To divide the content area into columns and insert a module into one of them, drag the 
module to the left or right edge of the content area and then insert it. Note that sidebar 
areas cannot be divided into columns. 

 To place a module on all pages of the website, select the module under the Modules tab, 
and drag it to any of the areas marked with the text SITE-WIDE AREA. Such areas are 
located above and below the main content block, in sidebars, header, and footer. 

 



 

 Managing Web Hosting 341 

 

In this section: 

Text, Tables, Hyperlinks, and Images ................................................................ 342 
Embedded Video ............................................................................................... 347 
Contact Form .................................................................................................... 347 
Blog ................................................................................................................... 347 
Commenting ...................................................................................................... 351 
Documents and Other Downloadable Files ........................................................ 353 
Buttons for Sharing on Social Networks ............................................................ 354 
Site Search ........................................................................................................ 354 
Online Store ...................................................................................................... 355 
Custom Scripts .................................................................................................. 356 
Advertisements ................................................................................................. 357 
 
 



 

342 Managing Web Hosting 

 

Text, Tables, Hyperlinks, and Images 

Before you start working on website content, we suggest that you select the appropriate 
website language in Settings tab > Languages > Website language menu. 

The website language is a site-wide setting that defines the language in which you will be 
adding content to your website. It affects the following: 

 The language in which certain website elements (in particular those provided by third-
party services), such as Google Search and navigation buttons in image galleries, will be 
shown. Note that not all third-party services and modules provided by the editor support 
all available languages. 

 The direction in which you will type text in the editor (from left to right or from right to left). 
If you select a right-to-left language, your website content and design will be RTL-
enabled. 

Note: Changing a website language does not reload the currently selected website topic in a 
different language. The topic language will remain unchanged, however, the text orientation 
will change. 

 To add text, lists, tables, or images to a page: 

1. Go to the Modules tab, select Text & Images, and drag the module to the page: 

 To add a block with text and images to the current page, drag the module to any of 
the areas marked with the text PAGE-SPECIFIC AREA. Such areas are located within the 
main content block and near the top of each sidebar. 

To divide the content area into columns and insert a block into one of them, drag the 
module to the left or right edge of the content area and then insert it. Note that sidebar 
areas cannot be divided into columns. 

 To add a block with text and images to all pages of the site, drag the module to any of 
the areas marked with the text SITE-WIDE AREA. Such areas are located above and 
below the main content block, in sidebars, header, and footer. 

2. Type the text on the screen and use the icons on the module's toolbar to 
format the text, add tables, hyperlinks, and images. 

The toolbar of the Text & Images module provides access to the following tools and functions. 
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1. Move the text and image block within the webpage. 

2. Remove the block with its contents. 

3. Save changes. 

4. Cancel the changes made. 

5. Move the toolbar. 

6. Select the paragraph style and font face. 

7. Select the font size. 

8. Select the font style: bold, italics, underlined, and strikethrough. 

9. Select the text and background colors. 

10. Select text alignment: left, center, right, or justified (aligned to both the left and right 
margins with added extra spaces between words). 

11. Increase and decrease the indent level of the paragraph. 

12. Start a numbered or bulleted list. 

13. Insert a table and specify the number of rows and columns. 

After you insert a table, a number of additional icons become accessible from the toolbar. 
Use them to change the properties of the table rows and cells, to insert and remove rows 
and columns, or to split and merge table cells. 

14. Insert symbols that are not on your keyboard, such as copyright and trade mark signs, 
and other Unicode symbols. 

15. Insert a horizontal line. 

16. Edit the HTML source code of the page. 

17. Undo and redo changes. 

18. Add and remove hyperlinks to the pages of your website or external resources. Insert 
HTML anchors into particular sections of webpages so that you can link to them from 
other pages of your site. 

19. Insert an image, adjust its size, specify an alternative text, and text wrapping. In browsers 
that do not support or are configured to not show images, the alternative text is shown 
instead of images.    

If you want to insert many pictures into a single page, consider using the Image Gallery module 
instead of the Text & Images module. With Image Gallery, you can upload pictures from your 
local computer or use pictures published to the Picasa Web Albums photo sharing service. 

 To add an image gallery to your site and upload pictures: 

1. Go to the Modules tab, select Image Gallery, and drag the module to the page. 

2. In module settings, on the Image Storage tab, select where you want to keep 
pictures: 

 If you do not have a Picasa Web Albums account that you would like to use, leave the 
Web Presence Builder option selected. All images you use on your site will be kept on 
your customer account. 
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 If you have an account in Picasa Web Albums and want to use pictures that you store 
there on your site, do the following: 

a. Select the Picasa option, click the link on the Image Storage tab to sign 
in to Google, and grant access to your albums from Web Presence 
Builder. 

b. Select the album whose pictures you want to use or click Create Album 
to create a new album. 

c. If you want Web Presence Builder to remove images from Picasa 
Web Albums when you remove them from the gallery, select the 
checkbox Delete images when I remove them from gallery. 

When you upload images to an image gallery through the Web Presence Builder 
editor, they are automatically copied to your Picasa Web Albums account. When you 
remove images from the gallery, they are removed from Picasa Web Albums only if 
you have selected the option Delete images when I remove them from gallery. 

3. (Optional step.) If you want to select the size of image thumbnails to be 
shown in the image gallery, click the Gallery Properties tab and select the size 
of thumbnails: 

 Small (95 x 75 pixels). 

 Normal (140 x 130 pixels). This is the default setting. 

 Large (170 x 170 pixels). 

4. To add images to the gallery, click the text Click here to upload your images, 
select the images that you want to upload, and click OK. 

You can select and upload multiple images at once. Only images in GIF, JPEG, and PNG 
formats are supported. 

We recommend that you use resized images that do not exceed 1024 x 768 pixels. 

5. To change image title and description, click the corresponding thumbnail, 
click the title or description, and edit the text. 

If you delete the default text entirely, it will not be shown on your published site; however, 
it will still be shown when you edit the site in the Web Presence Builder editor. 

 To remove an image from the gallery: 

Place the mouse pointer over the image thumbnail and click the icon [x]. 

 To remove an image gallery with all pictures: 

Place the mouse pointer over the image gallery block and click Remove. 

 To insert a hyperlink or a link to an e-mail address into text: 

1. Select the text that you want to make a link. 

2. On the toolbar of the Text & Images module, click the icon . 
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3. Do any of the following: 

 To add a link to another webpage on your site, select the option A page of this site. In 
the Select page menu, select the target webpage. 

 To add a link to a webpage or a file located on another site, select the option A 
webpage or file on the Internet, and type the address. For example, 

http://example.com. 

 To add a link to a document or another downloadable file that you have previously 
uploaded through the Document Manager (as described in Documents and Other 
Downloadable Files (on page 353)), select the option A document on this site, and select 
the target file. 

 To add a link that will open a new e-mail message with a pre-filled destination e-mail 
address, select the option A webpage or file on the Internet, and type 

mailto:<address>. For example, mailto:postmaster@example.com. 

You can also: 

 Predefine the message subject line. For example: 

mailto:postmaster@example.com?subject=My%20Subject. 

 Add recipients to CC and BCC lists. For example: 
mailto:postmaster@example.com?subject=My%20Subject&cc=addres

s1@example.com&bcc=address2@example.com. 

 Predefine text to put in the message body. For example: 
mailto:postmaster@example.com?subject=My%20Subject&body=This

%20is%20sent%20from%20your%20site! 

Note: You should replace white spaces with %20. 

4. In the Open link in menu, select where you want to open the target page. You 
can choose to open it in the same or in a new browser window or tab. 

5. In the Title box, type the description that should appear when users place the 
mouse pointer over the link. 

6. Click OK. 

  
 

mailto:%3Caddress
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Embedded Video 

You can embed into website pages video clips located on popular video sharing sites, such 
as YouTube (youtube.com), Vimeo (vimeo.com), MySpace (myspace.com), and Dailymotion 
(dailymotion.com). 

 To insert a video into a webpage: 

1. Go to the Modules tab, select Embedded Video, and drag the module to the 
page. 

2. Insert a link to the video or select the option Embed code if you have obtained 
a code from a file sharing site, and then paste the code. 

3. Click OK. 

 To remove a video: 

Place the mouse pointer over the video and click Remove. 

Contact Form 

If you want your site visitors to be able to send you messages from your site, you can add a 
contact form. 

 To add a contact form: 

1. Go to the Modules tab, select Contact Form, and drag the module to the page. 

2. On the Settings tab, specify the following: 

 Recipient's e-mail address. You can specify only one e-mail address. 

 Message subject. 

 Text to be shown on the button that sends the message.  

3. If you want to add, move, or remove input fields from the form, or change 
their labels, click the Fields tab, and make the required changes. 

4. If you want to change the default message "Your message was sent. Thank 
you." which is shown when a message is sent, click the Reply tab and type 
the new text. 

5. Click OK. 

 To remove a contact form: 

Place the mouse pointer over the form and click Remove. 
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Blog 

If you want to maintain an online diary on your site, or regularly publish articles on a subject 
and automatically present them in a chronological order, then you need a blog. 

A blog module can be added only to the first-level pages that do not have subpages. Within 
blog posts, you can use text, images, embedded videos and scripts. Each blog post can 
have its distinctive page description and meta information to be used by search engines. 
Note that blog posts are not listed on the Pages tab (on page 332). 

To let your visitors comment on your blog posts, you need to register with Disqus, a free 
third-party service that provides commenting functions for your sites and keeps all 
comments. 

 To add a blog to your webpage: 

1. Go to the Modules tab, select Blog, and drag the module to the page. 

2. In the module properties, specify the following: 

 Number of blog posts to show on the page. 

 Specify whether the site visitors will be able to leave their comments. 

3. Click OK. 

4. To enable commenting, click the link Click here to add a new blog post. 

5. Click within the gray information box at the bottom of the blank blog post.  

6. To register with Disqus, click the Register button. A registration form will open 
in a new browser window or tab. 

7. Specify the following: 

 Your site's URL, desired name and shortname (unique ID). You will need to specify 
this site ID (shortname) later in the Blog module settings to enable commenting. 

 Comment moderator's username, password, and e-mail address. A confirmation 
message will be sent to this e-mail address, so be sure that it is valid. 

8. Click Continue. 

9. Specify your language and other settings, and click Continue.  

10. On the last step of the registration form, no further action is required. Just 
log out of the Disqus site. 

11. Check your e-mail inbox for the confirmation message from Disqus. In this 
message, click the link to verify your address. 

12. Return to the browser window where you have the Web Presence Builder 
editor with the Blog module properties opened. 

13. In the box titled Apply here the website ID (shortname) received during registration, type 
or paste the site ID that you specified during registration with Disqus in step 
7. 
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14. Click Apply. 

15. Click OK. 

Now your blog can accept comments from visitors, and you can make the first post. 

 To add a blog post: 

1. Go to the website page containing a blog module. 

2. Click the link Click here to add a new blog post (might also appear as New Post 
Title). 

3. Type the post title and content. 

If you want to change the date of posting, click within the field Posted dd.mm.yy and then 
select a date from the calendar. 

If your post is lengthy and contains numerous text blocks, images, and embedded videos, 
you might want to show only a portion (beginning of the post) to site visitors in your blog's 
main page. To do this, while editing a blog post, move the divider element (containing the 
line -------- Drag this above modules that should not appear in the list of posts --------) to the desired 
area.  

4. Click OK. 

5. If you want to view, edit, or remove a concise description of the page that will 
be displayed on search engines results pages and the keywords by which 
the page will be found by search engines, click in a blank area to the right of 
the post title, and then click the SEO Settings tab. 

Note: Post link name is a required field. Meta description and Meta keywords are optional 
fields. If you specify keywords for a page, they should be separated by commas without 
white spaces. 

6. To return to the blog's main page, click the Back link below the post you have 
just created.  

 To remove a blog post: 

1. Go to the website page containing a blog module. 

2. Place the mouse pointer over the post title and click Remove. 

3. Click Yes to confirm removal. 

 To edit a blog post: 

1. Go to the website page containing a blog module. 

2. Click the post title. 

3. Make the required changes and click OK. 
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 To remove a blog with all posted content: 

1. Go to the website page containing a blog module. 

2. Place the mouse pointer over the link Click here to add a new blog post and click 
Remove. 

3. Click Yes to confirm removal. 
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Commenting 

If you want to let your site visitors leave comments on webpages, you need to insert the 
Commenting module into those webpages. 

The commenting functionality is powered by Disqus, a third-party service that stores and 
processes all comments. Before your visitors can leave comments, you need to register an 
account with Disqus and then specify a site ID in the Commenting module settings. 

You can insert several Commenting modules into a single website. Because all Commenting 
modules on the site will use the same site ID, you will only need to specify the site ID once in 
the module settings, when inserting the first Commenting module. 

 To add commenting functions to a webpage: 

1. Go to the Modules tab, select Commenting, and drag the module to the page. 

2. If you have not registered an account with Disqus yet, click the Register 
button. A registration form will open in a new browser window or tab. 

3. Specify the following: 

 Your site's URL, desired name and shortname (unique ID). You will need to specify 
this site ID (shortname) later in the Commenting module settings to enable 
commenting. 

 Comment moderator's username, password, and e-mail address. A confirmation 
message will be sent to this e-mail address, so be sure that it is valid. 

4. Click Continue. 

5. Specify your language and other settings, and click Continue.  

6. On the last step of the registration form, no further action is required. Just 
log out of the Disqus site. 

7. Check your e-mail inbox for the confirmation message from Disqus. In this 
message, click the link to verify your address. 

8. Return to the browser window where you have the Web Presence Builder 
editor with the Commenting module properties opened. 

9. In the box titled Apply here the website ID (shortname) received during registration, type 
or paste the site ID that you specified during registration with Disqus in step 
3. 

10. Click Apply. 

11. Click OK. 

Now you can publish your website to the customer account and start receiving comments 
from your visitors. 

 



 

352 Managing Web Hosting 

 

In addition to adding and viewing comments, you can do the following: 

 Edit comments. 

 Delete comments. 

 Mark comments as spam. 

 Ban users (by e-mail or IP address) from posting comments on your site. 

 Change the settings, such as appearance of comments, and remove the trackback URL. 
You can do this by logging in to your account at www.disqus.com, and going to the 
Settings tab.    

 To moderate comments: 

1. Log in to Disqus as the site administrator. You can do this in either of the 
following ways: 

 Visit the Disqus site at www.disqus.com and log in there. 

 In the Web Presence Builder editor, go to the page where you have the Commenting 
module and click inside the Add New Comment field. Click the Post as button, click the 
Disqus link in the left navigation pane, type your username and password, and click 
Login. 

2. After you are logged in to Disqus, you can moderate comments in either of 
the following ways: 

 On the Disqus site, use the items in the Dashboard and Admin areas. 

 In the Web Presence Builder editor or on the published site, go to the page where you 
have the Commenting module, place the mouse pointer over the comment you want 
to moderate, and use the Moderate link that will appear next to the comment. 

Alternately, you can moderate comments by using links in the notification messages that 
Disqus sends you when someone leaves a comment on your site. 

 To remove commenting functions from a webpage: 

1. In the Web Presence Builder editor, go to the website page containing the 
Commenting module. 

2. Place the mouse pointer over the Add New Comment field and click Remove. 

3. Click Yes to confirm removal. 
 

http://www.disqus.com/
http://www.disqus.com/
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Documents and Other Downloadable Files 

The editor now provides a convenient control panel for working with files in your customer 
account. You can upload your documents, images, and other files in various formats to the 
editor (on the Documents tab), and then insert links to them in your website pages. 
Alternatively, you can just keep them in your customer account for your own needs. 

 To upload a file to the customer account: 

1. Go to the Documents tab. 

2. Click Upload. 

3. Select the file and click Open. 

Now, to let your site visitors download this file, you can insert a link to it in a webpage. 

 To insert a link to file: 

1. Select the text that you want to make into a link. 

2. On the Text & Images module's toolbar, click the icon . 

3. Select the option A document on this site. 

4. Select your file and click OK. 

 To remove a file from the customer account: 

1. Go to the Documents tab. 

2. Select the file and click Remove. 

3. Confirm removal and click OK. 
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Buttons for Sharing on Social Networks 

If you want to let your visitors easily share your content on social networks or online 
bookmarking services, you can insert a toolbar with buttons for sharing on Facebook, Twitter, 
Myspace, and other popular services. 

 To add the Share on Social Media toolbar to a webpage: 

1. Go to the Modules tab, select Social Sharing, and drag the module to the page. 

2. Select the appearance of the toolbar. 

3. If you want to modify the list of social networks and sharing services shown 
on the toolbar, place the mouse pointer over the icon [+] and click the Settings 
link. 

The changes you make to the list of services will be visible after you publish the site. 

4. Click OK. 

Note: When someone shares your content on Twitter by using the Tweet button, the counter 
of tweets is not increased immediately. It can take several hours for the counter to update. 

 To remove the Social Media toolbar: 

Place the mouse pointer over the toolbar and click Remove. 

Site Search 

If you want to let your visitors search for information on your website, you can add a search 
bar to the site. After inserting the search bar into a webpage, it is automatically added to all 
pages of the site. 

By default, the search bar is configured to use the Google search engine. If you want to use 
another search engine, you can obtain the search script code and insert it into the Search 
module. 

 To add a search bar to the site: 

1. Go to the Modules tab, select Search, and drag the module to the page. 

2. Do any of the following: 

 If you want to use the search service provided by Google, leave the Google option 
selected. 

 If you want to use another search engine, select Other and paste the code that you 
have obtained from that service. 

Make sure that the code you insert is correct, as Web Presence Builder does not 
validate it.  
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3. Click OK. 

The search bar will appear on your site after publishing. 

 To remove a search bar: 

Place the mouse pointer over the search bar and click Remove. 

Online Store 

If you want to sell products or services through your site, you can use the Online Store and 
Shopping Cart modules to add a fully functional online store to the site. You can add only one 
store per site. 

The store functionality is provided by Ecwid - a third-party SaaS solutions provider that 
securely stores and processes all your data, including product catalogs, images, orders, and 
customers' payments. 

 To add an online store to your site: 

1. Go to the Modules tab, select Online Store, and drag the module to the page. 

2. Create an account with Ecwid if you do not have one yet, or specify the ID of 
an existing store if you have previously created a store at Ecwid through 
Web Presence Builder and want to show it on your site. 

If you do not have an account with Ecwid yet, do the following: 

a. In module settings, on the General tab, select the option Register with 
Ecwid. 

b. Type your name, e-mail address, and password. You will use the e-
mail address and password to sign in to Ecwid and manage your 
store. 

c. Click Send. A confirmation message from Ecwid will be sent to your e-
mail address. You will need to confirm that you own this e-mail 
address within three days, otherwise the online store will be 
deactivated. 

If you already have an account with Ecwid, select the option Enter an ID of an existing shop, 
specify the store ID and e-mail address that you specified during account registration, 
and click Apply. 

Note: If the online store was created directly at the Ecwid website without using Web 
Presence Builder, you can do the following: Create a new Ecwid account through WPB, 
log in to the previously existing Ecwid account, export all the goods to a CSV file. After 
that, log in to the new account and import the file.  
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3. (Optional step.) If you want to let your customers add items to the cart by 
dragging them to a shopping bag icon, go to the Modules tab, select the 
Shopping Cart module, and drag it to the page. 

Note that the shopping bag icon will be inserted into all pages of your site. If you do not 
want that, do not use the Shopping Cart module. Your customers will still be able to add 
items to the cart and proceed to checkout by using the Shopping Bag link that appears at 
the top of the product catalog area. 

4. (Optional step.) If you want to change the appearance of the product catalog, 
in module settings, go to the View tab. 

5. To set up your store, fill the product catalog with items, and remove the 
default fruit and vegetable items added by Ecwid, click the Manage link on the 
module's toolbar. 

The Ecwid control panel will open in a new browser window or tab. 

6. After you have finished setting up the store in the Ecwid control panel, return 
to the Web Presence Builder editor and click the Reload link on the Online Store 
module's toolbar. 

You must use the Reload link to synchronize the content of your online store with online 
store at Ecwid. 

7. Click OK to finish setting up the store. 

 To manage a store: 

Place the mouse pointer over the product catalog and click Manage. The Ecwid control panel 
will open in a new browser window or tab. 

Note: After publishing your site, you can also view information about new orders on the 

Dashboard (on page 366). 

 To remove a store: 

Place the mouse pointer over the product catalog and click Remove. 

Custom Scripts 

You can insert custom scripts written in PHP, JavaScript, or VBScript in any page of your 
website. 

 To insert a script in a webpage: 

1. Go to the Modules tab, select Script, and drag the module to the page. 

2. Paste the code into the input field. 

For PHP, use the opening tag <?php. Make sure the code you insert into this field is 

correct, as Web Presence Builder does not validate it. 

3. Click OK. 
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Your code will be active only on the published website. 

 To remove a script: 

Place the mouse pointer over the script block and click Remove. 

Advertisements 

If you are participating in a banner exchange or other online advertising programs, you might 
want to add an advertisement block to your site. After inserting the block in a webpage, it will 
be automatically added to all pages of your site. 

 To add an advertisement block: 

1. Go to the Modules tab, select Advertisement, and drag the module to the page. 

2. Paste the code provided by your advertising vendor into the input field.  

Make sure that the code you insert into this field is correct, as Web Presence Builder 
does not validate it. With some advertising vendors, you will need to validate your 
account first. 

3. Click OK. 

Advertisements will appear on your website after publishing. 

 To remove an advertising block: 

Place the mouse pointer over the block and click Remove. 



 

358 Managing Web Hosting 

 

Settings and Tools for Webmasters 

This section describes how to do the following: 

 Change website name, description, and keywords. 

 Upload a site icon (favicon) for your website. 

 Make your website more visible in search results, and embed various search engine 
services. 

 Prevent certain pages or areas of your website from being indexed by search engines 
and shown in search results. 

 To edit your website name, description, and keywords: 

1. Go to the Settings tab > Basic tab. 

2. Specify the website name that your visitors will see as the title of their 
browser window when they visit your website. 

3. To show both your website name and the current page name in the browser 
title window and to increase your website recognition in search engine 
results, select the Add website name to page titles checkbox. 

4. Add short description (up to 255 symbols) of your website. 

This will be used as the default description for new pages. It will be shown by search 
engines when people see your website in search results. 

5. Provide a list of keywords that describe your website (10-15 keywords are 
recommended). 

These keywords will be used as default keywords for new pages. Keywords are analyzed 
by search engines and are used for displaying your website when people search for 
these keywords. 

6. Click OK to save changes. 

A favicon is a small icon displayed in the browser’s address bar when you visit a website, 
and also appears next to the website name in the list of favorite bookmarks. You can create 
a favicon using a variety of online tools and then upload your favicon through the Web 
Presence Builder editor. All your website visitors will see this favicon. 

 To upload a favicon for your website: 

1. Go to the Settings tab > Basic tab. 

2. Click Browse and select the location of the favicon to upload. The favicon will 
be uploaded. 

3. Click OK to save changes. 
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 To remove a favicon from your website: 

1. Go to the Settings tab > Basic tab. 

2. Click Remove in the Favicon section. The favicon will be removed. 

3. Click OK to save changes. 

Most search engines require you to verify website ownership when you register your website 
or sign up for webmaster assistance services. Verification is typically done by uploading or 
creating a file with a specific file name. 

 To verify website ownership: 

1. Go to the Settings tab > Advanced tab. 

2. Provide the verification file: 

 If you know the name of the verification file requested by a search engine, provide the 
verification file name in the Create verification file field and click OK. Web Presence 
Builder will create it in the correct place.  

 If you have already downloaded your verification file from a search engine, upload the 
verification file to the Upload verification file field and click OK.  

3. After the verification file is created or uploaded and your website is 
published, confirm your ownership on the search engine website.  

4. Click OK to save changes. 

 To edit the HTML <head> section of your website (for example, to add 

ownership verification meta code): 

1. Go to the Settings tab of the Web Presence Builder's main menu, then go to 
the Advanced subtab. 

2. Click Edit Metadata. 

3. Insert the code into the provided field and click Add.  

Note: Only valid HTML tags permitted for <head> section by HTML standards are 

supported. Metadata changes will be available only after you publish your website. 

4. Click OK to save changes. 

Google Analytics is a tool that allows you to obtain information about your visitors. After you 
register with Google Analytics and acquire the required code, you can embed Google 
Analytics on your website. 

 To embed Google Analytics: 

1. Register with the Google Analytics service and acquire the code. 

2. Go to the Settings tab > Advanced tab. 
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3. Click Embed Google Analytics. 

4. Insert the code you have received from Google Analytics into the provided 
field and click Add.  

Note: Google Analytics will start working only after you publish your website. 

5. Click OK to save changes. 

Some search engines will ask you to provide your sitemap for analysis and optimization 
purposes. You can download your sitemap from the Web Presence Builder editor. 

 To download your website sitemap: 

1. Go to the Settings tab > Advanced tab. 

2. Click Download Sitemap. 

3. Click OK to start downloading the sitemap.xml file. 

To prevent search engines from indexing certain pages of your website, you can add the 

appropriate directives into the robots.txt file. This file is stored on the customer account 

to which your site is published.   

 To prevent search engines from indexing certain areas of your website: 

1. Go to the Settings tab > Advanced tab. 

2. Click the link Edit robots.txt. 

3. Type your directives into the input field. Place each directive on a new line.  

For example, to prevent all search engine robots and crawlers from indexing the contents 

of the directory /private and the file /my_secret.html on your customer account, 

add the following lines: 

User-agent: * 

Disallow: /private/ 

Disallow: /my_secret.html 

For more information about the robots.txt file and directives you can use, refer to 

http://www.robotstxt.org/robotstxt.html. 

http://www.robotstxt.org/robotstxt.html
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Saving and Loading Copies of a Website 

While working on the content and design of a website, you can save several copies of each 
site to the server and restore sites from the saved copies (also referred to as snapshots). 
Saving site copies can be useful in the following cases: 

 You want to prepare several versions of the same website, so that you can later load 
them for review, choose the best designed or the most appropriate version, and publish it 
to the Internet. 

 You want to make significant changes or experiment on the site design or content, but be 
sure that you can safely undo the changes should anything go wrong. 

Note: Pictures from the Image Gallery modules are not saved in snapshots. Images are stored 

on your customer account or Picasa Web Albums (if you use that option). 

 To save the current design and content of a site: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Save option. 

Note: If you click Save, a quick-save site copy will be saved under the name auto-saved 
snapshot. You will be able to restore a site from this copy later, by clicking Revert in the 
main menu. 

2. In the list that opens, select a free saving slot, type a name for the backup 
copy, and click Save. 

 To restore a site from a saved copy: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Revert option. 

Note: If you click Revert, a site will be restored from the quick-save copy that was made 
the last time you clicked Save. 

2. In the list that opens, select a site copy and click Load. 

3. Click Yes to confirm you want to restore. 

 To download a site copy: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Save option. 

2. Locate the copy that you want to download and click the (Download) icon. 

3. Select the directory on your computer where you want to save the file and 
click OK. 
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 To upload a site copy: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Revert option. 

2. Click the (Upload) icon next to the slot to which you want to upload the 
copy. 

3. Browse to the site snapshot file in the SSB format and select it.  

4. If you want to restore a site from the uploaded snapshot, select it and click 
Load. 

 To remove a site copy: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Save option. 

2. Locate the site copy that you want to remove and click the corresponding
(Remove) icon. 
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Publishing a Website to the Internet 

When your website design and content are ready to be published to the Internet, click Publish 
in the top right corner of the main menu. Web Presence Builder will publish your website 
automatically to the location specified by your hosting provider. 
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Publishing a Website Copy to Facebook 

After publishing a site on the Internet, you can drive more visitors to it by publishing a site 
copy to the popular social network site - Facebook (www.facebook.com). 

A site copy on Facebook will show most of the content from your site; however, the following 
changes will be applied to its design and layout: 

 Headers, sidebars, and footers will not be shown. 

 The navigation menu will be shown only at the top of the site pages. 

 Page width will be limited to 520 pixels. For pages wider than 520 pixels, a horizontal 
scrollbar will be shown. 

 The font face, size, and color will be changed to comply with the Facebook design, 
unless these font properties were specifically selected by the site owner in the Web 
Presence Builder editor. 

 Image galleries, online store, and links for sharing on social media sites will not be 
shown. 

 If you want to add a site copy to Facebook, do the following: 

1. In the main menu, click the Settings tab > Social Media tab. 

2. Leave the checkbox Show a copy of my site on Facebook selected. 

3. Click the link Add your site copy to Facebook. The Facebook home page opens in 
a new browser window or tab. 

4. To log in to your Facebook account, type your e-mail address and password, 
and click Log In. 

5. If you do not have a Facebook page where you want to show a site copy, 
create one. To do this, click Create It Now, and follow the onscreen guidelines. 
After your page is created, return to the Parallels Web Presence Builder at Facebook 
page, which is shown in another browser window or tab. 

6. Click Add Parallels Web Presence Builder Application. This application provides 
synchronization between the website on your hosting account and its copy 
on Facebook. 

7. To confirm that you want to add the application to your page, click Add 
Parallels Web Presence Builder. 

Now your site copy is added. To see it, click the Website link in the Facebook navigation pane 
on your left. 

Whenever you make changes to your site and republish it through the Web Presence Builder 
editor, your site copy on Facebook will be updated accordingly. 

 

 

http://www.facebook.com/
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 To remove a site copy from Facebook, do the following: 

1. In the Web Presence Builder editor's main menu, click the Settings tab > Social 
Media tab. 

2. Clear the checkbox Show a copy of my site on Facebook. 

3. Click Yes to confirm. 

4. Go to your Facebook page and remove the Web Presence Builder 
application from there. 
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Viewing Site Visits Statistics, Comments, and New Orders 
on the Dashboard 

After publishing a site, you can access the Dashboard from the Web Presence Builder's main 
menu to perform the following tasks: 

 View statistics on website visits. The statistics are provided by Google Analytics and are 
available after you specify the code for Google Analytics in website settings, as described 
in the section Settings and Tools for Webmasters (on page 358). 

 View new comments left by site visitors on your website pages. The comments are visible 
on the Dashboard after you set up the commenting functionality, as described in the 
sections Blog (on page 347) and Commenting (on page 351).  

 View new orders from customers visiting your online stores. The new orders are visible 
on the Dashboard after you set up an online store, as described in the section Online 
Store (on page 355). 

 To view website visits statistics: 

1. On the main menu, click Dashboard. 

2. If you access the dashboard for the first time, confirm association of your site 
with your Google Account: 

a. Click Log In to Google Analytics. 

b. Log in to your Google Account. 

c. Confirm that you want to allow access to your account. 

3. Under the Website Visits Statistics chart, click the link See more charts, or click the 

 icon. 

The Overview section shows the following statistics for the past 30 days: 

 A detailed chart for the metric currently selected under Profile report. 

 The total number of visits during the past 30 days. 

 The number of new visits. 

 Average time spent on a site by users. 

 The total number of page views. 

 The number of page views per each visit. 

 The percentage of new visits. 

The Traffic sources overview section shows the addresses of websites from which your 
visitors were coming during the past 30 days. The (direct) item shows the percentage of 
visitors who accessed your site by typing its address directly in their browsers. 

The Visitors' locations section shows the geographic locations of the visitors for the past 30 
days. 
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 To view comments from your site visitors: 

1. On the main menu, click Dashboard. 

2. Under Comments, click the link See them, or click the  icon. 

3. To go to the webpage where the comment was left, click Link to the comment. 

4. To go to the Disqus site for moderating the comments, click Manage Comments. 

 To view orders submitted by the customers visiting your online stores: 

1. On the main menu, click Dashboard. 

2. Under Orders, click the link See them, or click the  icon, and then click the 
Orders tab. 

3. To go to the Ecwid site for processing the orders, click Manage Orders. 
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Deleting Websites 

When you delete a site from the Web Presence Builder editor, only the current site draft 
opened in the editor and saved site copies (snapshots) are removed. The site copy published 
to your hosting account is not removed. 

 To delete a current site copy from the editor: 

In the Web Presence Builder editor's main menu, select More > Remove Site. 
 

FTP Access to Your Websites 

All files and directories related to your sites are kept on the server in a single directory, 
commonly referred to as webspace. To connect to the webspace over FTP for uploading, 
downloading, and deleting files, you use FTP account username and password. 

In this section: 

Changing FTP Access Credentials .................................................................... 368 
Adding FTP Accounts ........................................................................................ 369 
Setting Up Anonymous FTP Access .................................................................. 371 
 
 

Changing FTP Access Credentials 

 To change FTP account username or password: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the webspace where the website is hosted.     

2. Click the Websites & Domains tab. 

3. Click Web Hosting Settings. 

4. Type a new username or password. 

5. Click OK. 
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Adding FTP Accounts 

If you are working on your website together with someone else or host subdomains for other 
users, you might want to create separate FTP accounts for them. 

 To create an additional FTP account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click FTP Access. 

4. On the Additional FTP Accounts tab, click Create Additional FTP Account. 

5. Specify the following: 

 FTP account name. Type an arbitrary name. 

 Home directory. Select the directory to which the user will be taken when he or she 
connects to the FTP account. 

 FTP password. 

 Hard disk quota (on Windows hosting). To limit the amount of disk space on the server 
that the FTP user can occupy, clear the Unlimited checkbox next to the Hard disk quota 
box, and type the amount of disk space in megabytes. 

 Read permission (on Windows hosting). To allow the FTP user to view the contents of 
the home directory and download files from it, select the Read permission checkbox. 

 Write permission (on Windows hosting). To allow the FTP user to create, view, rename 
and delete directories in the home directory, select the Write permission checkbox. 

On Window hosting, if you do not grant any permissions, a connection to the FTP 
account will be made, but the contents of the home directory will not be shown to the 
user. 

6. Click OK. 

 To change the properties of an additional FTP account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 

the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click FTP Access. 

4. On the Additional FTP Accounts tab, click the required FTP account name in the 
list. 

5. Make the required changes and click OK. 
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 To remove an additional FTP account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click FTP Access. 

4. On the Additional FTP Accounts tab, select the checkbox corresponding to the 
FTP account you want to remove and click Remove. 

5. Confirm removal and click OK. 
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Setting Up Anonymous FTP Access 

If your site is hosted on a dedicated IP address (not shared by other users or sites), you can 
set up a directory within the site, where other users will be able to anonymously download or 
upload files through FTP. Once anonymous FTP is switched on, the users will be able to log 
in to the directory at an address like ftp://ftp.your-domain.com with the "anonymous" 
username and any password. 

 To allow anonymous FTP access: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 

the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click FTP Access. 

4. Click the Anonymous FTP tab. 

5. Do the following: 

a. To activate anonymous FTP service, click Switch On. 

b. To set up a welcoming message to be displayed when users log in to 
FTP site, select the Display login message checkbox and type the 
message text in the input field as desired. 

Note that not all FTP clients display welcoming messages. 

c. To allow visitors to upload files to the /incoming directory, select 

the Allow uploading to incoming directory checkbox. 

d. To allow users to create subdirectories in the /incoming directory, 

select the Allow creation of directories in the incoming directory checkbox. 

e. To allow downloading files from the /incoming directory, select the 

Allow downloading from the incoming directory checkbox. 

f. To limit the amount of disk space that can be occupied by uploaded 
files, clear the Unlimited checkbox corresponding to the Limit disk space 
in the incoming directory option, and specify the amount in kilobytes. 

This is the hard quota: The users will not be able to add more files to the directory 
when the limit is reached. 

g. To limit the number of simultaneous connections to the anonymous 
FTP server, clear the Unlimited checkbox corresponding to the Limit 
number of simultaneous connections option and specify the number of 
allowed connections. 

h. To limit the bandwidth for anonymous FTP connections, clear the 
Unlimited checkbox corresponding to the Limit download bandwidth for this 
virtual FTP domain option and enter the maximum bandwidth in 
kilobytes per second. 
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6. Click OK. 

 To change settings for anonymous FTP service or switch it off: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click FTP Access. 

4. Click the Anonymous FTP tab. 

5. Perform the operation you need: 

 Adjust the settings as required and click OK. 

 To switch off the anonymous FTP service, click Switch Off. 
 

Mail 

You can create and remove mail accounts right from the Control Panel, set up mail 
forwarding, protection from spam and viruses, and so on. For details on mail service 
configuration, refer to the section Configuring Mail (on page 374).  

If you want to use some of your e-mail addresses to distribute news and promotions, or set 
up group discussions, consider setting up mailing lists. These are e-mail addresses to which 
a number of users are subscribed. Learn more in the section Using Mailing Lists (on page 
382). 

In this section: 

Adding Mail Accounts ........................................................................................ 373 
Configuring Mail ................................................................................................ 374 
Using Mailing Lists ............................................................................................ 382 
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Adding Mail Accounts 

 To create an e-mail address: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Mail tab. 

3. Click Create E-mail Address. 

4. Type the left part of the e-mail address before the @ sign, and, if you have 
several domain names on your account, select the domain name under 
which the e-mail address will be created. 

5. Leave the Mailbox checkbox selected. 

Clearing this checkbox makes sense only if you want to use this address as a mail 
forwarder, which will forward all incoming mail to another address. 

6. Specify the mailbox size or use the default size defined by the provider's 
policy or your service plan. 

7. Specify a password consisting of five or more Latin characters. 

8. Click OK. 

 To remove an e-mail address: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Mail tab. 

3. Select a checkbox corresponding to the e-mail address you want to remove 
and click Remove. 

4. To confirm removal, click Yes. 
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Configuring Mail 

Panel allows you to configure mail services on two levels: 

 Configuring mail account settings. These settings affect mail account only. Say, where to 
forward received messages or what to do with potential spam. Learn more about possible 
operations on mail accounts in the section Configuring Mail Account (on page 375). 

 Configuring global mail settings. These are subscription-wide settings that affect all 
mailboxes within a subscription. Say, what webmail system Panel should use, or what to 
do with mail sent to nonexistent users. These settings may be unavailable in your hosting 
plan. To get the details on how to change global mail settings, refer to the section 
(Advanced) Configuring Global Mail Settings (on page 381). 

In this section: 

Configuring Mail Account .................................................................................. 375 
(Advanced) Configuring Global Mail Settings .................................................... 381 
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Configuring Mail Account 

If the provider's policy allows setting up mail accounts and services through the Control 
Panel, then you can set up and use the following types of e-mail services: 

 Mailboxes associated with your domain names. 

 E-mail aliases: additional e-mail addresses that are associated with a user's primary (or 
main) e-mail address. E-mail aliases can be used as temporary disposable addresses 
that can be published on the Internet. When spam starts coming to an address that was 
set up as an e-mail alias, you can remove that alias and create another one.    

 E-mail forwarding: for each e-mail account, you can set up e-mail forwarding service that 
will send copies of all incoming messages to another e-mail address.  

 Automatic response: for each e-mail account, you can switch on automatic response 
service, which will send a predefined e-mail message in reply to any incoming e-mail 
message. This is useful for sending "out of office" or "on vacation" notices when you are 
away. 

 Protection from spam: for each e-mail account, you can set up checking of all incoming 
messages by antispam filter. In addition, you can specify what to do with messages 
identified as spam: Remove them, move to a special folder, or just add some text to the 
message subject. 

 Protection from viruses: Panel can check all incoming and outgoing mail for viruses. 

In this section: 

Setting Up Mail Forwarding ............................................................................... 376 
Creating Mail Aliases ........................................................................................ 376 
Setting Up Auto-Reply ...................................................................................... 377 
Protecting from Spam ....................................................................................... 378 
Protecting from Viruses ..................................................................................... 380 
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Setting Up Mail Forwarding 

 To set up e-mail forwarding for an e-mail address:  

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Mail tab > e-mail address > Forwarding tab. 

3. Select the Switch on mail forwarding checkbox. 

4. Specify one or several e-mail addresses to which e-mail must be forwarded. 
When specifying e-mail addresses, separate them with white spaces, 
commas, semicolons, or type each of them on a new line. 

5. Click OK. 

6. If you do not want to keep copies of forwarded messages in the mailbox, go 
to the Mail tab > e-mail address, clear the Mailbox checkbox, and click OK. 

 To switch off mail forwarding: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Mail tab > e-mail address > Forwarding tab. 

3. Clear the Switch on mail forwarding checkbox, and click OK. 

 
 

Creating Mail Aliases 

 To add or remove additional e-mail addresses (e-mail aliases) for a mail 
account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 

the top of the screen, select the required webspace.     

2. Go to the Mail tab > e-mail address > E-mail Aliases tab. 

3. Do any of the following: 

 To add an address, type it into the E-mail alias box, and click OK. 

 To remove an address, click the Remove link to the right of the address you want to 
remove.  
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Setting Up Auto-Reply 

 To set up automatic reply for an e-mail address: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Mail tab > e-mail address > Auto-Reply tab. 

3. Select the Switch on auto-reply checkbox, and specify the following settings: 

 Auto-reply message subject. 

 Message format. We recommend that you leave the option Plain text selected because 
some of your recipients might be unable to see the text formatted with HTML. 

 Encoding. We recommend that you leave the UTF-8 encoding selected to ensure that 
the letters in your message are displayed properly. 

 Message text. 

 Forwarding address. If you want to forward incoming messages to another e-mail 
address, type an e-mail address in this box. 

 Attached files. If you want to attach a file to your message, click Browse and select a 
file. 

4. Click OK. 

 To switch off automatic reply for an e-mail address: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Mail tab > e-mail address > Auto-Reply tab. 

3. To switch off automatic reply, clear the Switch on auto-reply checkbox, and click 
OK. 
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Protecting from Spam 

 To switch on spam filtering for a mailbox: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Mail tab > e-mail address > Spam Filter tab. 

3. Select the checkbox Switch on spam filtering for this e-mail address. 

4. Specify what to do with messages classified as spam. 

 If you want to filter mail with the software on your local computer, select the option 
Mark spam messages by adding the following text to message subject, and then specify how 
spam filter should mark the messages recognized as spam. "X-Spam-Flag: YES" and 
"X-Spam-Status: Yes" headers are added to the message source by default, and if 
you want, the spam filter will also add a specific text string to the beginning of the 
subject line and to the message body. 

 If you are sure that your spam filter is accurate, you may want to set the filter to 
automatically delete all incoming messages recognized as spam. To do this, select 
the option Delete all spam messages. 

 If you are accessing your mailbox over IMAP protocol and want the spam filter to 
move all messages considered spam to the IMAP folder called Spam, select the 
option Move spam to the Spam folder. 

Because all messages are automatically removed from the Spam folder after 30 days, 
you will need to review the contents of the Spam folder on a regular basis to make 
sure you do not miss any important messages, and move all non-spam messages 
back to the Inbox folder. 

When the option Move spam to the Spam folder is selected, you can train the spam filter 
and improve its accuracy by moving spam messages from Inbox to Spam, and non-
spam messages from Spam to Inbox. 

5. If you want to adjust spam filter sensitivity, click Show Advanced Settings, and 
type a number of points that a message must score to be considered spam. 

SpamAssassin performs a number of different tests on contents and subject line of each 
message. As a result, each message scores a number of points. The higher the number, 
the more likely a message is spam. For example, a message containing the text string 
"BUY VIAGRA AT LOW PRICE!!!" in subject line and message body scores 8.3 points. 
By default, the filter sensitivity is set so that all messages that score 7 or more points are 
classified as spam. 

 If you receive lots of spam messages with the current setting, to make filter more 
sensitive, try setting a lesser value in the Spam filter sensitivity box; for example, 6. 

 If you are missing your e-mails because your spam filter thinks they are junk, try 
reducing filter sensitivity by setting a higher value in the Spam filter sensitivity box. 

Note: To further improve spam filter accuracy, you may want to train your spam filter on 
e-mail messages you receive, as described further in this section. 
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6. If you want to be sure that you will not miss e-mail from specific senders, 
type e-mail addresses or domain names into the White list field. 

Place each address in one row, or separate addresses with a coma, a colon, or a white 
space. You can use an asterisk (*) as a substitute for a number of letters, and question 
mark (?) as a substitute for a single letter. For example: address@mycompany.com, 
user?@mycompany.com, *@mycompany.com. Specifying *@mycompany.com will add 
to the white list all e-mail addresses that are under the mycompany.com mail domain. 

7. If you do not want to receive e-mail from specific domains or individual 
senders, type e-mail addresses or domain names into the Black list field. 

Place each address in one row, or separate addresses with a coma, a colon, or a white 
space. You can use an asterisk (*) as a substitute for a number of letters, and question 
mark (?) as a substitute for a single letter. For example: address@spammers.net, 
user?@spammers.net, *@spammers.net. Specifying *@spammers.net will block the 
entire mail domain spammers.net. 

8. If you use a Windows-based customer account, then you can also specify 
trusted languages and character sets. E-mail messages written in the 
specified languages and with the defined character sets will pass the spam 
filter and will not be marked as spam. 

9. On Windows-based customer accounts, you can also specify IP addresses of 
computers or networks from which e-mail must always be accepted. When 
specifying network addresses, type an address and add a network mask 
after a slash. For example, 192.168.10.10/24. 

10. Click OK. 

You can improve accuracy of spam detection if SpamAssassin spam filter on the server is 
switched on for your account and you are accessing your mailbox over IMAP protocol. 

 To improve accuracy of spam detection: 

1. Access your mailbox with webmail or a mail client program on your 
computer. 

2. Review the messages in your Inbox folder. Move all spam messages to the 
Spam folder. This will make the SpamAssassin spam filter recognize spam 
more efficiently. 
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Protecting from Viruses 

To defend your system from viruses, do not open suspicious e-mail attachments, enable 
antivirus protection on the server side, if this service is provided by your hosting company, 
and be sure to have a firewall and antivirus software installed on your personal computer. 
Also keep your operating system up-to-date and timely install security hot fixes and patches. 

 To switch on antivirus protection for a mailbox: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Mail tab > e-mail address > Antivirus tab. 

3. Select the checkbox Switch on antivirus protection for this e-mail address. 

4. Choose the desired mail scanning mode. You can switch on scanning for 
incoming mail, outgoing mail, or both. 

5. Click OK. 

When an infected message comes, you will be notified by e-mail. If Kaspersky Antivirus is 
used by your provider, then you might be able to configure it at the Mail tab > e-mail address > 
Antivirus tab. 

 To switch off antivirus protection for a mailbox: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Mail tab > e-mail address > Antivirus tab. 

3. Clear the checkbox Switch on antivirus protection for this e-mail address. 

4. Click OK. 
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(Advanced) Configuring Global Mail Settings 

You can configure the following mail service settings that apply to all domains created under 
a subscription: 

 Mail service status. You can switch the mail service on or off. If the mail service is 
switched off, then e-mail messages cannot be sent or received. 

 Mail bounce settings. When somebody sends an e-mail message to an e-mail address 
that does not exist under your domain, the mail server, by default, accepts mail, 
processes it, and when it finds out that there is no such a recipient under the domain, it 
returns the mail back to sender with an error message. You can choose to: 

 Continue returning all such mail back to senders (Bounce with message option), 

 Forward all such mail to the specified e-mail address (Forward to address option), 

 Forward all such mail to another mail server with the specified IP address using the 
option Redirect to external mail server with IP address (available only for Windows hosting), 

 Reject such mail without accepting it and without notifying senders (Reject option). 

 Webmail. If your service plan provides the option to choose which webmail program to 
use for your account, then you can select it in the global mail settings. 

 To configure the mail service settings: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Mail tab, and then click Change Settings. 

3. Select the required options, and click OK. 
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Using Mailing Lists 

Mailing list is a group e-mail address to which a number of users are subscribed. Mailing lists 
are used for sending e-mail messages to multiple recipients at once. E-mail messages sent 
to mailing list subscribers can include anything from plain text to colorful newsletters and 
promotions with embedded images and links, and attached multimedia and presentation 
materials. 

How it all works: you create a mailing list e-mail address in the Panel, and subscribe users to 
it. Then you send your message to the mailing list address, and all subscribers receive it. 

 To set up a mailing list and subscribe users to it: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Mail tab > Mailing Lists tab. 

3. Click Create Mailing List. 

4. Type the mailing list address and, if you have several websites, select the 
website under which the mailing list will be created. 

5. To subscribe users to the mailing list, type their e-mail addresses, one 
address per line.  

6. To notify the mailing list administrator about mailing list creation, select the 
checkbox Notify administrator on the mailing list creation. 

7. Click OK.  

 To subscribe or unsubscribe users: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Mail tab > Mailing Lists tab. 

3. Click the mailing list address. 

4. Do any of the following: 

 To subscribe users to the mailing list, type their e-mail addresses into the Subscribers 
field, one address per line. 

 To unsubscribe users, remove their addresses from the Subscribers field. 

5. Click OK.  
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 To remove a mailing list: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Mail tab > Mailing Lists tab. 

3. Select a checkbox corresponding to the mailing list you want to remove and 
click Remove. 

4. To confirm removal, click Yes. 

 To switch off the mailing lists service and all mailing lists created under the 
currently selected subscription: 

1. Go to the Mail tab > Mailing Lists tab. 

2. Click Switch Off the Service. 

 To switch on the mailing lists service for the currently selected subscription: 

1. Go to the Mail tab > Mailing Lists tab. 

2. Click Switch On the Service. 

 

  
 

Scheduling Tasks 

If you need to run scripts on your hosting account at specific time, use the task scheduler in 
the Panel to make the system automatically run the scripts for you. 

In this section: 

Scheduling Tasks (Linux) .................................................................................. 384 
Scheduling Tasks (Windows) ............................................................................ 387 
 
 



 

384 Managing Web Hosting 

 

Scheduling Tasks (Linux) 

If you need to run scripts on your hosting account at specific time, use the task scheduler in 
the Panel to make the system automatically run the scripts for you. 

During installation of the Panel, the following tasks are automatically created: 

 autoreport.php – delivers daily, weekly and monthly reports on domains (three 

separate tasks) 

 backupmng – initiates scheduled backing up of domains once every 30 minutes 

 statistics – generates statistics on resource usage by domains 

 mysqldump.sh - creates a backup copy of three MySQL databases: psadump, MySQL, 

and Horde databases 

As all these tasks are related to statistics, databases, and reports, it is strongly 
recommended that you neither change nor remove them. 

 To schedule a task: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

3. Click Schedule New Task. 

4. Leave the Switched on checkbox selected. 

5. Specify when to run your command: 

 Minute - enter the value from 0 to 59 

 Hour - enter the value from 0 to 23 

 Day of the month - enter the value from 1 to 31 

 Month - enter the value from 1 to 12, or select the month from a drop-down box 

 Day of the week - enter the value from 0 to 6 (0 for Sunday), or select the day of the 
week from a menu. 

You can schedule the time using the UNIX crontab entry format. In this format, you can: 

 Enter several values separated by commas. Two numbers separated by a hyphen 
mean an inclusive range. For example, to run a task on the 4th, 5th, 6th, and 20th of a 
month, type 4-6,20. 

 Insert an asterisk to specify all values allowed for this field. For example, to run a task 
daily, type * in the Day of the month text box. 

To schedule the task to run every Nth period, enter the combination */N, where N is a 
value for this field (minute, hour, day, month). For example, */15 in the Minute field 
schedules the task to start every 15 minutes.  



 

 Managing Web Hosting 385 

 

You can type the contracted names of months and days of the week, which are the first 
three letters: Aug, Jul, Mon, Sat, and so on. However, the contracted names cannot be 
separated with commas or used together with numbers. 

6. Specify which command to run. Type it into the Command input box. 

For example, if you want to run the backup creation task at the specified time and have 
the backup file sent to your e-mail, you need to specify the following command in the 
Command input box: 

/usr/local/psa/admin/sbin/backupmng 

7. Click OK. 

 To receive notifications when the tacts are started: 

1. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

2. Click Settings and specify the notification policy. 

 To temporarily suspend execution of a scheduled task: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

3. Locate the task that you want to suspend and click the corresponding link in 
the Command column. 

4. Clear the Switched on checkbox and click OK. 

 To resume execution of a scheduled task: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

3. Locate the task whose execution you want to resume and click the 
corresponding link in the Command column. 

4. Select the Switched on checkbox and click OK. 
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 To cancel a task: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

3. Select a checkbox to the left of the task that you want to cancel and click 
Remove. 

4. Confirm removal and click OK. 
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Scheduling Tasks (Windows) 

If you need to run scripts on your hosting account at specific time, use the task scheduler in 
the Panel to make the system automatically run the scripts for you. 

During installation of the Panel, the following tasks are automatically created: 

 Update antivirus database – updates Parallels Premium Antivirus database. 

 Statistics calculation - generates statistics on resource usage, such as traffic and disk 
space. 

As all these tasks are related to site statistics, databases and reports, it is strongly 
recommended that you neither change nor remove them. 

 To schedule a task: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

3. Click Schedule New Task. 

4. Leave the Switched on checkbox selected if you want your scheduled task to 
be active immediately after the creation. 

5. Type a name for your task in the Description field. 

6. In Scheduler notification, specify whether the scheduler should notify you when 
it runs this task. The following options are available: 

 Switched off - do not notify you. 

 Send to the default e-mail - send the notification to your default e-mail address. 

 Send to the e-mail I specify - send the notification to the e-mail specified in the 
corresponding field. After selecting this option, you need to type the required e-mail 
address in the field on the right. 

7. Specify which command or executable file to run. Type it into the Path to 
executable file input box. If you need to run the command with certain options, 
type them in the Arguments field. 

 For example, if you want to run the statistics calculation task to count disc space and 
see more detailed information for the example.com and example.net domains, you 
need to specify the following path in the Path to executable file input box: 

C:\Program Files\Parallels\Parallels 

Panel\admin\bin\statistics.exe 

and the following options in the Arguments field: 

--disk-usage --process-domains=example.com, example.net –

verbose 
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 If you want to run your own PHP script using the task scheduler, you need to specify 
the following path in the Path to executable file input box: 

C:\Program Files (x86)\Parallels\Parallels 

Panel\Additional\PleskPHP5\php.exe 

and specify the script location in the Arguments field: 

C:\Inetpub\vhosts\mydomain.tld\httpdocs\myscript.php 

8. Select the appropriate priority in the Task priority field. Task priority can be set 
to Low, Normal or High. 

9. Specify when to run your command by selecting the appropriate checkboxes 
in the Hours, Days of month, Months or Days of week fields. 

10. Click OK to schedule the task or click Run Now to schedule the task and 
immediately run it. 

 To temporarily suspend execution of a scheduled task: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

3. Choose a task that you want to suspend and click the corresponding link in 
the Description column. 

4. Clear the Switched on checkbox. 

5. Click OK. 

 To resume execution of scheduled task: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

3. Choose a task whose execution you want to resume and click the 
corresponding link in the Description column. 

4. Select the Switched on checkbox. 

5. Click OK. 
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 To cancel a task: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations 
group). 

3. Select a checkbox to the left of the task that you want to cancel and click 
Remove. 

4. Confirm removal and click OK. 

 
 

Using Databases 

If your website incorporates custom data processing applications or is designed to generate 
web pages dynamically, you will likely need a database for storing and retrieving data. You 
can either create a new database for your site or import the data from your previously backed 
up MySQL, PostgreSQL, or Microsoft SQL database. Note that when you install an 
application from the Applications Catalog, all required databases and database user 
accounts are created automatically. 

In this section: 

Managing Databases ........................................................................................ 389 
Accessing External Databases (Windows) ........................................................ 394 
 
 

Managing Databases 

Panel allows you to perform a number of database management operations: 

 Create and remove databases. 

 Import existing databases. 

 Create additional database user accounts for collaborative work. 

For the details on these operations, refer to the particular sections of this chapter. 

In this section: 

Creating Databases ........................................................................................... 390 
Importing Databases ......................................................................................... 392 
Creating Database User Accounts .................................................................... 392 
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Creating Databases 

 

Creating and Removing Databases 

 To create a new database on a customer account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click Databases (in the Advanced Operations group). 

4. Click Add New Database. 

5. Enter a name for the database.  

We recommend that you choose a name that starts with a Latin alphabet symbol and 
comprises only alphanumeric and underscore symbols (up to 64 symbols).  

6. Select the database type that you are going to use: MySQL, PostgreSQL or 
Microsoft SQL Server. Click OK. 

7. To set up database administrator’s credentials, click Add New Database User. 

8. Type a user name and a password that will be used for accessing the 
contents of the database. 

9. Click OK.   

 To remove a database with its contents: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Databases. 

3. Select a checkbox corresponding to the database that you want to remove.  

If the required checkbox appears grayed out, this means that this database is used by a 
web application and you can remove it only by removing the respective application. 

4. Click Remove. 

5. Confirm removal and click OK. 

 

Accessing Databases 

After you created a database and assigned a database user to it, you can access it from 
Panel using the Webadmin link on the Websites & Domains tab > Databases > database page. In 
this case, Panel automatically uses the corresponding database user credentials.  
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If you want to access your database using some other tools (like SQL Server Management 
Studio) or to give some applications access to it, you will need to provide these tools and 
applications with the following: 

 To connect to MySQL and PostgreSQL, you will need to provide the host name (or IP 
address) and the database user login and password.  

 To connect to Microsoft SQL Server, you will also need to specify the Microsoft SQL 

Server instance. For Microsoft SQL Server 2008, Panel uses the MSSQLSERVER2008 

named instance. Therefore, the host can be specified as  

mydomain.com\MSSQLSERVER2008 or 123.123.123.123\MSSQLSERVER2008. For 

Microsoft SQL Server 2005, Panel uses the default instance (MSSQL 2005), and you do 

not need to specify the instance name. 
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Importing Databases 

 To import an existing database: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Databases (in the Advanced Operations group) > 
Add New Database. 

3. Enter a name for the database. We recommend that you choose a name that 
starts with a Latin alphabet symbol and comprises only alphanumeric and 
underscore symbols (up to 64 symbols).  

4. Select the database type that you are going to use: MySQL, PostgreSQL, or 
Microsoft SQL Server. Click OK. 

5. To set up database administrator’s credentials, click Add New Database User. 

6. Type a user name and a password that will be used for accessing the 
contents of the database. Click OK. 

7. Click the Webadmin icon in the Tools group. An interface to phpMyAdmin, 
phpPgAdmin, or ASPEnterpriseManager database management tool will 
open in a separate browser window. The database management tools allow 
to operate database user accounts and execute SQL queries through the 
web browser. 

If you have a MySQL database: 

a. Click Query window in the left frame, click the Import files tab,  

b. Select the text file that contains the data and click Go. 

c. Click the Insert data from a text file link. 

If you have a MS SQL database: 

a. Click the name of your database in the left frame 

b. Click Query (the magnifying glass button) 

c. Copy the text of your script into the text area and click Run Query. 

To manage your databases and their contents, use your favorite MySQL, PostgreSQL, or 
Microsoft SQL Server client or the web-based database management tool accessible from 
the Panel (the Websites & Domains tab > Databases > database name > Webadmin). 
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Creating Database User Accounts 

If you collaborate with other people on managing a website and wish to give them access to 
the database, you should create separate user accounts for them. 

 To create a database user account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Databases > database name, and click Add New 
Database User. 

3. Type a user name and a password that will be used for accessing the 
contents of the database. Click OK. 

 To change a password for a database user: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Databases > database name > database user 
name. 

3. Type a new password and click OK. 

 To specify whose user account credentials should be used by default for 
managing a database through the Webadmin tool: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Databases > database name. 

3. Select a checkbox corresponding to the user account you need. 

4. Click Default for DB Webadmin. 

 To remove a database user account:  

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Databases > database name. 

3. Select a checkbox corresponding to the user account that you want to 
remove. 

4. Click Remove, then confirm removing and click OK.  



 

394 Managing Web Hosting 

 

 

Accessing External Databases (Windows) 

If your applications need to access external databases for storing data, then you need to 
create ODBC connections through the Panel. 

 To create an ODBC connection to an external database: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > ODBC Data Sources (in the Advanced Operations 
group). 

3. Click Add New ODBC DSN. 

4. Specify the ODBC connection name and description in the corresponding 
fields. 

5. Select the required driver in the Driver field. 

6. Click OK. 

7. Choose the appropriate options on the driver configuration screen. Typically, 
you should specify the path to the database, user credentials and other 
connection options, depending on the selected driver. 

8. Click Test Connection to check whether the connection will function properly 
with provided settings. Click Finish to complete the creation. 

 To change settings of an ODBC connection: 

1. Go to the Websites & Domains tab > ODBC Data Sources (in the Advanced Operations 
group). 

2. Click the required connection name in the list. 

3. Change the settings as needed. 

4. Click Test Connection to check whether the connection will function properly 
with new settings. Click Finish to save changes. 

 To remove an ODBC connection: 

1. Go to the Websites & Domains tab > ODBC Data Sources (in the Advanced Operations 
group). 

2. Select the checkbox corresponding to a connection you want to remove. 

3. Click Remove, confirm the removal and click OK. 
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Backing Up and Recovering Websites 

Unfortunately, data loss events are quite common problem today. The reasons of these 
events may vary: Hardware failures, hacking attacks, and so on. To minimize the 
consequences of  data loss, Panel provides the back up / restore feature. During the backup 
Panel saves your account configuration along with all websites content into a number of files. 
You can restore the backup at any time later to recover corrupted data, or just to return Panel 
to stable state. 

This chapter describes how to perform the following operations in your Panel: 

 Back up all data related to your account and sites. Learn more in the section Backing Up 
Account and Websites (on page 398). 

 Back up databases (Windows). Learn more in the section Backing Up Databases (Windows) 
(on page 400). 

 Schedule backups. Learn more in the section Scheduling Backups (on page 401). 

 Restore data from backup archives. Learn more in the section Restoring Data (on page 
404). 

 

 

 

In this section: 

Backing Up Data ............................................................................................... 396 
Managing Backup Files ..................................................................................... 402 
Restoring Data .................................................................................................. 404 
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Backing Up Data 

Depending on your needs, Panel can perform two types of backup: 

 Customer account configuration. Such backups have small size and are convenient for 
restoring account settings in case of configuration problems. 

 Customer account configuration and websites content. This type of backup requires more 
disk space and system resources because the Panel also saves the content of all 
websites. Such full backups are the best way to prevent data loss. 

You can perform backup manually at any time, or schedule it for a specific time. For 
example, make the full backup once a day at night time when the number of site visits is 
minimal. To get the details on scheduling backups, refer to the section Scheduling Backups (on 
page 401). 

Storing Backups 

There are two ways of storing backups in Panel: 

 On the Panel-managed hosting server. All backup files are stored on your Panel server 
along with other account content. Note that in this case backup files occupy the disk 
space provided by your subscription. 

 On a remote FTP server. All backup files are stored on a remote FTP repository. In this 
case, backup files do not occupy the disk space provided by your subscription. The 
instructions on how to configure Panel to save backups to an FTP account are provided 
below in this section. 

 

Creating Password-protected Backups 

Since Panel 11.0, you are able to secure sensitive data in your backups by protecting them 
with a password. Protection makes it impossible for an attacker to reveal backup data if the 
security of your external backup storage is compromised. 

You can specify a backup password in the following circumstances: 

 In your FTP repository settings (Websites & Domains > Backup Manager > Personal FTP 
Repository Settings).  

 When downloading a backup file from the Panel internal repository to some external 
location. 

When uploading these backups back to Panel and restoring them, you will be prompted to 
provide the password you used for protection. 

Important:  
If you forget the password you used for backup protection, it cannot be recovered. 
Therefore, it is strongly recommended to keep a list of your passwords and corresponding 
backup file names in a safe place. 

    

Configuring Panel for Working with an FTP Repository 
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If you are going to use an FTP server for storing backup files, you should specify its settings 
in Account tab > Back Up My Account and Websites > Personal FTP Repository Settings: 

 FTP server's IP address or host name. 

 Directory on the server where you want to store backup files. 

 User name and password for access to the FTP account. 

 Password that Panel will use for protecting backup files. 

In this section: 

Backing Up Account and Websites ................................................................... 398 
Backing Up and Restoring Databases (Windows) ............................................. 400 
Scheduling Backups ......................................................................................... 401 

 
 



 

398 Managing Web Hosting 

 

Backing Up Account and Websites 

 To back up all data related to your account and all your subscriptions: 

1. Go to the Account tab > Back Up My Account and Websites > Back Up. 

2. Specify the following: 

 Backup file name prefix and description. You cannot specify an arbitrary file name, 
however, you can set the Panel to add a prefix to backup file names. Note that the 
Panel automatically adds the date and time of backup file creation (in Universal Time) 
to backup file names.  

 Splitting of the backup file. To create a multivolume backup, select the corresponding 
checkbox and specify volume size in megabytes. 

 Location where to store the backup file. Select the repository where you would like to 
store the backup file. 

 E-mail notification on backup completion. If you want to be notified of the backup 
completion, type your e-mail address. 

 What data to back up. You can back up only the account settings or account settings 
and all data. 

 Suspend domains until backup task is completed. Select this option to prohibit users from 
making changes to content or settings of websites while they are being backed up. 

Note: If you select this option, then, after restoring the data from this backup file, you 

will need to manually switch on every domain alias for every site that needs to 
have domain aliases. This can be done at Websites & Domains tab > domain alias 
name > Switch On. 

3. Click Back Up. 

When backing up is finished, the backup file will be saved to the repository you selected. 

 To back up all websites related to a subscription: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Account tab > Back Up Websites > Back Up. 

3. Specify the following: 

 Backup file name prefix and description. You cannot specify an arbitrary file name, 
however, you can set the Panel to add a prefix to backup file names. Note that the 
Panel automatically adds the date and time of backup file creation (in Universal Time) 
to backup file names.  

 Splitting of the backup file. To create a multivolume backup, select the corresponding 
checkbox and specify volume size in megabytes. 

 Location where to store the backup file. Select the repository where you would like to 
store the backup file. 
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 E-mail notification on backup completion. If you want to be notified of the backup 
completion, type your e-mail address. 

 What data to back up. You can choose to back up: 

 Only settings of websites. 

 All settings and data with or without mail accounts and messages in mailboxes. 

 Only mail accounts with messages. 

 Suspend domains until backup task is completed. Select this option to prohibit users from 
making changes to content or settings of websites while they are being backed up. 

Note: If you select this option, then, after restoring the data from this backup file, you 

will need to manually switch on every domain alias for every site that needs to 
have domain aliases. This can be done at Websites & Domains tab > domain alias 
name > Switch On. 

4. Click Back Up. 

When backing up is finished, the backup file will be saved to the repository you selected. 
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Backing Up and Restoring Databases (Windows) 

If you are using a Windows-based customer account, then you can back up and 
subsequently restore databases, database user accounts, and data used by your websites. 

You can: 

 Back up your domain databases with all data and user accounts. 

 Restore databases from backup files. 

 Download, upload and remove database backup files. 

 Recover users who became orphaned after the restoration. 

Important: Panel does not back up stored procedures, views, and triggers. The backup 
utility ignores them and, therefore, they cannot be restored. 

 To back up databases: 

1. Go to the Websites & Domains tab > Backup Manager > Database Backup Repository. 

2. Using the Database menu, select the databases you want to back up. 

3. Click Back Up. 

4. Specify the name of the backup file and click OK. 

5. If you want to download the resulting backup file, click the file name on the 
next page after the backup process was finished. Specify the location where 
you want to save the file and click Save. 

6. Click OK. 

 

 To restore a database: 

1. Log in to Control Panel. 

2. Go to Websites & Domains tab > Backup Manager > Database Backup Repository, 
select the checkbox corresponding to the backup file you want to restore and 
click Restore. 

If you do not have the backup file on your server, you can upload the backup file to the 
server repository from your local machine. 

3. Confirm the restoration by selecting the corresponding checkbox and click 
OK. 
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 To upload a backup file to a backup repository: 

1. Go to Control Panel > Websites & Domains tab > Backup Manager > Database Backup 
Repository, and click Upload Backup File. 

2. In the Database name menu, select the database in whose repository you want 
to upload the backup file.  

3. Click Browse... and select the required backup file. 

4. Leave the Restore database backup immediately upon uploading check box selected 
if you want the database contents to be restored immediately after the 
backup file is uploaded. 

5. Click OK. 

The database backup file will be uploaded to the backup repository of the specified 
database. 

Scheduling Backups 

 To schedule backing up of data: 

1. Go to the Account tab > Back Up My Account and Websites > Scheduled Backup 
Settings. 

2. Select the Activate this backup task checkbox and specify the following: 

 When and how often to run the backup. 

 A prefix that should be added to the backup file name. 

 Splitting of the backup file. To create a multivolume backup, select the respective 
checkbox and specify volume size in megabytes. Note that volume size cannot 
exceed 4095 megabytes. 

 Location where to store the backup file. Select the repository where you would like to 
store the backup file. 

 Maximum number of backup files stored in the repository. Type a number if you want 
to recycle backup files: When this limit is reached, the oldest backup files are 
removed. 

 E-mail notification on backing up errors. If you want to send an e-mail notice when 
something goes wrong during backing up, type the e-mail address you need. 

 What data to back up. You can back up only account settings, or account settings and 
all related data. 

 Suspend domains until backup task is completed. Select this option to prohibit users from 
making changes to content or settings of websites while they are being backed up. 

3. Click OK. 
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Managing Backup Files 

In this section: 

Uploading and Downloading Backup Files......................................................... 402 
Uploading and Downloading Database Backup Files (Windows) ....................... 403 

 
 

Uploading and Downloading Backup Files 

Downloading Backup Files from Panel 

To download a backup file from the Panel repository, choose the corresponding backup file 
name in Account tab > Back Up My Account and Websites and specify the location for the file. 
Before starting the download, Panel will prompt you to enter the backup password.    

Uploading Backup Files to Panel 

To upload a backup file to the Panel repository, use the Account tab > Back Up My Account and 
Websites > Upload Files to Server Repository wizard. Before starting the upload, Panel will prompt 
you to enter the following backup parameters: 

 Backup file location. 

 Password.  
This is the password that you used for protecting the backup data. If you did not use 
password-protection, leave the corresponding field blank.  

Note: If the password you provide is incorrect, Panel will warn you, but will upload the 
backup to the server anyway. During the backup restoration, you will be prompted to 
enter the password again. 

Removing Backup Files  

To remove a backup file from the Panel repository, select a checkbox corresponding to the 
backup file you want to remove in Account tab > Back Up My Account and Websites and сlick 
Remove. 
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Uploading and Downloading Database Backup Files (Windows) 

 To upload a backup file to backup repository: 

1. Go to the Websites & Domains tab > Backup Manager > Database Backup Repository 
and click Upload Backup File. 

2. Select the database in whose repository you want to upload the backup file 
to in the Database name menu.  

3. Click Browse... and select the required backup file. 

4. Leave the Restore database backup immediately upon uploading checkbox selected if 
you want the database contents to be restored immediately after the backup 
file is uploaded. 

5. Click OK. 

The database backup file will be uploaded to the backup repository of the specified 
database. 

 To download a backup file from backup repository: 

1. Go to the Websites & Domains tab > Backup Manager > Database Backup Repository. 

2. In the Database menu, select the database whose backup files you want to 
browse. Leave All domain databases selected if you want to browse backup files 
of all databases on a domain. 

3. Click the icon  corresponding to the database backup file you want to 
download. 

4. Select the location where you want to save the backup file and click Save. 

The backup file will be downloaded from the backup repository. 

 To remove a backup file from backup repository: 

1. Go to the Websites & Domains tab > Backup Manager > Database Backup Repository. 

2. In the Database menu, select the database whose backup files you want to 
remove. Leave All domain databases selected if you want to browse backup files 
of all databases on a domain. 

3. Select a checkbox corresponding to the database backup file you want to 
remove. Click Remove, confirm removal and click OK. 
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Restoring Data 

In this section: 

Restoring Backups ............................................................................................ 404 
Restoring Databases (Windows) ....................................................................... 405 

 
 

Restoring Backups 

You can restore data from backup files kept in: 

 The Panel internal repository. 
To restore backup files from Panel repository, choose the backup file name you want to 
restore on the Account tab > Back Up My Account and Websites > Server Repository tab.  

 An external FTP repository. 
To restore backup files from Panel repository, choose the backup file name you want to 
restore on the Account tab > Back Up My Account and Websites > Personal FTP Repository tab.  

After you choose the backup file, Panel will start the restoration wizard. You will be prompted 
to specify the following restoration parameters: 

 Types of data to be restored. 

 Suspend website until restoration task is completed. Select this if you want to avoid possible 
conflicts that may occur when users modify site content or settings while they are being 
restored. 

 Send an e-mail notice when restoration task is completed. Type your e-mail address if you want 
the control panel to notify you when restoring is completed. 

 Conflicts resolution policy. Specify what to do if any conflicts occur during restoration. 

 Backup security settings. If the backup was protected with a password, enter the password 
into the Password field. Note that Panel is unable to check whether the password you 
enter is wrong: The backup will be successfully restored but the data will be corrupted. 
If you wish to reset user passwords, clear the Provide the passwords option. 

If any errors or conflicts occur during restoration of data, the wizard will prompt you to select 
an appropriate resolution. Follow the instructions provided on the screen to complete the 
wizard. 
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Restoring Databases (Windows) 

 If the database already exists and you only need to restore its contents: 

1. Go to the Websites & Domains tab > Backup Manager > Database Backup Repository. 

2. Select the required backup file from the list and click Restore Selected. 

If you do not have the backup file on the server, you can upload the backup file to the 
server repository from your local machine. For more information, refer to the section 
Uploading, Downloading, and Removing Database Backup Files.  

3. Confirm the restoration by selecting the corresponding checkbox and click 
OK. 

If you are restoring an MS SQL database, there is a possibility that some database users 
will be orphaned. In order to provide the ability to access and use the database for these 
users, you need to repair them. For more information, refer to the section Recovering 
Orphaned Database Users. 

In this section: 

Post-Restoration Database Repair .................................................................... 405 
 
 

Post-Restoration Database Repair 

If you are restoring an MS SQL database, there is a possibility that some database users will 
be orphaned. In order to provide the ability to access and use the database for these users, 
you need to repair them.  

 To check if a database has orphaned users and to repair them: 

1. Go to Websites & Domains tab > Databases (in the Advanced Operations group) > 
database name. 

2. If you see a warning saying that there are several orphaned users that 
should be repaired in order to function properly, you have orphaned users 
who need to be repaired. 

3. To repair orphaned users, click the Repair now button corresponding to the 
users you want to repair. 

4. Provide password for the users and click Repair. 

If a user is supposed to be a system user without a password, run repair with empty 
password field. 
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